Official 364.51 Game Ready WHQL Display Driver Feedback Thread (Released 3/10/16) - Updated
  37 / 89    
[quote="sylex"].51 is not working for me :\ Same as the 362.00 and the 364.47.... It is a beta so there is still hope...[/quote] Implying the WHQL one won't be beta? .47 was obviously still beta too. WHQL certification is meaningless.
sylex said:.51 is not working for me :\ Same as the 362.00 and the 364.47.... It is a beta so there is still hope...

Implying the WHQL one won't be beta?

.47 was obviously still beta too.

WHQL certification is meaningless.

i7-5930K 4.5GHz, 2x GTX 780, 32GB 2800MHz CL15 RAM, 7 SSDs & 4TB RAID1, PB298Q (21:9, 2560x1080), HP f2304 (16:10, 1920x1200). Windows 7 x64.

Posted 03/08/2016 08:34 PM   
Edit: Wow, site was like DDoS'd and my comment posted 3 times, whoops. Can a mod delete this?
Edit: Wow, site was like DDoS'd and my comment posted 3 times, whoops.

Can a mod delete this?

i7-5930K 4.5GHz, 2x GTX 780, 32GB 2800MHz CL15 RAM, 7 SSDs & 4TB RAID1, PB298Q (21:9, 2560x1080), HP f2304 (16:10, 1920x1200). Windows 7 x64.

Posted 03/08/2016 08:34 PM   
Edit: Wow, site was like DDoS'd and my comment posted 3 times, whoops. Can a mod delete this?
Edit: Wow, site was like DDoS'd and my comment posted 3 times, whoops.

Can a mod delete this?

i7-5930K 4.5GHz, 2x GTX 780, 32GB 2800MHz CL15 RAM, 7 SSDs & 4TB RAID1, PB298Q (21:9, 2560x1080), HP f2304 (16:10, 1920x1200). Windows 7 x64.

Posted 03/08/2016 08:48 PM   
Well, I installed 364.47 and I didn't have any of the issues other users are reporting (I have a GTX 770). I never install Nvidia drivers from the GE Force Experience tool, since I had issues in the past when failed installation messages, so I always download the stand-alone installation from Support Nvidia site instead, and in this case, worked very well even selecting "Express" mode. In any case, I just installed beta 364.51, just to be in the sure side, and also didn't have any issue with the installation, normal black screen flickering when installing it, but that's it, is good to go.
Well, I installed 364.47 and I didn't have any of the issues other users are reporting (I have a GTX 770). I never install Nvidia drivers from the GE Force Experience tool, since I had issues in the past when failed installation messages, so I always download the stand-alone installation from Support Nvidia site instead, and in this case, worked very well even selecting "Express" mode. In any case, I just installed beta 364.51, just to be in the sure side, and also didn't have any issue with the installation, normal black screen flickering when installing it, but that's it, is good to go.

Posted 03/08/2016 08:50 PM   
I was able to play the Division last night on this driver and it was stable and didn't seem to give me issues. I think there were some server issues so i gave up as it was late. I used the express install on it and the latest beta driver today as well and still no issues. I am running a 4k gsync monitor, hero 7 mobo, 4790k cpu, 16 gigs gskill ram etc and SLI GTX 980's. Today after the latest update, regardless of where I put my settings (low medium high etc) the game is really slowing down. I tried the optimized settings that nvidia recommends and also the in game auto detect, neither work and the optimized ones are way lower than what the in game says. the benchmark in game works fine and avg fps is like 48 or something so that is plenty for gsync so not sure why the game is bogging down so much. Anyone else seeing this with this new driver? Last night I wasn't seeing any of this.
I was able to play the Division last night on this driver and it was stable and didn't seem to give me issues. I think there were some server issues so i gave up as it was late. I used the express install on it and the latest beta driver today as well and still no issues. I am running a 4k gsync monitor, hero 7 mobo, 4790k cpu, 16 gigs gskill ram etc and SLI GTX 980's.

Today after the latest update, regardless of where I put my settings (low medium high etc) the game is really slowing down. I tried the optimized settings that nvidia recommends and also the in game auto detect, neither work and the optimized ones are way lower than what the in game says. the benchmark in game works fine and avg fps is like 48 or something so that is plenty for gsync so not sure why the game is bogging down so much.

Anyone else seeing this with this new driver? Last night I wasn't seeing any of this.

Posted 03/08/2016 08:55 PM   
I installed newest driver and don't have any problems. Yet. I always download the drivers from Nvidia site, do Express install and never uninstalling old version, I just do "udpate" when installing new version. Doing this +3 years. Never had an issue. I'm using Windows 7 and GTX 980 by the way. Maybe these problems only occur for Windows 10 users or those, who are using two or more monitors.
I installed newest driver and don't have any problems. Yet. I always download the drivers from Nvidia site, do Express install and never uninstalling old version, I just do "udpate" when installing new version. Doing this +3 years. Never had an issue.

I'm using Windows 7 and GTX 980 by the way. Maybe these problems only occur for Windows 10 users or those, who are using two or more monitors.

Posted 03/08/2016 09:10 PM   
got a gtx 960. I could install no problem, but as soon as i turn on my second monitor, the screens go black, flicker, then the entire pc crashes. This is with 364.47 on win 10
got a gtx 960. I could install no problem, but as soon as i turn on my second monitor, the screens go black, flicker, then the entire pc crashes.
This is with 364.47 on win 10

Posted 03/08/2016 09:14 PM   
[quote="carlostib"]Well, I installed 364.47 and I didn't have any of the issues other users are reporting (I have a GTX 770). I never install Nvidia drivers from the GE Force Experience tool, since I had issues in the past when failed installation messages, so I always download the stand-alone installation from Support Nvidia site instead, and in this case, worked very well even selecting "Express" mode. In any case, I just installed beta 364.51, just to be in the sure side, and also didn't have any issue with the installation, normal black screen flickering when installing it, but that's it, is good to go. [/quote] Same here. Always downloading from the driver page since I got a error message with geforce experience. On Win7 the LEDs wouldn't turn on without Geforce experience. (Yeah I wanted them turned on cus I swapped the LEDs ^^) With Win10 GE isn't necessary anymore.
carlostib said:Well, I installed 364.47 and I didn't have any of the issues other users are reporting (I have a GTX 770). I never install Nvidia drivers from the GE Force Experience tool, since I had issues in the past when failed installation messages, so I always download the stand-alone installation from Support Nvidia site instead, and in this case, worked very well even selecting "Express" mode. In any case, I just installed beta 364.51, just to be in the sure side, and also didn't have any issue with the installation, normal black screen flickering when installing it, but that's it, is good to go.

Same here. Always downloading from the driver page since I got a error message with geforce experience.


On Win7 the LEDs wouldn't turn on without Geforce experience. (Yeah I wanted them turned on cus I swapped the LEDs ^^)

With Win10 GE isn't necessary anymore.

CPU: Intel Core i7 6700K@4.2Ghz 1.23V
MOBO: Asus Z170I Pro Gaming (Bios 3405)
Graphicscard: GTX 1080 Founders Edition @2100Mhz
RAM: G.Skill TridentZ DDR4-3000 2x16GB
SSD: Samsung 950 Pro
SSD: Samsung 850 Pro 1TB
HDD: Seagate SV35 2TB
PSU: Corsair RMx650
CPU Cooling: EK Supremacy EVO
Monitor: Asus Swift PG279Q
OS: Win 10 64bit

Posted 03/08/2016 09:22 PM   
Please stop telling people to use DDU, everyone knows DDU and is using it, don't consider yourself better and others idiots. If your system works it's just luck with your current registry state and windows 10 mood. I have myself had a strange experience. having a 100% stable system with 347.88 i decide to try again installing this version on my windows 10. uninstalled 347.88 and every NV related from control pannel, rebooted in safe mode, run DDU as an admin. rebooted and installed 364.47 (only physx and driver) rebooted and my system was f***** up ... no way to shutdown or enter sleep mode properly. (I always test this first after installing a driver, if this test fails I know I can give up) So this is classic ... but, now listen, here comme the interresting part. I tryed to go back to 347.88 Uninstalled 364.47 and every NV related from control pannel, rebooted in safe mode, run DDU as an admin. rebooted and installed 347.88 (only physx and driver) rebooted and my system was STILL f***** up ... no way to shutdown or enter sleep mode properly. I see you ! smiling "ha ha his machine is crap, does not work anyway" Stop KID ! I had a partition backup of my working 347.88 config. Took me 7 hours to restore 500GB Samsung 850 EVO SSD partition from external USB drive. rebooted, and guess what ? my system is 100% stable ! games, shutdown, sleep wake, fast start, everything works again. Conclusion ??? well my conclusion is that nvidia will never find the cause of this in their drivers ... it's a problem between Windows 10 and their installer. It's an installer issue and DDU can't help because it's not caused by leftover parts. It's a random installer/OS issue. What Nvidia could do instead of only relying on free tools like DDU that do the job their own installer should have been able to in the first time, is providing a system analysis tool that checks registry and veryfies the installer job and checks if everything is in place like expected. The tool could even backup the system registry before update and compare after install to pinpoint changes. If DDU is done properly, I believe there must be something different in the registry between a machine that works and a machine that doesn't. The tool could also send them back registry system data to gather informations.
Please stop telling people to use DDU, everyone knows DDU and is using it, don't consider yourself better and others idiots. If your system works it's just luck with your current registry state and windows 10 mood.

I have myself had a strange experience.
having a 100% stable system with 347.88 i decide to try again installing this version on my windows 10.
uninstalled 347.88 and every NV related from control pannel, rebooted in safe mode, run DDU as an admin.
rebooted and installed 364.47 (only physx and driver)
rebooted and my system was f***** up ... no way to shutdown or enter sleep mode properly.
(I always test this first after installing a driver, if this test fails I know I can give up)

So this is classic ... but, now listen, here comme the interresting part.

I tryed to go back to 347.88
Uninstalled 364.47 and every NV related from control pannel, rebooted in safe mode, run DDU as an admin.
rebooted and installed 347.88 (only physx and driver)
rebooted and my system was STILL f***** up ... no way to shutdown or enter sleep mode properly.

I see you ! smiling "ha ha his machine is crap, does not work anyway"
Stop KID ! I had a partition backup of my working 347.88 config.

Took me 7 hours to restore 500GB Samsung 850 EVO SSD partition from external USB drive.

rebooted, and guess what ? my system is 100% stable ! games, shutdown, sleep wake, fast start, everything works again.


Conclusion ??? well my conclusion is that nvidia will never find the cause of this in their drivers ... it's a problem between Windows 10 and their installer. It's an installer issue and DDU can't help because it's not caused by leftover parts. It's a random installer/OS issue.

What Nvidia could do instead of only relying on free tools like DDU that do the job their own installer should have been able to in the first time, is providing a system analysis tool that checks registry and veryfies the installer job and checks if everything is in place like expected. The tool could even backup the system registry before update and compare after install to pinpoint changes. If DDU is done properly, I believe there must be something different in the registry between a machine that works and a machine that doesn't. The tool could also send them back registry system data to gather informations.

Posted 03/08/2016 09:22 PM   
Personally running Win10x64, Titan X, single monitor, single GPU, I've had no issues. Used DDU to clean out the last driver, then ran a custom install on 364.47 and installed the driver and PhysicsX only. For me the best driver that's been released in a long time. Games I've tested, Rainbow 6, BF4, BFBC2, Insurgency and Squad. All have great stable frame rate, (most of them at 144 to match monitor refresh rate). This will be my new roll back to driver when I have any issues with future releases. Shame it's not that great an experience for everyone.
Personally running Win10x64, Titan X, single monitor, single GPU, I've had no issues. Used DDU to clean out the last driver, then ran a custom install on 364.47 and installed the driver and PhysicsX only. For me the best driver that's been released in a long time. Games I've tested, Rainbow 6, BF4, BFBC2, Insurgency and Squad. All have great stable frame rate, (most of them at 144 to match monitor refresh rate).

This will be my new roll back to driver when I have any issues with future releases.

Shame it's not that great an experience for everyone.

Intel Core i7-5960X; Asus X99-Deluxe; 64Gb Hyper X Fury 2133MHz DDR4; 512Gb Samsung 850 Pro; EVGA Titan X SC; Asus PG279Q ROG Swift 27"; NZXT Kraken X61; Corsair AX1200i 1200W PSU 80+ Platinum; Phanteks Enthoo Luxe; Sennheiser GSX 1000; Sennheiser Game Zero; Logitech G13; Logitech G502 Spectrum; Roccat Taito Control; Windows 10 x64

Posted 03/08/2016 09:22 PM   
anyone running the division in nvidia surround with this driver? Do you have good fps? Stuttering when using SLI?
anyone running the division in nvidia surround with this driver? Do you have good fps? Stuttering when using SLI?

Posted 03/08/2016 09:41 PM   
[quote="WallsBalls"]I have had complete system crash and now I can't even boot to Windows keep getting different q codes coming up or try to get int bios and just getting black screen! Intel i7 6700k Asus ROG maximus viii hero 16gb ram corsair dominator platinum Asus GeForce 970gtx strix 4gb Windows 10 pro 64bit[/quote] == Skylake Bug.
WallsBalls said:I have had complete system crash and now I can't even boot to Windows keep getting different q codes coming up or try to get int bios and just getting black screen!

Intel i7 6700k
Asus ROG maximus viii hero
16gb ram corsair dominator platinum
Asus GeForce 970gtx strix 4gb
Windows 10 pro 64bit


== Skylake Bug.

MSI N770 TF 4GD5/OC
4790K@4.4Ghz all cores
Prime95 FFT 768K stable !!! Lol
All C-states w/o freeze !!! double Lol
ASROCK Z97m Pro4
Vengeance DDR3 1600 CL10 CR 1T
Corsair TX650 V2 PSU
Windows 10 1703 build 16215.1000

Posted 03/08/2016 10:06 PM   
[quote="HBUG"][quote="Juni0rM1nt"]Looks like they are going to release a new WHQL driver today, version 364.51[/quote] 364.51 is a beta driver that has been on the driver download page since 7:00 a.m. this morning pacific west coast time. [url]http://www.nvidia.com/download/driverResults.aspx/99506/en-us[/url][/quote] Still not available for windows 10 though.
HBUG said:
Juni0rM1nt said:Looks like they are going to release a new WHQL driver today, version 364.51


364.51 is a beta driver that has been on the driver download page since 7:00 a.m. this morning pacific west coast time.
http://www.nvidia.com/download/driverResults.aspx/99506/en-us




Still not available for windows 10 though.

Posted 03/08/2016 10:15 PM   
[quote="DrunkMonk74"]Personally running Win10x64, Titan X, single monitor, single GPU, I've had no issues. Used DDU to clean out the last driver, then ran a custom install on 364.47 and installed the driver and PhysicsX only. For me the best driver that's been released in a long time. Games I've tested, Rainbow 6, BF4, BFBC2, Insurgency and Squad. All have great stable frame rate, (most of them at 144 to match monitor refresh rate). This will be my new roll back to driver when I have any issues with future releases. Shame it's not that great an experience for everyone.[/quote] Since nvidia officially pulled this crap off . It is not a great experience for everyone.
DrunkMonk74 said:Personally running Win10x64, Titan X, single monitor, single GPU, I've had no issues. Used DDU to clean out the last driver, then ran a custom install on 364.47 and installed the driver and PhysicsX only. For me the best driver that's been released in a long time. Games I've tested, Rainbow 6, BF4, BFBC2, Insurgency and Squad. All have great stable frame rate, (most of them at 144 to match monitor refresh rate).

This will be my new roll back to driver when I have any issues with future releases.

Shame it's not that great an experience for everyone.


Since nvidia officially pulled this crap off . It is not a great experience for everyone.

AMD FX 8350@4.8 Ghz, GA 890 FXA UD5, Seasonic M12D 750W, Corsair and Kingston 12 Gigabytes 1600 Mhz RAM@ 1700 Mhz, Gainward GTX 580@1050 mhz(will get to the max , 1100-1200) 3072MB "Phantom"@Half DX 12 driver, Corsair SSD 250 , 12 TB HDD, Asus Xonar D2X PCIE, WIN 10 PRO 64 bit always up to date, Cooler master HAF 932, Cooler master Nepton 240m,CPU temp: idle 21 C , Full 45 C , 2x 2560*1600 Display, Mouse : Razer Abyssus 1800 , Razer DeathAdder Chroma, Mouse pad : Steelseries QCK+, Corsair Vengeance 1500 Dolby 7.1 USB Gaming Headset, Corsair Flash Voyager GS USB 3.0 64GB Flash Drive https://www.youtube.com/user/siriq111

Posted 03/08/2016 10:20 PM   
[quote="PHIBALNATION"][quote="HBUG"][quote="Juni0rM1nt"]Looks like they are going to release a new WHQL driver today, version 364.51[/quote] 364.51 is a beta driver that has been on the driver download page since 7:00 a.m. this morning pacific west coast time. [url]http://www.nvidia.com/download/driverResults.aspx/99506/en-us[/url][/quote] Still not available for windows 10 though.[/quote] Try it here: http://www.guru3d.com/files-details/geforce-364-51-beta-driver-download.html
PHIBALNATION said:
HBUG said:
Juni0rM1nt said:Looks like they are going to release a new WHQL driver today, version 364.51


364.51 is a beta driver that has been on the driver download page since 7:00 a.m. this morning pacific west coast time.
http://www.nvidia.com/download/driverResults.aspx/99506/en-us




Still not available for windows 10 though.


Try it here: http://www.guru3d.com/files-details/geforce-364-51-beta-driver-download.html

AMD FX 8350@4.8 Ghz, GA 890 FXA UD5, Seasonic M12D 750W, Corsair and Kingston 12 Gigabytes 1600 Mhz RAM@ 1700 Mhz, Gainward GTX 580@1050 mhz(will get to the max , 1100-1200) 3072MB "Phantom"@Half DX 12 driver, Corsair SSD 250 , 12 TB HDD, Asus Xonar D2X PCIE, WIN 10 PRO 64 bit always up to date, Cooler master HAF 932, Cooler master Nepton 240m,CPU temp: idle 21 C , Full 45 C , 2x 2560*1600 Display, Mouse : Razer Abyssus 1800 , Razer DeathAdder Chroma, Mouse pad : Steelseries QCK+, Corsair Vengeance 1500 Dolby 7.1 USB Gaming Headset, Corsair Flash Voyager GS USB 3.0 64GB Flash Drive https://www.youtube.com/user/siriq111

Posted 03/08/2016 10:22 PM   
  37 / 89    
Scroll To Top