Diagonal Screen Tearing Issues on GTX 860M/870M/960M/965M/970M/980M...
  42 / 42    
[quote="PANDAriusz"][quote="sharedaccount874"]I am pretty sure this SHIM_MCCOMPAT_INTEGRATED business disables use of the nvidia GPU for that game. It causes FF14 to run at about 17 fps here, for example.[/quote] Yes You are most likely right. I noticed some FPS drops too. Try setting [i]Power management mode:[/i] Prefer maximum performace [i]Enable application for Optimus :[/i] ... SHIM_RENDERGIN_MODE_AUTO_SELECT and [i]Optimus flags for enabled applications:[/i] default ( in my case ...AUTO_SELECT) [i]Maximum pre-rendered frames:[/i] Use the 3D application settings ( If I set pre- rendered frames to 1 the "microstuttering" is gone but I get diagonal tearing again so it's possible that this can fix tearing too.) I'm not sure but my eye notice "improvements".[/quote] That's because both the optimus values change depending on what processor you chose globally in the control panel. When you have SHIM_MCCOMPAT on Enabled it sets it to the Nvidia processor (which is what tears). The optimus flags value seems to just copy the first optimus value. So either way that's why you've been getting fps drops. As for the quiet mode one, i haven't seen any difference with it on or off.
PANDAriusz said:
sharedaccount874 said:I am pretty sure this SHIM_MCCOMPAT_INTEGRATED business disables use of the nvidia GPU for that game. It causes FF14 to run at about 17 fps here, for example.


Yes You are most likely right. I noticed some FPS drops too.
Try setting
Power management mode: Prefer maximum performace
Enable application for Optimus : ... SHIM_RENDERGIN_MODE_AUTO_SELECT
and
Optimus flags for enabled applications: default ( in my case ...AUTO_SELECT)
Maximum pre-rendered frames: Use the 3D application settings
( If I set pre- rendered frames to 1 the "microstuttering" is gone but I get diagonal tearing again so it's possible that this can fix tearing too.)

I'm not sure but my eye notice "improvements".


That's because both the optimus values change depending on what processor you chose globally in the control panel.
When you have SHIM_MCCOMPAT on Enabled it sets it to the Nvidia processor (which is what tears). The optimus flags value seems to just copy the first optimus value.

So either way that's why you've been getting fps drops. As for the quiet mode one, i haven't seen any difference with it on or off.

Posted 10/20/2017 01:15 AM   
THE SOLUTION THAT WORKED FOR ME IN WINDOWS 10 BUILD 1703 (CREATORS UPDATE): This is how I solved the problem in my sister's laptop. 1. I made a clean installation of the latest drivers (yeah, pretty mainstream), currently having the 387.xx drivers for GTX 1060 laptop version. 2. Open the "Nvidia Graphics Panel" and enable: "FXAA - ON" "VSYNC - ON" "Triple buffer - ON" 3. Checked that you have installed the "Windows Creators Update". Press "Win + I" and click on "Gaming", the button has the XBOX logo on it. 4. Check the box "Show Game bar when I play games Microsoft has verified" and also "Enable Gaming Mode". 5. Enter the game, in my case, it was "The Evil Within", and do some random 360º camera moves and check if the problem it's solved. For me, I had the diagonal tearing like 1 second, and then it disappeared all of the sudden. After restarting the game, the 1 second problem didn't happen again. 6. PD: If you still got the tearing, press "Alt + Enter" to switch the game to "Windowed Mode", and then press again the same key combination, to go again to "Full Screen". If the problem got solved, restart the game, but this time, don't touch the graphics setting. I'm not 100% sure if this works on all the other games out there, but sure works for "The Evil Within 1". Cheers.
THE SOLUTION THAT WORKED FOR ME IN WINDOWS 10 BUILD 1703 (CREATORS UPDATE):

This is how I solved the problem in my sister's laptop.

1. I made a clean installation of the latest drivers (yeah, pretty mainstream), currently having the 387.xx drivers for GTX 1060 laptop version.

2. Open the "Nvidia Graphics Panel" and enable:
"FXAA - ON"
"VSYNC - ON"
"Triple buffer - ON"

3. Checked that you have installed the "Windows Creators Update". Press "Win + I" and click on "Gaming", the button has the XBOX logo on it.

4. Check the box "Show Game bar when I play games Microsoft has verified" and also "Enable Gaming Mode".

5. Enter the game, in my case, it was "The Evil Within", and do some random 360º camera moves and check if the problem it's solved. For me, I had the diagonal tearing like 1 second, and then it disappeared all of the sudden. After restarting the game, the 1 second problem didn't happen again.

6. PD: If you still got the tearing, press "Alt + Enter" to switch the game to "Windowed Mode", and then press again the same key combination, to go again to "Full Screen". If the problem got solved, restart the game, but this time, don't touch the graphics setting.

I'm not 100% sure if this works on all the other games out there, but sure works for "The Evil Within 1".

Cheers.

Posted 10/21/2017 10:38 AM   
Download Nvidia Inspector and set the refresh rate to Adaptive. I had the same issue and this fixed it. I haven't had a screen tear since.
Download Nvidia Inspector and set the refresh rate to Adaptive. I had the same issue and this fixed it. I haven't had a screen tear since.

Posted 10/26/2017 03:28 AM   
Hey guys! I have a great news!!(for me at least). After installing windows 10 Fall creator's update.... Guess what?! No more Diagonal Tearing! I did update my AW13R3 BIOS as well today, but I doubt it fixed the diagonal tearing. Anyway, now I can play Wolfenstein The Old Blood without those annoying Diagonal Tearing! But now I have horrible horizontal screen tearing in PUBG, the diagonal one was less noticeable. Is there any way to make the diagonal tearing comes back? lol Update: Dota 2 still has diagonal tearing on windowed/boarderless mode(but not full screen).
Hey guys! I have a great news!!(for me at least).
After installing windows 10 Fall creator's update.... Guess what?!



No more Diagonal Tearing!


I did update my AW13R3 BIOS as well today, but I doubt it fixed the diagonal tearing.

Anyway, now I can play Wolfenstein The Old Blood without those annoying Diagonal Tearing!
But now I have horrible horizontal screen tearing in PUBG, the diagonal one was less noticeable. Is there any way to make the diagonal tearing comes back? lol


Update: Dota 2 still has diagonal tearing on windowed/boarderless mode(but not full screen).

Desktop:
Leadtek GTX 1070 FE, I7 4790k, 8GB RAM Corsair LP, ASUS Z97I-plus, Corsair RM550, Windows 10-64bit, Monitor: Benq XL2420G

Notebook:
AW13 R3, GTX 1060, i7 7700hq, 16gb RAM, 256GB PCIE NVME SSD, 1080p IPS Display

Posted 11/04/2017 08:20 AM   
I have the same problem
I have the same problem

Posted 11/06/2017 07:11 PM   
So, any update on this? Did Microsoft/Nvidia/whoever-should-have-been-responsible-for-a-fix just give up now?
So, any update on this? Did Microsoft/Nvidia/whoever-should-have-been-responsible-for-a-fix just give up now?

Posted 12/04/2017 05:19 PM   
Windows 10 Fall Creators Update (10.0.16299.125) completely fixes the problem on my PC now. (My PC is the Dell Inspiron 7559 with GTX 960M) You can force an update by downloading the tool at https://www.microsoft.com/en-us/software-download/windows10 I can't see any diagonal tearing in D3D9, D3D11, OpenGL, or Vulkan games at all.
Windows 10 Fall Creators Update (10.0.16299.125) completely fixes the problem on my PC now. (My PC is the Dell Inspiron 7559 with GTX 960M)

You can force an update by downloading the tool at https://www.microsoft.com/en-us/software-download/windows10

I can't see any diagonal tearing in D3D9, D3D11, OpenGL, or Vulkan games at all.

Posted 12/13/2017 10:20 PM   
double post, delete me
double post, delete me

Posted 12/13/2017 10:22 PM   
  42 / 42    
Scroll To Top