Ge Force Experience takes at least five minutes to open
  3 / 4    
[quote="newfolder77"][quote="E-Block"][quote="newfolder77"]same problem here, turned it out it was a conflict with a game tuning app, in my case it was the Asus Gamefirst. Try uninstalling apps like that, worked for me.[/quote] I've got gamefirst as well, and I disabled it (didn't uninstall) because of an issue with minecraft. Should I uninstall it for this issue?[/quote] yes, if you're not actually using it then uninstall it, it won't affect anything in your system negatively anyway.[/quote] Well, I finally got around to uninstalling it, and it's solved! Thanks a bunch!
newfolder77 said:
E-Block said:
newfolder77 said:same problem here, turned it out it was a conflict with a game tuning app, in my case it was the Asus Gamefirst. Try uninstalling apps like that, worked for me.

I've got gamefirst as well, and I disabled it (didn't uninstall) because of an issue with minecraft. Should I uninstall it for this issue?


yes, if you're not actually using it then uninstall it, it won't affect anything in your system negatively anyway.

Well, I finally got around to uninstalling it, and it's solved! Thanks a bunch!

#31
Posted 12/03/2015 09:59 PM   
Registered just to chime in and confirm that uninstalling GameFirst III fixed the problem. Anybody know which version of GameFirst they are/were running? I believe I uninstalled the latest version (ROG GameFirst III V1.00.20).
Registered just to chime in and confirm that uninstalling GameFirst III fixed the problem. Anybody know which version of GameFirst they are/were running? I believe I uninstalled the latest version (ROG GameFirst III V1.00.20).

#32
Posted 12/04/2015 04:53 AM   
Same here! Version 2.5. opens immediately while version 2.7 sure takes its time in the loading screen and then in the black window before it opens. So I'm guessing it's the new version? I also saw some people saying that Asus Gamefirst is causing this while others have this problem wether they have that program or not. I have an Asus G751JY so should I uninstall Game first? Will it cause any problems? Why didn't this occur with the older versions too? Let's hope a new update will fix this and that we won't have to go through this ever again.
Same here! Version 2.5. opens immediately while version 2.7 sure takes its time in the loading screen and then in the black window before it opens. So I'm guessing it's the new version? I also saw some people saying that Asus Gamefirst is causing this while others have this problem wether they have that program or not. I have an Asus G751JY so should I uninstall Game first? Will it cause any problems? Why didn't this occur with the older versions too? Let's hope a new update will fix this and that we won't have to go through this ever again.

#33
Posted 12/04/2015 08:20 PM   
Yes but its been way to long, you would think Nvidia wouldve at least announced something by now. But its probably a asus blames geforce experiance/nvidia blames gamefirst.
Yes but its been way to long, you would think Nvidia wouldve at least announced something by now. But its probably a asus blames geforce experiance/nvidia blames gamefirst.

#34
Posted 12/05/2015 05:20 AM   
I don't have Gamefirst but I'm still having this issue, Geforce Experience is very slow to start and respond and Shadowplay won't activate even after re-starting services etc & re-install. I had no problems with the previous version, Nvidia please fix!!
I don't have Gamefirst but I'm still having this issue, Geforce Experience is very slow to start and respond and Shadowplay won't activate even after re-starting services etc & re-install.

I had no problems with the previous version, Nvidia please fix!!

MSI G4 GTX980 x2 SLI @1455Mhz (EK Water Cooled)
i7-4930K - 4.3Ghz @1.37v (EK Water Cooled)
Asus Rampage IV Black Edition
32Gb Kingston Hyp-Beast @2133Mhz
Corsair AX860i
Windows 10 Pro
2xSSD 485Gb Raid0
Sony KD55-X8505B (3840x2160)

#35
Posted 12/06/2015 10:05 PM   
[quote="elisest"]I don't have Gamefirst but I'm still having this issue, Geforce Experience is very slow to start and respond and Shadowplay won't activate even after re-starting services etc & re-install. I had no problems with the previous version, Nvidia please fix!![/quote] Same problem. Don't have GameFirst and don't use Killer Network. Slow startup and no ShadowPlay.
elisest said:I don't have Gamefirst but I'm still having this issue, Geforce Experience is very slow to start and respond and Shadowplay won't activate even after re-starting services etc & re-install.

I had no problems with the previous version, Nvidia please fix!!


Same problem. Don't have GameFirst and don't use Killer Network. Slow startup and no ShadowPlay.

Intel Core i7 4770k @ 4,2GHz
MSI Z87M Gaming
SLI MSI GTX 770 Twin Frozr Gaming OC 2 GB
8GB G.Skill Sniper 2133MHz
Watercooled By EKWB
Corsair Force 3 60GB - Windows 10
Corsair Force 3 120GB Steam Library
Corsair Carbide Air 540
Corsair AX750
Corsair Vengeance 1500
Benq X2420T
SteelSeries Kinzu+SteelSeries QcK

#36
Posted 12/08/2015 01:27 PM   
Hello all, Wanted to quickly chime in on my SOLUTION TO THIS! I have a ASUS ROG G752, Skylake i7 6700, GTX-970 3gb, 16gb ram, Windows 10, same deal, program wouldn't open faster than 10 minutes on a 2gb/s Samsung SSD. [b]So first, I updated from 2.7.4 to 2.8.0 Beta Second, Opened up Task manager > services and found "GameFirst" or something similar with an indescript icon. End the "GameFirst" service. Ended GeForce Exp. and reopened. [/b] Viola. Opens in maybe 8 seconds now. HOPE THIS HELPS
Hello all,

Wanted to quickly chime in on my SOLUTION TO THIS!

I have a ASUS ROG G752, Skylake i7 6700, GTX-970 3gb, 16gb ram, Windows 10, same deal, program wouldn't open faster than 10 minutes on a 2gb/s Samsung SSD.

So first, I updated from 2.7.4 to 2.8.0 Beta
Second, Opened up Task manager > services and found "GameFirst" or something similar with an indescript icon.
End the "GameFirst" service.
Ended GeForce Exp. and reopened.

Viola. Opens in maybe 8 seconds now.

HOPE THIS HELPS

#37
Posted 12/09/2015 10:38 AM   
[b]Uninstalling Asus Game First resolved half of my problem.[/b] Thank you for that tip! I am now able to launch Geforce Experience, but my games are all still marked as, "Game cannot be optimized." There is a beta version of GFE available if you check the bets option in the update section of Preferences. This did not resolve my optimization issue though. Note: The non-beta version still opens normally wihtout Game First installed. The version of GFE that came with 358.87 had no issues on my system: Asus Maximus VIII Impact (mini-ITX), i7 6700K, Asus Strix GTX 980 Ti OC. -Doc
Uninstalling Asus Game First resolved half of my problem. Thank you for that tip!

I am now able to launch Geforce Experience, but my games are all still marked as, "Game cannot be optimized."

There is a beta version of GFE available if you check the bets option in the update section of Preferences. This did not resolve my optimization issue though. Note: The non-beta version still opens normally wihtout Game First installed.

The version of GFE that came with 358.87 had no issues on my system:

Asus Maximus VIII Impact (mini-ITX), i7 6700K, Asus Strix GTX 980 Ti OC.

-Doc

#38
Posted 12/09/2015 09:40 PM   
[b]Problem:[/b] GeForce Experience [i]takes over 5 minutes to open on ASUS computer: I didn't have a problem until after recently updating my NVidia drivers and then it took GeForce Experience well over 5 minutes to open on my ASUS ROG computer with Windows 10. Tried several fixes but no success until I uninstalled the ASUS program [/i]ROG Game First III.[i] It won't show up in Programs & Features like other programs though. To uninstall it you need to go to Apps > ASUS > Uninstall ROG Game First III and then reboot as instructed. [/i][b]Fix for ASUS computers [/b][i](works for Windows 10 and probably Windows 8 too): [b]Go to [/i]Apps > ASUS > Uninstall ROG Game First III [i]and then reboot as instructed[/i]. [/b]
Problem: GeForce Experience takes over 5 minutes to open on ASUS computer:

I didn't have a problem until after recently updating my NVidia drivers and then it took GeForce Experience well over 5 minutes to open on my ASUS ROG computer with Windows 10. Tried several fixes but no success until I uninstalled the ASUS program
ROG Game First III. It won't show up in Programs & Features like other programs though. To uninstall it you need to go to Apps > ASUS > Uninstall ROG Game First III and then reboot as instructed.

Fix for ASUS computers (works for Windows 10 and probably Windows 8 too):

Go to
Apps > ASUS > Uninstall ROG Game First III and then reboot as instructed.

#39
Posted 12/30/2015 03:09 AM   
On my Windows 10 build, I have an Asus Maximus VIII Hero and can also confirm that removing GameFirst is a potential fix. On my Windows 7 build however, I have an Asus Z97 Deluxe, which doesn't even support GameFirst, and I still have this issue. It's actually much, much worse than virtually everyone here has described. It takes [b][u]over 25 minutes[/u][/b] to load the main GFE window, and [b][u]over an hour and a half[/u][/b] to check for updates. <Nvidia_devs> I only have 20 games or so installed on this machine.. </Nvidia_devs> The issue started happening sometime during the summer of 2015. Whether that corresponds with a particular GFE release, I don't know. I suppose GFE could be incompatible with some other Asus utility as well, not just GameFirst..
On my Windows 10 build, I have an Asus Maximus VIII Hero and can also confirm that removing GameFirst is a potential fix.

On my Windows 7 build however, I have an Asus Z97 Deluxe, which doesn't even support GameFirst, and I still have this issue. It's actually much, much worse than virtually everyone here has described. It takes over 25 minutes to load the main GFE window, and over an hour and a half to check for updates. <Nvidia_devs> I only have 20 games or so installed on this machine.. </Nvidia_devs> The issue started happening sometime during the summer of 2015. Whether that corresponds with a particular GFE release, I don't know. I suppose GFE could be incompatible with some other Asus utility as well, not just GameFirst..

#40
Posted 12/30/2015 06:52 PM   
Windows 10 GTX 970M Asus Gaming Laptop This was driving me crazy. Thank you to whoever discovered the ROG Game First 3 uninstall fix. That's all it took. Now Geforce Experience opens right up and shadowplay works as advertised. Thanks again.
Windows 10
GTX 970M
Asus Gaming Laptop

This was driving me crazy. Thank you to whoever discovered the ROG Game First 3 uninstall fix. That's all it took. Now Geforce Experience opens right up and shadowplay works as advertised.

Thanks again.

#41
Posted 01/13/2016 02:00 PM   
Windows 10 Maximus VIII Hero GTX 970 For the problem with GeForce Experience takes over 5 minutes to run it I have uninstall ROG Game First III and this fix work for me too. Thank you very much ! But all my games are always marked "Game cannot be optimized."
Windows 10
Maximus VIII Hero
GTX 970

For the problem with GeForce Experience takes over 5 minutes to run it
I have uninstall ROG Game First III and this fix work for me too.
Thank you very much !

But all my games are always marked "Game cannot be optimized."

#42
Posted 02/06/2016 12:59 AM   
Same problem here. Tried everything in this thread and suggestions from other forums as well but no luck. Can we please get an official word on this issue??? NVIDIA Hello? Edit: I just realized that the program actually was running but the window was somehow hidden. I used this fix: [quote="bleedingfang"]I was having the same issue until some of the above comments gave me an idea so it's kinda fixed now. Try these steps after opening up the GeForce Experience from the taskbar icon: 1. Move your mouse over the GeForce Experience taskbar button until it shows the preview. 2. Right click on the preview and click on move. 3. [Important: Do not move your mouse after the previous step] You should be seeing a "move" cursor. Now press the left button on your keyboard a couple of times. 4. Now move your mouse around until you see the GeForce Experience window. 5. Click again to escape the Move-Window mode.
Same problem here.

Tried everything in this thread and suggestions from other forums as well but no luck.

Can we please get an official word on this issue??? NVIDIA Hello?

Edit:
I just realized that the program actually was running but the window was somehow hidden.
I used this fix:

bleedingfang said:I was having the same issue until some of the above comments gave me an idea so it's kinda fixed now.

Try these steps after opening up the GeForce Experience from the taskbar icon:
1. Move your mouse over the GeForce Experience taskbar button until it shows the preview.
2. Right click on the preview and click on move.
3. [Important: Do not move your mouse after the previous step] You should be seeing a "move" cursor. Now press the left button on your keyboard a couple of times.
4. Now move your mouse around until you see the GeForce Experience window.
5. Click again to escape the Move-Window mode.

#43
Posted 02/08/2016 06:53 PM   
This one I used to use a while ago. In the control panel. I messed with this a bit and got some results. Manage 3D settings> Global settings> multi-display/mixed-GPU acceleration Have you tried changing to compatibility performance mode? (edit: make sure you save after you select this.) I say this now cuz when I open it the splash will be on one screen and the actual geforce experience will be on the other monitor. I think it wants to display on another monitor but I could be wrong. I had this issue a while back before I got the second screen but i'm not sure if I got it to show before it was put in. The only other thing that might help would be to make sure the shortcut was set to run as administrator. Sorry if I couldn't be of any more help.
This one I used to use a while ago.

In the control panel. I messed with this a bit and got some results.

Manage 3D settings> Global settings> multi-display/mixed-GPU acceleration

Have you tried changing to compatibility performance mode? (edit: make sure you save after you select this.)

I say this now cuz when I open it the splash will be on one screen and the actual geforce experience will be on the other monitor.

I think it wants to display on another monitor but I could be wrong.

I had this issue a while back before I got the second screen but i'm not sure if I got it to show before it was put in.

The only other thing that might help would be to make sure the shortcut was set to run as administrator.

Sorry if I couldn't be of any more help.

If you have Driver, GeForce Experience or Shadowplay "Share(BETA)" problems click here> DDU Click here> MY GeForce Experience "SHARE" GUIDE to find your recording and streaming settings. -MY PC 'HARDWARE' (software) INFORMATION-> || EVGA PRECISION XOC x64 v6.2.2.0 || Eset Nod32 Antivirus 10.1.235.0 || HWiNFO64 v5.59-3265 || running nvidia driver 388.31 || geforce experience version 3.11.0.73 beta ||NVIDIA 3D Vision 2 Wireless Glasses Kit Model 942-11431-0007-001 || OS: WINDOWS 10 Home 64 bit version 1709 (OS build-16299.64)|| Logitech Gaming Software v8.96.81 (mouse, keyboard and headset) || MainBoard: MSI Z77A-G45 Thunderbolt Intel ATX UEFI AND LEGACY BIOS {BIOS Version/Date American Megatrends Inc. V10.6, 9/29/2013} (Memory Fast Boot off) (Limited Windows 8 Feature enabled Bios) w/ Realtec HD Audio onboard v6.0.1.8036 || CPU: INTEL(R) CORE(TM) i7 3770k Ivy Bridge @ 3.5 ghz - oc genie @ 4.2ghz COOLERMASTER V6 GT Heatsink cooling solution || Ram: 32 GB Patriot Intel memory @ 1600 Ghz x.m.p. profile || 2x EVGA© backplates 100-BP-0972-B9 on my 2x GPU-video cards: EVGA© GeForce GTX 970 04G-P4-2978-KR 4GB FTW GAMING ACX 2.0 Silent Cooling Graphics Card (sli enabled)EVGA Pro SLI Bridge V2 (2-Way Long) Model 100-2W-0023-LR || FIRESRIKE score=16249/Time Spy=6734 || PSU: PC Power&Cooling 950w silencer mkII 80+silver || Drive 1: ADATA SX900 223 Gb SSD BOOT RECORD (SATA3) || Drive 2: CORSAIR FORCE GS 238 Gb SSD BACKUP SYS IMG || Drive 3: SAMSUNG 840 PRO 238 Gb SSD GAME EXE. FILES || Drive 4: SEAGATE ST2000M001-1CH164 2 Tb HDD SHADOWPLAY SAVE FILES || Drive 5: SAMSUNG 840 EVO 1 Tb SSD for Shadowplay Temp files, future games and software || blue yeti mic || logitech g502 mouse, Logitech G910 Orion Spark RGB Mechanical Gaming Keyboard, G933 headset and C615 HD Webcam || Case: COOLERMASTER HAF 932(FULL TOWER)3.0usb || Dual Monitors: Main (gaming only) ASUS VG248QE 24" 1ms 144Hz 1920x1080p on a DVI-I port DUAL LINK + Second monitor (w/all media web and apps) ASUS VH232H 23" 5ms Widescreen Full HD 1080p LCD Monitor 1920x1080 resolution @ 60Hz connected via DVI-D single port || Sage's Twitch and YouTube Channel (still working 2x: EVGA® gtx 660 SC 2Gb with sli bridge ready for a new home :D)Free Firestrike/Time Spy Demo and Benchmark Download ImageImage

#44
Posted 02/09/2016 04:24 AM   
[quote="JSiepmann"][b]Problem:[/b] GeForce Experience [i]takes over 5 minutes to open on ASUS computer: I didn't have a problem until after recently updating my NVidia drivers and then it took GeForce Experience well over 5 minutes to open on my ASUS ROG computer with Windows 10. Tried several fixes but no success until I uninstalled the ASUS program [/i]ROG Game First III.[i] It won't show up in Programs & Features like other programs though. To uninstall it you need to go to Apps > ASUS > Uninstall ROG Game First III and then reboot as instructed. [/i][b]Fix for ASUS computers [/b][i](works for Windows 10 and probably Windows 8 too): [b]Go to [/i]Apps > ASUS > Uninstall ROG Game First III [i]and then reboot as instructed[/i]. [/b][/quote] Did this while GeForce Experience was opening and BOOM it works. Thanks for the info!
JSiepmann said:Problem: GeForce Experience takes over 5 minutes to open on ASUS computer:

I didn't have a problem until after recently updating my NVidia drivers and then it took GeForce Experience well over 5 minutes to open on my ASUS ROG computer with Windows 10. Tried several fixes but no success until I uninstalled the ASUS program
ROG Game First III. It won't show up in Programs & Features like other programs though. To uninstall it you need to go to Apps > ASUS > Uninstall ROG Game First III and then reboot as instructed.

Fix for ASUS computers (works for Windows 10 and probably Windows 8 too):

Go to
Apps > ASUS > Uninstall ROG Game First III and then reboot as instructed.


Did this while GeForce Experience was opening and BOOM it works. Thanks for the info!

#45
Posted 02/10/2016 02:01 AM   
  3 / 4    
Scroll To Top