Call of Cthulhu corrupted graphics - Windows 7 fix?
  1 / 2    
Hello! There's a perfect horror game - Call of Cthulhu Dark Corners of the Earth. It performs well under win 7 except for one thing - completely corrupted graphics. Here how it looks under windows XP: [img]http://i.playground.ru/i/16/06/74/00/pix/image.jpg[/img] and here's windows 7: [img]http://i.playground.ru/i/26/06/74/00/pix/image.jpg[/img] What I'd like to ask is: even if it's related to DX9 implementation of Win 7, is it possible by nvidia to fix rendering with some hookups or I dunno what with just their drivers? That would be just awesome :) Please post if you are curious about if this beautiful game is possible to be fixed under win 7 too.
Hello!

There's a perfect horror game - Call of Cthulhu Dark Corners of the Earth. It performs well under win 7 except for one thing - completely corrupted graphics.
Here how it looks under windows XP:
Image

and here's windows 7:
Image

What I'd like to ask is: even if it's related to DX9 implementation of Win 7, is it possible by nvidia to fix rendering with some hookups or I dunno what with just their drivers? That would be just awesome :)

Please post if you are curious about if this beautiful game is possible to be fixed under win 7 too.

#1
Posted 10/11/2015 03:44 PM   
Disable HDR/Bloom and add 8x AA. It's not the drivers, it's your game settings.
Disable HDR/Bloom and add 8x AA.
It's not the drivers, it's your game settings.

Facebook PC parts Trade/Sales page

Help fight Cancer, Diabetes, Neuro-degenerative, and other disease's while you sleep!

MS-Physics (Thermal Dynamics)/BA-IT/BS-Electronic Engineering
Asus,HP/CQ,MSI,Toshiba mobile service center

My main rig:
OS- Win8.1 x64
CPU- i7-4790k @ 4.8Ghz 1.289v (Turbo OFF) Liquid Cooled
RAM-16GB TEAM Xtreme DDR3 @ 2400Mhz (9-12-11-30)1.625v
Motherboard- Gigabyte Z97X Gamer GT
Main Graphics- 2-way SLI EVGA GTX1070
Power Supply- Corsair RM-1000i
3X Surround Samsung 27" (7680 x 1440p)

Radio Server/ Scientific Simulator
CPU1- Xeon X5650 @ 3.2Ghz (locked)
CPU2- Xeon X5650 @ 3.2Ghz (locked)
Motherboard- Asus Z8PE-D12X
RAM- G-Skill RipJaws 24Gb (6x4Gb) DDR3 @ 1600Mhz Cas8
Graphics- GTX780 + GTX560
HDDs- WD RED 3TB (3x3TB) Raid 0= 9TB +1 3Tb back up
PSU- Corsair CX750M
Monitor- 768p Dell P.O.S

STILL working Nvidia GPUs-FX5200,FX5700,6800GT,7900GT(x2),8800GTS(x2),9800GTX,GTX275(x2),GTX285(x2),GTX295(x2),GTX470(x3),GTX480,GTX660ti(x3)GTX770(x3)HWbot Overclocking results

OVERCLOCKING LEAGUE RANKING
Worldwide: #1771 out of 51912
Extreme League: #1255 out of 2826
National: #213 of 20048 in United States
Team: #70 of 3166 in Overclock.net

#2
Posted 10/11/2015 04:05 PM   
[quote="MrInfinit3"]Disable HDR/Bloom and add 8x AA. It's not the drivers, it's your game settings.[/quote] Please, use ur brain before posting.
MrInfinit3 said:Disable HDR/Bloom and add 8x AA.
It's not the drivers, it's your game settings.

Please, use ur brain before posting.

#3
Posted 10/11/2015 06:11 PM   
It will help if we knew your specs? and driver you're using. Also i have the game right next to me, i will check the game in about an hour and let you know how it works out. But can you list your video card and drive your're using?
It will help if we knew your specs? and driver you're using.

Also i have the game right next to me, i will check the game in about an hour and let you know how it works out. But can you list your video card and drive your're using?

#4
Posted 10/11/2015 06:47 PM   
Windows 7 1920x1080 with aax4. Looks the same without AA. Looks good to me though, just lots of bloom effects which i don't mind. Not sure why it looks like that on XP though. [img]http://s28.postimg.org/bdh5bs1rh/AACC.png[/img] [img]http://s28.postimg.org/owxzhhfql/AACC2.png[/img]
Windows 7 1920x1080 with aax4. Looks the same without AA. Looks good to me though, just lots of bloom effects which i don't mind. Not sure why it looks like that on XP though.
Image
Image

#5
Posted 10/11/2015 08:27 PM   
Copy "Resources" folder from this archive - [url=https://mega.nz/#!FABG3abL!hdNP35xYrYsoQxQ4gx5MSTwm0KJIvrunkU6meYzQRqs]Call_of_Cthulhu_NVIDIA_BUGFIX.zip[/url] in the game folder.
Copy "Resources" folder from this archive - Call_of_Cthulhu_NVIDIA_BUGFIX.zip in the game folder.

ASUS P8Z68-V PRO/GEN3 / 2550k@4.8Ghz / 8GB DDR III / Gigabyte GTX 970 WindForce OC / Chieftec SPS-850C 850W / Windows 10 Pro x64

#6
Posted 10/11/2015 10:31 PM   
[quote="Guzz"]Copy "Resources" folder from this archive - [url=https://mega.nz/#!klcjxR7I!OgUAhCkyAyFLdCm9Lve5EmkLkT08sw3y1_uB7A3TRO0]Call_of_Cthulhu_NVIDIA_BUGFIX.7z[/url] in the game folder.[/quote] it removes the bloom :( thanks, but i like my bloom effects. so im going keep it the way it is. OP might enjoy it though :)
Guzz said:Copy "Resources" folder from this archive - Call_of_Cthulhu_NVIDIA_BUGFIX.7z in the game folder.


it removes the bloom :( thanks, but i like my bloom effects. so im going keep it the way it is. OP might enjoy it though :)

#7
Posted 10/11/2015 10:54 PM   
[quote="GMAlonzo"] It will help if we knew your specs? and driver you're using. Also i have the game right next to me, i will check the game in about an hour and let you know how it works out. But can you list your video card and drive your're using?[/quote] I'm on: Win 7 x64 sp1 GTX 970 driver ver. 355.98 It seems like this game just discards rendering of objects on long distance like the sky, so it's completely white. Also there's a moment in gameplay which is impossible to pass because of this (u have to kill someone on long distance while u see nothing there) This is a common problem on Win Vista/7, because this game is pretty old. Probably it even exists with AMD cards and probably it's just the way DX9 rendering in Win7 differs to the Win XP one. As an example I know that the same DX9 function Blt has hardware acceleration under XP while it doesn't under Vista/7 (and probably newer OSes) so it may cause the "pixelation" of some stuff. It's a very known bug in this game and there's no way to completely fix graphics by any settings or compatibility modes from what I was able to google. I realise that it's pretty old game. I realise that it's definitely not the most popular one. And I'm not even sure if it's possible to fix this issue with some driver hacks. But I just thought that why not to ask here? Maybe some of nVidia devs that are fans of this game will pay attention and fix it somehow (in my dreams :D )
GMAlonzo said:
It will help if we knew your specs? and driver you're using.

Also i have the game right next to me, i will check the game in about an hour and let you know how it works out. But can you list your video card and drive your're using?

I'm on:
Win 7 x64 sp1
GTX 970
driver ver. 355.98

It seems like this game just discards rendering of objects on long distance like the sky, so it's completely white. Also there's a moment in gameplay which is impossible to pass because of this (u have to kill someone on long distance while u see nothing there)

This is a common problem on Win Vista/7, because this game is pretty old. Probably it even exists with AMD cards and probably it's just the way DX9 rendering in Win7 differs to the Win XP one. As an example I know that the same DX9 function Blt has hardware acceleration under XP while it doesn't under Vista/7 (and probably newer OSes) so it may cause the "pixelation" of some stuff. It's a very known bug in this game and there's no way to completely fix graphics by any settings or compatibility modes from what I was able to google.

I realise that it's pretty old game. I realise that it's definitely not the most popular one. And I'm not even sure if it's possible to fix this issue with some driver hacks. But I just thought that why not to ask here? Maybe some of nVidia devs that are fans of this game will pay attention and fix it somehow (in my dreams :D )

#8
Posted 10/12/2015 01:08 AM   
[quote="GMAlonzo"] Windows 7 1920x1080 with aax4. Looks the same without AA. Looks good to me though, just lots of bloom effects which i don't mind. Not sure why it looks like that on XP though. [img]http://s28.postimg.org/bdh5bs1rh/AACC.png[/img] [img]http://s28.postimg.org/owxzhhfql/AACC2.png[/img][/quote] I've installed XP on VirtualBox and a few screenshots to show how it's supposed to look (AA is disabled, not supported by VirtualBox D3D): [url=http://postimg.org/image/r3o14ccfd/full/][img]http://s28.postimg.org/asnx80zxp/image.jpg[/img][/url] [url=http://postimg.org/image/yskvg2cx5/full/][img]http://s28.postimg.org/g090chgj1/image.jpg[/img][/url] [url=http://postimg.org/image/kano82lm1/full/][img]http://s28.postimg.org/y4c0x4e7h/image.jpg[/img][/url] [url=http://postimg.org/image/oautkbc2x/full/][img]http://s28.postimg.org/m6agj8agd/image.jpg[/img][/url] [url=http://postimg.org/image/gfka5i2g9/full/][img]http://s28.postimg.org/f0ipgs1d9/image.jpg[/img][/url] As you can see - the sky is there and it's not white :) Looks much better :D
GMAlonzo said:
Windows 7 1920x1080 with aax4. Looks the same without AA. Looks good to me though, just lots of bloom effects which i don't mind. Not sure why it looks like that on XP though.
Image
Image

I've installed XP on VirtualBox and a few screenshots to show how it's supposed to look (AA is disabled, not supported by VirtualBox D3D):
Image

Image

Image

Image

Image

As you can see - the sky is there and it's not white :) Looks much better :D

#9
Posted 10/12/2015 01:50 AM   
[quote="Guzz"]Copy "Resources" folder from this archive - [url=https://mega.nz/#!klcjxR7I!OgUAhCkyAyFLdCm9Lve5EmkLkT08sw3y1_uB7A3TRO0]Call_of_Cthulhu_NVIDIA_BUGFIX.7z[/url] in the game folder.[/quote] Omg, thanks man!! The sky is fixed at least, looks exactly as on XP! Does it also fix the invisible sorcerers bug? Are you the author of this fixed shader?
Guzz said:Copy "Resources" folder from this archive - Call_of_Cthulhu_NVIDIA_BUGFIX.7z in the game folder.

Omg, thanks man!! The sky is fixed at least, looks exactly as on XP!
Does it also fix the invisible sorcerers bug?
Are you the author of this fixed shader?

#10
Posted 10/12/2015 02:02 AM   
Have fun! IMO though i like the bloom effects, looks too dark on xp and less detail. but thats just me. But have fun! I never did complete the game, this thread made me reinstall it again :) I also love the music in the game, gotta look for a soundtrack if they have one.
Have fun! IMO though i like the bloom effects, looks too dark on xp and less detail. but thats just me. But have fun! I never did complete the game, this thread made me reinstall it again :) I also love the music in the game, gotta look for a soundtrack if they have one.

#11
Posted 10/12/2015 02:07 AM   
Hi again! I found some time to play through the game during new year holidays, finished about 80% already. So I just wanted to say that fix shared by [b]Guzz[/b] really fixes lighting/skyboxes rendering - which is great, but problem with invisible sorcerers on reef in ship level still exists. They are fine under windows xp, but invisible in win 7. [b]Guzz[/b], do you know if some other fix for this exists? It would be really cool to have one instead of just cheating in any form like unofficial patch modding script to have sorcerers dead after 3rd wave.
Hi again!

I found some time to play through the game during new year holidays, finished about 80% already. So I just wanted to say that fix shared by Guzz really fixes lighting/skyboxes rendering - which is great, but problem with invisible sorcerers on reef in ship level still exists. They are fine under windows xp, but invisible in win 7.

Guzz, do you know if some other fix for this exists? It would be really cool to have one instead of just cheating in any form like unofficial patch modding script to have sorcerers dead after 3rd wave.

#12
Posted 01/04/2016 03:16 PM   
[quote="Dragonheart"]Hi again! I found some time to play through the game during new year holidays, finished about 80% already. So I just wanted to say that fix shared by [b]Guzz[/b] really fixes lighting/skyboxes rendering - which is great, but problem with invisible sorcerers on reef in ship level still exists. They are fine under windows xp, but invisible in win 7. [b]Guzz[/b], do you know if some other fix for this exists? It would be really cool to have one instead of just cheating in any form like unofficial patch modding script to have sorcerers dead after 3rd wave.[/quote] Upload save game with this bug.
Dragonheart said:Hi again!

I found some time to play through the game during new year holidays, finished about 80% already. So I just wanted to say that fix shared by Guzz really fixes lighting/skyboxes rendering - which is great, but problem with invisible sorcerers on reef in ship level still exists. They are fine under windows xp, but invisible in win 7.

Guzz, do you know if some other fix for this exists? It would be really cool to have one instead of just cheating in any form like unofficial patch modding script to have sorcerers dead after 3rd wave.

Upload save game with this bug.

ASUS P8Z68-V PRO/GEN3 / 2550k@4.8Ghz / 8GB DDR III / Gigabyte GTX 970 WindForce OC / Chieftec SPS-850C 850W / Windows 10 Pro x64

#13
Posted 01/04/2016 04:38 PM   
[quote="Guzz"] Upload save game with this bug.[/quote] Many thanks for the quick reply! Here's the save: [url]https://mega.nz/#!XdliVTRQ!g3ipZp4dZCeOmgHZvXR-mNQkDuVbXSo0fUje1D8Ryco[/url] And here's short video demonstrating how to get to the cannon which allows us to see the reef far away zoomed in, but without anyone on it: https://youtu.be/SvCGvEFtYa0 (sorry for the quality, my upload bandwith is just 0.5Mbit on ADSL). On windows XP blue lights (3 of them as far as I remember) are visible on reef. On Win 7 there are none of them. But you still can hit them if you know where to hit so this glitch is only about rendering for sure, not about some spawning stuff.
Guzz said:
Upload save game with this bug.

Many thanks for the quick reply!

Here's the save: https://mega.nz/#!XdliVTRQ!g3ipZp4dZCeOmgHZvXR-mNQkDuVbXSo0fUje1D8Ryco

And here's short video demonstrating how to get to the cannon which allows us to see the reef far away zoomed in, but without anyone on it: https://youtu.be/SvCGvEFtYa0 (sorry for the quality, my upload bandwith is just 0.5Mbit on ADSL).
On windows XP blue lights (3 of them as far as I remember) are visible on reef. On Win 7 there are none of them. But you still can hit them if you know where to hit so this glitch is only about rendering for sure, not about some spawning stuff.

#14
Posted 01/04/2016 06:16 PM   
[quote="Dragonheart"]Many thanks for the quick reply! Here's the save: [url]https://mega.nz/#!XdliVTRQ!g3ipZp4dZCeOmgHZvXR-mNQkDuVbXSo0fUje1D8Ryco[/url] And here's short video demonstrating how to get to the cannon which allows us to see the reef far away zoomed in, but without anyone on it: https://youtu.be/SvCGvEFtYa0 (sorry for the quality, my upload bandwith is just 0.5Mbit on ADSL). On windows XP blue lights (3 of them as far as I remember) are visible on reef. On Win 7 there are none of them. But you still can hit them if you know where to hit so this glitch is only about rendering for sure, not about some spawning stuff.[/quote] Here's fix - [url=https://mega.nz/#!BVsFRSbD!4CAMWSftcYlhTio0lbaSioOGhoDo4M_M_03VB6VEh3o]Call_of_Cthulhu_Modern_OS_BUGFIX.zip[/url] Copy "Resources" folder from archive in the game folder. Without fix, sorcerers are invisible: [url=http://abload.de/img/coc_unfix4xb05.jpg][img]http://abload.de/img/coc_unfix_th7oasr.jpg[/img][/url] With fix, sorcerers and blue lights are visible: [url=http://abload.de/img/coc_fixwkyj3.jpg][img]http://abload.de/img/coc_fix_thsnly7.jpg[/img][/url]
Dragonheart said:Many thanks for the quick reply!

Here's the save: https://mega.nz/#!XdliVTRQ!g3ipZp4dZCeOmgHZvXR-mNQkDuVbXSo0fUje1D8Ryco

And here's short video demonstrating how to get to the cannon which allows us to see the reef far away zoomed in, but without anyone on it: https://youtu.be/SvCGvEFtYa0 (sorry for the quality, my upload bandwith is just 0.5Mbit on ADSL).
On windows XP blue lights (3 of them as far as I remember) are visible on reef. On Win 7 there are none of them. But you still can hit them if you know where to hit so this glitch is only about rendering for sure, not about some spawning stuff.

Here's fix - Call_of_Cthulhu_Modern_OS_BUGFIX.zip
Copy "Resources" folder from archive in the game folder.

Without fix, sorcerers are invisible:
Image

With fix, sorcerers and blue lights are visible:
Image

ASUS P8Z68-V PRO/GEN3 / 2550k@4.8Ghz / 8GB DDR III / Gigabyte GTX 970 WindForce OC / Chieftec SPS-850C 850W / Windows 10 Pro x64

#15
Posted 01/05/2016 03:32 PM   
  1 / 2    
Scroll To Top