Drastical FPS drop after Windows 10 upgrade and NVIDIA drivers update.
  1 / 7    
OK, here is the thing: I have a few games on my computer. After my Windows 8.1 upgraded yesterday to Windows 10, FPS in ALL of those games drastically dropped! FPS in all those games was over 60fps before upgrade, now barely reach 30. Most drastically example is Deus Ex Human Revolution which is not demanding game at all and which was very much smooth with minimal FPS of 60 before this Windows upgrade, and now barely has 10 FPS and it's completely unplayable !!! But situation in other games is not better either. After Windows 10 upgrade, NVidia updated it's drivers yesterday as well.... System: Asus laptop, "republic of gamers", CPU: Intel(R) core(TM) i7-4700HQ CPU @ 2.40GHz, 4 cores, 8 logical procesors; RAM: 16 GB DDR3 1600 MHz; NVIDIA GeForce GTX 770M Windows 10, 64 bit This is very good computer. This things should NOT HAPPEN! Any idea what causing this?
OK, here is the thing:

I have a few games on my computer.
After my Windows 8.1 upgraded yesterday to Windows 10, FPS in ALL of those games drastically dropped!
FPS in all those games was over 60fps before upgrade, now barely reach 30. Most drastically example is Deus Ex Human Revolution which is not demanding game at all and which was very much smooth with minimal FPS of 60 before this Windows upgrade, and now barely has 10 FPS and it's completely unplayable !!! But situation in other games is not better either.

After Windows 10 upgrade, NVidia updated it's drivers yesterday as well....

System:
Asus laptop, "republic of gamers",
CPU: Intel(R) core(TM) i7-4700HQ CPU @ 2.40GHz,
4 cores, 8 logical procesors;
RAM: 16 GB DDR3
1600 MHz;

NVIDIA GeForce GTX 770M

Windows 10, 64 bit

This is very good computer. This things should NOT HAPPEN!
Any idea what causing this?

#1
Posted 07/31/2015 12:15 AM   
Same exact issue! Updated to windows 10 and now the FPS in all games that actually require a graphics card are less than 60 fps unless I turn all the settings off. Example : Just two days ago before windows 10 I was running Killing Floor 2 @60fps/1920x1080 res with Everything on "Ultra" except shadows which was on High. Now, with Windows 10 I tried to run Killing Floor 2 with the same settings and I got 20-30 fps. Specs : ASUS ROG LAPTOP Win10 x64 RAM - 8 GB Processor : Intel(R) core(TM) i7-4710HQ CPU @ 2.50GHz Graphics : Nvidia GEFORCE GTX 860M Driver Version : 353.62
Same exact issue! Updated to windows 10 and now the FPS in all games that actually require a graphics card are less than 60 fps unless I turn all the settings off.

Example : Just two days ago before windows 10 I was running Killing Floor 2 @60fps/1920x1080 res with Everything on "Ultra" except shadows which was on High.

Now, with Windows 10 I tried to run Killing Floor 2 with the same settings and I got 20-30 fps.

Specs :
ASUS ROG LAPTOP
Win10 x64
RAM - 8 GB
Processor : Intel(R) core(TM) i7-4710HQ CPU @ 2.50GHz
Graphics : Nvidia GEFORCE GTX 860M
Driver Version : 353.62

#2
Posted 07/31/2015 05:30 AM   
OK, I know I am not the only one. Let's see now if anyone will pay attention to us and give us some answer....
OK, I know I am not the only one.
Let's see now if anyone will pay attention to us and give us some answer....

#3
Posted 07/31/2015 04:34 PM   
Same thing! I'm getting 6fps on GARRYS MOD! My PC is a decent enough machine to run Grand Theft Auto V with about 50fps. Nvidia GTX 750 AMD 6120 Six Core Processor 10gb RAM I am really hoping for a fix.
Same thing! I'm getting 6fps on GARRYS MOD! My PC is a decent enough machine to run Grand Theft Auto V with about 50fps.

Nvidia GTX 750
AMD 6120 Six Core Processor
10gb RAM

I am really hoping for a fix.

#4
Posted 07/31/2015 06:12 PM   
Same here.. All my games are way lower FPS since I upgraded to Windows 10. I'm running a brand new Asus Laptop "ROG" GTX 980M RAM 16 GB i7 Hoping for a quick solution...
Same here.. All my games are way lower FPS since I upgraded to Windows 10.
I'm running a brand new Asus Laptop "ROG"

GTX 980M
RAM 16 GB
i7

Hoping for a quick solution...

#5
Posted 07/31/2015 06:33 PM   
I just chatted with NVIDIA support. They're still trying to figure things out themselves apparently. But so far they've told me to make sure my BIOS is up to date. About to check that now.
I just chatted with NVIDIA support. They're still trying to figure things out themselves apparently. But so far they've told me to make sure my BIOS is up to date. About to check that now.

#6
Posted 07/31/2015 06:50 PM   
Ok forget the BIOS thing! I just chatted with support again and he gave me this solution : Open "NVIDIA Control Panel" > "3D Settings" > "Manage 3D Settings" > "Global Settings" a. Power management mode - Prefer maximum performance b. Vertical sync- Off c. Threaded optimization - off d. Triple buffering - off Please set to these settings and click on apply. I did that and my FPS has returned! Hope it works for you guys too! EDIT : I just now tried turning "Threaded optimization" back on and it still worked, so you can leave that one on if you want to maybe. It was most likely the "Power Management mode" being set to "adaptive" that caused the issues.
Ok forget the BIOS thing! I just chatted with support again and he gave me this solution :

Open "NVIDIA Control Panel" > "3D Settings" > "Manage 3D Settings" > "Global Settings"

a. Power management mode - Prefer maximum performance
b. Vertical sync- Off
c. Threaded optimization - off
d. Triple buffering - off
Please set to these settings and click on apply.

I did that and my FPS has returned! Hope it works for you guys too!


EDIT : I just now tried turning "Threaded optimization" back on and it still worked, so you can leave that one on if you want to maybe. It was most likely the "Power Management mode" being set to "adaptive" that caused the issues.

#7
Posted 08/01/2015 04:34 AM   
[quote=""]Ok forget the BIOS thing! I just chatted with support again and he gave me this solution : Open "NVIDIA Control Panel" > "3D Settings" > "Manage 3D Settings" > "Global Settings" a. Power management mode - Prefer maximum performance b. Vertical sync- Off c. Threaded optimization - off d. Triple buffering - off Please set to these settings and click on apply. I did that and my FPS has returned! Hope it works for you guys too! EDIT : I just now tried turning "Threaded optimization" back on and it still worked, so you can leave that one on if you want to maybe. It was most likely the "Power Management mode" being set to "adaptive" that caused the issues.[/quote] Thanks man, but, that's not the solution. I don't want to turn off Vertical sync - I had 60fps with V-sync on before.... I don't want to go backwards! You know, their job is to provide us what we payed for! I don't care for these things, I want to have everything in full for my money! How simple is that. I want v-sync on, and I don't want to turn on "Prefer maximum performance" because I don't want to sacrifice quality because of performance - if I wanted to do that I would buy some cheap laptop, not the one which cost almost 3.000 USD! Very simple! They need to provide me what I payed for! ...and, by the way, in global setting V-sync is off by default - actually it is set to be controlled by 3d aplication.... And v-sync is very important. I'm not going to play games without it!
said:Ok forget the BIOS thing! I just chatted with support again and he gave me this solution :

Open "NVIDIA Control Panel" > "3D Settings" > "Manage 3D Settings" > "Global Settings"

a. Power management mode - Prefer maximum performance
b. Vertical sync- Off
c. Threaded optimization - off
d. Triple buffering - off
Please set to these settings and click on apply.

I did that and my FPS has returned! Hope it works for you guys too!


EDIT : I just now tried turning "Threaded optimization" back on and it still worked, so you can leave that one on if you want to maybe. It was most likely the "Power Management mode" being set to "adaptive" that caused the issues.




Thanks man, but, that's not the solution.
I don't want to turn off Vertical sync - I had 60fps with V-sync on before.... I don't want to go backwards!
You know, their job is to provide us what we payed for! I don't care for these things, I want to have everything in full for my money!
How simple is that.
I want v-sync on, and I don't want to turn on "Prefer maximum performance" because I don't want to sacrifice quality because of performance - if I wanted to do that I would buy some cheap laptop, not the one which cost almost 3.000 USD!
Very simple! They need to provide me what I payed for!

...and, by the way, in global setting V-sync is off by default - actually it is set to be controlled by 3d aplication.... And v-sync is very important. I'm not going to play games without it!

#8
Posted 08/01/2015 05:07 AM   
OK guys, I found solution BY MYSELF! Here what I did: Go into your game settings and in video options turn off V-sync and triple buffering. Then exit the game and open your nvidia control panel and in program settings find your game and turn on V-sync and triple buffering there (force V-sync on). I did that to all my games and FPS jumped back to completely stable 60 fps with ultra high video settings in all games - like it was before! Each game is fixed at 60 fps now, only because of this trick. Try to do that with your games. So, don't do things with turning off global settings which "CyberShadow" wrote- just what I told you now - it works perfectly in my case. In this way you have your fps back and you not sacrificing the quality and V-sync. Hope it will works in your case as well. Good luck guys. Anyway, nvidia should fix this issue!!!
OK guys, I found solution BY MYSELF!
Here what I did:
Go into your game settings and in video options turn off V-sync and triple buffering.
Then exit the game and open your nvidia control panel and in program settings find your game and turn on V-sync and triple buffering there (force V-sync on).

I did that to all my games and FPS jumped back to completely stable 60 fps with ultra high video settings in all games - like it was before!
Each game is fixed at 60 fps now, only because of this trick.

Try to do that with your games.
So, don't do things with turning off global settings which "CyberShadow" wrote- just what I told you now - it works perfectly in my case. In this way you have your fps back and you not sacrificing the quality and V-sync.

Hope it will works in your case as well. Good luck guys.


Anyway, nvidia should fix this issue!!!

#9
Posted 08/01/2015 05:28 AM   
[quote=""] Thanks man, but, that's not the solution. I don't want to turn off Vertical sync - I had 60fps with V-sync on before.... I don't want to go backwards! You know, their job is to provide us what we payed for! I don't care for these things, I want to have everything in full for my money! How simple is that. I want v-sync on, and I don't want to turn on "Prefer maximum performance" because I don't want to sacrifice quality because of performance - if I wanted to do that I would buy some cheap laptop, not the one which cost almost 3.000 USD! Very simple! They need to provide me what I payed for! ...and, by the way, in global setting V-sync is off by default - actually it is set to be controlled by 3d aplication.... And v-sync is very important. I'm not going to play games without it![/quote] Great you solved your problem. But some things to note. "Prefer Maximum performance" is a good thing, how is it sacrificing? We're talking about making your graphics card "perform at maximum", and it's job is to make your games look good, so why would you not want it to perform this job at maximum? V-Sync locks your fps at 60, it doesn't improve your fps, it actually prevents it from going past 60 when it possibly could. This is to prevent screen tearing (seeing a line travel down your screen due to your game pushing out more frames than your monitor's refresh rate), but this is really only an issue in very few games, I had actually never seen screen tear in a game until I played Metro Redux without V-sync. Perhaps the issue simply solved itself, since we both did opposite solutions but got the same result.
said:


Thanks man, but, that's not the solution.
I don't want to turn off Vertical sync - I had 60fps with V-sync on before.... I don't want to go backwards!
You know, their job is to provide us what we payed for! I don't care for these things, I want to have everything in full for my money!
How simple is that.
I want v-sync on, and I don't want to turn on "Prefer maximum performance" because I don't want to sacrifice quality because of performance - if I wanted to do that I would buy some cheap laptop, not the one which cost almost 3.000 USD!
Very simple! They need to provide me what I payed for!

...and, by the way, in global setting V-sync is off by default - actually it is set to be controlled by 3d aplication.... And v-sync is very important. I'm not going to play games without it!


Great you solved your problem. But some things to note.
"Prefer Maximum performance" is a good thing, how is it sacrificing? We're talking about making your graphics card "perform at maximum", and it's job is to make your games look good, so why would you not want it to perform this job at maximum?
V-Sync locks your fps at 60, it doesn't improve your fps, it actually prevents it from going past 60 when it possibly could. This is to prevent screen tearing (seeing a line travel down your screen due to your game pushing out more frames than your monitor's refresh rate), but this is really only an issue in very few games, I had actually never seen screen tear in a game until I played Metro Redux without V-sync.

Perhaps the issue simply solved itself, since we both did opposite solutions but got the same result.

#10
Posted 08/01/2015 09:27 AM   
[quote=""][quote=""] Thanks man, but, that's not the solution. I don't want to turn off Vertical sync - I had 60fps with V-sync on before.... I don't want to go backwards! You know, their job is to provide us what we payed for! I don't care for these things, I want to have everything in full for my money! How simple is that. I want v-sync on, and I don't want to turn on "Prefer maximum performance" because I don't want to sacrifice quality because of performance - if I wanted to do that I would buy some cheap laptop, not the one which cost almost 3.000 USD! Very simple! They need to provide me what I payed for! ...and, by the way, in global setting V-sync is off by default - actually it is set to be controlled by 3d aplication.... And v-sync is very important. I'm not going to play games without it![/quote] Great you solved your problem. But some things to note. "Prefer Maximum performance" is a good thing, how is it sacrificing? We're talking about making your graphics card "perform at maximum", and it's job is to make your games look good, so why would you not want it to perform this job at maximum? V-Sync locks your fps at 60, it doesn't improve your fps, it actually prevents it from going past 60 when it possibly could. This is to prevent screen tearing (seeing a line travel down your screen due to your game pushing out more frames than your monitor's refresh rate), but this is really only an issue in very few games, I had actually never seen screen tear in a game until I played Metro Redux without V-sync. Perhaps the issue simply solved itself, since we both did opposite solutions but got the same result.[/quote] 1. I think that power option needs to be "adaptive" because it's much more stable than the other option. And, most important, what I said, is that these computers (at least this one which I have) are made to run with maximum graphic settings and give best performances at the same time with most of the games. That's why I said I don't want to go backwards. 2. V-sync is very important. It does lock your FPS, but it removes very annoying screen tearing and makes gameplay smooth.... It locks your GPU to output frames as high as the refresh rate of your monitor. 3. As I said I found the solution to keep the quality and v-sync just turning it off in game video settings and after that forcing it in nvidia control panel. When I turned off V-sync inside game I got fps jump from 10fps to 250 or 300 fps, but with plenty screen tearing... then I went to nvidia control panel and turned on v-sync for that specific game there and i got perfectly stable and smooth 60fps without screen tearing. The only difference is that before these upgrades I had the same quality and performance just with game settings... And i realy don't know what happened that everything went to hell after these upgrades. That is my opinion but it doesn't mean that I am right. On the other hand, if screen tearing doesn't bother you, then it's ok for you to play like that - I simply don't like it. I also noticed that some games became more unstable - freezing/crashing after upgrades although they running in windows 8 and other compatibility modes...
said:
said:


Thanks man, but, that's not the solution.
I don't want to turn off Vertical sync - I had 60fps with V-sync on before.... I don't want to go backwards!
You know, their job is to provide us what we payed for! I don't care for these things, I want to have everything in full for my money!
How simple is that.
I want v-sync on, and I don't want to turn on "Prefer maximum performance" because I don't want to sacrifice quality because of performance - if I wanted to do that I would buy some cheap laptop, not the one which cost almost 3.000 USD!
Very simple! They need to provide me what I payed for!

...and, by the way, in global setting V-sync is off by default - actually it is set to be controlled by 3d aplication.... And v-sync is very important. I'm not going to play games without it!


Great you solved your problem. But some things to note.
"Prefer Maximum performance" is a good thing, how is it sacrificing? We're talking about making your graphics card "perform at maximum", and it's job is to make your games look good, so why would you not want it to perform this job at maximum?
V-Sync locks your fps at 60, it doesn't improve your fps, it actually prevents it from going past 60 when it possibly could. This is to prevent screen tearing (seeing a line travel down your screen due to your game pushing out more frames than your monitor's refresh rate), but this is really only an issue in very few games, I had actually never seen screen tear in a game until I played Metro Redux without V-sync.

Perhaps the issue simply solved itself, since we both did opposite solutions but got the same result.




1. I think that power option needs to be "adaptive" because it's much more stable than the other option.

And, most important, what I said, is that these computers (at least this one which I have) are made to run with maximum graphic settings and give best performances at the same time with most of the games. That's why I said I don't want to go backwards.

2. V-sync is very important. It does lock your FPS, but it removes very annoying screen tearing and makes gameplay smooth.... It locks your GPU to output frames as high as the refresh rate of your monitor.

3. As I said I found the solution to keep the quality and v-sync just turning it off in game video settings and after that forcing it in nvidia control panel.
When I turned off V-sync inside game I got fps jump from 10fps to 250 or 300 fps, but with plenty screen tearing... then I went to nvidia control panel and turned on v-sync for that specific game there and i got perfectly stable and smooth 60fps without screen tearing.
The only difference is that before these upgrades I had the same quality and performance just with game settings...
And i realy don't know what happened that everything went to hell after these upgrades.

That is my opinion but it doesn't mean that I am right.

On the other hand, if screen tearing doesn't bother you, then it's ok for you to play like that - I simply don't like it.

I also noticed that some games became more unstable - freezing/crashing after upgrades although they running in windows 8 and other compatibility modes...

#11
Posted 08/01/2015 03:27 PM   
Windows 10 Pro, GTX 770 2 GB. I still can't do anything about massive fps drops in Borderlands 2, in certain areas. I'm not blaming Nvidia as of yet, though, it could be an issue with the OS. P.S I've noticed that these drops occur in heavy CPU-bound areas.
Windows 10 Pro, GTX 770 2 GB.

I still can't do anything about massive fps drops in Borderlands 2, in certain areas. I'm not blaming Nvidia as of yet, though, it could be an issue with the OS.

P.S I've noticed that these drops occur in heavy CPU-bound areas.

#12
Posted 08/01/2015 05:10 PM   
My setup: i5 2500K @ 4.5 stable GTX 780 16 GB RAM I'm getting massive frame drops in GTA V to the point where I can't even play and have to restart the game. This only recently started when I did a clean install of Windows 10. Not sure what to do about it...
My setup:
i5 2500K @ 4.5 stable
GTX 780
16 GB RAM

I'm getting massive frame drops in GTA V to the point where I can't even play and have to restart the game. This only recently started when I did a clean install of Windows 10. Not sure what to do about it...

#13
Posted 08/02/2015 05:22 AM   
GTA V I am experiencing a huge FPS drop after being in game for a few minutes. I have narrowed it down to the Shadow Quality. If I set it to anything higher than normal the FPS drops to 15 but if I set it back to normal my FPS return to 60. Intel i7-4770K @ 4.0 Ghz 16GB RAM 1920x1080 (up to 144hz, using 60hz in game) Geforce GTX 780 in SLi Driver 353.62 Nvidia GeForce Experience 2.5.12.11 - used for FPS monitoring Windows 10 Pro
GTA V
I am experiencing a huge FPS drop after being in game for a few minutes. I have narrowed it down to the Shadow Quality. If I set it to anything higher than normal the FPS drops to 15 but if I set it back to normal my FPS return to 60.

Intel i7-4770K @ 4.0 Ghz
16GB RAM
1920x1080 (up to 144hz, using 60hz in game)
Geforce GTX 780 in SLi
Driver 353.62
Nvidia GeForce Experience 2.5.12.11 - used for FPS monitoring
Windows 10 Pro

#14
Posted 08/02/2015 01:59 PM   
Hahahahaha, and the funniest thing is that today when I turned on the same games - EVERYTHING IS BACK DOWN AGAING, regardless of all these v-sync settings! My fix worked two days and today, without any reason, is back to 10 fps although I didn't change absolutely anything! I'm really loosing my patience now! THEY NEED TO FIX THIS! Everything worked perfectly before these upgrades, now everything is messed up!!!
Hahahahaha, and the funniest thing is that today when I turned on the same games - EVERYTHING IS BACK DOWN AGAING, regardless of all these v-sync settings!
My fix worked two days and today, without any reason, is back to 10 fps although I didn't change absolutely anything!

I'm really loosing my patience now!
THEY NEED TO FIX THIS!

Everything worked perfectly before these upgrades, now everything is messed up!!!

#15
Posted 08/02/2015 04:04 PM   
  1 / 7    
Scroll To Top