Witcher 3 Kepler 700 series pathetic performance
Now officially my friend is running Witcher 3 with a 970 all maxed out at 60fps 1080p solid and my single 780 Ti sits between 45-55 FPS at exact same resolution and settings. I'm sorry but this is ridiculous. NVIDIA WTF!?
Now officially my friend is running Witcher 3 with a 970 all maxed out at 60fps 1080p solid and my single 780 Ti sits between 45-55 FPS at exact same resolution and settings. I'm sorry but this is ridiculous. NVIDIA WTF!?

#1
Posted 05/22/2015 05:05 PM   
this is nvidia [quote="ExGreyFox"]Now officially my friend is running Witcher 3 with a 970 all maxed out at 60fps 1080p solid and my single 780 Ti sits between 45-55 FPS at exact same resolution and settings. I'm sorry but this is ridiculous. NVIDIA WTF!? [/quote] Same here (gtx 780ghz i can't play even high settings with hair work shit off), nvidia push us to amd
this is nvidia
ExGreyFox said:Now officially my friend is running Witcher 3 with a 970 all maxed out at 60fps 1080p solid and my single 780 Ti sits between 45-55 FPS at exact same resolution and settings. I'm sorry but this is ridiculous. NVIDIA WTF!?


Same here (gtx 780ghz i can't play even high settings with hair work shit off), nvidia push us to amd

#2
Posted 05/23/2015 08:07 AM   
If you can't run the game at 60 fps with everything on High and hairworks off, you're doing something wrong (or something is bottlenecking you). My FPS is between 60 and 80 in Velen, and everything is maxed except Foliage Distance and Shadows which is at High instead of Ultra. Even using HBAO+. Using a 780ti with a 4700k.
If you can't run the game at 60 fps with everything on High and hairworks off, you're doing something wrong (or something is bottlenecking you).

My FPS is between 60 and 80 in Velen, and everything is maxed except Foliage Distance and Shadows which is at High instead of Ultra. Even using HBAO+.

Using a 780ti with a 4700k.

#3
Posted 05/23/2015 09:03 AM   
what planet are you from maximum settings 1920x1080 30-35 fps unacceptable to gtx780 ti http://www.youtube.com/watch?v=Imhpe5KNIW0 4k all settings low drawdown <30fps http://www.youtube.com/watch?v=aH0M_rFDUdw
what planet are you from
maximum settings 1920x1080
30-35 fps unacceptable to gtx780 ti



4k all settings low drawdown <30fps

#4
Posted 05/23/2015 09:11 AM   
[quote="eljug"]what planet are you from maximum settings 1920x1080 30-35 fps unacceptable to gtx780 ti [/quote] Pay close attention to the first video where the settings are being gone through. Hairworks is on and Hairworks is a bigger drag on the 780Ti than the 970 apparently as the latter has an architecture that better supports tessellation. That's the theory anyway. I have a 780Ti and as Skylinee, I'm not getting this poor performance. In another post he states: "I'm having between 60 and 80 FPS with my card (currently in Velen). Is this not comparable to a 970? Everything is maxed, except hairworks off and Foliage Distance+Shadows at high instead of Ultra. From what i've seen in benchmarks like in the OP, i should be getting around 40 fps with these settings. Maybe the benchmark is wrong" This is around about the same performance as I get. We both have the same in-game settings: Here's my evidence: https://www.youtube.com/watch?v=lWj1mmIMHQA So why are we both not getting the 30-35fps?
eljug said:what planet are you from
maximum settings 1920x1080
30-35 fps unacceptable to gtx780 ti


Pay close attention to the first video where the settings are being gone through. Hairworks is on and Hairworks is a bigger drag on the 780Ti than the 970 apparently as the latter has an architecture that better supports tessellation.
That's the theory anyway.

I have a 780Ti and as Skylinee, I'm not getting this poor performance. In another post he states:

"I'm having between 60 and 80 FPS with my card (currently in Velen). Is this not comparable to a 970?
Everything is maxed, except hairworks off and Foliage Distance+Shadows at high instead of Ultra. From what i've seen in benchmarks like in the OP, i should be getting around 40 fps with these settings. Maybe the benchmark is wrong"

This is around about the same performance as I get. We both have the same in-game settings:

Here's my evidence:



So why are we both not getting the 30-35fps?

Xeon X5670 @ 4.2GHz
Asus Sabertooth X58
12GB Corsair Dominator DDR3
EVGA 980 Ti SC
Samsung 840 Pro 256GB
Highpoint RR640L controller
Corsair AX1200 PSU
Sound Blaster X-Fi Titanium Fatal1ty Professional
Asus VG278HE via DVI dual link
Windows 10 Pro 64 bit

#5
Posted 05/23/2015 10:17 AM   
[quote="Skylinee"]If you can't run the game at 60 fps with everything on High and hairworks off, you're doing something wrong (or something is bottlenecking you). My FPS is between 60 and 80 in Velen, and everything is maxed except Foliage Distance and Shadows which is at High instead of Ultra. Even using HBAO+. Using a 780ti with a 4700k.[/quote] I am sorry mate but you don't know what you are talking about. I am playing at 1080p, with Hairworks OFF, Foliage at HIGH, Motion Blur OFF, Blur OFF, Depth of Field OFF, Chromatic Aberration OFF, everything else maxed out and I drop as low as 39 FPS in the woods near the merchant for the first quest so there IS A MASSIVE PROBLEM with Nvidia's driver... Post a video of the section where you get the first griffon quest from the merchant. Run into the woods on horseback. Are you seriously telling me you get 60 FPS there??? I DOUBT IT. Prove it! My specs are in signature and I DO take care of my PC, I monitor everything.
Skylinee said:If you can't run the game at 60 fps with everything on High and hairworks off, you're doing something wrong (or something is bottlenecking you).

My FPS is between 60 and 80 in Velen, and everything is maxed except Foliage Distance and Shadows which is at High instead of Ultra. Even using HBAO+.

Using a 780ti with a 4700k.


I am sorry mate but you don't know what you are talking about.

I am playing at 1080p, with Hairworks OFF, Foliage at HIGH, Motion Blur OFF, Blur OFF, Depth of Field OFF, Chromatic Aberration OFF, everything else maxed out and I drop as low as 39 FPS in the woods near the merchant for the first quest so there IS A MASSIVE PROBLEM with Nvidia's driver...

Post a video of the section where you get the first griffon quest from the merchant. Run into the woods on horseback. Are you seriously telling me you get 60 FPS there???

I DOUBT IT. Prove it!

My specs are in signature and I DO take care of my PC, I monitor everything.

CPU: i7 3770k @ 4.5Ghz
GPU: MSI GTX 1080 Ti GAMING X (382.53 Driver)
RAM: GSkill Ripjaws X 16GB DDR3 1600Mhz
MOTHERBOARD: ASUS Sabertooth Z77 (Bios version 2104)
BOOT DRIVE: Samsung 850 EVO 250GB SSD
GAME DRIVES: OCZ AGILITY 3 120GB SSD, Western Digital Caviar Black 2TB 7200RPM HDD
PSU: Corsair RM1000 1000W
DISPLAY: Acer XB270HU 1440p 144Hz GSYNC
OS: Windows 10 PRO 64 Bit

#6
Posted 05/23/2015 04:34 PM   
[quote="gringopig"] Pay close attention to the first video where the settings are being gone through. Hairworks is on and Hairworks is a bigger drag on the 780Ti than the 970 apparently as the latter has an architecture that better supports tessellation. That's the theory anyway.[/quote] 780 Ti has a lot more cores than the 970 though. It's not effective to simply say that the 970 has better tessellation because it's a Maxwell card. Anyway outside of Hairworks, W3 doesn't appear to use much tessellation that's a large impact on performance.
gringopig said:
Pay close attention to the first video where the settings are being gone through. Hairworks is on and Hairworks is a bigger drag on the 780Ti than the 970 apparently as the latter has an architecture that better supports tessellation.
That's the theory anyway.


780 Ti has a lot more cores than the 970 though. It's not effective to simply say that the 970 has better tessellation because it's a Maxwell card.
Anyway outside of Hairworks, W3 doesn't appear to use much tessellation that's a large impact on performance.

#7
Posted 05/23/2015 04:34 PM   
Scroll To Top