Steam update breaks HelixMod on some games
  1 / 5    
UPDATE: This thread was originally about my attempts to get Mass Effect running on Steam with Helixmod, but it appears to have affected other games as well. Currently afffected games are: FEAR 2 Mass Effect 1 Viking Battle for Asgard Dead Space 2 There may be more, please report them. This can currently be fixed by deleting or renaming the following file while Steam is running: C:\Program Files (x86)\Steam\GameOverlayRenderer.dll This will kill the Steam overlay and resolve the issue, though unless you rename the file back before you next start Steam, it will cause Steam to take a little longer to start up next time while it redownloads the file. Credit to b03b for discovering this. --------------------- [Original Post] Hey everyone, I've been trying to get the fix for Mass Effect running, but I'm crashing out just after the game launches. eqzitara was kind enough to put together an injector version of the fix which works, but I'd like to be able to run sweetfx at the same time, which I've never succeeded at with the injector. Game runs fine with no fix, with the injector fix, or with sweetfx. But it crashes with the fix (with or without sweetfx proxied). So far I've tried: Deleting shaderoverride Deleting dx9settings.ini Disabling SLI Disabling Steam overlay (no other overlays running) Reinstalling game Deleting all saves/config files to force re-creation Latest drivers Driver 332.21 Running as admin Compatibility mode (XP) Killing every process on my PC that's not absolutely essential Alternate versions of the DLL (though not all yet) At this stage, it might be helpful to get a few more data points. I'm running SLI 770s on Windows 8 64bit, if anyone else has it installed would you mind giving it a quick test and reporting in with your specs/results?
UPDATE: This thread was originally about my attempts to get Mass Effect running on Steam with Helixmod, but it appears to have affected other games as well. Currently afffected games are:

FEAR 2
Mass Effect 1
Viking Battle for Asgard
Dead Space 2

There may be more, please report them.

This can currently be fixed by deleting or renaming the following file while Steam is running:
C:\Program Files (x86)\Steam\GameOverlayRenderer.dll

This will kill the Steam overlay and resolve the issue, though unless you rename the file back before you next start Steam, it will cause Steam to take a little longer to start up next time while it redownloads the file.

Credit to b03b for discovering this.

---------------------
[Original Post]

Hey everyone,

I've been trying to get the fix for Mass Effect running, but I'm crashing out just after the game launches. eqzitara was kind enough to put together an injector version of the fix which works, but I'd like to be able to run sweetfx at the same time, which I've never succeeded at with the injector. Game runs fine with no fix, with the injector fix, or with sweetfx. But it crashes with the fix (with or without sweetfx proxied).

So far I've tried:
Deleting shaderoverride
Deleting dx9settings.ini
Disabling SLI
Disabling Steam overlay (no other overlays running)
Reinstalling game
Deleting all saves/config files to force re-creation
Latest drivers
Driver 332.21
Running as admin
Compatibility mode (XP)
Killing every process on my PC that's not absolutely essential
Alternate versions of the DLL (though not all yet)

At this stage, it might be helpful to get a few more data points. I'm running SLI 770s on Windows 8 64bit, if anyone else has it installed would you mind giving it a quick test and reporting in with your specs/results?

#1
Posted 07/02/2014 02:33 PM   
New 0.8 GeDoSaTo has many SweetFX features and it works IIRC with the shader fix. Try it :)
New 0.8 GeDoSaTo has many SweetFX features and it works IIRC with the shader fix. Try it :)

Windows 10 64-bit, Intel 7700K @ 5.1GHz, 16GB 3600MHz DDR4 RAM, 2x GTX 1080 SLI, Asus Maximus IX Hero, Sound Blaster ZxR, PCIe Quad SSD, Oculus Rift CV1, DLP Link PGD-150 glasses, ViewSonic PJD6531w 3D DLP Projector @ 1280x800 120Hz native / 2560x1600 120Hz DSR 3D Gaming.

#2
Posted 07/02/2014 09:54 PM   
For each of the 4 following: In the Game Folder...Launcher and MassEffectLauncher In the Binaries Folder..Mass Effect and MassEffectConfig Right on click, select properties>compatibility. Check both of the boxes, first the "run this program in compatibility mode for Windows XP (Service Pack 3) and second check the box "Run this program as administrator"
For each of the 4 following:
In the Game Folder...Launcher and MassEffectLauncher
In the Binaries Folder..Mass Effect and MassEffectConfig

Right on click, select properties>compatibility. Check both of the boxes, first the "run this program in compatibility mode for Windows XP (Service Pack 3) and second check the box "Run this program as administrator"

#3
Posted 07/02/2014 10:59 PM   
Rage, the injector version doesn't like to play with other dlls in general so I doubt that will work - but I'll give it a shot. D-Man - I've tried that already, but thanks
Rage, the injector version doesn't like to play with other dlls in general so I doubt that will work - but I'll give it a shot.

D-Man - I've tried that already, but thanks

#4
Posted 07/03/2014 12:01 AM   
Random thought based on a recent crash I just had with similar vintage game (FEAR2). Are you running Steam Beta? The Beta turned out to be causing my crash, because it was still enabling the overlay, even though set to disabled.
Random thought based on a recent crash I just had with similar vintage game (FEAR2).

Are you running Steam Beta? The Beta turned out to be causing my crash, because it was still enabling the overlay, even though set to disabled.

Acer H5360 (1280x720@120Hz) - ASUS VG248QE with GSync mod - 3D Vision 1&2 - Driver 372.54
GTX 970 - GTX 760 Dedicated PhysX - i5-4670K@4.2GHz - 12GB RAM - Win7x64+evilKB2670838 - 4 Disk X25 RAID
Latest 3Dmigoto Release
Bo3b's School for ShaderHackers

#5
Posted 07/03/2014 12:33 AM   
Hmm, I played Mass Effect back in May with no problems using the shader override folders from the Helix Mod site. I launced it today, to see if there was any change. Sure enough, it kept crashing. As soon as I did the above, it worked perfectly. W7 64bit driver 332.21
Hmm, I played Mass Effect back in May with no problems using the shader override folders from the Helix Mod site.

I launced it today, to see if there was any change. Sure enough, it kept crashing.

As soon as I did the above, it worked perfectly.

W7 64bit driver 332.21

#6
Posted 07/03/2014 12:35 AM   
D-Man, I'll give that another shot tonight to confirm, just in case I missed one of those files. Does it crash without Helixmod installed for you though? Because I'm seeing crashes only when Helixmod is installed. Bo3b, I am indeed running Steam Beta. Seems that could be a culprit, I'll test without it when I get home.
D-Man, I'll give that another shot tonight to confirm, just in case I missed one of those files. Does it crash without Helixmod installed for you though? Because I'm seeing crashes only when Helixmod is installed.

Bo3b, I am indeed running Steam Beta. Seems that could be a culprit, I'll test without it when I get home.

#7
Posted 07/03/2014 01:31 AM   
Unfortunately, reverting to non-beta Steam and the compatibility/admin thing didn't help either. Anyone running Windows 8 mind giving it a test?
Unfortunately, reverting to non-beta Steam and the compatibility/admin thing didn't help either.

Anyone running Windows 8 mind giving it a test?

#8
Posted 07/03/2014 10:25 AM   
Well, it's long past time I played this game too, so I downloaded it to try it out as well. Running from Steam, no Helix, I got the startup crash that it seems everyone gets. Running Steam as Admin fixed that crash and ran. Looks OK in 3D, but we know it can be better. Installed the HelixMod fix- and I get the same crash. And only with HelixMod. So, just as a data point, crashes for me with Win7 x64, 337.88. Not tried injector style, or other drivers yet. (Not sure about Steam, I'm not running Beta, but I did get a Steam update yesterday, which might have moved that bad fix to the main app. When I look at the crash with Visual Studio I see the Steam Overlay dll loaded, when it is specifically disabled. But, my test case of FEAR2 still runs without crashing.)
Well, it's long past time I played this game too, so I downloaded it to try it out as well.

Running from Steam, no Helix, I got the startup crash that it seems everyone gets. Running Steam as Admin fixed that crash and ran. Looks OK in 3D, but we know it can be better.

Installed the HelixMod fix- and I get the same crash. And only with HelixMod.

So, just as a data point, crashes for me with Win7 x64, 337.88. Not tried injector style, or other drivers yet.


(Not sure about Steam, I'm not running Beta, but I did get a Steam update yesterday, which might have moved that bad fix to the main app. When I look at the crash with Visual Studio I see the Steam Overlay dll loaded, when it is specifically disabled. But, my test case of FEAR2 still runs without crashing.)

Acer H5360 (1280x720@120Hz) - ASUS VG248QE with GSync mod - 3D Vision 1&2 - Driver 372.54
GTX 970 - GTX 760 Dedicated PhysX - i5-4670K@4.2GHz - 12GB RAM - Win7x64+evilKB2670838 - 4 Disk X25 RAID
Latest 3Dmigoto Release
Bo3b's School for ShaderHackers

#9
Posted 07/03/2014 11:05 AM   
It's (almost) definitely a Steam problem. I installed using Origin (your steam CD key can be registered on Origin, so this doesn't cost anything). Then I ran with Origin overlay enabled, crashed. Disabled Origin overlay, and it ran fine, with the fix. I believe the Steam and Origin versions of the game are similar, as I installed it by making a symbolic link from my Steam install to my Origin games directory, then letting Origin verify. I deleted the binaries folder to force an exe redownload (as they have different DRM), but otherwise it didn't download much. At present if I try and launch the Steam version, I get a missing ssleay32.dll error (a file that, strangely, was not in the backup I took of the folder). I'm going to verify my Steam cache to revert things to the Steam version, then see what happens when I launch through Origin and Steam. I'll try other similar things too, see if I can narrow things down any further. EDIT: The main page of the board isn't displaying new posts for me, the most recent thread activity was 3 hours ago on the thread "Benq XL2420TE 3d Vision ready?? Can't get mine to work.". Yet there's clearly been activity here since.
It's (almost) definitely a Steam problem.

I installed using Origin (your steam CD key can be registered on Origin, so this doesn't cost anything). Then I ran with Origin overlay enabled, crashed. Disabled Origin overlay, and it ran fine, with the fix.

I believe the Steam and Origin versions of the game are similar, as I installed it by making a symbolic link from my Steam install to my Origin games directory, then letting Origin verify. I deleted the binaries folder to force an exe redownload (as they have different DRM), but otherwise it didn't download much.

At present if I try and launch the Steam version, I get a missing ssleay32.dll error (a file that, strangely, was not in the backup I took of the folder). I'm going to verify my Steam cache to revert things to the Steam version, then see what happens when I launch through Origin and Steam. I'll try other similar things too, see if I can narrow things down any further.

EDIT: The main page of the board isn't displaying new posts for me, the most recent thread activity was 3 hours ago on the thread "Benq XL2420TE 3d Vision ready?? Can't get mine to work.". Yet there's clearly been activity here since.

#10
Posted 07/03/2014 11:39 AM   
It's been a while since i played it, but i had this exact same issue. If i remember correctly, launching the game (or was it steam) as an administrator, solves it. Not sure what causes it, and this workaround shouldn't be necessary, but it's been an issue for me with the steam version for a long time.
It's been a while since i played it, but i had this exact same issue.

If i remember correctly, launching the game (or was it steam) as an administrator, solves it.
Not sure what causes it, and this workaround shouldn't be necessary, but it's been an issue for me with the steam version for a long time.

#11
Posted 07/03/2014 12:44 PM   
I can confirm that the problem is the new Steam client. Frickin' Valve rolled out that Beta to the main client, and it blows up the Helix mod. Good thing I put in the effort to report the bug. F! If I roll back the Steam client using System Restore, I can launch the game from Steam with no problem.
I can confirm that the problem is the new Steam client. Frickin' Valve rolled out that Beta to the main client, and it blows up the Helix mod. Good thing I put in the effort to report the bug. F!

If I roll back the Steam client using System Restore, I can launch the game from Steam with no problem.

Acer H5360 (1280x720@120Hz) - ASUS VG248QE with GSync mod - 3D Vision 1&2 - Driver 372.54
GTX 970 - GTX 760 Dedicated PhysX - i5-4670K@4.2GHz - 12GB RAM - Win7x64+evilKB2670838 - 4 Disk X25 RAID
Latest 3Dmigoto Release
Bo3b's School for ShaderHackers

#12
Posted 07/03/2014 12:52 PM   
dp.
dp.

Acer H5360 (1280x720@120Hz) - ASUS VG248QE with GSync mod - 3D Vision 1&2 - Driver 372.54
GTX 970 - GTX 760 Dedicated PhysX - i5-4670K@4.2GHz - 12GB RAM - Win7x64+evilKB2670838 - 4 Disk X25 RAID
Latest 3Dmigoto Release
Bo3b's School for ShaderHackers

#13
Posted 07/03/2014 12:52 PM   
Mines working. I've had Steam up for a few days, so its maybe not updated yet.
Mines working. I've had Steam up for a few days, so its maybe not updated yet.

46" Samsung ES7500 3DTV (checkerboard, high FOV as desktop monitor, highly recommend!) - Metro 2033 3D PNG screens - Metro LL filter realism mod - Flugan's Deus Ex:HR Depth changers - Nvidia tech support online form - Nvidia support: 1-800-797-6530

#14
Posted 07/03/2014 01:10 PM   
I'd like to file a report too, could you please post your report here so I can include the technical details (assuming you have a few)?
I'd like to file a report too, could you please post your report here so I can include the technical details (assuming you have a few)?

#15
Posted 07/03/2014 01:19 PM   
  1 / 5    
Scroll To Top