Application Has Been Blocked
  1 / 5    
Hello everyone. I'm having this problem for about one week now. I searched the forum and couldn't find any solution. I have a MSI gaming laptop with NVIDIA GeForce GTX 780M, using Windows 8.1 64-bit Whenever i try to play a game with my NVIDIA graphic card i get the [b]application has been blocked from accessing graphics hardware[/b] and after that [b]sometimes[/b] display driver has stopped responding and recovered error at the right corner. Can use my integrated intel card to play games with no problem but fps is kinda at the bottom you know. I googled it a million times and still couldn't find a proper solution, i tried every solution i found and still the problem insists. I don't have recovery and I don't want to lose my files. I used MSI Afterburner to check my GPU and it hits max when this error occurs and game crashes. Then GPU goes to normal. And i don't remember overclocking my GPU. Things i tried so far; I updated my drivers. I downgraded my drivers. I entirely deleted the driver and reinstalled it. I used TdrDelay and TdrLevel on regedit. I disabled the anti-virus i'm using. (Windows Defender) I disabled windows firewall. My laptop: http://www.amazon.com/MSI-2OD-064US-4900MQ-3-8GHz-Windows/dp/B00DS12X0S The problem still insist. I'm waiting your replies. Thanks.
Hello everyone.

I'm having this problem for about one week now.

I searched the forum and couldn't find any solution.

I have a MSI gaming laptop with NVIDIA GeForce GTX 780M, using Windows 8.1 64-bit

Whenever i try to play a game with my NVIDIA graphic card i get the application has been blocked from accessing graphics hardware and after that sometimes display driver has stopped responding and recovered error at the right corner. Can use my integrated intel card to play games with no problem but fps is kinda at the bottom you know. I googled it a million times and still couldn't find a proper solution, i tried every solution i found and still the problem insists. I don't have recovery and I don't want to lose my files.
I used MSI Afterburner to check my GPU and it hits max when this error occurs and game crashes. Then GPU goes to normal. And i don't remember overclocking my GPU.

Things i tried so far;
I updated my drivers.
I downgraded my drivers.
I entirely deleted the driver and reinstalled it.
I used TdrDelay and TdrLevel on regedit.
I disabled the anti-virus i'm using. (Windows Defender)
I disabled windows firewall.

My laptop: http://www.amazon.com/MSI-2OD-064US-4900MQ-3-8GHz-Windows/dp/B00DS12X0S

The problem still insist. I'm waiting your replies.

Thanks.

#1
Posted 04/20/2014 02:35 AM   
Bump, im desperate here.
Bump, im desperate here.

#2
Posted 04/21/2014 05:54 PM   
Any chance of you uploading a screenshot of the blocking message? If you can't do that you might want to install a free firewall and see if you have the same problem.
Any chance of you uploading a screenshot of the blocking message?

If you can't do that you might want to install a free firewall and see if you have the same problem.

CPU: Intel i7-3770k @4.6ghz (Noctura NH-D14 Cooler)
MB: Asrock Z77 Extreme4
RAM: 4x4gb @2400mhz(10-11-11-30) G-Skill F3-19200CL11Q-16GBZHD
GPU: EVGA GTX 780 SC w/ ACX Cooler
SSDs: OCZ Vertex 4 256gb x2 in Raid 0 array
HDDs: Seagate 3TB x2
PSU: Thermaltake 750W Toughpower Gold
CASE: Thermaltake VN700M1W2N Overseer RX-I
OS: Windows 7 Pro x64
Mon: LG W2486L-PF

#3
Posted 04/21/2014 06:50 PM   
[quote="Huntnsouls"]Any chance of you uploading a screenshot of the blocking message? If you can't do that you might want to install a free firewall and see if you have the same problem.[/quote] Thank you deeply for your reply. I couldn't manage to snap a screenshot of the error it's just pops on the right corner and says "the "application name" has been blocked from accesing the graphic hardware". I tried a free firewall named zonealarm and it also didn't help, sadly. Problem still persists.
Huntnsouls said:Any chance of you uploading a screenshot of the blocking message?

If you can't do that you might want to install a free firewall and see if you have the same problem.


Thank you deeply for your reply. I couldn't manage to snap a screenshot of the error it's just pops on the right corner and says "the "application name" has been blocked from accesing the graphic hardware".

I tried a free firewall named zonealarm and it also didn't help, sadly.

Problem still persists.

#4
Posted 04/23/2014 02:11 AM   
I'm pretty sure your laptop is still under warranty and it may be easier troubleshooting this problem with MSI Tech Support as they will be able to remote access your laptop if required to see what the problem may be.
I'm pretty sure your laptop is still under warranty and it may be easier troubleshooting this problem with MSI Tech Support as they will be able to remote access your laptop if required to see what the problem may be.

CPU: Intel i7-3770k @4.6ghz (Noctura NH-D14 Cooler)
MB: Asrock Z77 Extreme4
RAM: 4x4gb @2400mhz(10-11-11-30) G-Skill F3-19200CL11Q-16GBZHD
GPU: EVGA GTX 780 SC w/ ACX Cooler
SSDs: OCZ Vertex 4 256gb x2 in Raid 0 array
HDDs: Seagate 3TB x2
PSU: Thermaltake 750W Toughpower Gold
CASE: Thermaltake VN700M1W2N Overseer RX-I
OS: Windows 7 Pro x64
Mon: LG W2486L-PF

#5
Posted 04/23/2014 09:09 AM   
I reinstalled w8 with deleting everything i have and the problem changed now it says driver has stopped working and recovered succesfully and sometimes it says out of video memory. Still can't run any games with my nvidia card. I reinstalled w8 2 times one with 8.0 the other one with 8.1 same problem for both. I'm very frustated with this problem and i mailed MSI about it 2 weeks ago and they didn't reply. So I can only watch series&movies and play shitty games on my 3000$ gaming laptop.
I reinstalled w8 with deleting everything i have and the problem changed now it says driver has stopped working and recovered succesfully and sometimes it says out of video memory. Still can't run any games with my nvidia card. I reinstalled w8 2 times one with 8.0 the other one with 8.1 same problem for both. I'm very frustated with this problem and i mailed MSI about it 2 weeks ago and they didn't reply. So I can only watch series&movies and play shitty games on my 3000$ gaming laptop.

#6
Posted 05/09/2014 04:50 PM   
Try by installing slimdrivers and updating your drivers with that program. http://download.cnet.com/SlimDrivers-Free/3000-18513_4-75279940.html Dont worry it is made by a Microsoft Partner.
Try by installing slimdrivers and updating your drivers with that program.


http://download.cnet.com/SlimDrivers-Free/3000-18513_4-75279940.html


Dont worry it is made by a Microsoft Partner.

CPU: Intel i7-3770k @4.6ghz (Noctura NH-D14 Cooler)
MB: Asrock Z77 Extreme4
RAM: 4x4gb @2400mhz(10-11-11-30) G-Skill F3-19200CL11Q-16GBZHD
GPU: EVGA GTX 780 SC w/ ACX Cooler
SSDs: OCZ Vertex 4 256gb x2 in Raid 0 array
HDDs: Seagate 3TB x2
PSU: Thermaltake 750W Toughpower Gold
CASE: Thermaltake VN700M1W2N Overseer RX-I
OS: Windows 7 Pro x64
Mon: LG W2486L-PF

#7
Posted 05/10/2014 09:31 AM   
Thanks again for your reply. I used the program you reccomended and updated every driver it showed via it. Problem still persist, sadly.
Thanks again for your reply.

I used the program you reccomended and updated every driver it showed via it.

Problem still persist, sadly.

#8
Posted 05/10/2014 09:44 PM   
Bump
Bump

#9
Posted 05/16/2014 08:50 PM   
Hardware problem perhaps, because there's very little left to do. How's your warranty on getting replacement for the faulty one?
Hardware problem perhaps, because there's very little left to do. How's your warranty on getting replacement for the faulty one?

|CPU> Intel Core i7 4770K @ 4.4GHz (Noctua NH-D14)|GPU> MSI GTX 1080 Ti Gaming X @ 2000MHz|RAM> Crucial Ballistix Tactical 16GB DDR3 @ 1866MHz CL9|MOB> ASRock Z87 OC Formula|PSU> Corsair AX860i|CAS>
Thermaltake Chaser A71|MON> Asus PB238Q (dual screen)|OPS> Windows 10 64-bit (Kingston HyperX 3K 120GB SSD)

#10
Posted 05/16/2014 09:43 PM   
Hi Kaientei, I have almost same problem. No messages though, just random crashes. Unstable system, tried to underclock the pre overclocked system. NOthing works. However I see their new Firmware Vbios update (something about the graphics I guess, since it is named Optimus). Find it at http://www.msi.com/support/nb/GT70_2PE_Dominator_Pro.html#down-firmware&Win8.1%2064 Maybe it will work, but for some reason I cannot boot USB, so, no luck to install it yet. Can you ? -best
Hi Kaientei,
I have almost same problem. No messages though, just random crashes. Unstable system, tried to underclock the pre overclocked system. NOthing works.

However I see their new Firmware Vbios update (something about the graphics I guess, since it is named Optimus). Find it at http://www.msi.com/support/nb/GT70_2PE_Dominator_Pro.html#down-firmware&Win8.1%2064

Maybe it will work, but for some reason I cannot boot USB, so, no luck to install it yet. Can you ?

-best

#11
Posted 06/05/2014 10:19 PM   
I have exactly the same problem. Several of my games (most of all Skyrim and GTA IV) are unstable and crash randomly (in Skyrim quite frequently when accessing world map). If I'm fast enough, I can see the "display driver stopped responding and has recovered" or the "application blocked from graphics hardware" balloon message in the Windows 8 taskbar. Sometimes Skyrim even recovers within ~10 seconds, but it's highly unstable afterwards. My hardware is i7-4770k, Radeon R9 280X, and 16GB G.Skill TridentX memory. The crashes are most definitely not due to insufficient hardware capabilities, since Skyrim and GTA IV are really old games. So it can't be the driver's fault, because you have an Nvidia and I have an ATI, I guess? I very much suspect that the true fault lies with Windows 8.1. Other people suggested that it's faulty or incompatible memory, but I highly doubt that, since it's rather expensive enthusiast memory using Hynix ICs...? I also tried the TdrDelay thing and reinstalling drivers. This problem is driving me crazy - I spent quite a lot on that new i7-4770 rig and now it's crashing on my favorite games when I thought I finally could play them at the most ultra high settings :(
I have exactly the same problem. Several of my games (most of all Skyrim and GTA IV) are unstable and crash randomly (in Skyrim quite frequently when accessing world map). If I'm fast enough, I can see the "display driver stopped responding and has recovered" or the "application blocked from graphics hardware" balloon message in the Windows 8 taskbar. Sometimes Skyrim even recovers within ~10 seconds, but it's highly unstable afterwards.

My hardware is i7-4770k, Radeon R9 280X, and 16GB G.Skill TridentX memory. The crashes are most definitely not due to insufficient hardware capabilities, since Skyrim and GTA IV are really old games.

So it can't be the driver's fault, because you have an Nvidia and I have an ATI, I guess?
I very much suspect that the true fault lies with Windows 8.1. Other people suggested that it's faulty or incompatible memory, but I highly doubt that, since it's rather expensive enthusiast memory using Hynix ICs...?

I also tried the TdrDelay thing and reinstalling drivers. This problem is driving me crazy - I spent quite a lot on that new i7-4770 rig and now it's crashing on my favorite games when I thought I finally could play them at the most ultra high settings :(

#12
Posted 08/24/2014 05:54 PM   
I have exactly the same problem. I have been trying everything but to no effect. Any help much appreciated! GPU: GeForece GTX 780 CPU: Intel(R) Core(TM) i7-4770K CPU@ 3.50GHz Memory: 16 GB Drive: 340.52 OS: Windows 8.1 Pro
I have exactly the same problem. I have been trying everything but to no effect. Any help much appreciated!
GPU: GeForece GTX 780
CPU: Intel(R) Core(TM) i7-4770K CPU@ 3.50GHz
Memory: 16 GB
Drive: 340.52
OS: Windows 8.1 Pro

#13
Posted 09/07/2014 08:11 PM   
I also have these problems since upgrading from vista to win8. I've so for had the problems (including freezing of the GPU-driver) while running any of the games from blizzard (WoW, DiabloII, Heartstone). Not been trying any more demanding games yet. No matter different Dx-settings, lowering graphics, underclocking the GPU (its running at temp about 50C at normal clocking), disabling onboard graphics and audio via BIOS (Intel onboard graphic and RealTech audio), reinstalling graphics drivers, updating windows. Gigabyte Z97x-gaming3 CPU intel core i7 4790 GPU GeForce GTX 660 16GB RAM OS: Windows 8.1 More suggestions on what to do to solve it, please.
I also have these problems since upgrading from vista to win8.
I've so for had the problems (including freezing of the GPU-driver) while running any of the games from blizzard (WoW, DiabloII, Heartstone). Not been trying any more demanding games yet.

No matter different Dx-settings, lowering graphics, underclocking the GPU (its running at temp about 50C at normal clocking), disabling onboard graphics and audio via BIOS (Intel onboard graphic and RealTech audio), reinstalling graphics drivers, updating windows.


Gigabyte Z97x-gaming3
CPU intel core i7 4790
GPU GeForce GTX 660
16GB RAM
OS: Windows 8.1

More suggestions on what to do to solve it, please.

#14
Posted 09/08/2014 04:03 PM   
Yup, same problem here: GPU: Nvidia Geforce GTX 675M / 2 GB GDDR5 CPU: intelcore i7-3630QM 12 GB RAM GDDR3 OS: windows 8 64 bit <--- i think this is the problem (Ikeep opening League of Legends, i open it, and i play a game but after about 3 min. in the game. The screen freezes and the windows alert keeps popping up "application is blocked for access to graphics hardware") The hardware is fine, i factory-reseted my laptop (MSI GT70) 2 times by now and uninstalled/reinstalled the drivers
Yup, same problem here:
GPU: Nvidia Geforce GTX 675M / 2 GB GDDR5
CPU: intelcore i7-3630QM
12 GB RAM GDDR3
OS: windows 8 64 bit <--- i think this is the problem

(Ikeep opening League of Legends, i open it, and i play a game but after about 3 min. in the game. The screen freezes and the windows alert keeps popping up "application is blocked for access to graphics hardware")

The hardware is fine, i factory-reseted my laptop (MSI GT70) 2 times by now and uninstalled/reinstalled the drivers

#15
Posted 09/16/2014 11:20 PM   
  1 / 5    
Scroll To Top