Shield sees PC but throws 'Cannot Connect to PC' message after accepting
Good evening, Just picked up my Shield tonight and had one hell of a time getting the unit to recognize my PC. Newly built Windows 8.1 that meets all the specs and has a wonderful new GTX 750 TI inside. Anyway I had to remove all of the drivers that came with the new card and pulled down the freshest installs from Geforce.com. After that I was able to see the PC on the Shield and I got the prompt on the PC that the Shield was asking to connect. However the second I accept a message on the shield says 'Cannot connect to (MyPCNAME)'. I've been reading through threads for a couple of hours and most of of what I have found seems related to not finding the PC. Now that I have I am wondering what the next steps are. I have 3 Wireless networks here. Two primaries (5 & 2.4 ghz) from a Netgear WNDRMACv2 and I also have an Gen 2 Airport Extreme that I connected directly to. The Shield can see the PC on both 5 GHZ networks but behaves by saying 'Cannot Connect to PC'. Does anyone have any thoughts on what might be going on here? I've got an insane collection of titles I NEED to stream into this little powerhouse! Thanks! DCHAD
Good evening,

Just picked up my Shield tonight and had one hell of a time getting the unit to recognize my PC. Newly built Windows 8.1 that meets all the specs and has a wonderful new GTX 750 TI inside. Anyway I had to remove all of the drivers that came with the new card and pulled down the freshest installs from Geforce.com. After that I was able to see the PC on the Shield and I got the prompt on the PC that the Shield was asking to connect. However the second I accept a message on the shield says 'Cannot connect to (MyPCNAME)'. I've been reading through threads for a couple of hours and most of of what I have found seems related to not finding the PC. Now that I have I am wondering what the next steps are. I have 3 Wireless networks here. Two primaries (5 & 2.4 ghz) from a Netgear WNDRMACv2 and I also have an Gen 2 Airport Extreme that I connected directly to. The Shield can see the PC on both 5 GHZ networks but behaves by saying 'Cannot Connect to PC'.

Does anyone have any thoughts on what might be going on here? I've got an insane collection of titles I NEED to stream into this little powerhouse!

Thanks!
DCHAD

#1
Posted 03/29/2014 03:07 AM   
Did you end up getting this issue resolved? I am having the same problem.
Did you end up getting this issue resolved? I am having the same problem.

#2
Posted 08/02/2014 07:23 PM   
Scroll To Top