dxgi_error_device_removed GTX 680
I've been getting a dxgi_error_device_removed error in my games lately. I first thought it was an issue with an ArmA 3 patch or something, but it just happened in Banished as well. It seems to happen after a relatively short period of time, maybe 5 or so minutes. Since I had the issue in ArmA 3 I updated my drivers as it had been a while, but then the same error popped up in Banished.
I've been getting a dxgi_error_device_removed error in my games lately. I first thought it was an issue with an ArmA 3 patch or something, but it just happened in Banished as well. It seems to happen after a relatively short period of time, maybe 5 or so minutes. Since I had the issue in ArmA 3 I updated my drivers as it had been a while, but then the same error popped up in Banished.

I7 3770K :: GTX 680 OC :: 16GB Corsair Platinum DDR3 :: Windows 8 64Bit

#1
Posted 03/08/2014 11:00 PM   
http://supercomputers1tech.blogspot.com/2013/02/how-to-solve-dxgierrordeviceremoved.html

Windows 7 64 Bit
Intel i72600K @ 4.5 GHz
Asus P8P67 Deluxe B3 BIOS 1606
Swiftech water cooling components
G. Skill Ripjaws Model F3-12800CL8D-8GBXM (2 X 4 GB)
MSI GTX970
Crucial 128 GB M4 SSD
Asus 26" and 22" Gateway widescreen
X-Fi Extremegamer
Logitech 5.1 sound
Logitech MX518 mouse
Nostromo n52 HID SpeedPad 2.0 and Logitech G13

#2
Posted 03/09/2014 12:39 AM   
I guess I'll try cleaning my GPU... I already did the rest pretty much prior to this.
I guess I'll try cleaning my GPU... I already did the rest pretty much prior to this.

I7 3770K :: GTX 680 OC :: 16GB Corsair Platinum DDR3 :: Windows 8 64Bit

#3
Posted 03/09/2014 05:46 AM   
Scroll To Top