Can't run diablo 2: LoD. Please help!
When i try to run the game i get an error message saying "Error 1: Diablo II is unable to proceed. Please run D2VidTst and try again". And when i run the video test i get "No video modes found!" and "this computer cannot run Diablo II". Note that I at first got this error: "Error 25: A critical error has occurred while initializing Direct3D" But it later changed to error 1. I contacted Blizzard's support and tried all of the following without success: The way I got around this issue was the following: 1. Right click on your game shortcut (from the desktop) 2. Select 'Properties' 3. Click the 'Compatibility' tab 3a. Tick the box which says 'Run this program in compatibility mode for' and then from the drop down list, choose one of the following: - Windows 98 / ME or - Windows XP Service Pack 3 (Some people had issues with 98 / ME but XP worked for them and vise versa) 4. Tick the box 'Run in 256 colours' 5. Tick the box 'Run in 640 x 480 screen resolution' 6. Tick the box for 'Disable desktop composition' 7. Tick the box for 'Run this program as an administrator' - Click Apply, Click OK. Next you will need to right click on your desktop and click 'Screen Resolution', once you have this window open you don't actually need to do anything with it - just make sure you leave it open on your desktop. Finally, double click on your game shortcut and keep your fingers crossed! If you continue to get issues with the rainbow colours / black screens etc or video card problems, this is more than likely going to be related to your monitor or background applications, you may need to also manually config the monitor to support the 256 colours. - Conflicting Applications: It is possible you are experiancing 'insufficent system resources' or 'conflicting apps', this can tend to be if you have a lot of background applications running, try running a selective startup to limit the amount of background applications: http://eu.blizzard.com/support/article/19382 If anyone out there had this problem or knows how to fix it, please help! Thanks!
When i try to run the game i get an error message saying "Error 1: Diablo II is unable to proceed. Please run D2VidTst and try again". And when i run the video test i get "No video modes found!" and "this computer cannot run Diablo II".

Note that I at first got this error: "Error 25: A critical error has occurred while initializing Direct3D" But it later changed to error 1.

I contacted Blizzard's support and tried all of the following without success:

The way I got around this issue was the following:

1. Right click on your game shortcut (from the desktop)
2. Select 'Properties'
3. Click the 'Compatibility' tab
3a. Tick the box which says 'Run this program in compatibility mode for' and then from the drop down list, choose one of the following:

- Windows 98 / ME
or
- Windows XP Service Pack 3

(Some people had issues with 98 / ME but XP worked for them and vise versa)

4. Tick the box 'Run in 256 colours'
5. Tick the box 'Run in 640 x 480 screen resolution'
6. Tick the box for 'Disable desktop composition'
7. Tick the box for 'Run this program as an administrator'
- Click Apply, Click OK.

Next you will need to right click on your desktop and click 'Screen Resolution', once you have this window open you don't actually need to do anything with it - just make sure you leave it open on your desktop.

Finally, double click on your game shortcut and keep your fingers crossed!

If you continue to get issues with the rainbow colours / black screens etc or video card problems, this is more than likely going to be related to your monitor or background applications, you may need to also manually config the monitor to support the 256 colours.

- Conflicting Applications:
It is possible you are experiancing 'insufficent system resources' or 'conflicting apps', this can tend to be if you have a lot of background applications running, try running a selective startup to limit the amount of background applications: http://eu.blizzard.com/support/article/19382

If anyone out there had this problem or knows how to fix it, please help!

Thanks!

#1
Posted 06/05/2013 07:29 PM   
Those tricks can help, but the easy way, and one which allows higher resolution, is the Glice to OpenGL Wrapper - [url]http://www.svenswrapper.de/english/index.html[/url]
Those tricks can help, but the easy way, and one which allows higher resolution, is
the Glice to OpenGL Wrapper -

http://www.svenswrapper.de/english/index.html

BossDweebe is in his second childhood, or would be if he'd ever left the first.

#2
Posted 06/06/2013 09:23 AM   
Bump bump
Bump bump

#3
Posted 06/09/2013 10:38 AM   
Bump again..
Bump again..

#4
Posted 06/13/2013 03:18 PM   
Scroll To Top