Nvidia Inspector, unhandled exception has occurred
I've spent hours reading through forums and still can't get this fixed. To my understanding, it's an issue with Microsoft .net Framework. I've tried Aaron Stebner's removal tool, but it doesn't remove 3.5, apparently that's embedded into Windows 7. So how is everyone else getting this to work? I've tried installing .net framework 2 but can only find a version that says can only install on vista... I have a GTX 675MX in a GT70 laptop, I need the inspector to work because I can't get the game Tera to run using the dedicated graphics
I've spent hours reading through forums and still can't get this fixed. To my understanding, it's an issue with Microsoft .net Framework. I've tried Aaron Stebner's removal tool, but it doesn't remove 3.5, apparently that's embedded into Windows 7. So how is everyone else getting this to work?
I've tried installing .net framework 2 but can only find a version that says can only install on vista...

I have a GTX 675MX in a GT70 laptop, I need the inspector to work because I can't get the game Tera to run using the dedicated graphics

#1
Posted 03/31/2013 12:08 AM   
Could you copy and paste the entire error message here? An unhandled exception is typically an error in program function, and may be unrelated to version of .NET framework.
Could you copy and paste the entire error message here? An unhandled exception is typically an error in program function, and may be unrelated to version of .NET framework.

"This is your code. These are also your bugs. Really. Yes, the API runtime and the
driver have bugs, but this is not one of them. Now go fix it already." -fgiesen

#2
Posted 03/31/2013 01:54 AM   
See the end of this message for details on invoking just-in-time (JIT) debugging instead of this dialog box. ************** Exception Text ************** System.DivideByZeroException: Attempted to divide by zero. at ?.?(Int32 ?) at ?.?(Int32 ?) at ?.?(Int32 ?) at System.Windows.Forms.ListControl.OnSelectedValueChanged(EventArgs e) at System.Windows.Forms.ComboBox.OnSelectedValueChanged(EventArgs e) at System.Windows.Forms.ComboBox.OnSelectedIndexChanged(EventArgs e) at System.Windows.Forms.ComboBox.set_SelectedIndex(Int32 value) at ?.?() at ?.?(Object ?, EventArgs ?) at System.Windows.Forms.Form.OnLoad(EventArgs e) at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible) at System.Windows.Forms.Control.CreateControl() at System.Windows.Forms.Control.WmShowWindow(Message& m) at System.Windows.Forms.Control.WndProc(Message& m) at ?.WndProc(Message& m) at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m) at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam) ************** Loaded Assemblies ************** mscorlib Assembly Version: 2.0.0.0 Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900) CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll ---------------------------------------- nvidiaInspector Assembly Version: 1.9.7.0 Win32 Version: 1.9.7.0 CodeBase: file:///C:/Users/Laptop/Downloads/nvidiaInspector/nvidiaInspector.exe ---------------------------------------- System Assembly Version: 2.0.0.0 Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900) CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll ---------------------------------------- System.Management Assembly Version: 2.0.0.0 Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900) CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Management/2.0.0.0__b03f5f7f11d50a3a/System.Management.dll ---------------------------------------- System.Windows.Forms Assembly Version: 2.0.0.0 Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900) CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll ---------------------------------------- System.Drawing Assembly Version: 2.0.0.0 Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900) CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll ---------------------------------------- ************** JIT Debugging ************** To enable just-in-time (JIT) debugging, the .config file for this application or computer (machine.config) must have the jitDebugging value set in the system.windows.forms section. The application must also be compiled with debugging enabled. For example: <configuration> <system.windows.forms jitDebugging="true" /> </configuration> When JIT debugging is enabled, any unhandled exception will be sent to the JIT debugger registered on the computer rather than be handled by this dialog box.
See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.DivideByZeroException: Attempted to divide by zero.
at ?.?(Int32 ?)
at ?.?(Int32 ?)
at ?.?(Int32 ?)
at System.Windows.Forms.ListControl.OnSelectedValueChanged(EventArgs e)
at System.Windows.Forms.ComboBox.OnSelectedValueChanged(EventArgs e)
at System.Windows.Forms.ComboBox.OnSelectedIndexChanged(EventArgs e)
at System.Windows.Forms.ComboBox.set_SelectedIndex(Int32 value)
at ?.?()
at ?.?(Object ?, EventArgs ?)
at System.Windows.Forms.Form.OnLoad(EventArgs e)
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.Control.CreateControl()
at System.Windows.Forms.Control.WmShowWindow(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at ?.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll
----------------------------------------
nvidiaInspector
Assembly Version: 1.9.7.0
Win32 Version: 1.9.7.0
CodeBase: file:///C:/Users/Laptop/Downloads/nvidiaInspector/nvidiaInspector.exe
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Management
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Management/2.0.0.0__b03f5f7f11d50a3a/System.Management.dll
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.
Attachments

Capture.JPG

#3
Posted 03/31/2013 01:58 AM   
Added a picture of the error message too
Added a picture of the error message too

#4
Posted 03/31/2013 02:04 AM   
[quote="therealdave"]System.DivideByZeroException: Attempted to divide by zero.[/quote] This is most likely an application bug, so I would recommend you contact Inspector's developer (Orbmu2k): [url]http://forums.guru3d.com/showthread.php?t=375250[/url]
therealdave said:System.DivideByZeroException: Attempted to divide by zero.


This is most likely an application bug, so I would recommend you contact Inspector's developer (Orbmu2k):
http://forums.guru3d.com/showthread.php?t=375250

"This is your code. These are also your bugs. Really. Yes, the API runtime and the
driver have bugs, but this is not one of them. Now go fix it already." -fgiesen

#5
Posted 03/31/2013 03:02 AM   
Thanks for trying!
Thanks for trying!

#6
Posted 03/31/2013 04:13 AM   
you can remove dot net 3.5 (including 2.0 and 3.0) from the "Turn Windows Features on and off" sub screen of Programs and Features.
you can remove dot net 3.5 (including 2.0 and 3.0) from the "Turn Windows Features on and off" sub screen of Programs and Features.



In Memory of Chris "ChrisRay" Arthington, 1982-2010

Specs:
CPU:Intel Xeon x5690 @ 4.2Ghz, Mainboard:Asus Rampage III Extreme, Memory:48GB Corsair Vengeance LP 1600
Video:EVGA Geforce GTX 1080 Founders Edition, NVidia Geforce GTX 1060 Founders Edition
Monitor:BenQ G2400WD, BenQ BL2211
Sound:Creative XFI Titanium Fatal1ty Pro
SDD:Crucial MX300 275, Crucial MX300 525, Crucial MX200 250
HDD:500GB Spinpoint F3, 1TB WD Black, 2TB WD Red, 1TB WD Black
Case:NZXT Phantom 820, PSU:Seasonic X-850, OS:Windows 7 SP1
Cooler: ThermalRight Silver Arrow IB-E Extreme

WIP:
CPU:Intel Xeon x5660, Mainboard:Asus Rampage II Gene, Memory:16GB Corsair Vengeance 1600 LP
Video:EVGA Geforce GTX 680+ 4GB, Palit Geforce GTX 550ti
Monitor:Pending
Sound:HDMI
SDD:Pending
HDD:Pending
Case:NZXT Guardian 921RB, PSU:Corsair 620HX, OS:Windows 7 SP1
Cooler: ThermalRight True Spirit 120M

#7
Posted 03/31/2013 09:09 AM   
I have it disabled already, still getting that error in inspector
I have it disabled already, still getting that error in inspector

#8
Posted 03/31/2013 07:51 PM   
I don't think it's something you can fix by uninstalling or reinstalling the .net framework. My opinion is still application bug. Good luck getting a response from the developer.
I don't think it's something you can fix by uninstalling or reinstalling the .net framework. My opinion is still application bug. Good luck getting a response from the developer.

"This is your code. These are also your bugs. Really. Yes, the API runtime and the
driver have bugs, but this is not one of them. Now go fix it already." -fgiesen

#9
Posted 03/31/2013 08:06 PM   
Any other way than inspector to get Tera to use the GTX 675MX?
Any other way than inspector to get Tera to use the GTX 675MX?

#10
Posted 03/31/2013 10:14 PM   
if its turned off, TURN IT ON.
if its turned off, TURN IT ON.



In Memory of Chris "ChrisRay" Arthington, 1982-2010

Specs:
CPU:Intel Xeon x5690 @ 4.2Ghz, Mainboard:Asus Rampage III Extreme, Memory:48GB Corsair Vengeance LP 1600
Video:EVGA Geforce GTX 1080 Founders Edition, NVidia Geforce GTX 1060 Founders Edition
Monitor:BenQ G2400WD, BenQ BL2211
Sound:Creative XFI Titanium Fatal1ty Pro
SDD:Crucial MX300 275, Crucial MX300 525, Crucial MX200 250
HDD:500GB Spinpoint F3, 1TB WD Black, 2TB WD Red, 1TB WD Black
Case:NZXT Phantom 820, PSU:Seasonic X-850, OS:Windows 7 SP1
Cooler: ThermalRight Silver Arrow IB-E Extreme

WIP:
CPU:Intel Xeon x5660, Mainboard:Asus Rampage II Gene, Memory:16GB Corsair Vengeance 1600 LP
Video:EVGA Geforce GTX 680+ 4GB, Palit Geforce GTX 550ti
Monitor:Pending
Sound:HDMI
SDD:Pending
HDD:Pending
Case:NZXT Guardian 921RB, PSU:Corsair 620HX, OS:Windows 7 SP1
Cooler: ThermalRight True Spirit 120M

#11
Posted 04/01/2013 04:54 AM   
[quote=Orbmu2k]please try the just released version 1.9.7.1. ############################################### ### NVIDIA INSPECTOR - CHANGELOG ### ############################################### Version 1.9.7.1 - fixed overclocking panel was expanded by default [b]- fixed divide by zero bug for some mobile kepler cards[/b][/quote]
Orbmu2k said:please try the just released version 1.9.7.1.

###############################################
### NVIDIA INSPECTOR - CHANGELOG ###
###############################################

Version 1.9.7.1

- fixed overclocking panel was expanded by default
- fixed divide by zero bug for some mobile kepler cards

"This is your code. These are also your bugs. Really. Yes, the API runtime and the
driver have bugs, but this is not one of them. Now go fix it already." -fgiesen

#12
Posted 04/01/2013 06:58 PM   
divide by zero's are tasty :D
divide by zero's are tasty :D



In Memory of Chris "ChrisRay" Arthington, 1982-2010

Specs:
CPU:Intel Xeon x5690 @ 4.2Ghz, Mainboard:Asus Rampage III Extreme, Memory:48GB Corsair Vengeance LP 1600
Video:EVGA Geforce GTX 1080 Founders Edition, NVidia Geforce GTX 1060 Founders Edition
Monitor:BenQ G2400WD, BenQ BL2211
Sound:Creative XFI Titanium Fatal1ty Pro
SDD:Crucial MX300 275, Crucial MX300 525, Crucial MX200 250
HDD:500GB Spinpoint F3, 1TB WD Black, 2TB WD Red, 1TB WD Black
Case:NZXT Phantom 820, PSU:Seasonic X-850, OS:Windows 7 SP1
Cooler: ThermalRight Silver Arrow IB-E Extreme

WIP:
CPU:Intel Xeon x5660, Mainboard:Asus Rampage II Gene, Memory:16GB Corsair Vengeance 1600 LP
Video:EVGA Geforce GTX 680+ 4GB, Palit Geforce GTX 550ti
Monitor:Pending
Sound:HDMI
SDD:Pending
HDD:Pending
Case:NZXT Guardian 921RB, PSU:Corsair 620HX, OS:Windows 7 SP1
Cooler: ThermalRight True Spirit 120M

#13
Posted 04/02/2013 06:12 AM   
Great support from the developer I must say! Hope the new version squashed that problem once and for all, for the several folks experiencing that issue.
Great support from the developer I must say! Hope the new version squashed that problem once and for all, for the several folks experiencing that issue.

"This is your code. These are also your bugs. Really. Yes, the API runtime and the
driver have bugs, but this is not one of them. Now go fix it already." -fgiesen

#14
Posted 04/02/2013 08:06 PM   
Scroll To Top