Games wont use my dedicated nvidia graphics, instead they use my integrated. How to fix?!
For some reason, a few of my games such as ARMA 2, GTA IV seem to be running at very low fps. I now know the reason is because they are running on my Integrated graphics card. I've tried going on the nvidia control panel and setting the games to run off High-performance NVIDIA processor, but this does absolutely nothing. I've enabled Add 'run graphics processor' then righting clicking on a game and selecting Run with - High-performance NVIDIA processor, but this does nothing either! I know for sure my laptop should in fact be running these games at a high fps. I can run Black Ops 2 on high setting at a stable 60fps. So how do I make these games run of nvidia instead of integrated? Thanks! Specs: Intel Core i7 8GB Ram nVidia GeForce GT640
For some reason, a few of my games such as ARMA 2, GTA IV seem to be running at very low fps. I now know the reason is because they are running on my Integrated graphics card. I've tried going on the nvidia control panel and setting the games to run off High-performance NVIDIA processor, but this does absolutely nothing. I've enabled Add 'run graphics processor' then righting clicking on a game and selecting Run with - High-performance NVIDIA processor, but this does nothing either! I know for sure my laptop should in fact be running these games at a high fps. I can run Black Ops 2 on high setting at a stable 60fps. So how do I make these games run of nvidia instead of integrated? Thanks!

Specs:
Intel Core i7
8GB Ram
nVidia GeForce GT640

#1
Posted 03/13/2013 04:50 PM   
Scroll To Top