Crashing in Starcraft 2: HotS
  1 / 4    
I am crashing in Starcraft 2 heart of the swarm campaign quite a bit. The error message says that the game has encountered an "unexpected directx/opengl error" which indicates "out of date video card drivers" and must close. I am currently running a GTX 670M on an ASUS laptop, I easily exceed all minimum system requirements. I have tried clean installs of 310.90, 314.07, and 314.14 drivers and none have remedied the issue. A fair number of others have also had this issue and have been discussing it in this thread http://us.battle.net/sc2/en/forum/topic/7801130601 . One individual claims that reverting to a clean install of 310.90 drivers worked for him and others, but for me that was totally useless. I already have an open support ticket with blizzard and I am participating in the thread, but since the problem is so persistent and seems related to drivers, though as you can see in the thread it is happening on a wide range of cards.
I am crashing in Starcraft 2 heart of the swarm campaign quite a bit. The error message says that the game has encountered an "unexpected directx/opengl error" which indicates "out of date video card drivers" and must close.

I am currently running a GTX 670M on an ASUS laptop, I easily exceed all minimum system requirements. I have tried clean installs of 310.90, 314.07, and 314.14 drivers and none have remedied the issue.

A fair number of others have also had this issue and have been discussing it in this thread http://us.battle.net/sc2/en/forum/topic/7801130601 . One individual claims that reverting to a clean install of 310.90 drivers worked for him and others, but for me that was totally useless.

I already have an open support ticket with blizzard and I am participating in the thread, but since the problem is so persistent and seems related to drivers, though as you can see in the thread it is happening on a wide range of cards.

#1
Posted 03/13/2013 04:59 AM   
I'm having the exact same problem on an asus g75vw with the 670m, have also tried reverting to the 314.07 from the latest beta driver with no success. seems to only happen in the campaign. I have however noticed non game crashing graphical glitches in multi-player that were not present during the beta when im running 314.07. if anyone knows a fix that would be great! :)
I'm having the exact same problem on an asus g75vw with the 670m, have also tried reverting to the 314.07 from the latest beta driver with no success. seems to only happen in the campaign. I have however noticed non game crashing graphical glitches in multi-player that were not present during the beta when im running 314.07. if anyone knows a fix that would be great! :)

#2
Posted 03/13/2013 07:29 AM   
Thanks for the info. I'll have our driver team investigate.
Thanks for the info. I'll have our driver team investigate.

We can't fix your bug if we can't reproduce it. Please provide as much details as possible including specs, steps to reproduce, graphics settings used, etc..

For GeForce driver issues, please leave feedback in driver feedback form: Driver Feedback

For SHIELD Android TV issues/requests, please leave feedback in the SHIELD feedback form: SHIELD Feedback

For SHIELD Tablet issues/requests, please leave feedback in the SHIELD Tablet feedback form: SHIELD Tablet Feedback

I am also available on Twitter:
www.twitter.com/manuelguzman

#3
Posted 03/13/2013 08:03 AM   
Just as an update, I wanted to mention that what happens with the OP's card also happens with mine. A 560GTX HAWK.
Just as an update, I wanted to mention that what happens with the OP's card also happens with mine. A 560GTX HAWK.

#4
Posted 03/13/2013 12:43 PM   
New SC2 patch changed nothing, I am still crashing occasionally.
New SC2 patch changed nothing, I am still crashing occasionally.

#5
Posted 03/13/2013 06:48 PM   
Having the same problem as the OP, playing on an Asus laptop too, 670M GTX 3gb. Cant play for more than 15 minutes, freezes the game or goes into black screen and then a crash.
Having the same problem as the OP, playing on an Asus laptop too, 670M GTX 3gb.

Cant play for more than 15 minutes, freezes the game or goes into black screen and then a crash.

#6
Posted 03/13/2013 10:07 PM   
I've exactly the same problem on my Asus ROG G75VW with my GTX670M 3Gb All my drivers are ok, tried to uninstall and reinstall Sc2:HotS but same result : random crashes on campaign and ladder... I'm very disappointed. :(
I've exactly the same problem on my Asus ROG G75VW with my GTX670M 3Gb

All my drivers are ok, tried to uninstall and reinstall Sc2:HotS but same result : random crashes on campaign and ladder...
I'm very disappointed. :(

#7
Posted 03/13/2013 10:51 PM   
i have the same problems too samsung laptop 675gtx this beast cost me 2000$ last month dont know if the problem is a driver issus or game issus
i have the same problems too
samsung laptop 675gtx
this beast cost me 2000$ last month dont know if the problem is a driver issus or game issus

#8
Posted 03/14/2013 12:30 AM   
I get similar crash with GTX 670 Win 8 64bit 314.14
I get similar crash with GTX 670 Win 8 64bit 314.14

#9
Posted 03/14/2013 10:58 AM   
I'm having the same issue along with MANY others on the SC2 Forum. http://us.battle.net/sc2/en/forum/topic/8156055985?page=1 GTX 460 here with all drivers up to date. Within 3-5 min of ANY map I get BSOD. EVERY single time.
I'm having the same issue along with MANY others on the SC2 Forum.


http://us.battle.net/sc2/en/forum/topic/8156055985?page=1


GTX 460 here with all drivers up to date. Within 3-5 min of ANY map I get BSOD. EVERY single time.

#10
Posted 03/14/2013 11:15 AM   
Blizzard is asking for PC info but it's obvious they do not have a fix at this time.
Blizzard is asking for PC info but it's obvious they do not have a fix at this time.

#11
Posted 03/14/2013 11:19 AM   
The info in the referenced thread is actually different from the issue the OP describes. In the reference Blizzard post we are discussing an issue which causes a BSOD. Within a few minutes of starting a mission you get graphics issues...the cursor turns into a large square which sort of looks like a bar code, other tearing and graphics errors...the screen almost fills with smoke, or flashes grey, etc....then within about 60 seconds we get a BSOD listing nvlddmkm.sys as the problem file. Several peoples dxdiags are available on thread Zarawer referenced. HELP!!!!
The info in the referenced thread is actually different from the issue the OP describes.

In the reference Blizzard post we are discussing an issue which causes a BSOD.

Within a few minutes of starting a mission you get graphics issues...the cursor turns into a large square which sort of looks like a bar code, other tearing and graphics errors...the screen almost fills with smoke, or flashes grey, etc....then within about 60 seconds we get a BSOD listing nvlddmkm.sys as the problem file.

Several peoples dxdiags are available on thread Zarawer referenced. HELP!!!!

#12
Posted 03/14/2013 12:28 PM   
I have the same issue - GB GTX 670 OC 2GB. There's a similar topic on the EU forums as well. -> http://eu.battle.net/sc2/en/forum/topic/6893569912
I have the same issue - GB GTX 670 OC 2GB.

There's a similar topic on the EU forums as well. -> http://eu.battle.net/sc2/en/forum/topic/6893569912

#13
Posted 03/15/2013 09:09 AM   
I have the same issue as Zarawer. Squared cursor crash thing. It seems i found a workaround for my machine. I installed the 267.85 driver version http://dlcdnet.asus.com/pub/ASUS/vga/nVidia/nv26785_Win7Vista64bit_WHQL.zip and can now play without this crash. Please try this. If it works for more people its clear that it is a general problem that needs fixing.
I have the same issue as Zarawer. Squared cursor crash thing. It seems i found a workaround for my machine. I installed the 267.85 driver version http://dlcdnet.asus.com/pub/ASUS/vga/nVidia/nv26785_Win7Vista64bit_WHQL.zip
and can now play without this crash. Please try this. If it works for more people its clear that it is a general problem that needs fixing.

#14
Posted 03/15/2013 10:10 AM   
I seem to have the same problem. The game crashes on the same level over and over again. The laptop gives me a blue screen of death. With the advice to update, I did that already. It worked fine in Wings of Liberty. My laptop has a GT 540M videocard.
I seem to have the same problem. The game crashes on the same level over and over again. The laptop gives me a blue screen of death. With the advice to update, I did that already. It worked fine in Wings of Liberty.

My laptop has a GT 540M videocard.

#15
Posted 03/15/2013 10:14 AM   
  1 / 4    
Scroll To Top