This thing with the screen shifted to the right...
I apologize if this has been covered before, or multiple times. I found the forum when searching for clues to the problem and I didn't really come across a suitable answer. After tinkering around, I figured it out on my own, however, and since I did find some unanswered threads on the subject here (although a few years old) I thought I'd share what I did in case they help anyone else in my situation. I finally hooked up my old desktop computer, which is a HP running Vista 64, to my Sony HDTV. Everything looked fine to me - I'm not too picky - save for the screen being shifted to the right. There was a black bar on the left and the PM on the time was cut off on the bottom right. Besides being frustrating, it made it difficult to close fullscreen windows. I went into the Control Panel and then "Appearance and Personalization," then clicked on the tab for GeForce 6150SE nForce 430 and started the NVIDIA Control Panel. There, I used the feature for shifting the CRT screen over to the left. No problem, right? Well, a few minutes after closing out of that, the screen would shift back out of whack again. After multiple attempts, this is where I started looking around online. Outside of some unanswered questions about similar problems, here and elsewhere, I did come across a long thread here that ran for years and had this fix involving major hacking (seemed major to me, anyway. I'm not much of a techie). Anyway, I wasn't sure if it would work for my specific problem and it was Greek to me, so I didn't try it. So I played around with the NVIDIA some more... and fixed it. When going back into the NVIDIA Control Panel, the screen snaps right back into place, so in the top menu, I clicked on Profiles and clicked Save. I just typed 1 to name the profile. Then I went out. This didn't take care of the issue, so I went back in, clicked on Profiles and now I clicked Load and loaded 1 which had the saved setting for the proper shifting that I wanted. It stayed put after I closed out! I shut down and started her up again. Still there! Easy as pie. Again, if everyone already knows this, my bad. If not, I hope it helps.
I apologize if this has been covered before, or multiple times. I found the forum when searching for clues to the problem and I didn't really come across a suitable answer. After tinkering around, I figured it out on my own, however, and since I did find some unanswered threads on the subject here (although a few years old) I thought I'd share what I did in case they help anyone else in my situation.

I finally hooked up my old desktop computer, which is a HP running Vista 64, to my Sony HDTV.

Everything looked fine to me - I'm not too picky - save for the screen being shifted to the right. There was a black bar on the left and the PM on the time was cut off on the bottom right. Besides being frustrating, it made it difficult to close fullscreen windows.

I went into the Control Panel and then "Appearance and Personalization," then clicked on the tab for GeForce 6150SE nForce 430 and started the NVIDIA Control Panel. There, I used the feature for shifting the CRT screen over to the left. No problem, right?

Well, a few minutes after closing out of that, the screen would shift back out of whack again. After multiple attempts, this is where I started looking around online. Outside of some unanswered questions about similar problems, here and elsewhere, I did come across a long thread here that ran for years and had this fix involving major hacking (seemed major to me, anyway. I'm not much of a techie). Anyway, I wasn't sure if it would work for my specific problem and it was Greek to me, so I didn't try it.

So I played around with the NVIDIA some more... and fixed it.

When going back into the NVIDIA Control Panel, the screen snaps right back into place, so in the top menu, I clicked on Profiles and clicked Save. I just typed 1 to name the profile. Then I went out. This didn't take care of the issue, so I went back in, clicked on Profiles and now I clicked Load and loaded 1 which had the saved setting for the proper shifting that I wanted.

It stayed put after I closed out! I shut down and started her up again. Still there! Easy as pie. Again, if everyone already knows this, my bad. If not, I hope it helps.

#1
Posted 02/27/2013 11:12 PM   
I was out for a bit thanks to some health issues but wanted to drop back in with an update to this for those interested or who might have the same problem. While the above fix was working great, the screen did, on occasion, snap back to the right. I would just go in and load the NVIDIA profile and it would stay again for while, which was still a lot less frustration than previously. It mostly happened after playing certain games or something like that. However, I poked around and I'm happy to say I found a permanent, and even easier fix to it all. Since I haven't been around for over a month and use the computer daily, I can safely say it's definitely in place and good to go. In Display Settings, I went into Advanced Settings and under the Adapter tab, clicked List All Modes. There, I changed it from 1024 by 768, True Color (32 bit), 60 Hertz to 1280 by 768, etc... It seems that the entire issue evolved around 1024 needing to be 1280. Why, I have no clue but it worked. Lol, then I had to put the picture adjustment I'd made in NVIDIA back to normal because I had it too far left, but all is right in my world now. So try that if you're having trouble with your computer on a big HDTV. It's only a few clicks.
I was out for a bit thanks to some health issues but wanted to drop back in with an update to this for those interested or who might have the same problem.

While the above fix was working great, the screen did, on occasion, snap back to the right. I would just go in and load the NVIDIA profile and it would stay again for while, which was still a lot less frustration than previously. It mostly happened after playing certain games or something like that.

However, I poked around and I'm happy to say I found a permanent, and even easier fix to it all. Since I haven't been around for over a month and use the computer daily, I can safely say it's definitely in place and good to go.

In Display Settings, I went into Advanced Settings and under the Adapter tab, clicked List All Modes. There, I changed it from 1024 by 768, True Color (32 bit), 60 Hertz to 1280 by 768, etc...

It seems that the entire issue evolved around 1024 needing to be 1280. Why, I have no clue but it worked. Lol, then I had to put the picture adjustment I'd made in NVIDIA back to normal because I had it too far left, but all is right in my world now.

So try that if you're having trouble with your computer on a big HDTV. It's only a few clicks.

#2
Posted 04/06/2013 11:19 PM   
Scroll To Top