DXGI ERROR DEVICE REMOVED
I have a EVGA GTX680 with the latest driver am playing Crysis3 but am getting the error message DXGI ERROR DEVICE REMOVED. I've run the GeForce optimization program but that didn't help. I have also notice these strange issues associated with this message. The message pops up in the game and it crashes to desktop where I get a message in the tray that says something to the effect that the nVidia kernel has stopped working and the video card has been reset. On my other machine which is a MacPro I have an nVidia GTX280 I can boot to OSX or Windows Vista. In Vista I was running AutoCAD and got the same system tray message (not the DXGI ERROR DEVICE REMOVED message). When they came out with an AutoCAD version for the Mac I switched to that and did not have any issues at all. Now I was running DX10 with the GTX280 card and DX11 on the GTX680 card (not sure if that has any bearing). What I am thinking is that it's the driver. A lot of people over on the C3 forum are having this issue as well as very bad stuttering. Do I need to use the nVidia driver (314.07) or one from EVGA?
I have a EVGA GTX680 with the latest driver am playing Crysis3 but am getting the error message DXGI ERROR DEVICE REMOVED. I've run the GeForce optimization program but that didn't help. I have also notice these strange issues associated with this message. The message pops up in the game and it crashes to desktop where I get a message in the tray that says something to the effect that the nVidia kernel has stopped working and the video card has been reset. On my other machine which is a MacPro I have an nVidia GTX280 I can boot to OSX or Windows Vista. In Vista I was running AutoCAD and got the same system tray message (not the DXGI ERROR DEVICE REMOVED message). When they came out with an AutoCAD version for the Mac I switched to that and did not have any issues at all. Now I was running DX10 with the GTX280 card and DX11 on the GTX680 card (not sure if that has any bearing).
What I am thinking is that it's the driver. A lot of people over on the C3 forum are having this issue as well as very bad stuttering. Do I need to use the nVidia driver (314.07) or one from EVGA?

#1
Posted 02/26/2013 12:19 PM   
Crysis 3 is buggy... You're not the only one with that problem
Crysis 3 is buggy... You're not the only one with that problem

Asus P8Z77 V LE

Intel i5 3570K @ 4.6ghz

EVGA GTX680 SC

Corsair Vengeance 8GB DDR3 @ 1800mhz

#2
Posted 02/26/2013 11:31 PM   
I ran this DXGI DLL fixer and it seems to have fixed the issue as that error message hasn't popped up since. Now I'm having very bad stuttering -- to the extent that the game is unplayable.
I ran this DXGI DLL fixer and it seems to have fixed the issue as that error message hasn't popped up since. Now I'm having very bad stuttering -- to the extent that the game is unplayable.

#3
Posted 02/27/2013 01:01 PM   
Well the stuttering got so bad I sent the game back to Amazon for a refund. Not sure if this is a driver issue but more likely a game issue. I uninstalled all references to nVidia (both in the file system as well as the registry) but it's impossible to remove all drivers as Windows puts an older one back in. So I ran the game for about 25 minutes with no issues and thought I was home free but then the freezes came back again. Not sure if it's a GPU heat issue because of the time it takes to start freezing but I have no way of checking that.
Well the stuttering got so bad I sent the game back to Amazon for a refund. Not sure if this is a driver issue but more likely a game issue. I uninstalled all references to nVidia (both in the file system as well as the registry) but it's impossible to remove all drivers as Windows puts an older one back in. So I ran the game for about 25 minutes with no issues and thought I was home free but then the freezes came back again. Not sure if it's a GPU heat issue because of the time it takes to start freezing but I have no way of checking that.

#4
Posted 02/28/2013 02:18 PM   
i have had this device remove error and the only way i stopped crysis 3 from crashing was to set the gpu fan speed to max.after that crysis 3 didnt crash. i used msi after burner to increase the fan speed.hope i can be of help to anyone.
i have had this device remove error and the only way i stopped crysis 3 from crashing was to set the gpu fan speed to max.after that crysis 3 didnt crash. i used msi after burner to increase the fan speed.hope i can be of help to anyone.

#5
Posted 03/23/2013 01:37 AM   
I have this same problem in Hitman Absolution. Tried to monitor the GPU temp but it did not go past 53 Celsius when playing the game. I'm completely puzzled!
I have this same problem in Hitman Absolution. Tried to monitor the GPU temp but it did not go past 53 Celsius when playing the game. I'm completely puzzled!

#6
Posted 03/25/2013 10:35 PM   
I had exactly the same problem but found a post somewhere which suggested adding additional voltage using MSI afterburner. That did the trick for me and the game next crashes anymore. Just google the error and I am sure you will find the same post I stumbled across, careful upping the voltage and only do it in very small increments.
I had exactly the same problem but found a post somewhere which suggested adding additional voltage using MSI afterburner. That did the trick for me and the game next crashes anymore.

Just google the error and I am sure you will find the same post I stumbled across, careful upping the voltage and only do it in very small increments.

Current Rig:
Nvidia GTX 570
6gb Corsair Ram
Gigabyte EX58-UD3RIntel
I7 920 @ 3.2ghz
Creative X-Fi Titanium Fatal1ty Champion
Corsair H80 Hydro
Windows 8 Pro

#7
Posted 03/27/2013 10:14 PM   
I think I found a solution. (Worked for me) 1. Download MSI Afterburner here http://event.msi.com/vga/afterburner/download.htm 2. Install it and run it. 3. In the "menu" there is a "power limit" slider. 4. Usually it's on 100%. 5. Run Crysis 3 on MAXIMUM detail and resolution, AA, Vsync etc. 6. Play for about a minute then shut it down. 7. Open MSI Afterburner and look at the top graph on the right side of the window (Power%). 8. If your card consumes about 100% power, then put the slider to 70 - 80%. 9. That's all! This limitation prevents Nvidia BOOST - does not undervolt. core. Hope it was useful. ;)
I think I found a solution. (Worked for me)

1. Download MSI Afterburner here http://event.msi.com/vga/afterburner/download.htm

2. Install it and run it.
3. In the "menu" there is a "power limit" slider.
4. Usually it's on 100%.
5. Run Crysis 3 on MAXIMUM detail and resolution, AA, Vsync etc.
6. Play for about a minute then shut it down.
7. Open MSI Afterburner and look at the top graph on the right side of the window (Power%).
8. If your card consumes about 100% power, then put the slider to 70 - 80%.
9. That's all! This limitation prevents Nvidia BOOST - does not undervolt. core.

Hope it was useful. ;)

#8
Posted 07/15/2013 12:06 PM   
Scroll To Top