Crysis 3.
Hi All, I got Crysis 3 Hunter Edition on Friday and didn't really get a chance to play around with it as I had to go away this weekend. Just got back and everyone says this is supposed to be 3d ready like Crysis2. Well I get into the main menu and nothing is in 3d. I go to the options and there’s no option to enable 3d like in crysis 2. There’s a driver option that is greyed out and a swap eye option. No worries thinks I, it’s going to be in game. Well I start a new game and go into options and it’s not in 3d. There’s a render depth bar but no option to turn on 3d. The game is definitely not in 3d and doesn’t look anything like crysis 2 in 3d. Also I get no 3d recommendation info come up and the CONTROL F3 and F4 buttons don’t work like it does with Crysis 2. Does anyone know how to get 3d working please. I’m running the latest 417 drivers with an Acer 3d monitor and Nvision 2. All my other games and films etc work fine. Thanks, BB
Hi All,

I got Crysis 3 Hunter Edition on Friday and didn't really get a chance to play around with it as I had to go away this weekend.

Just got back and everyone says this is supposed to be 3d ready like Crysis2.
Well I get into the main menu and nothing is in 3d. I go to the options and there’s no option to enable 3d like in crysis 2. There’s a driver option that is greyed out and a swap eye option.

No worries thinks I, it’s going to be in game. Well I start a new game and go into options and it’s not in 3d. There’s a render depth bar but no option to turn on 3d. The game is definitely not in 3d and doesn’t look anything like crysis 2 in 3d. Also I get no 3d recommendation info come up and the CONTROL F3 and F4 buttons don’t work like it does with Crysis 2.
Does anyone know how to get 3d working please.
I’m running the latest 417 drivers with an Acer 3d monitor and Nvision 2. All my other games and films etc work fine.

Thanks,

BB

#1
Posted 02/24/2013 01:33 PM   
I was playing it in 3D for 10 hours yesterday, and it looks just like Crysis 2 did, just press CTRl-T to enable it, and have the 3D option set to DRIVER in the Crysis 3 3D menu. You will probably want it set to 100% depth.
I was playing it in 3D for 10 hours yesterday, and it looks just like Crysis 2 did, just press CTRl-T to enable it, and have the 3D option set to DRIVER in the Crysis 3 3D menu. You will probably want it set to 100% depth.

#2
Posted 02/24/2013 02:56 PM   
Are there any r_stereo console commands like in Crysis 2 ? (I mean in Crysis 2 after patches) In Crysis 2 there were many 3D rendering options only available in console commands, including convergence, various types of 3D displays, and one that let you choose between re-projection and dual-camera rendering mode (which was bugged like hell unfortunately). Some of these commands could be set in game, some required to restart the game, some had to be set in the game startup config file.
Are there any r_stereo console commands like in Crysis 2 ? (I mean in Crysis 2 after patches)

In Crysis 2 there were many 3D rendering options only available in console commands, including convergence, various types of 3D displays, and one that let you choose between re-projection and dual-camera rendering mode (which was bugged like hell unfortunately).
Some of these commands could be set in game, some required to restart the game, some had to be set in the game startup config file.

#3
Posted 02/24/2013 07:03 PM   
Hi All, Fixed it. The CTL T thing didn't work for me. Here’s what did: Go to nvidia control panel turn off Stereoscopic 3d and apply. Start up Crysis 3 the driver section is no longer greyed out cycle through the drivers until driver is back up. Apply the change. Alt tab back to Nvidia control panel and re select the stereoscopic 3D. Set up glasses. Alt Tab back into the game and resume and it works. Works just as well as Crysis2. I used the old system file foe the Crysis 2 fix and changed the Crysis 2 info for the stuff in the Crysis 3 system.cfg(for the paths etc) Worked like a chard. Have full depth of vision when set to max in the Crysis 3 in game options. The only extra thing is sometimes I have to alt tab in and out of Crysis 3 if I restart the programme. But it works. BB
Hi All,

Fixed it. The CTL T thing didn't work for me. Here’s what did:

Go to nvidia control panel turn off Stereoscopic 3d and apply.

Start up Crysis 3 the driver section is no longer greyed out cycle through the drivers until driver is back up. Apply the change. Alt tab back to Nvidia control panel and re select the stereoscopic 3D. Set up glasses. Alt Tab back into the game and resume and it works. Works just as well as Crysis2. I used the old system file foe the Crysis 2 fix and changed the Crysis 2 info for the stuff in the Crysis 3 system.cfg(for the paths etc) Worked like a chard. Have full depth of vision when set to max in the Crysis 3 in game options.

The only extra thing is sometimes I have to alt tab in and out of Crysis 3 if I restart the programme. But it works.


BB

#4
Posted 02/24/2013 09:43 PM   
[quote="Beastie Boy"]Hi All, Fixed it. The CTL T thing didn't work for me. Here’s what did: Go to nvidia control panel turn off Stereoscopic 3d and apply. Start up Crysis 3 the driver section is no longer greyed out cycle through the drivers until driver is back up. Apply the change. Alt tab back to Nvidia control panel and re select the stereoscopic 3D. Set up glasses. Alt Tab back into the game and resume and it works. Works just as well as Crysis2. I used the old system file foe the Crysis 2 fix and changed the Crysis 2 info for the stuff in the Crysis 3 system.cfg(for the paths etc) Worked like a chard. Have full depth of vision when set to max in the Crysis 3 in game options. The only extra thing is sometimes I have to alt tab in and out of Crysis 3 if I restart the programme. But it works. BB [/quote] Wwwwwwwwwwwwwwait a second. Share the joy. What are you using to make the crappy 3D better?
Beastie Boy said:Hi All,

Fixed it. The CTL T thing didn't work for me. Here’s what did:

Go to nvidia control panel turn off Stereoscopic 3d and apply.

Start up Crysis 3 the driver section is no longer greyed out cycle through the drivers until driver is back up. Apply the change. Alt tab back to Nvidia control panel and re select the stereoscopic 3D. Set up glasses. Alt Tab back into the game and resume and it works. Works just as well as Crysis2. I used the old system file foe the Crysis 2 fix and changed the Crysis 2 info for the stuff in the Crysis 3 system.cfg(for the paths etc) Worked like a chard. Have full depth of vision when set to max in the Crysis 3 in game options.

The only extra thing is sometimes I have to alt tab in and out of Crysis 3 if I restart the programme. But it works.


BB

Wwwwwwwwwwwwwwait a second.

Share the joy. What are you using to make the crappy 3D better?

#5
Posted 02/24/2013 11:03 PM   
Indeed. Please share the joy. The even at 100% depth the 3D looks like crud.
Indeed. Please share the joy.

The even at 100% depth the 3D looks like crud.

i7-2600K-4.5Ghz/Corsair H100i/8GB/GTX780SC-SLI/Win7-64/1200W-PSU/Samsung 840-500GB SSD/Coolermaster-Tower/Benq 1080ST @ 100"

#6
Posted 02/25/2013 12:10 AM   
@Beastie Boy: Can you get the maximum separation (seen with your glasses off) to match your IPD (distance between your eyes)??? Anyone else have this success? Also, does anyone want to take up the courageous task of gathering up all the quotes and links to those many quotes around the web about how crappy the 3D in Crysis 2 (and 3?) is and post them on the mycrsis forum? AVSforum has a lot of them. Its such bull****.
@Beastie Boy: Can you get the maximum separation (seen with your glasses off) to match your IPD (distance between your eyes)???


Anyone else have this success?



Also, does anyone want to take up the courageous task of gathering up all the quotes and links to those many quotes around the web about how crappy the 3D in Crysis 2 (and 3?) is and post them on the mycrsis forum? AVSforum has a lot of them. Its such bull****.

46" Samsung ES7500 3DTV (checkerboard, high FOV, highly recommend!) - Metro 2033 3D screens - Mass Effect 1 3D scenery - Metro LL filter realism mod - Flugan's Deus Ex:HR Depth changers - Nvidia online tech support - Nvidia Support number: 1-800-797-6530 - Marissa Alexander has received a new trial :)
.
.
Post here for support for 3D in BF4, BF devs will see it

#7
Posted 02/25/2013 12:59 AM   
So true. I don't know why they didn't just go to the effort to make proper 3D work rather than spend time implementing this crap.
So true. I don't know why they didn't just go to the effort to make proper 3D work rather than spend time implementing this crap.

#8
Posted 02/25/2013 01:40 AM   
I cross posted the stereo command(s) that were available in C2 (at least what was listed here in another thread on the same subject) in a mycrysis PC thread about the configuration tweaking tool, dono if/when they may get implemented. (the developer that was posting in the thread may of gotten overwhelmed with questionable feature requests and has not posted there for a while)
I cross posted the stereo command(s) that were available in C2 (at least what was listed here in another thread on the same subject) in a mycrysis PC thread about the configuration tweaking tool, dono if/when they may get implemented. (the developer that was posting in the thread may of gotten overwhelmed with questionable feature requests and has not posted there for a while)

i7-2600K-4.5Ghz/Corsair H100i/8GB/GTX780SC-SLI/Win7-64/1200W-PSU/Samsung 840-500GB SSD/Coolermaster-Tower/Benq 1080ST @ 100"

#9
Posted 02/25/2013 01:46 AM   
Scroll To Top