Windows 8 Issues SOLVED. PLEASE READ if you're having black screen and/or flickering.

Please let me know if this worked for your issues.

It did work, thanks!
No, it was a waste of my time.
  1 / 2    
After tirelessly searching for a fix to the massive flickering issues I was having after installing the newest Nvidia drivers in Windows 8, I finally found out how to fix this. I came across this PDF document: [url]http://us.download.nvidia.com/Windows/310.54/310.54-win8-win7-winvista-desktop-release-notes.pdf[/url] (Go down to page 29 to see for yourself or keep reading here). :Page 29 Pasted below: [b]Issue[/b] After installing the R310 driver on Windows 8, the subsequent reboot results in a black or flickering screen. [b]Root Cause[/b] This occurs because Windows Update performed a background installation of a Release 304 driver, which requires a reboot to complete the installation. After installing the Release 310 driver and then rebooting the system, installation of both the Release 304 as well as the Release 310 is completed, resulting in conflicting driver binaries and the black/ flickering screen. [b]Workaround - Prevention[/b] To avoid the issue, reboot the system before installing the Release 310 driver. Alternately, you can check the driver status under the Device Manager and perform the reboot if the Device Manager indicates that a restart is needed. Then install the driver. [b]Workaround - Recovery[/b](!Keep reading below before following these steps!)(!If you don't know how to boot into safe mode on windows 8, it's different than 7 and earlier, keep reading!) If you did not perform the necessary reboot prior to installing the driver and now encounter the black screen, do the following: 1 Reboot in Safe Mode. 2 Uninstall the driver. 3 Disconnect from the internet and then restart the system. 4 In normal mode, install the new driver. These steps are almost perfect. BUT, I followed these steps exactly and that did not fix the issue. There is one more reboot that needs to happen between steps 2 and 3. Here are my steps: 1: Make sure you have access to the 310.90 driver AS WELL AS a driver that works. If you have downloaded them prior, they should be found in C:/NVIDIA/DisplayDriver/*number of driver* (Note that I used forward slashes, these need to be back slashes, the forum doesn't let you type backslashes.) My system ran fine with 306.97, try that one. Getting your system to a usable condition, is the basis of step one. 2. Disable your internet connection. This is extremely important. That's why we have the divers in step 1. Don't turn it back on until step 8. 3. BOOTING IN SAFE MODE. Once your computer is fine to run, hit Windows+R, type "msconfig" without the quotes, and hit RETURN/ENTER. You have opened up the "System Configuration" window. Click the tab labeled "Boot". Under "Boot Options", click the box next to "Safe Boot" and it should be auto set to "Minimal". Click "Apply". Restart your system either though the dialogue window that pops up or manually. 4. You should now be in Safe Mode. Put your mouse in the bottom left corner of the screen and RIGHT CLICK. A menu will pop up. Click "Control Panel". Just to make it easy, in the top of the window, next to "View By", click Category. At the bottom of the left column, click "Uninstall a Program". Wait for all your programs to load into the list and then navigate to the one labeled "NVIDIA Graphics Driver XXX.XX". Right click this and select Uninstall/Change. Follow the directions here to get rid of the drivers. You may also get rid of the HD Audio or any others that are still there. 5. Reboot your system. If you didn't play with the boot settings, it should still boot into Safe Mode. This is what we want. 6. Install the new drivers. I'm not sure where you saved them, but find them. If you already extracted the package, they should be found here: C:/NVIDIA/DisplayDriver/310.90/Win8_WinVista_Win7_64/English In this folder, double click "setup" and follow the installation settings. 7. Now we need to boot into normal mode. Refer to step 3 on how to bring up the System Configuration window. Uncheck "Safe Boot" and restart the computer. 8. Turn your internet back on and enjoy your new, working drivers. I tried to be very thorough. If I missed anything or made any mistakes, please let me know. Thank You.
After tirelessly searching for a fix to the massive flickering issues I was having after installing the newest Nvidia drivers in Windows 8, I finally found out how to fix this. I came across this PDF document: http://us.download.nvidia.com/Windows/310.54/310.54-win8-win7-winvista-desktop-release-notes.pdf (Go down to page 29 to see for yourself or keep reading here). :Page 29 Pasted below:

Issue
After installing the R310 driver on Windows 8, the subsequent reboot results in a black or
flickering screen.

Root Cause
This occurs because Windows Update performed a background installation of a Release
304 driver, which requires a reboot to complete the installation. After installing the
Release 310 driver and then rebooting the system, installation of both the Release 304 as
well as the Release 310 is completed, resulting in conflicting driver binaries and the black/
flickering screen.

Workaround - Prevention
To avoid the issue, reboot the system before installing the Release 310 driver.
Alternately, you can check the driver status under the Device Manager and perform the
reboot if the Device Manager indicates that a restart is needed. Then install the driver.

Workaround - Recovery(!Keep reading below before following these steps!)(!If you don't know how to boot into safe mode on windows 8, it's different than 7 and earlier, keep reading!)
If you did not perform the necessary reboot prior to installing the driver and now
encounter the black screen, do the following:
1 Reboot in Safe Mode.
2 Uninstall the driver.
3 Disconnect from the internet and then restart the system.
4 In normal mode, install the new driver.


These steps are almost perfect. BUT, I followed these steps exactly and that did not fix the issue. There is one more reboot that needs to happen between steps 2 and 3. Here are my steps:

1: Make sure you have access to the 310.90 driver AS WELL AS a driver that works. If you have downloaded them prior, they should be found in C:/NVIDIA/DisplayDriver/*number of driver* (Note that I used forward slashes, these need to be back slashes, the forum doesn't let you type backslashes.) My system ran fine with 306.97, try that one. Getting your system to a usable condition, is the basis of step one.

2. Disable your internet connection. This is extremely important. That's why we have the divers in step 1. Don't turn it back on until step 8.

3. BOOTING IN SAFE MODE. Once your computer is fine to run, hit Windows+R, type "msconfig" without the quotes, and hit RETURN/ENTER. You have opened up the "System Configuration" window. Click the tab labeled "Boot". Under "Boot Options", click the box next to "Safe Boot" and it should be auto set to "Minimal". Click "Apply". Restart your system either though the dialogue window that pops up or manually.

4. You should now be in Safe Mode. Put your mouse in the bottom left corner of the screen and RIGHT CLICK. A menu will pop up. Click "Control Panel". Just to make it easy, in the top of the window, next to "View By", click Category. At the bottom of the left column, click "Uninstall a Program". Wait for all your programs to load into the list and then navigate to the one labeled "NVIDIA Graphics Driver XXX.XX". Right click this and select Uninstall/Change. Follow the directions here to get rid of the drivers. You may also get rid of the HD Audio or any others that are still there.

5. Reboot your system. If you didn't play with the boot settings, it should still boot into Safe Mode. This is what we want.

6. Install the new drivers. I'm not sure where you saved them, but find them. If you already extracted the package, they should be found here: C:/NVIDIA/DisplayDriver/310.90/Win8_WinVista_Win7_64/English In this folder, double click "setup" and follow the installation settings.

7. Now we need to boot into normal mode. Refer to step 3 on how to bring up the System Configuration window. Uncheck "Safe Boot" and restart the computer.

8. Turn your internet back on and enjoy your new, working drivers.


I tried to be very thorough. If I missed anything or made any mistakes, please let me know. Thank You.

Graphics: NVIDIA GeForce GTX 550 Ti
Processor: AMD FX 4100 Quad Core Processor
Motherboard: Asus M5A97
Ram: 4 x 4 = 16 Gigs
Displays: Primary - Acer S232HL
Secondary - HP w1707
OS: Windows 8 Pro x 64

#1
Posted 01/15/2013 02:36 AM   
Well, this fixed the issue up until a system crash. Once the computer booted after the crash, the OS was flickery and messed up again. I went through the steps above one more time and my system is once again working great. That is, until the next inevitable blue screen. This is just a huge inconvenience. I shouldn't have to spend 15-20 minutes OF my free time just so I can HAVE free time, which I don't get much of to begin with. Does anyone have a fix for this? Does anyone know how to stop Windows from auto-downloading the release 304 drivers? Anyone? Nvidia Devs? Maybe somebody with the appropriate skills can write a little program to stop this from happening? Maybe Nvidia can write into their drivers, that when a conflict of drivers like this happens, the newest driver version is used only? I'd like to be able to use my computer without spending half an hour fixing it every time it crashes.
Well, this fixed the issue up until a system crash. Once the computer booted after the crash, the OS was flickery and messed up again. I went through the steps above one more time and my system is once again working great. That is, until the next inevitable blue screen. This is just a huge inconvenience. I shouldn't have to spend 15-20 minutes OF my free time just so I can HAVE free time, which I don't get much of to begin with.

Does anyone have a fix for this? Does anyone know how to stop Windows from auto-downloading the release 304 drivers? Anyone? Nvidia Devs? Maybe somebody with the appropriate skills can write a little program to stop this from happening? Maybe Nvidia can write into their drivers, that when a conflict of drivers like this happens, the newest driver version is used only? I'd like to be able to use my computer without spending half an hour fixing it every time it crashes.

Graphics: NVIDIA GeForce GTX 550 Ti
Processor: AMD FX 4100 Quad Core Processor
Motherboard: Asus M5A97
Ram: 4 x 4 = 16 Gigs
Displays: Primary - Acer S232HL
Secondary - HP w1707
OS: Windows 8 Pro x 64

#2
Posted 01/16/2013 04:50 AM   
[quote="RoxaSora64"]Does anyone know how to stop Windows from auto-downloading the release 304 drivers?[/quote] If the driver is coming thru automatic update then disable the "recommended" updates (or even all updates) until you determine whether or not this is really the source of your problem. There should also be a way to prevent Windows from automatically installing drivers for your devices, check the control panel.
RoxaSora64 said:Does anyone know how to stop Windows from auto-downloading the release 304 drivers?


If the driver is coming thru automatic update then disable the "recommended" updates (or even all updates) until you determine whether or not this is really the source of your problem. There should also be a way to prevent Windows from automatically installing drivers for your devices, check the control panel.

"This is your code. These are also your bugs. Really. Yes, the API runtime and the
driver have bugs, but this is not one of them. Now go fix it already." -fgiesen

#3
Posted 01/16/2013 10:12 AM   
Had the same issue and this worked for me!: After installing Windows 7/8 KILL the auto-update-and-install option within AutoUpdate and change that to I'LL DECIDE!!! Auto update will install OLD Nvidia drivers when card is detected! I quarantaine all updates untill I decide to install them, AFTER evaluating user experiences and/or bug reports!!!! E.G.: This update will trouble your newly installed WHQL drivers..... NVIDIA GeForce GT 640 nVidia Graphics Adapter WDDM1.1, Graphics Adapter WDDM1.2, Other hardware software update released in [b]October, 2012[/b] Hope this helps! Cheers and goodluck!
Had the same issue and this worked for me!:

After installing Windows 7/8 KILL the auto-update-and-install option within AutoUpdate and change that to I'LL DECIDE!!! Auto update will install OLD Nvidia drivers when card is detected!

I quarantaine all updates untill I decide to install them, AFTER evaluating user experiences and/or bug reports!!!!

E.G.: This update will trouble your newly installed WHQL drivers.....

NVIDIA GeForce GT 640
nVidia Graphics Adapter WDDM1.1, Graphics Adapter WDDM1.2, Other hardware software update released in October, 2012

Hope this helps!

Cheers and goodluck!

310.90 WHQL (5*) + EVGA GTX-670 FTW 4GB - Win8proX64 || MAC PRO 3.1 [early 2008] || BOOTCAMP 5.0.545 || MAC OS X 10.8.5 (12F45) + CUDA 5.5.28 + GPU 8.12.47 310.40.00.05f01 - NVIDIA Geforce GT8800 512 MB MAC-Edition + Samsung SyncMaster 191T || EVGA GTX-670 FTW 4GB + Hewlett Packard HP LP2480zx || 2x 2,8 GHz Quad-Core Intel Xeon || 16GB DDR2 800 MHz FB-DIMM || 3x SSD 840 EVO 500GB || 2x 2 TB WD RED || MAC PRO 3.1 980W || OnBoard Realtek Soundcard

#4
Posted 01/16/2013 12:20 PM   
[quote="BDMSTUDIOS"]After installing Windows 7/8 KILL the auto-update-and-install option within AutoUpdate and change that to I'LL DECIDE!!! Auto update will install OLD Nvidia drivers when card is detected![/quote] Through testing, I have ruled this out as a possible fix for my issues. Here's what I did to test this: First, I made sure to go and disable windows auto update through the control panel. I also had some things to tend to in the action center, so I did some updates to AVG and some other things, some which required a restart. I manually restarted my PC and was greeted again with the corrupted Windows 8 environment. Ugh, again? Turned internet off, booted into safe mode and did all the stuff to regain use of my PC with 310.90. Please note that after booting back into normal mode in Windows, I never turned my internet connection back on. All I really wanted to do was play Far Cry 3 anyway. So I did that, about 15 minutes in, I was blessed with a system crash. -_- And of course, when Windows booted again, it was unusable. So, we've figured out that disabling Windows Update did not fix this issue. We also figured out that if Windows Update is indeed the issue, Windows is NOT downloading the release 304 drivers at every restart. It turns out that this can't be the issue because Windows could not have downloaded them at this restart even if it wanted to. Also note that before it was corrupted the last time, I made sure to uninstall everything regarding Nvidia. This includes the HD Audio Driver as well as the 3D drivers. And the only thing installed was the actual Graphics Driver, as a clean install. Can anyone tell me what could be the cause of this problem after eliminating these possible solutions?
BDMSTUDIOS said:After installing Windows 7/8 KILL the auto-update-and-install option within AutoUpdate and change that to I'LL DECIDE!!! Auto update will install OLD Nvidia drivers when card is detected!


Through testing, I have ruled this out as a possible fix for my issues. Here's what I did to test this:

First, I made sure to go and disable windows auto update through the control panel. I also had some things to tend to in the action center, so I did some updates to AVG and some other things, some which required a restart. I manually restarted my PC and was greeted again with the corrupted Windows 8 environment. Ugh, again? Turned internet off, booted into safe mode and did all the stuff to regain use of my PC with 310.90. Please note that after booting back into normal mode in Windows, I never turned my internet connection back on. All I really wanted to do was play Far Cry 3 anyway. So I did that, about 15 minutes in, I was blessed with a system crash. -_- And of course, when Windows booted again, it was unusable.

So, we've figured out that disabling Windows Update did not fix this issue. We also figured out that if Windows Update is indeed the issue, Windows is NOT downloading the release 304 drivers at every restart. It turns out that this can't be the issue because Windows could not have downloaded them at this restart even if it wanted to.

Also note that before it was corrupted the last time, I made sure to uninstall everything regarding Nvidia. This includes the HD Audio Driver as well as the 3D drivers. And the only thing installed was the actual Graphics Driver, as a clean install.

Can anyone tell me what could be the cause of this problem after eliminating these possible solutions?

Graphics: NVIDIA GeForce GTX 550 Ti
Processor: AMD FX 4100 Quad Core Processor
Motherboard: Asus M5A97
Ram: 4 x 4 = 16 Gigs
Displays: Primary - Acer S232HL
Secondary - HP w1707
OS: Windows 8 Pro x 64

#5
Posted 01/17/2013 02:38 AM   
Maybe this helps. Note that what I'm about to tell you all happened during the crash and fix cycle where I had no internet connection the entire time. I'm really trying to find out what the issue is, so i was going through the event viewer for the gpu. At 8:55:19, there was a driver installation of DriverVersion 9.18.13.1090 (310.90) and DriverName nv_disp.inf_amd64_d33a89233f30d9f3v_disp.inf (This must be me installing the latest drivers and my computer is working.) At 9:14:40 (This must be just after the crash where I only played Far Cry 3 for about 10 minutes) there is a driver installation of DriverVersion 9.18.13.697 (306.97) and DriverName nv_dispi.inf_amd64_3158f15673095c23 v_dispi.inf It's at this point in time where my computer would restart and be corrupted. After the auto install of 9.18.13.697. Could this be the conflict mentioned? Does anyone know of a way to make this not happen? Through my testing above, we can see that disabling windows update does not fix this problem because, as we can see, because this particular cycle of breaking and fixing happened at a time when there was absolutely no internet connection, this is happening because of something already on my PC. Then I can see me installing the DriverVersion 9.18.13.1090 driver again at 9:16:01. That's the last item listed in the event viewer for this gpu. Why is my computer auto installing the 306.97 driver after a crash? Obviously (I think), the issues I'm having are because my computer is running 306.97 and 310.90 at the same time, as explained would happen in the driver release notes. Does anyone have an idea of how to fix this?
Maybe this helps. Note that what I'm about to tell you all happened during the crash and fix cycle where I had no internet connection the entire time. I'm really trying to find out what the issue is, so i was going through the event viewer for the gpu.

At 8:55:19, there was a driver installation of DriverVersion 9.18.13.1090 (310.90) and DriverName nv_disp.inf_amd64_d33a89233f30d9f3v_disp.inf (This must be me installing the latest drivers and my computer is working.)

At 9:14:40 (This must be just after the crash where I only played Far Cry 3 for about 10 minutes) there is a driver installation of DriverVersion 9.18.13.697 (306.97) and DriverName nv_dispi.inf_amd64_3158f15673095c23
v_dispi.inf

It's at this point in time where my computer would restart and be corrupted. After the auto install of 9.18.13.697. Could this be the conflict mentioned? Does anyone know of a way to make this not happen? Through my testing above, we can see that disabling windows update does not fix this problem because, as we can see, because this particular cycle of breaking and fixing happened at a time when there was absolutely no internet connection, this is happening because of something already on my PC.

Then I can see me installing the DriverVersion 9.18.13.1090 driver again at 9:16:01. That's the last item listed in the event viewer for this gpu.

Why is my computer auto installing the 306.97 driver after a crash? Obviously (I think), the issues I'm having are because my computer is running 306.97 and 310.90 at the same time, as explained would happen in the driver release notes.

Does anyone have an idea of how to fix this?

Graphics: NVIDIA GeForce GTX 550 Ti
Processor: AMD FX 4100 Quad Core Processor
Motherboard: Asus M5A97
Ram: 4 x 4 = 16 Gigs
Displays: Primary - Acer S232HL
Secondary - HP w1707
OS: Windows 8 Pro x 64

#6
Posted 01/17/2013 03:15 AM   
Maybe is there a way to lock the driver to a specific version? Or stop driver changes from happening?
Maybe is there a way to lock the driver to a specific version? Or stop driver changes from happening?

Graphics: NVIDIA GeForce GTX 550 Ti
Processor: AMD FX 4100 Quad Core Processor
Motherboard: Asus M5A97
Ram: 4 x 4 = 16 Gigs
Displays: Primary - Acer S232HL
Secondary - HP w1707
OS: Windows 8 Pro x 64

#7
Posted 01/17/2013 03:16 AM   
MOD please delete! Sorry
MOD please delete! Sorry

310.90 WHQL (5*) + EVGA GTX-670 FTW 4GB - Win8proX64 || MAC PRO 3.1 [early 2008] || BOOTCAMP 5.0.545 || MAC OS X 10.8.5 (12F45) + CUDA 5.5.28 + GPU 8.12.47 310.40.00.05f01 - NVIDIA Geforce GT8800 512 MB MAC-Edition + Samsung SyncMaster 191T || EVGA GTX-670 FTW 4GB + Hewlett Packard HP LP2480zx || 2x 2,8 GHz Quad-Core Intel Xeon || 16GB DDR2 800 MHz FB-DIMM || 3x SSD 840 EVO 500GB || 2x 2 TB WD RED || MAC PRO 3.1 980W || OnBoard Realtek Soundcard

#8
Posted 01/17/2013 04:39 PM   
[quote]At 8:55:19, there was a driver installation of DriverVersion 9.18.13.1090 (310.90) and DriverName nv_disp.inf_amd64_d33a89233f30d9f3v_disp.inf (This must be me installing the latest drivers and my computer is working.) At 9:14:40 (This must be just after the crash where I only played Far Cry 3 for about 10 minutes) there is a driver installation of DriverVersion 9.18.13.697 (306.97) and DriverName nv_dispi.inf_amd64_3158f15673095c23 v_dispi.inf It's at this point in time where my computer would restart and be corrupted. After the auto install of 9.18.13.697. Could this be the conflict mentioned? Does anyone know of a way to make this not happen? Through my testing above, we can see that disabling windows update does not fix this problem because, as we can see, because this particular cycle of breaking and fixing happened at a time when there was absolutely no internet connection, this is happening because of something already on my PC. Does anyone have an idea of how to fix this?[/quote] Perhaps your auto-update installing your driver in the background while playing a game!? When not paying attention to it the system will reboot to make the (old) driver install effective. Is that perhaps the cause for you to see a 306.97 install after reboot? http://sysdev.microsoft.com/support/default.aspx http://support.microsoft.com/select/?target=hub Goodluck mate!
At 8:55:19, there was a driver installation of DriverVersion 9.18.13.1090 (310.90) and DriverName nv_disp.inf_amd64_d33a89233f30d9f3v_disp.inf (This must be me installing the latest drivers and my computer is working.)

At 9:14:40 (This must be just after the crash where I only played Far Cry 3 for about 10 minutes) there is a driver installation of DriverVersion 9.18.13.697 (306.97) and DriverName nv_dispi.inf_amd64_3158f15673095c23
v_dispi.inf

It's at this point in time where my computer would restart and be corrupted. After the auto install of 9.18.13.697. Could this be the conflict mentioned? Does anyone know of a way to make this not happen? Through my testing above, we can see that disabling windows update does not fix this problem because, as we can see, because this particular cycle of breaking and fixing happened at a time when there was absolutely no internet connection, this is happening because of something already on my PC.

Does anyone have an idea of how to fix this?


Perhaps your auto-update installing your driver in the background while playing a game!? When not paying attention to it the system will reboot to make the (old) driver install effective. Is that perhaps the cause for you to see a 306.97 install after reboot?

http://sysdev.microsoft.com/support/default.aspx
http://support.microsoft.com/select/?target=hub

Goodluck mate!

310.90 WHQL (5*) + EVGA GTX-670 FTW 4GB - Win8proX64 || MAC PRO 3.1 [early 2008] || BOOTCAMP 5.0.545 || MAC OS X 10.8.5 (12F45) + CUDA 5.5.28 + GPU 8.12.47 310.40.00.05f01 - NVIDIA Geforce GT8800 512 MB MAC-Edition + Samsung SyncMaster 191T || EVGA GTX-670 FTW 4GB + Hewlett Packard HP LP2480zx || 2x 2,8 GHz Quad-Core Intel Xeon || 16GB DDR2 800 MHz FB-DIMM || 3x SSD 840 EVO 500GB || 2x 2 TB WD RED || MAC PRO 3.1 980W || OnBoard Realtek Soundcard

#9
Posted 01/17/2013 04:42 PM   
I stop Windows Update from installing Nvidia Display Drivers on both Windows 7 and Windows 8 by going to Windows Control Panel, System, Advanced System Settings, Hardware, Device Installation Settings and selecting "Never install driver software from Windows Update". When Nvidia Display Drivers appear in Windows Update I right-click them and select Hide. If I change my mind about a Hidden Update I select "Restore hidden updates".
I stop Windows Update from installing Nvidia Display Drivers on both Windows 7 and Windows 8 by going to Windows Control Panel, System, Advanced System Settings, Hardware, Device Installation Settings and selecting "Never install driver software from Windows Update". When Nvidia Display Drivers appear in Windows Update I right-click them and select Hide. If I change my mind about a Hidden Update I select "Restore hidden updates".

HP Firebird 802 + HP 2159m monitor + Windows 7 Home Premium + Windows 8 Pro with Media Center
2 x GeForce 9800 S dGPU in 2-way SLI + nForce 760i SLI mGPU
GeForce Display Driver 266.58 WHQL installs correctly without modification.
GeForce Display Driver 296.10 WHQL requires modified NV_DISP.INF file to install correctly but NVIDIA Control Panel is broken.
GeForce Display Driver 320.49 WHQL requires modified NV_DISP.INF file to install correctly but 2-way SLI is broken.

#10
Posted 01/17/2013 09:27 PM   
Ok, I just needed to let you all know that these steps actually did fix my issues and Windows is running great now with multiple restarts. I'm not really sure why it would've done that the last time but never again, but at least it works. And I'm sorry for the multiple posts above, I meant to just edit the post but hit the wrong button and I can't seem to find a way to delete a post, or I already would've.
Ok, I just needed to let you all know that these steps actually did fix my issues and Windows is running great now with multiple restarts. I'm not really sure why it would've done that the last time but never again, but at least it works. And I'm sorry for the multiple posts above, I meant to just edit the post but hit the wrong button and I can't seem to find a way to delete a post, or I already would've.

Graphics: NVIDIA GeForce GTX 550 Ti
Processor: AMD FX 4100 Quad Core Processor
Motherboard: Asus M5A97
Ram: 4 x 4 = 16 Gigs
Displays: Primary - Acer S232HL
Secondary - HP w1707
OS: Windows 8 Pro x 64

#11
Posted 01/19/2013 03:17 AM   
I installed the 310.90 drivers and I faced the same issue (black screen flickering at login). After reading OP's post I found a way which does not require you to disable the internet connection. [b]1. Get into Safe Mode:[/b] When you start the PC, hold (or press repeatedly) the F8 key to view the boot loader screen and enter the options screen. If you see the login screen/flicker then you have missed the boot loader screen. Shut down and try again. I have a dual boot configuration so I get the boot loader screen by default. In dual-boot config, select Change defaults or choose other options->Choose Other Options to get the options screen. Once you get the options screen, select Troubleshoot -> Advanced Options -> Windows Startup Settings. Select Restart. Your PC will restart. If you get a black & white screen with the menu then user the up/down arrow keys and press enter on the Enter Safe Mode option. If you get a blue screen with the menu then press the number key associated with the 'Enter Safe Mode' option. I think it was 3. Your PC will enter the Safe Mode. [b]2. Uninstall the Driver[/b] Login and RIGHT CLICK at the bottom left corner of your screen. Select Device Manager. Alternatively, you can press the WinKey+PauseBreak to bring up the System window and select Device Manager in the left pane. Under the Display Adapter you will get your graphics card name. Double click on it to open the properties window. Under the 'Driver' tab select 'Uninstall'. Select 'Delete the driver software for this device' and hit OK. Restart the PC normally. [b]3. Revert to the built-in drivers[/b] You will get a low resolution display when you restart. Log in and go to the Device Manager again. Open the graphics card properties window. Just hit OK to close the window. Now windows will ask you to restart the PC for it is about to install the built-in Nvidia drivers. Restart the PC. [b]Update to new 310.90 drivers[/b] Don't run the 310.90 package setup. Log in and open Device Manager, the graphics card properties window. Under the 'Driver' tab select 'Update Driver'. Select 'Browse my PC'. Enter the path to the Nvidia 310.90 driver. It was C:\Nvidia\DisplayDriver\310.90 for me. Make sure you select 'Include Subfolders' checkbox. Hit 'Next' and let windows install the new drivers. Restart the PC. If you cant find the driver path, download the 310.90 package from Nvidia website and run it. It will extract the driver to the C:\Nvidia path by default. Don't run the setup after it finishes extracting (Hit cancel or exit when the setup starts).
I installed the 310.90 drivers and I faced the same issue (black screen flickering at login). After reading OP's post I found a way which does not require you to disable the internet connection.

1. Get into Safe Mode:
When you start the PC, hold (or press repeatedly) the F8 key to view the boot loader screen and enter the options screen. If you see the login screen/flicker then you have missed the boot loader screen. Shut down and try again.

I have a dual boot configuration so I get the boot loader screen by default. In dual-boot config, select Change defaults or choose other options->Choose Other Options to get the options screen.

Once you get the options screen, select Troubleshoot -> Advanced Options -> Windows Startup Settings. Select Restart.

Your PC will restart. If you get a black & white screen with the menu then user the up/down arrow keys and press enter on the Enter Safe Mode option. If you get a blue screen with the menu then press the number key associated with the 'Enter Safe Mode' option. I think it was 3.

Your PC will enter the Safe Mode.

2. Uninstall the Driver
Login and RIGHT CLICK at the bottom left corner of your screen. Select Device Manager. Alternatively, you can press the WinKey+PauseBreak to bring up the System window and select Device Manager in the left pane.

Under the Display Adapter you will get your graphics card name. Double click on it to open the properties window. Under the 'Driver' tab select 'Uninstall'. Select 'Delete the driver software for this device' and hit OK.

Restart the PC normally.

3. Revert to the built-in drivers
You will get a low resolution display when you restart. Log in and go to the Device Manager again. Open the graphics card properties window. Just hit OK to close the window. Now windows will ask you to restart the PC for it is about to install the built-in Nvidia drivers. Restart the PC.

Update to new 310.90 drivers
Don't run the 310.90 package setup.

Log in and open Device Manager, the graphics card properties window. Under the 'Driver' tab select 'Update Driver'. Select 'Browse my PC'. Enter the path to the Nvidia 310.90 driver. It was C:\Nvidia\DisplayDriver\310.90 for me. Make sure you select 'Include Subfolders' checkbox. Hit 'Next' and let windows install the new drivers. Restart the PC.

If you cant find the driver path, download the 310.90 package from Nvidia website and run it. It will extract the driver to the C:\Nvidia path by default. Don't run the setup after it finishes extracting (Hit cancel or exit when the setup starts).

#12
Posted 02/05/2013 06:50 AM   
I've tried the above method so far with: -306.23 -306.97 -310.70 -310.90 -313.96 And I still can't get Windows to go past the black screen. It stays at the black screen for a few seconds then reboots. Any other advice? System: Alienware X51 Intel i7-3770 1.5GB GDDR5 NVIDIA® GeForce® GTX 660 16 GB DDR3 1600 MHZ Win8 64bit
I've tried the above method so far with:
-306.23
-306.97
-310.70
-310.90
-313.96

And I still can't get Windows to go past the black screen. It stays at the black screen for a few seconds then reboots.

Any other advice?

System:
Alienware X51
Intel i7-3770
1.5GB GDDR5 NVIDIA® GeForce® GTX 660
16 GB DDR3 1600 MHZ
Win8 64bit

#13
Posted 02/06/2013 06:11 AM   
Finally i write here to see if someone can help me to resolve this. I have exactly the same problem than the others and as the guy before me i tried all the drivers and nothing. Basically i was working with the computer it did an automatically windows update and i saw a tooltip saying conflict drivers or something, next day when i turn on the computer... surprise! I tried all the scenarios: - New installation, windows system update, driver installation. Fail. (win7 and win Ultimate) - New installation, driver installation. Fail.(win7 and win Ultimate) - New installation without Internet, same process than above. Fail. (win7 and win Ultimate) - Rebooting in safe mode, uninstalling the driver, rebooting in VGA mode, installing the driver from NVIDIA packgage. Fail. (win7 and win Ultimate) - Rebooting in safe mode, uninstalling the driver, rebooting in VGA mode, installing the driver from a folder where i extracted the NVIDIA packgage (so i didn't used the exe to install the drivers at all). Fail. (win7 and win Ultimate) In all cases windows update are set to "Don't, download, I will choose", thats a lie, if it see your drivers in any folder it will start to update the hardware drivers without asking anything. Conclusion any of the post I read in the forums related to this problems helped me, I always end it always with a black screen (or green one 2 or 3 times). I am wondering if maybe my DVD "All windows versions" have that driver already inside windows and thats why it doesnt work at all, so i am downloading windows xp to try it. Any additional idea? Thx.
Finally i write here to see if someone can help me to resolve this.
I have exactly the same problem than the others and as the guy before me i tried all the drivers and nothing.

Basically i was working with the computer it did an automatically windows update and i saw a tooltip saying conflict drivers or something, next day when i turn on the computer... surprise!

I tried all the scenarios:
- New installation, windows system update, driver installation. Fail. (win7 and win Ultimate)
- New installation, driver installation. Fail.(win7 and win Ultimate)
- New installation without Internet, same process than above. Fail. (win7 and win Ultimate)
- Rebooting in safe mode, uninstalling the driver, rebooting in VGA mode, installing the driver from NVIDIA packgage. Fail. (win7 and win Ultimate)
- Rebooting in safe mode, uninstalling the driver, rebooting in VGA mode, installing the driver from a folder where i extracted the NVIDIA packgage (so i didn't used the exe to install the drivers at all). Fail. (win7 and win Ultimate)

In all cases windows update are set to "Don't, download, I will choose", thats a lie, if it see your drivers in any folder it will start to update the hardware drivers without asking anything.

Conclusion any of the post I read in the forums related to this problems helped me, I always end it always with a black screen (or green one 2 or 3 times).

I am wondering if maybe my DVD "All windows versions" have that driver already inside windows and thats why it doesnt work at all, so i am downloading windows xp to try it.

Any additional idea?

Thx.

#14
Posted 02/06/2013 10:39 AM   
Have you read the Dunsany post? "I stop Windows Update from installing Nvidia Display Drivers on both Windows 7 and Windows 8 by going to Windows Control Panel, System, Advanced System Settings, Hardware, Device Installation Settings and selecting "[b]Never install driver software from Windows Update[/b]". [b]When Nvidia Display Drivers appear in Windows Update I right-click them and select Hide[/b]. If I change my mind about a Hidden Update I select "Restore hidden updates".
Have you read the Dunsany post?

"I stop Windows Update from installing Nvidia Display Drivers on both Windows 7 and Windows 8 by going to Windows Control Panel, System, Advanced System Settings, Hardware, Device Installation Settings and selecting "Never install driver software from Windows Update". When Nvidia Display Drivers appear in Windows Update I right-click them and select Hide. If I change my mind about a Hidden Update I select "Restore hidden updates".

MSI GeForce GTX 660 Ti OC EDITION

Win 8(64bit)

#15
Posted 02/06/2013 11:22 AM   
  1 / 2    
Scroll To Top