Assassin's Creed III LOW FPS
Assassins Creed 3 freezes and drops fps to 10-15 when i'm in a big city (Boston). Will nVidia release a driver to fix it?
Assassins Creed 3 freezes and drops fps to 10-15 when i'm in a big city (Boston). Will nVidia release a driver to fix it?

#1
Posted 11/23/2012 07:39 AM   
1) There is a WQHL driver that was just released today that includes AC:3 performance fixes in the release notes 2) You need to list system specifications for more accurate responses Try the new driver and post a follow up with your system information if the issue continues. Also, there are more than enough AC:3 threads on these forums, try to locate an appropriate one to follow in next time. It helps to keep down the congestion. -Hooks
1) There is a WQHL driver that was just released today that includes AC:3 performance fixes in the release notes

2) You need to list system specifications for more accurate responses

Try the new driver and post a follow up with your system information if the issue continues. Also, there are more than enough AC:3 threads on these forums, try to locate an appropriate one to follow in next time. It helps to keep down the congestion.

-Hooks

QUOTE (The Professor @ Oct 31 2010, 04:59 AM)

*Jeremy Clarkson face*



So we must hand it over to our tame PC tweaker. Some say he sticky tapes a block of uranium to his dinner before eating it and that he sucks moisture out of ducks. All we know is, he's called Hooks.



"Eye of the Storm" Window Mod Tutorial <> "Inside Crysis 2" <> Top Tier Water-Blocks 2011 <> SSD Unlimited Storage Tutorial

#2
Posted 12/04/2012 09:22 PM   
Good afternoon. Big problem on assassin creed soft 3 PC version. I have the same problem FPS that everyone apparently. My PC is an Asus, Intel (R) Core (TM) i5-2320 CPU@3.00GHz, 6.2 GB RAM, Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit GeForce GTX 680 2048MB GAINWARD GDDRS with an SSD vertex 3 930 GB. (My drivers are updated and my PC is well maintained) It runs many games as rather greedy Witcher 2, Skyrim, Diablo 3, Borderland 2 ultra. With 60FPS for fluidity. But in the case of assassin 3 it is differing: The game runs ultra 60fps to the city of Boston where he started to make 35 FPS. FPS are now aléatoir. (25, 35, 55 ...) I have done many tests with graphics settings but it seems that even at the lowest and with ultra low screen resolution, the problem is the same. Multiple testing adjustments gtx680: Change DIRECTX 11-9 and 10, up the voltage of my card, change the GPU (GTX570 to a 680) put the game in low, adjust my graphics card performance mode, overclock my cards and my CPU change of diet, pass the application priority AC3 "HIGH", GameBooster use, test the last 5 and NVIDIA beta drivers, copy the ini files on-line instead of those of the solo cut physX , deactivate the cuda. What is the solution to this problem? Thank you. arnaud_reichart@hotmail.com
Good afternoon.

Big problem on assassin creed soft 3 PC version.

I have the same problem FPS that everyone apparently. My PC is an Asus, Intel (R) Core (TM) i5-2320 CPU@3.00GHz, 6.2 GB RAM, Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit GeForce GTX 680 2048MB GAINWARD GDDRS with an SSD vertex 3 930 GB. (My drivers are updated and my PC is well maintained) It runs many games as rather greedy Witcher 2, Skyrim, Diablo 3, Borderland 2 ultra. With 60FPS for fluidity. But in the case of assassin 3 it is differing: The game runs ultra 60fps to the city of Boston where he started to make 35 FPS. FPS are now aléatoir. (25, 35, 55 ...)

I have done many tests with graphics settings but it seems that even at the lowest and with ultra low screen resolution, the problem is the same.

Multiple testing adjustments gtx680:

Change DIRECTX 11-9 and 10, up the voltage of my card, change the GPU (GTX570 to a 680) put the game in low, adjust my graphics card performance mode, overclock my cards and my CPU change of diet, pass the application priority AC3 "HIGH", GameBooster use, test the last 5 and NVIDIA beta drivers, copy the ini files on-line instead of those of the solo cut physX , deactivate the cuda.

What is the solution to this problem?

Thank you.

arnaud_reichart@hotmail.com

#3
Posted 12/05/2012 05:03 PM   
Bonjour. Gros problème sur le soft assassin creed 3 version PC. J'ai le même problème de FPS que tout le monde apparemment. Mon PC est un asus, Intel(R) Core(TM) i5-2320 CPU @ 3.00GHz, 6.2 GB de ram, Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit, GeForce GTX 680 GAINWARD 2048MB GDDRS avec un disque dur SSD vertex 3 930 GB. (Mes drivers sont à jour et mon PC est bien entretenu) Il fait tourner de nombreux jeux assez gourmand comme Witcher 2, Skyrim, Diablo 3, Borderland 2 en ultra. Avec 60FPS pour le fluidité. Mais dans le cas d'assassin 3 c'est bien différant: Le jeu tourne en ultra 60fps jusqu'à la ville de Boston ou il commence à faire du 35 FPS. Les FPS sont maintenant aléatoir. ( 25, 35, 55...) J'ai effectué de nombreux tests avec les réglages graphiques mais il semble que même au plus bas et avec une résolution d'écran ultra basse, le problème soit le même. Multiples tests de réglages sur gtx680: Le changement de DIRECTX 11 à 9 et 10, monter le voltage de ma carte, changer de GPU (d'une GTX570 à une 680) mettre le jeu en low, régler mes cartes graphiques en mode performance, overclock mes cartes et mon CPU, changer d'alimentation, passer la priorité de l’application AC3 en "HAUTE" , utiliser GameBooster, tester les 5 derniers drivers NVIDIA et les drivers bêta, copier les fichiers ini du on-line à la place de ceux du solo, couper physX, déactiver le cuda. Quel est la solution à ce problème? Merci. arnaud_reichart@hotmail.com
Bonjour.

Gros problème sur le soft assassin creed 3 version PC. J'ai le même problème de FPS que tout le monde apparemment. Mon PC est un asus, Intel(R) Core(TM) i5-2320 CPU @ 3.00GHz, 6.2 GB de ram, Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit, GeForce GTX 680 GAINWARD 2048MB GDDRS avec un disque dur SSD vertex 3 930 GB. (Mes drivers sont à jour et mon PC est bien entretenu)

Il fait tourner de nombreux jeux assez gourmand comme Witcher 2, Skyrim, Diablo 3, Borderland 2 en ultra. Avec 60FPS pour le fluidité.

Mais dans le cas d'assassin 3 c'est bien différant: Le jeu tourne en ultra 60fps jusqu'à la ville de Boston ou il commence à faire du 35 FPS. Les FPS sont maintenant aléatoir. ( 25, 35, 55...) J'ai effectué de nombreux tests avec les réglages graphiques mais il semble que même au plus bas et avec une résolution d'écran ultra basse, le problème soit le même.

Multiples tests de réglages sur gtx680:

Le changement de DIRECTX 11 à 9 et 10, monter le voltage de ma carte, changer de GPU (d'une GTX570 à une 680) mettre le jeu en low, régler mes cartes graphiques en mode performance, overclock mes cartes et mon CPU, changer d'alimentation, passer la priorité de l’application AC3 en "HAUTE" , utiliser GameBooster, tester les 5 derniers drivers NVIDIA et les drivers bêta, copier les fichiers ini du on-line à la place de ceux du solo, couper physX, déactiver le cuda.

Quel est la solution à ce problème?

Merci.

arnaud_reichart@hotmail.com

#4
Posted 12/05/2012 05:08 PM   
Scroll To Top