GTX 580 driver stoppes working / crashes in all recently released games (assassin's creed 3, COD

Do you have the same problem with your GTX 500 card?

Yes i have this problem with my GTX 590
Yes i have this problem with my GTX 580
Yes i have this problem with my GTX 570
Yes i have this problem with my GTX 560
Yes i have this problem with my GTX 5XX series card
  1 / 39    
I'm having [b]MAJOR[/b] issues with my graphics card! The problem is, that the drivers stop working randomly in all the newly released games such as Call of duty black ops 2 and Assassin's Creed 3. EDIT: And Hitman Absolution as well! I'm getting green artifacts when the game crashes and a small pop up note in the corner saying the "(currently installed) graphics card driver has stopped working. if i'm fast enought at tapping out (ALT + tap) or CTRL + ALT + Delete i can stop the computer from crashing, but if not, then the computer reboots. The computer has no problem what so ever running Battlefield 3 at ultra resolution, but these new games make i crash, running on the lowest settings and even in lowered resolution of 800 x 600 for instance. so far i have updated BIOS on the motherboard, updated audio drivers and graphicscard drivers, windows update.. i have actually updated EVERY driver on the computer, but it doesn't work. It has come to my attention, that i'm not the only one having troubles with these new games running on a GTX5xx series card. Many have suggested underclocking the graphics card via GPU Tweak etc, which i have also tried. (both under AND over clocking it, both to a reasonable clock, both also to the extreme on both ends!) non seems to work, or maybe it gave me a minute or more of gaming. i've tried with the: [b]306.97 WHQL Driver 310.61 BETA Driver[/b] and actually all available drivers in between + an old driver i found very stable a couple of months ago. Non did the job. Games still crash, tho my BF3 seems to run smoother. The computer should fit the requirements for the games, because im getting 200 FPS+ when running on the lowest settings with messed up resolutions, but it still crashes. Specs: G.Skill 8GB DDR3 1600MHz (2x4) [b]ASUS ENGTX580 DCII/2DIS/1536MD5[/b] ASUS P8P67 Deluxe B3 Sandy Bridge Corsair Air Series A50 CPU Cooler Corsair SSD Force Series 3, 120GB Intel® Core i7-2600K Processor Corsair TX V2 850W PSU some suggested that the card just can't handle the new games, but come on, you can't be serious that the card is already ready to go into the bin? Would getting another card and running it in SLI fix the problem, or just give me twice the number of crashes?
I'm having MAJOR issues with my graphics card!
The problem is, that the drivers stop working randomly in all the newly released games such as Call of duty black ops 2 and Assassin's Creed 3. EDIT: And Hitman Absolution as well!

I'm getting green artifacts when the game crashes and a small pop up note in the corner saying the "(currently installed) graphics card driver has stopped working.
if i'm fast enought at tapping out (ALT + tap) or CTRL + ALT + Delete i can stop the computer from crashing, but if not, then the computer reboots.
The computer has no problem what so ever running Battlefield 3 at ultra resolution, but these new games make i crash, running on the lowest settings and even in lowered resolution of 800 x 600 for instance.

so far i have updated BIOS on the motherboard, updated audio drivers and graphicscard drivers, windows update.. i have actually updated EVERY driver on the computer, but it doesn't work.

It has come to my attention, that i'm not the only one having troubles with these new games running on a GTX5xx series card.
Many have suggested underclocking the graphics card via GPU Tweak etc, which i have also tried. (both under AND over clocking it, both to a reasonable clock, both also to the extreme on both ends!) non seems to work, or maybe it gave me a minute or more of gaming.

i've tried with the:
306.97 WHQL Driver
310.61 BETA Driver

and actually all available drivers in between + an old driver i found very stable a couple of months ago.

Non did the job. Games still crash, tho my BF3 seems to run smoother.
The computer should fit the requirements for the games, because im getting 200 FPS+ when running on the lowest settings with messed up resolutions, but it still crashes.

Specs:
G.Skill 8GB DDR3 1600MHz (2x4)
ASUS ENGTX580 DCII/2DIS/1536MD5
ASUS P8P67 Deluxe B3 Sandy Bridge
Corsair Air Series A50 CPU Cooler
Corsair SSD Force Series 3, 120GB
Intel® Core i7-2600K Processor
Corsair TX V2 850W PSU



some suggested that the card just can't handle the new games, but come on, you can't be serious that the card is already ready to go into the bin? Would getting another card and running it in SLI fix the problem, or just give me twice the number of crashes?

#1
Posted 11/22/2012 09:58 AM   
i've of course also tried to reinstall the games twice, but it did not help the problem go away! it would be lovely to know weather it is a Geforce driver problem, or my setup that is bad, or even a malfunctioning graphics card, since i bought it November 2011, so i might still be able to get a new one if its a problem that has been there all the time. But its weird that it runs Battlefield 3 just perfect?
i've of course also tried to reinstall the games twice, but it did not help the problem go away!

it would be lovely to know weather it is a Geforce driver problem, or my setup that is bad, or even a malfunctioning graphics card, since i bought it November 2011, so i might still be able to get a new one if its a problem that has been there all the time. But its weird that it runs Battlefield 3 just perfect?

#2
Posted 11/22/2012 10:36 AM   
I've talked to people who are going to try changing their GTX 580 card with a GTX 600 series card. If that fixes the problem, then you GeForce REALLY needs to work on a functioning driver update! ! !
I've talked to people who are going to try changing their GTX 580 card with a GTX 600 series card. If that fixes the problem, then you GeForce REALLY needs to work on a functioning driver update! ! !

#3
Posted 11/22/2012 01:09 PM   
Same problem. GeForce GTX580 too, and got green artifacts on the screen. Occured with Assassin's Creed 3,sometimes Battlefield 3, and LA NOIRE. Can't play more than 30min on AC3, but BF3 only the crash 2 or 3 times per month. Got the last driver : 306.97, but, i've got this problem with older driver too.
Same problem.

GeForce GTX580 too, and got green artifacts on the screen. Occured with Assassin's Creed 3,sometimes Battlefield 3, and LA NOIRE.

Can't play more than 30min on AC3, but BF3 only the crash 2 or 3 times per month.

Got the last driver : 306.97, but, i've got this problem with older driver too.

#4
Posted 11/22/2012 02:07 PM   
This is what it starts like. Weird artifacts, then it becomes like green squares. After that the GPU fan speed then cranks up to around 25% (loud) and goes back down again. [img]http://exceeder.dk//RandomFILES/IMG_2405a.jpg[/img] [img]http://exceeder.dk//RandomFILES/IMG_2408a.jpg[/img] The screen resolution is like that because if i go up to the full resolution it crashes even faster.
This is what it starts like. Weird artifacts, then it becomes like green squares.
After that the GPU fan speed then cranks up to around 25% (loud) and goes back down again.

Image

Image

The screen resolution is like that because if i go up to the full resolution it crashes even faster.

#5
Posted 11/22/2012 02:34 PM   
And here again in Call Of Duty Black Ops 2, exact same procedure. [img]http://exceeder.dk//RandomFILES/IMG_2428b.jpg[/img] [img]http://exceeder.dk//RandomFILES/IMG_2431b.jpg[/img] If there isn't any fix for this, i'm thinking about going AMD next, because of such poor costumer from GeForce service! I can see i'm not the only one who's got the exact same problem. More like everyone with this card has the same problem! I found this thread with more then 50.000 views addressing the same problem with this graphics card http://community.callofduty.com/thread/200530031?start=0&tstart=0 Also on the Assassins Creed 3 community forums i'm not alone with this problem http://forums.ubi.com/showthread.php/728020-GTX-580-driver-stoppes-working-crashes-in-Assassins-Creed-3?p=8719342 The fix is to underclock the GPU, but that does not do the job, it just delays the crashing a bit (like 2-3 minutes) [b][u]DO SOMETHING ABOUT IT![/u][/b]
And here again in Call Of Duty Black Ops 2, exact same procedure.

Image

Image


If there isn't any fix for this, i'm thinking about going AMD next, because of such poor costumer from GeForce service!
I can see i'm not the only one who's got the exact same problem. More like everyone with this card has the same problem!
I found this thread with more then 50.000 views addressing the same problem with this graphics card
http://community.callofduty.com/thread/200530031?start=0&tstart=0

Also on the Assassins Creed 3 community forums i'm not alone with this problem
http://forums.ubi.com/showthread.php/728020-GTX-580-driver-stoppes-working-crashes-in-Assassins-Creed-3?p=8719342

The fix is to underclock the GPU, but that does not do the job, it just delays the crashing a bit (like 2-3 minutes)



DO SOMETHING ABOUT IT!

#6
Posted 11/22/2012 02:50 PM   
Exactly the same as your first picture of AC3 and BO2 on my AC3, BF3, and L.A. Noire games. Little green artifacts, and the screen go black. Then, must ctrl+alt+del.
Exactly the same as your first picture of AC3 and BO2 on my AC3, BF3, and L.A. Noire games. Little green artifacts, and the screen go black.
Then, must ctrl+alt+del.

#7
Posted 11/22/2012 03:11 PM   
Okay, i think i found the solution! :D Set the clock settings in MSI afterburner / GPU Tweak or whatever you use to the stock setting, but upping the Core Voltage to 1100 mV. This did the trick for me. Now i'm running the game on maximum settings without it crashing. :D (for now! )
Okay, i think i found the solution! :D

Set the clock settings in MSI afterburner / GPU Tweak or whatever you use to the stock setting, but upping the Core Voltage to 1100 mV.

This did the trick for me. Now i'm running the game on maximum settings without it crashing. :D (for now! )

#8
Posted 11/22/2012 05:00 PM   
Yep, same solution. Found here : http://forums.ubi.com/showthread.php/697120-Solution-for-GTX580-crash-display-driver-stoped-responding-but-has-recovered Works fine now. I've played 3hours without crashing.
Yep, same solution.

Found here : http://forums.ubi.com/showthread.php/697120-Solution-for-GTX580-crash-display-driver-stoped-responding-but-has-recovered

Works fine now. I've played 3hours without crashing.

#9
Posted 11/22/2012 08:32 PM   
I don't get artifacts with my MSI branded GTX 570 card. But I do experience freezes after a few minutes of play and sometimes a message saying that my drivers have stopped/crashed and recovered. Get it happening on games Ghost Recon Future Soldier, Sleeping Dogs and now Assassin's Creed III. To fix it, I underclock the clock speeds on my card and now I can play them indefinitely without any freezes after. The 'sweet spot' of clock speeds being 700 for GPU, 1800 for Memory and 1400 for Shader
I don't get artifacts with my MSI branded GTX 570 card. But I do experience freezes after a few minutes of play and sometimes a message saying that my drivers have stopped/crashed and recovered.

Get it happening on games Ghost Recon Future Soldier, Sleeping Dogs and now Assassin's Creed III.

To fix it, I underclock the clock speeds on my card and now I can play them indefinitely without any freezes after.

The 'sweet spot' of clock speeds being 700 for GPU, 1800 for Memory and 1400 for Shader

#10
Posted 11/24/2012 12:11 AM   
same problem for me with gtx 580... we need a driver fix pc configuration: intel i7 3770k nvidia geforce gtx 580 16gb ram 1600mhz gigabyte z77-ds3h corsair force 3 SSD 240gb
same problem for me with gtx 580... we need a driver fix

pc configuration:

intel i7 3770k
nvidia geforce gtx 580
16gb ram 1600mhz
gigabyte z77-ds3h
corsair force 3 SSD 240gb

#11
Posted 11/24/2012 12:06 PM   
try upping only the Core Voltage to 1100 mV and see if it fixes the problem for now, until GeForce fixes the driver problems :D
try upping only the Core Voltage to 1100 mV and see if it fixes the problem for now, until GeForce fixes the driver problems :D

#12
Posted 11/24/2012 02:14 PM   
[s]Same crashes with a gtx 570. Unfortunately the Core Voltage trick didn't work for me, AC3 still crashes after a couple of minutes :([/s] Nevermind, stupid me forgot to click "apply" in afterburner :P I can now play for hours without any crash or freeze upping the core voltage from 988 standard to just about 1000-1010, no need to go all the way to the maximum in my case.
Same crashes with a gtx 570. Unfortunately the Core Voltage trick didn't work for me, AC3 still crashes after a couple of minutes :(


Nevermind, stupid me forgot to click "apply" in afterburner :P I can now play for hours without any crash or freeze upping the core voltage from 988 standard to just about 1000-1010, no need to go all the way to the maximum in my case.

#13
Posted 11/25/2012 09:25 AM   
AC3 continuos crash to desktop (game stay up but forced to desktop) with GFX580 with all last driver 306 and 310 (beta)
AC3 continuos crash to desktop (game stay up but forced to desktop) with GFX580
with all last driver 306 and 310 (beta)

#14
Posted 11/25/2012 07:38 PM   
The driver used to crash in certain games back when it went from 2xx to 3xx drivers and now its back. What is worse that it crashes even in desktop while browsing the web for example. The voltage trick did not work for me. I suppose the card itself is not broken at all, since we all have simillar issue. Still considering RMA, cause you cant really do anything else. Few minutes ago I formatted my drive and installed fresh Windows and even the default driver(304) crashed after couple of seconds in Chrome. I am desperate. running: i7-2600k msi gtx 580 lightning XE 8 gigs of ram z68a chipset motherboard
The driver used to crash in certain games back when it went from 2xx to 3xx drivers and now its back. What is worse that it crashes even in desktop while browsing the web for example. The voltage trick did not work for me. I suppose the card itself is not broken at all, since we all have simillar issue. Still considering RMA, cause you cant really do anything else. Few minutes ago I formatted my drive and installed fresh Windows and even the default driver(304) crashed after couple of seconds in Chrome. I am desperate.

running:

i7-2600k
msi gtx 580 lightning XE
8 gigs of ram
z68a chipset motherboard

#15
Posted 11/25/2012 10:55 PM   
  1 / 39    
Scroll To Top