Certain games run very sluggishly on Win 7 64, GTX 680 w/ 320.18 in fullscreen mode
So far this has happened with Bastion, Capsized, and A.R.E.S., but the problem is exactly the same so I imagine it will occur with others as well. Running these games in fullscreen mode, at any resolution, drops the framerate down to around 15 FPS or so, while in the game or even the main menu. Switching to windowed mode stabilizes the framerate for about 5 minutes, before it degrades again. I have already tried most of the compatibility settings for each game, as well as forcing vsync on and off and dropping core affinity down to two, and just about every possible option in the 3D settings tab. Nothing has had any effect so far. The other people I've spoke to now think it is a driver issue, which is why I'm posting here. I am running Windows 7 Pro 64-bit SP1 with a GTX 680 (306.97 through 320.18 tested), core i7 3770 @3.5GHz, ASUS P8Z77i dlx mobo w/ onboard audio, 16 gigs RAM and a 1920x1080 monitor @60Hz. If anyone has any suggestions I'd love to hear them. Edit: I've also tried setting Adaptive Power to "Max Performance" and setting Threaded Optimization both on and off. Edit 2: Found some new info about the problem: [quote="jordanredd"]Even if I start the game in windowed mode, [i]alt-tabbing to another window, even for a moment, causes the exact same problem to occur once returning to the game window.[/i] If I then go to the game menu and change resolutions (say, from 1280x720 windowed to 1600x900 windowed), the problem goes away and the game is at full speed again. In other words, here are the scenarios in which the problem appears: Starting the game in full screen mode, in any resolution. Starting the game in windowed mode, then switching to fullscreen mode. Starting the game in windowed mode, then alt-tabbing away from the game window. In all cases, the problem goes away if I switch to any windowed resolution, or switching to a [i]different[/i] resolution if I am already in windowed mode.[/quote]
So far this has happened with Bastion, Capsized, and A.R.E.S., but the problem is exactly the same so I imagine it will occur with others as well. Running these games in fullscreen mode, at any resolution, drops the framerate down to around 15 FPS or so, while in the game or even the main menu. Switching to windowed mode stabilizes the framerate for about 5 minutes, before it degrades again.

I have already tried most of the compatibility settings for each game, as well as forcing vsync on and off and dropping core affinity down to two, and just about every possible option in the 3D settings tab. Nothing has had any effect so far. The other people I've spoke to now think it is a driver issue, which is why I'm posting here.

I am running Windows 7 Pro 64-bit SP1 with a GTX 680 (306.97 through 320.18 tested), core i7 3770 @3.5GHz, ASUS P8Z77i dlx mobo w/ onboard audio, 16 gigs RAM and a 1920x1080 monitor @60Hz.

If anyone has any suggestions I'd love to hear them.

Edit: I've also tried setting Adaptive Power to "Max Performance" and setting Threaded Optimization both on and off.

Edit 2: Found some new info about the problem:

jordanredd said:Even if I start the game in windowed mode, alt-tabbing to another window, even for a moment, causes the exact same problem to occur once returning to the game window. If I then go to the game menu and change resolutions (say, from 1280x720 windowed to 1600x900 windowed), the problem goes away and the game is at full speed again.

In other words, here are the scenarios in which the problem appears:
Starting the game in full screen mode, in any resolution.
Starting the game in windowed mode, then switching to fullscreen mode.
Starting the game in windowed mode, then alt-tabbing away from the game window.

In all cases, the problem goes away if I switch to any windowed resolution, or switching to a different resolution if I am already in windowed mode.

#1
Posted 11/15/2012 08:18 PM   
is adaptive power set ? if so turn prefer max on for those games or in Global
is adaptive power set ? if so turn prefer max on for those games or in Global

Evga x58 SLI LE
i7 920 Stock
6gb @ 1600mhz
Evga 660GTX SIG2 FTW - 331.82
Onboard Realtek Sound
Win 7 64bit
Asus VS248h
Antec 750w Truepower New

#2
Posted 11/15/2012 08:30 PM   
Yes, I tried the max performance setting for both games as well. Should've mentioned that. No effect. Also tried turning "Threaded Optimization" on and off.
Yes, I tried the max performance setting for both games as well. Should've mentioned that. No effect. Also tried turning "Threaded Optimization" on and off.

#3
Posted 11/15/2012 08:33 PM   
might be game engine specific issue, you sure GPU isnt clocking back in those instances?
might be game engine specific issue, you sure GPU isnt clocking back in those instances?

Evga x58 SLI LE
i7 920 Stock
6gb @ 1600mhz
Evga 660GTX SIG2 FTW - 331.82
Onboard Realtek Sound
Win 7 64bit
Asus VS248h
Antec 750w Truepower New

#4
Posted 11/15/2012 08:59 PM   
How could I check if it is? There are no power management options enabled that I'm aware of, but I'm new at Win 7 (coming from XP), so if there's an option I can check I'm just not sure where it is. As far as the engine possibility, both games use their own custom made in-house engines, so I would say it's unlikely.
How could I check if it is? There are no power management options enabled that I'm aware of, but I'm new at Win 7 (coming from XP), so if there's an option I can check I'm just not sure where it is.

As far as the engine possibility, both games use their own custom made in-house engines, so I would say it's unlikely.

#5
Posted 11/15/2012 09:10 PM   
Get Evga Precision X or MSI afterburner they will tell you if the games are down clocking in those situations
Get Evga Precision X or MSI afterburner they will tell you if the games are down clocking in those situations

Evga x58 SLI LE
i7 920 Stock
6gb @ 1600mhz
Evga 660GTX SIG2 FTW - 331.82
Onboard Realtek Sound
Win 7 64bit
Asus VS248h
Antec 750w Truepower New

#6
Posted 11/15/2012 09:15 PM   
So I installed EVGA Precesion X and did not notice any clock speed shifting or downclocking at all while running either game. I can confidently say that is not an issue. However, I did learn something new that I very much hope will help identify the problem. Even if I start either game in windowed mode, [i]alt-tabbing to another window, even for a moment, causes the exact same problem to occur once returning to the game window.[/i] If I then go to the game menu and change resolutions (say, from 1280.720 windowed to 1600x900 windowed), the problem goes away and the game is at full speed again. In other words, here are the scenarios in which the problem appears: Starting the game in full screen mode, in any resolution. Starting the game in windowed mode, then switching to fullscreen mode. Starting the game in windowed mode, then alt-tabbing away from the game window. In all cases, the problem goes away if I switch to any windowed resolution, or switching to a [i]different[/i] resolution if I am already in windowed mode. I hope this helps.
So I installed EVGA Precesion X and did not notice any clock speed shifting or downclocking at all while running either game. I can confidently say that is not an issue.

However, I did learn something new that I very much hope will help identify the problem. Even if I start either game in windowed mode, alt-tabbing to another window, even for a moment, causes the exact same problem to occur once returning to the game window. If I then go to the game menu and change resolutions (say, from 1280.720 windowed to 1600x900 windowed), the problem goes away and the game is at full speed again.

In other words, here are the scenarios in which the problem appears:
Starting the game in full screen mode, in any resolution.
Starting the game in windowed mode, then switching to fullscreen mode.
Starting the game in windowed mode, then alt-tabbing away from the game window.

In all cases, the problem goes away if I switch to any windowed resolution, or switching to a different resolution if I am already in windowed mode.

I hope this helps.

#7
Posted 11/15/2012 10:19 PM   
Can someone tell me how to submit this problem to nVidia, so that they may (hopefully) work on a fix for the next driver release? I've been unable to find any other possible solution. Edit: Never mind, I found the submission form.
Can someone tell me how to submit this problem to nVidia, so that they may (hopefully) work on a fix for the next driver release? I've been unable to find any other possible solution.

Edit: Never mind, I found the submission form.

#8
Posted 11/17/2012 03:45 PM   
I also found that the game Capsized exhibits the same problem. The three games all have similar 2D graphical styles, so I wonder if it's a specific feature of the game engines that is causing this.
I also found that the game Capsized exhibits the same problem. The three games all have similar 2D graphical styles, so I wonder if it's a specific feature of the game engines that is causing this.

#9
Posted 11/22/2012 12:48 AM   
Just an update: This problem still has not been fixed, even after several driver updates (I am now on 320.18). Worse is that I submitted the problem to nVidia support many months ago, plus several reminders since then, but have not received any response at all.
Just an update: This problem still has not been fixed, even after several driver updates (I am now on 320.18). Worse is that I submitted the problem to nVidia support many months ago, plus several reminders since then, but have not received any response at all.

#10
Posted 06/15/2013 04:49 PM   
Scroll To Top