Need for Speed: Most Wanted (2012) - Bad Performance
  1 / 4    
Hey Nvidia- Glad to see the forums back!! I picked up the new NFS: Most Wanted game recently and very sad to see no SLI support and also completely horrible performance! As it stands currently with GTX680 SLI I only get about 35-50fps in most areas. Looking at my GPU usage it barely hits 50% on a single GPU. So clearly there is room for improvement here. I ended up having to force the game to 30fps just to make it playable. :( Currently running the 310.33 Beta drivers as these have a profile for the game, earlier drivers don't show any profile for NFS: MW. Please tell me you guys are working with Criterion/EA to improve performance and add SLI support!
Hey Nvidia-

Glad to see the forums back!! I picked up the new NFS: Most Wanted game recently and very sad to see no SLI support and also completely horrible performance!

As it stands currently with GTX680 SLI I only get about 35-50fps in most areas. Looking at my GPU usage it barely hits 50% on a single GPU. So clearly there is room for improvement here. I ended up having to force the game to 30fps just to make it playable. :(

Currently running the 310.33 Beta drivers as these have a profile for the game, earlier drivers don't show any profile for NFS: MW. Please tell me you guys are working with Criterion/EA to improve performance and add SLI support!

GPU: EVGA GTX680 SLI / CPU: Intel i7-4770K (o/c: 4.2Ghz) / Motherboard: Asus Maximus VI Hero / Memory: G.Skill 16GB DDR3-2400 / Audio: SoundBlaster Z PCIe

Shacknews Chatty & Guru3D Forums Regular

#1
Posted 11/01/2012 02:34 PM   
Agreed! Running off an i7-2600k @ 3.4GHz, with 16GB of RAM Corsair XMS @ 1333MHz, PNY GTX 670 XL8 2GB RAM. Have to set most graphical settings on Medium to achieve 50-60fps. I can set Ambient Occlusion to High, and also Shadow Details and Reflections. Game is still beautiful, but wish performance could be better with options set on their highest.
Agreed!

Running off an i7-2600k @ 3.4GHz, with 16GB of RAM Corsair XMS @ 1333MHz, PNY GTX 670 XL8 2GB RAM. Have to set most graphical settings on Medium to achieve 50-60fps. I can set Ambient Occlusion to High, and also Shadow Details and Reflections. Game is still beautiful, but wish performance could be better with options set on their highest.

#2
Posted 11/01/2012 02:50 PM   
I have GTX 580 in SLI but as you know the game doesn't support SLI!!! Anyway i have very poor performance too i've tryed several fixes and the only think that was working but not it like should be working was to change the settings of the FPS in the config file of the game!!!!
I have GTX 580 in SLI but as you know the game doesn't support SLI!!! Anyway i have very poor performance too i've tryed several fixes and the only think that was working but not it like should be working was to change the settings of the FPS in the config file of the game!!!!

PC Specs: Chassis-Cooler Master 690
Asus Crosshair Formula-Z
GPU-NVidia GTX 580 SLI
PSU-Fortron 1200w
2X RAM-Kingston Predator 2400Mhz 4GB
CPU-AMD FX-8350 4 GHz Black Edition Cooled With V8
HDD-Seagate Baracuda 1TB SATA3 7200

#3
Posted 11/01/2012 04:28 PM   
I guess it's just a metter of time before they get SLI working. Patience guys. I'm running it adequately despite of the low GPU usage and no SLI support. It will surely be an issue to the guys with mid range videocards. My Rig: i7 980x @ 4.1GHz Watercooled Corsair H100 Corsair Dominator 1600MHz 24Gb ( 4GB x 6 ) ASUS Xonar D2X sound EVGA GTX 690 Signature Stock ASUS GTX 480 stock ( just for the fun of having it installed ) love this card ASUS Rampage III Extreme Mobo OCZ Revodrive 3 X2 480Gb Boot Samsung Spinpoint 2Tb x 5 for porn ( just kidding ) Corsair Force 3 240Gb for games Corsair Nova 128Gb
I guess it's just a metter of time before they get SLI working. Patience guys. I'm running it adequately despite of the low GPU usage and no SLI support. It will surely be an issue to the guys with mid range videocards.

My Rig:
i7 980x @ 4.1GHz Watercooled Corsair H100
Corsair Dominator 1600MHz 24Gb ( 4GB x 6 )
ASUS Xonar D2X sound
EVGA GTX 690 Signature Stock
ASUS GTX 480 stock ( just for the fun of having it installed ) love this card
ASUS Rampage III Extreme Mobo
OCZ Revodrive 3 X2 480Gb Boot
Samsung Spinpoint 2Tb x 5 for porn ( just kidding )
Corsair Force 3 240Gb for games
Corsair Nova 128Gb

i7 980x @ 4.1GHz 1.36v Watercooled Corsair H100
Corsair Dominator 1600MHz 24Gb ( 4GB x 6 )
ASUS Xonar D2X sound
EVGA GTX 690 Signature Stock x2 ( Quad SLI boys! )
ASUS Rampage III Extreme Mobo
OCZ Revodrive 3 X2 480Gb Boot
Samsung Spinpoint 2Tb x 5 for porn ( just kidding )
Corsair Force 3 240Gb for games
Corsair Nova 128Gb
Corsair AX 1200 PSu
Cooler Master CM690 NVIDIA Chassis
12000 BTU Air Conditioner
One very angry spouse

#4
Posted 11/01/2012 06:50 PM   
I also experience gpu usage and low fps issue. Currently running the 310.33 beta drivers. Turn off Vsync via control panel to gain more fps. It also helps utilize GPU power. I'm playing at resolution 1920x1200. Had to set every setting to lowest to make sure the game run smooth. I can't wait for any driver improvement in this game.
I also experience gpu usage and low fps issue. Currently running the 310.33 beta drivers.
Turn off Vsync via control panel to gain more fps. It also helps utilize GPU power.
I'm playing at resolution 1920x1200. Had to set every setting to lowest to make sure the game run smooth.
I can't wait for any driver improvement in this game.

Graphics card: Asus GeForce GTS 250 Dark Knight 1 GB GDDR3
CPU: Intel Core 2 Quad Q9400
Motherboard: Asus P5E-VM DO bios 0902
Memory: 6 GB DDR2 RAM
Monitor: LG FLATRON W2452T 24"
Operating system: Windows 7 x64 SP1
Sound card: Realtek ALC883
PSU: Fortron 500W FSP500 60GLN(80)

#5
Posted 11/01/2012 08:32 PM   
[quote="Thiopental"]I guess it's just a metter of time before they get SLI working. Patience guys. I'm running it adequately despite of the low GPU usage and no SLI support. It will surely be an issue to the guys with mid range videocards. My Rig: i7 980x @ 4.1GHz Watercooled Corsair H100 Corsair Dominator 1600MHz 24Gb ( 4GB x 6 ) ASUS Xonar D2X sound EVGA GTX 690 Signature Stock ASUS GTX 480 stock ( just for the fun of having it installed ) love this card ASUS Rampage III Extreme Mobo OCZ Revodrive 3 X2 480Gb Boot Samsung Spinpoint 2Tb x 5 for porn ( just kidding ) Corsair Force 3 240Gb for games Corsair Nova 128Gb[/quote] Be patient?!?!?! I was patient with SLI fix for Dirt Showdown.. which came out with 310.33 Drivers.. [b]5 MONTHS[/b] after Showdown was released!! Running 3 680's here.. and NFS Most Wanted runs like crap! It shouldn't take 5 months to come out with an SLI fix for a game! If you wanna call it whining.. call it that.. but I'm just fed up with purchasing new $50-$60 games and have them running like this! It's 2012 Nvidia! Get with the program! SLI is nothing new... so dont act like it takes an act of congress to get a fix for SLI systems! BTW.. thank you for releasing Dirt Showdown SLI fix.. I can now enjoy the game again on my 3 680's :)
Thiopental said:I guess it's just a metter of time before they get SLI working. Patience guys. I'm running it adequately despite of the low GPU usage and no SLI support. It will surely be an issue to the guys with mid range videocards.

My Rig:
i7 980x @ 4.1GHz Watercooled Corsair H100
Corsair Dominator 1600MHz 24Gb ( 4GB x 6 )
ASUS Xonar D2X sound
EVGA GTX 690 Signature Stock
ASUS GTX 480 stock ( just for the fun of having it installed ) love this card
ASUS Rampage III Extreme Mobo
OCZ Revodrive 3 X2 480Gb Boot
Samsung Spinpoint 2Tb x 5 for porn ( just kidding )
Corsair Force 3 240Gb for games
Corsair Nova 128Gb


Be patient?!?!?! I was patient with SLI fix for Dirt Showdown.. which came out with 310.33 Drivers.. 5 MONTHS after Showdown was released!!

Running 3 680's here.. and NFS Most Wanted runs like crap! It shouldn't take 5 months to come out with an SLI fix for a game!

If you wanna call it whining.. call it that.. but I'm just fed up with purchasing new $50-$60 games and have them running like this! It's 2012 Nvidia! Get with the program! SLI is nothing new... so dont act like it takes an act of congress to get a fix for SLI systems!

BTW.. thank you for releasing Dirt Showdown SLI fix.. I can now enjoy the game again on my 3 680's :)

NZXT Phantom 820 Case

Asus Rampage IV Extreme

Silverstone 1200w PSU

Intel i7 3960X OC'd @ 4.7Ghz

Corsair H100i Cooler

3 EVGA GTX 780 SC w/ACX GPU's SLI

16GB (8 x 4GB) Corsair Dominator GT 2133Mhz

2 Samsung 840-Pro Series 256GB SSD's (RAID-0)

2 WD 1TB SATA III Caviar Black Hard Drives (RAID-0)

LG Blu-Ray Burner

Windows 8.1 Professional 64-bit

#6
Posted 11/01/2012 08:39 PM   
Hell the game runs like crap on single GPU systems. So this really needs to be addressed. You shouldn't need a 5Ghz CPU and GTX780 to max this game out. lol No that wasn't a typo on the GPU... currently you can't max this out on a single GTX680 unless you like fps dips below 60fps.
Hell the game runs like crap on single GPU systems. So this really needs to be addressed. You shouldn't need a 5Ghz CPU and GTX780 to max this game out. lol

No that wasn't a typo on the GPU... currently you can't max this out on a single GTX680 unless you like fps dips below 60fps.

GPU: EVGA GTX680 SLI / CPU: Intel i7-4770K (o/c: 4.2Ghz) / Motherboard: Asus Maximus VI Hero / Memory: G.Skill 16GB DDR3-2400 / Audio: SoundBlaster Z PCIe

Shacknews Chatty & Guru3D Forums Regular

#7
Posted 11/01/2012 10:34 PM   
I'm on GTX580 SLI and I went into the NVCP to change it Single GPU in the hopes it would run better. Imagine my surprise the game is already set to Single GPU. NFS:MW is using Frostbite 2 engine which is the same as BF3, but BF3 runs fine, so what's the problem here?
I'm on GTX580 SLI and I went into the NVCP to change it Single GPU in the hopes it would run better. Imagine my surprise the game is already set to Single GPU.

NFS:MW is using Frostbite 2 engine which is the same as BF3, but BF3 runs fine, so what's the problem here?

#8
Posted 11/01/2012 11:02 PM   
The problem is to do with the bad port to PC, as i yer seen anyone that can run it good. settings does not change much, seems like bad optimization problem, it happen on ATI cards too
The problem is to do with the bad port to PC, as i yer seen anyone that can run it good. settings does not change much, seems like bad optimization problem, it happen on ATI cards too

#9
Posted 11/01/2012 11:27 PM   
Alright, I found the culprits that caused the frame rate fluctuations. I set the following Shadows= None Ambient Occlusion= Off Reflection Detail= Low Geometry Detail= Low My testing methodology was to go to the middle of the city, set all options to minimum and spin the car in one place. With all options off, the FPS didn't drop, it was pretty smooth. And then I proceeded to turn on each option one at a time and continue the car spinning. When I noticed that FPS dropped, I turned the graphic option off and turned the next one on. Turning on either one of the above will cause poor FPS. I hope Criterion or Nvidia can fix this.
Alright, I found the culprits that caused the frame rate fluctuations. I set the following

Shadows= None
Ambient Occlusion= Off
Reflection Detail= Low
Geometry Detail= Low

My testing methodology was to go to the middle of the city, set all options to minimum and spin the car in one place. With all options off, the FPS didn't drop, it was pretty smooth. And then I proceeded to turn on each option one at a time and continue the car spinning. When I noticed that FPS dropped, I turned the graphic option off and turned the next one on.

Turning on either one of the above will cause poor FPS. I hope Criterion or Nvidia can fix this.

#10
Posted 11/01/2012 11:28 PM   
[quote="VoodooKing"]I'm on GTX580 SLI and I went into the NVCP to change it Single GPU in the hopes it would run better. Imagine my surprise the game is already set to Single GPU. NFS:MW is using Frostbite 2 engine which is the same as BF3, but BF3 runs fine, so what's the problem here?[/quote] NFS:MW is not using Frostbite 2. It's using a modified version of the Chameleon engine which was used in NFS: Hot Pursuit. [url]http://twitter.com/NeedforSpeed/status/210984390866644992[/url]
VoodooKing said:I'm on GTX580 SLI and I went into the NVCP to change it Single GPU in the hopes it would run better. Imagine my surprise the game is already set to Single GPU.

NFS:MW is using Frostbite 2 engine which is the same as BF3, but BF3 runs fine, so what's the problem here?


NFS:MW is not using Frostbite 2. It's using a modified version of the Chameleon engine which was used in NFS: Hot Pursuit.

http://twitter.com/NeedforSpeed/status/210984390866644992

GPU: EVGA GTX680 SLI / CPU: Intel i7-4770K (o/c: 4.2Ghz) / Motherboard: Asus Maximus VI Hero / Memory: G.Skill 16GB DDR3-2400 / Audio: SoundBlaster Z PCIe

Shacknews Chatty & Guru3D Forums Regular

#11
Posted 11/02/2012 03:17 AM   
Ya I hope Nvidia and EA (Criterion) fix these choppy framerate issues. This is a really fun game I think. I play at max settings with 20-35 FPS with a GTX 660 but EVGA Precision is saying my GPU is only using 45-70% and only 850MB V-Ram. Every resource demanding game ive run so far only uses up to 65-70% of my GPU like GTA 4 and Crysis. Why is it limited to only useing a fraction of the cards resources? Games would play so much better if the GPU was really working at its peak 90-100%. I dont know if this is an Nvidia issue or what but I really hope they fix it.
Ya I hope Nvidia and EA (Criterion) fix these choppy framerate issues. This is a really fun game I think. I play at max settings with 20-35 FPS with a GTX 660 but EVGA Precision is saying my GPU is only using 45-70% and only 850MB V-Ram. Every resource demanding game ive run so far only uses up to 65-70% of my GPU like GTA 4 and Crysis. Why is it limited to only useing a fraction of the cards resources? Games would play so much better if the GPU was really working at its peak 90-100%. I dont know if this is an Nvidia issue or what but I really hope they fix it.

#12
Posted 11/02/2012 03:23 AM   
Hello! I run Most Wanted 2012 on a Radeon HD 7970, 1080p, all maxed out, and I have 60fps with very few drops to 45 fps in very few places. Clearly the game needs optimization but Radeon cards run this game very very well.
Hello! I run Most Wanted 2012 on a Radeon HD 7970, 1080p, all maxed out, and I have 60fps with very few drops to 45 fps in very few places. Clearly the game needs optimization but Radeon cards run this game very very well.

My Gaming Rig: Mobo: Asus P8Z68-V PRO| CPU: Intel Core i5-2500k | RAM: 2 x 2 GB DDR3@1600Mhz Kingston HyperX | GPU: Gigabyte AMD Radeon HD7970@1000Mhz | Intel SSD X25-M 80GB | HDD: Seagate Barracuda XT 2TB | PSU: CM GX 750W | Case: Cooler Master HAF 932 Advanced | Periferice: Razer Arctosa | Imperator | Destructor

#13
Posted 11/02/2012 06:53 AM   
I seriously just want to vent the fuck out of this game for its pathetic support. but i will hold back at what ive already said. This game has many areas to improve upon: 1. low gpu utilisation - people with single cards need decent fps 2. sli profile - may be an nvidia issue, but it needs dev input. make this work with sli. 3. just work on the above. i have found not a single issue with this game apart from the above. im capped at 60fps but cannot even reach it on dual 580gtx's. a single 580 should run this fine, 2 should run it at 75fps. make it happen. its a racing game. i am running 2560x1440, max details, ssao on medium. on high i dont get over 35fps, on medium i get 44fps, on off i get 44fps. i should be able to get 80fps on max, hot pursit gave me fps in the hundreds. a racing game needs the highest fps possible. why do i run ssao at med instead of high? cause at 35 fps the game suffers input lag, my steering just doesnt work, its laggy its unplayable. on med when the game decides it can run at 50fps on the off world parts of the highway it is smooth as silk. we need 60fps.
I seriously just want to vent the fuck out of this game for its pathetic support. but i will hold back at what ive already said.

This game has many areas to improve upon:
1. low gpu utilisation - people with single cards need decent fps
2. sli profile - may be an nvidia issue, but it needs dev input. make this work with sli.
3. just work on the above. i have found not a single issue with this game apart from the above. im capped at 60fps but cannot even reach it on dual 580gtx's. a single 580 should run this fine, 2 should run it at 75fps. make it happen.

its a racing game. i am running 2560x1440, max details, ssao on medium. on high i dont get over 35fps, on medium i get 44fps, on off i get 44fps. i should be able to get 80fps on max, hot pursit gave me fps in the hundreds.

a racing game needs the highest fps possible. why do i run ssao at med instead of high? cause at 35 fps the game suffers input lag, my steering just doesnt work, its laggy its unplayable. on med when the game decides it can run at 50fps on the off world parts of the highway it is smooth as silk. we need 60fps.

#14
Posted 11/02/2012 02:07 PM   
I`ve been tweaking with the nvidia control panel. It seems the game won`t go over 60FPS ever, it`s capped. Forcing Alternate frame rendering 2 improves SLI GPU usage and you will be able to turn on all the eye candy IF you have the hardware for that. I`m playing 60FPS all the time maxed out @ 1920x1080. GPU usage does not go beyond 65% ever, but the GPU load is way better balanced. Give it a try.
I`ve been tweaking with the nvidia control panel. It seems the game won`t go over 60FPS ever, it`s capped. Forcing Alternate frame rendering 2 improves SLI GPU usage and you will be able to turn on all the eye candy IF you have the hardware for that. I`m playing 60FPS all the time maxed out @ 1920x1080. GPU usage does not go beyond 65% ever, but the GPU load is way better balanced. Give it a try.

i7 980x @ 4.1GHz 1.36v Watercooled Corsair H100
Corsair Dominator 1600MHz 24Gb ( 4GB x 6 )
ASUS Xonar D2X sound
EVGA GTX 690 Signature Stock x2 ( Quad SLI boys! )
ASUS Rampage III Extreme Mobo
OCZ Revodrive 3 X2 480Gb Boot
Samsung Spinpoint 2Tb x 5 for porn ( just kidding )
Corsair Force 3 240Gb for games
Corsair Nova 128Gb
Corsair AX 1200 PSu
Cooler Master CM690 NVIDIA Chassis
12000 BTU Air Conditioner
One very angry spouse

#15
Posted 11/02/2012 06:44 PM   
  1 / 4    
Scroll To Top