On behalf of Arkham fans
Just wanna thank you guys for the latest PhysX update 9.12.0507


You've made Arkham so much better, flying round the city is now a total joy, i'm sure you've advanced PhysX in general too over the last wee while, so thanks for that, and have a great day fellas.
Peace.
*playin' Arkham with 'one frame thread lag' disabled.
Just wanna thank you guys for the latest PhysX update 9.12.0507





You've made Arkham so much better, flying round the city is now a total joy, i'm sure you've advanced PhysX in general too over the last wee while, so thanks for that, and have a great day fellas.

Peace.

*playin' Arkham with 'one frame thread lag' disabled.

i5 3570k @4.8
Gigabyte z77x up4 th
680 Classified
8gb Dominator GT @2400
xfx 850w psu /Win8.1

#1
Posted 06/11/2012 08:41 PM   
Where did you acquire this update? Through the Toshiba laptop drivers or what?
Where did you acquire this update? Through the Toshiba laptop drivers or what?

EVGA E758 A1 X58 // Core i7 920@4Ghz // OCZ Platinum DDR3 1600 // EVGA GTX 670 SLI // Seasonic X Series Gold 1050w // Corsair 800D // Dual Dell Ultrasharp U2410 displays // Dell Ultrasharp 2408WFP

#2
Posted 06/12/2012 02:04 AM   
it was posted in Guru3D
http://forums.guru3d.com/forumdisplay.php?f=40

physX update:
http://forums.laptopvideo2go.com/topic/29522-physx-v9120507/
it was posted in Guru3D

http://forums.guru3d.com/forumdisplay.php?f=40



physX update:

http://forums.laptopvideo2go.com/topic/29522-physx-v9120507/

i5 3570k @4.8
Gigabyte z77x up4 th
680 Classified
8gb Dominator GT @2400
xfx 850w psu /Win8.1

#3
Posted 06/12/2012 05:34 AM   
[img]http://i.imgur.com/yf5RM.jpg[/img]

Gpu usage while flying around Arkham, very nice indeed. : )
*note the 1366mb VRAM usage, this is the most i've ever seen it.
Image



Gpu usage while flying around Arkham, very nice indeed. : )

*note the 1366mb VRAM usage, this is the most i've ever seen it.

i5 3570k @4.8
Gigabyte z77x up4 th
680 Classified
8gb Dominator GT @2400
xfx 850w psu /Win8.1

#4
Posted 06/13/2012 07:31 AM   
Still running the same on my rig, which is terrible to say the least. Even in DX9 mode the game dips to 28 fps when the PhysX effects are heavy. In DX11 mode, the game will stutter and hitch like crazy, with fps dips into the single digit territory.

Having tried just about every .ini tweak, along with loads of other tweaks via Nvidia inspector, I'm pretty much ready to give up on this game entirely. It's going to take its place next to GTA IV on my "should have been" shelf.

Thankfully, I was able to make it through the game. I even did most of the side quests, including the Riddler challenges. I was able to look past all the performance issues at the time, because the core game is really good.

That said, I was hoping that all the bugs would be ironed out at some point. I really wanted to play through the game again without having to deal with all the performance issues that kill the experience. Sadly, it seems that's never going to happen. Unfortunately, that's just the way it is when it comes to PC gaming in general. It's sad to see a great game like Arkham City get sloppily ported to the PC, but there's just not much anyone can do about it (save for the developer, who obviously doesn't care).
Still running the same on my rig, which is terrible to say the least. Even in DX9 mode the game dips to 28 fps when the PhysX effects are heavy. In DX11 mode, the game will stutter and hitch like crazy, with fps dips into the single digit territory.



Having tried just about every .ini tweak, along with loads of other tweaks via Nvidia inspector, I'm pretty much ready to give up on this game entirely. It's going to take its place next to GTA IV on my "should have been" shelf.



Thankfully, I was able to make it through the game. I even did most of the side quests, including the Riddler challenges. I was able to look past all the performance issues at the time, because the core game is really good.



That said, I was hoping that all the bugs would be ironed out at some point. I really wanted to play through the game again without having to deal with all the performance issues that kill the experience. Sadly, it seems that's never going to happen. Unfortunately, that's just the way it is when it comes to PC gaming in general. It's sad to see a great game like Arkham City get sloppily ported to the PC, but there's just not much anyone can do about it (save for the developer, who obviously doesn't care).

EVGA E758 A1 X58 // Core i7 920@4Ghz // OCZ Platinum DDR3 1600 // EVGA GTX 670 SLI // Seasonic X Series Gold 1050w // Corsair 800D // Dual Dell Ultrasharp U2410 displays // Dell Ultrasharp 2408WFP

#5
Posted 06/14/2012 03:37 AM   
Nice, thank you! I get no less than 36fps at the scene with the ice gun now in 1080p with 4xSGSSAA. Before it was below 30 as far as I remember.
Nice, thank you! I get no less than 36fps at the scene with the ice gun now in 1080p with 4xSGSSAA. Before it was below 30 as far as I remember.

Intel Core i7-3930K @4,2GHz *** 16GB DDR3-1333 *** GTX Titan 6GB SLI

#6
Posted 06/15/2012 08:36 PM   
I take back some of what I said earlier. With this update applied (and DX11 disabled) the game runs very well. I had DX11 enabled the first go round, so I really didn't notice the improved PhysX performance.

I disabled SLI so I could use my secondary card as a PPU, then I ran the built-in benchmark. I averaged 55 fps, but what's really nice is that my min framerate was a more reasonable 41 fps. That's not bad at all. The ice gun scene previously fell below 30 fps on every GPU configuration I've used, but now it runs over 40 fps the whole time.

So DX11 is still broken, but this update does change things for the better. It's a pity it took this long for this update to surface (and it hasn't even been officially released for desktop machines [b]yet[/b]).
I take back some of what I said earlier. With this update applied (and DX11 disabled) the game runs very well. I had DX11 enabled the first go round, so I really didn't notice the improved PhysX performance.



I disabled SLI so I could use my secondary card as a PPU, then I ran the built-in benchmark. I averaged 55 fps, but what's really nice is that my min framerate was a more reasonable 41 fps. That's not bad at all. The ice gun scene previously fell below 30 fps on every GPU configuration I've used, but now it runs over 40 fps the whole time.



So DX11 is still broken, but this update does change things for the better. It's a pity it took this long for this update to surface (and it hasn't even been officially released for desktop machines yet).

EVGA E758 A1 X58 // Core i7 920@4Ghz // OCZ Platinum DDR3 1600 // EVGA GTX 670 SLI // Seasonic X Series Gold 1050w // Corsair 800D // Dual Dell Ultrasharp U2410 displays // Dell Ultrasharp 2408WFP

#7
Posted 06/16/2012 04:27 AM   
I know the benchmark quite well, dx11 extreme detail, physx high :
ice gun starting -50fps ice gun ending - 45 /46fps
average frames - 48 /49fps
*note :i never use any kind of AA nor blur in my games, and have tweaked the .ini (but only to boost or disable settings never to gimp them down).
i've removed FOV, glare, & one frame thread lag from the .ini
I know the benchmark quite well, dx11 extreme detail, physx high :

ice gun starting -50fps ice gun ending - 45 /46fps

average frames - 48 /49fps

*note :i never use any kind of AA nor blur in my games, and have tweaked the .ini (but only to boost or disable settings never to gimp them down).

i've removed FOV, glare, & one frame thread lag from the .ini

i5 3570k @4.8
Gigabyte z77x up4 th
680 Classified
8gb Dominator GT @2400
xfx 850w psu /Win8.1

#8
Posted 06/16/2012 06:09 AM   
Is it just me or does the ice gun scene look different now? Like some projectiles are missing?
Is it just me or does the ice gun scene look different now? Like some projectiles are missing?

Intel Core i7-3930K @4,2GHz *** 16GB DDR3-1333 *** GTX Titan 6GB SLI

#9
Posted 06/16/2012 07:36 AM   
The game does look different when you run it at higher FPS, very detailed indeed, here's a silly slo-mo vid of the Freeze gun i did a while back, just for lols>

Arkham City Freeze Gun Slow Motion
http://www.youtube.com/watch?v=XGP0UONyKFQ
*of course the gameplay was much smoother than this vid would suggest.
The game does look different when you run it at higher FPS, very detailed indeed, here's a silly slo-mo vid of the Freeze gun i did a while back, just for lols>



Arkham City Freeze Gun Slow Motion

/>
*of course the gameplay was much smoother than this vid would suggest.

i5 3570k @4.8
Gigabyte z77x up4 th
680 Classified
8gb Dominator GT @2400
xfx 850w psu /Win8.1

#10
Posted 06/16/2012 07:54 AM   
[quote name='SLI-756' date='16 June 2012 - 02:54 AM' timestamp='1339833257' post='1422006']
The game does look different when you run it at higher FPS, very detailed indeed, here's a silly slo-mo vid of the Freeze gun i did a while back, just for lols>

Arkham City Freeze Gun Slow Motion
http://www.youtube.com/watch?v=XGP0UONyKFQ
*of course the gameplay was much smoother than this vid would suggest.
[/quote]

Has anyone tried the newest beta drivers with Arkhan Asylum (playing that first). On my Gefore GTC 580/i7 it is now unplayable with PhysX enabled. I had it on "high" with the older drivers.

Playing at 1920x1080p/4x AA. Now I need PhysX off.
[quote name='SLI-756' date='16 June 2012 - 02:54 AM' timestamp='1339833257' post='1422006']

The game does look different when you run it at higher FPS, very detailed indeed, here's a silly slo-mo vid of the Freeze gun i did a while back, just for lols>



Arkham City Freeze Gun Slow Motion

/>
*of course the gameplay was much smoother than this vid would suggest.





Has anyone tried the newest beta drivers with Arkhan Asylum (playing that first). On my Gefore GTC 580/i7 it is now unplayable with PhysX enabled. I had it on "high" with the older drivers.



Playing at 1920x1080p/4x AA. Now I need PhysX off.

#11
Posted 06/20/2012 05:48 PM   
[b]Catwoman - Arkham Hit Girl 1080
http://www.youtube.com/watch?v=-_cBo0cTfkE[/b]

[i]Arkham City, dx11 extreme detail, physx high.
*DOF & frame lag disabled[/i]
Catwoman - Arkham Hit Girl 1080

/>


Arkham City, dx11 extreme detail, physx high.

*DOF & frame lag disabled

i5 3570k @4.8
Gigabyte z77x up4 th
680 Classified
8gb Dominator GT @2400
xfx 850w psu /Win8.1

#12
Posted 06/25/2012 03:49 AM   
What are the DOF and frame lag settings in the INI file? Are these what make yours not stutter when flying around the city? Mine stutters like crazy with a GTX670 and 2600K @ 4.5GHz.
What are the DOF and frame lag settings in the INI file? Are these what make yours not stutter when flying around the city? Mine stutters like crazy with a GTX670 and 2600K @ 4.5GHz.

#13
Posted 06/29/2012 06:42 PM   
[SystemSettings]
[...]
MotionBlur=False
MotionBlurPause=True
MotionBlurSkinning=1
DepthOfField=False <<<<<<<<<<<<<<< /teehee.gif' class='bbc_emoticon' alt=':teehee:' />
AmbientOcclusion=False
HBAORadius=2.000000
HBAOGamma=3.000000
HBAOAngleBias=10.000000
HBAOBlurSharpness=8.000000
HBAOStepSize=2
RockAOApplyFarCull=0.998000
Bloom=False <<<<<<<<<<<<<<<< /smile.gif' class='bbc_emoticon' alt=':smile:' />
bAllowLightShafts=True
Distortion=False
FilteredDistortion=True
DropParticleDistortion=False
bAllowDownsampledTranslucency=False
NVParticleDownsamplingThreshold=100.000000
DefaultUIDepth=1.000000
bAllowMatineeStereoConvergence=True
SpeedTreeLeaves=True
SpeedTreeFronds=True
OnlyStreamInTextures=False
LensFlares=False
FogVolumes=True
FloatingPointRenderTargets=True
OneFrameThreadLag=False <<<<<<< /turned.gif' class='bbc_emoticon' alt=':turned:' /> this introduces input lag when enabled /more demanding on system when disabled
UseVsync=True
UpscaleScreenPercentage=True
Fullscreen=True
AllowD3D10=False
AllowD3D11=True
[...]

C:\Users\YOURUSERNAME\Documents\WB Games\Batman Arkham City\BmGame\Config

bmengine.ini is what you're looking for (set to 'read-only' after tweaking.
[SystemSettings]

[...]

MotionBlur=False

MotionBlurPause=True

MotionBlurSkinning=1

DepthOfField=False <<<<<<<<<<<<<<< /teehee.gif' class='bbc_emoticon' alt=':teehee:' />

AmbientOcclusion=False

HBAORadius=2.000000

HBAOGamma=3.000000

HBAOAngleBias=10.000000

HBAOBlurSharpness=8.000000

HBAOStepSize=2

RockAOApplyFarCull=0.998000

Bloom=False <<<<<<<<<<<<<<<< /smile.gif' class='bbc_emoticon' alt=':smile:' />

bAllowLightShafts=True

Distortion=False

FilteredDistortion=True

DropParticleDistortion=False

bAllowDownsampledTranslucency=False

NVParticleDownsamplingThreshold=100.000000

DefaultUIDepth=1.000000

bAllowMatineeStereoConvergence=True

SpeedTreeLeaves=True

SpeedTreeFronds=True

OnlyStreamInTextures=False

LensFlares=False

FogVolumes=True

FloatingPointRenderTargets=True

OneFrameThreadLag=False <<<<<<< /turned.gif' class='bbc_emoticon' alt=':turned:' /> this introduces input lag when enabled /more demanding on system when disabled

UseVsync=True

UpscaleScreenPercentage=True

Fullscreen=True

AllowD3D10=False

AllowD3D11=True

[...]



C:\Users\YOURUSERNAME\Documents\WB Games\Batman Arkham City\BmGame\Config



bmengine.ini is what you're looking for (set to 'read-only' after tweaking.

i5 3570k @4.8
Gigabyte z77x up4 th
680 Classified
8gb Dominator GT @2400
xfx 850w psu /Win8.1

#14
Posted 06/29/2012 06:59 PM   
Scroll To Top