BSOD switching to GT520M VGA
Hi,

3 day ago I bought an ASUS U30S laptop. This laptop has a Core-i5 cpu with a nvidia GT520M graphic card. I've installad a Windows 7 Ultimate 64bit on it.
The problem is that as long as the laptop uses the integrated graphics there are no problems but every time it wants to switch to nvidia graphic card (through nvidia control panel preview section or running Unigine Heavean or disabling integrated graphics) the BSOD appears telling the is a problem with nvlddmkm.sys file; I have attached some of dump files.

Things I do till now but didn't work:
[list]
[*]Download and install latest GT520m driver from nvidia
[*]Uninstall the driver, clean all traces using Driver Sweep and reinstall the driver
[*]Reinstalling Windows
[/list]

Thanks,
Aydin
Hi,



3 day ago I bought an ASUS U30S laptop. This laptop has a Core-i5 cpu with a nvidia GT520M graphic card. I've installad a Windows 7 Ultimate 64bit on it.

The problem is that as long as the laptop uses the integrated graphics there are no problems but every time it wants to switch to nvidia graphic card (through nvidia control panel preview section or running Unigine Heavean or disabling integrated graphics) the BSOD appears telling the is a problem with nvlddmkm.sys file; I have attached some of dump files.



Things I do till now but didn't work:


  • Download and install latest GT520m driver from nvidia
  • Uninstall the driver, clean all traces using Driver Sweep and reinstall the driver
  • Reinstalling Windows




Thanks,

Aydin
Attachments

Dump.zip

#1
Posted 05/10/2012 07:50 AM   
[quote name='Aydin192' date='10 May 2012 - 03:50 PM' timestamp='1336636245' post='1406385']
Hi,

3 day ago I bought an ASUS U30S laptop. This laptop has a Core-i5 cpu with a nvidia GT520M graphic card. I've installad a Windows 7 Ultimate 64bit on it.
The problem is that as long as the laptop uses the integrated graphics there are no problems but every time it wants to switch to nvidia graphic card (through nvidia control panel preview section or running Unigine Heavean or disabling integrated graphics) the BSOD appears telling the is a problem with nvlddmkm.sys file; I have attached some of dump files.

Things I do till now but didn't work:
[list]
[*]Download and install latest GT520m driver from nvidia
[*]Uninstall the driver, clean all traces using Driver Sweep and reinstall the driver
[*]Reinstalling Windows
[/list]

Thanks,
Aydin
[/quote]
I have the same problem with a ASUS PRO36S (U36SD) i7-2620M Sandy Bridge w/ GT520M 1GB. I have been using it over a year and always get the BSOD when the switch-on-demand happens. It appears to be an overheating problem, the temp surges during the switch. However, there are a few times I am able to 'switch' to the GT520M w/o BSOD and then I also found a sort of workaround for it for Diablo 3, I call it the 'manual switch'.

Manual switch:
1. I set the 3D processor to GT520M and PhysX to GT520M in Nvidia control panel.
2. Disable Nvidia GT520M in Device Manager. (better if restart PC afterwards)
3. Start Diablo 3
4. Press windows key to minimize Diablo 3 (if you run fullscreen)
5. Go to Device Manager and enable Nvidia GT520M
Most of the time, step 5 fails, you'll see a yellow-mini-icon over the device icon for Nvidia GT520M in Dev Manager, just disable then enable again. This happens 4 out of 5 times.

Twice out of approx 50 runs, besides getting the switch to work (fps is better than just pure Integrated), the GT520M finally did it's job for like 30minutes. I get liquid-smooth gamplay even at 1280x720. AA off and LowFX on, of course. When this happens, the left palm rest of the laptop isn't hot, it's just warm.
[quote name='Aydin192' date='10 May 2012 - 03:50 PM' timestamp='1336636245' post='1406385']

Hi,



3 day ago I bought an ASUS U30S laptop. This laptop has a Core-i5 cpu with a nvidia GT520M graphic card. I've installad a Windows 7 Ultimate 64bit on it.

The problem is that as long as the laptop uses the integrated graphics there are no problems but every time it wants to switch to nvidia graphic card (through nvidia control panel preview section or running Unigine Heavean or disabling integrated graphics) the BSOD appears telling the is a problem with nvlddmkm.sys file; I have attached some of dump files.



Things I do till now but didn't work:


  • Download and install latest GT520m driver from nvidia
  • Uninstall the driver, clean all traces using Driver Sweep and reinstall the driver
  • Reinstalling Windows




Thanks,

Aydin



I have the same problem with a ASUS PRO36S (U36SD) i7-2620M Sandy Bridge w/ GT520M 1GB. I have been using it over a year and always get the BSOD when the switch-on-demand happens. It appears to be an overheating problem, the temp surges during the switch. However, there are a few times I am able to 'switch' to the GT520M w/o BSOD and then I also found a sort of workaround for it for Diablo 3, I call it the 'manual switch'.



Manual switch:

1. I set the 3D processor to GT520M and PhysX to GT520M in Nvidia control panel.

2. Disable Nvidia GT520M in Device Manager. (better if restart PC afterwards)

3. Start Diablo 3

4. Press windows key to minimize Diablo 3 (if you run fullscreen)

5. Go to Device Manager and enable Nvidia GT520M

Most of the time, step 5 fails, you'll see a yellow-mini-icon over the device icon for Nvidia GT520M in Dev Manager, just disable then enable again. This happens 4 out of 5 times.



Twice out of approx 50 runs, besides getting the switch to work (fps is better than just pure Integrated), the GT520M finally did it's job for like 30minutes. I get liquid-smooth gamplay even at 1280x720. AA off and LowFX on, of course. When this happens, the left palm rest of the laptop isn't hot, it's just warm.

#2
Posted 06/18/2012 08:45 AM   
Scroll To Top