ASUS N53SM GT 630M Drivers Windows 7 64bit cannot find correct driver / install fails to find device
Hi,
I bought ASUS N53SM Laptop which has geforce GT 630M graphics. It had windows 7 home premium 64bit pre-installed and nvidia drivers version 285.48 and graphics worked just fine. I formatted it and installed windows 7 ultimate 64bit retail and tried to install nvidia drivers but it failed: "No compatible device found" and install aborted. I tried same version (from ASUS support website) it had pre-installed but same problem. Then i tried every nvidia driver i could find but all gave same error. Tested with 285.48, 285.62, 296.10 and 301.24. Driver installer can't detect device for some reason.

Laptop GPU-indicator led show nvidia graphics are active (light is white, blue is for intel internal-chip). I have installed every other driver and all other devices work fine. I also re-installed (to test if card is broken) original windows version from recovery dvd's and it worked so graphic card is not broken. I have tried to install driver in safe mode and with build-in admin account but no success: every time same error: no compatible device found. Device manager shows exclamation mark on 'standard vga-adapter' and device ID (on details tab) is PCI\VEN_10DE&DEV_0DE9&SUBSYS_21141043&REV_A1. I have also tried to manually install all driver versions via device manager -> update driver -> manually select drier -> disk -> driver for GT 630M but it tells driver is not compatbile with this version of windows.

[all versions are 64bit and i have re-downloaded each pack just to be sure, windows is activated and i have downloaded all updates, system drivers (intel&asus) are updated to latest]

Please help, how to install nvidia drivers? Where i can download correct version? ASUS support can't help :(

Thank you!
Hi,

I bought ASUS N53SM Laptop which has geforce GT 630M graphics. It had windows 7 home premium 64bit pre-installed and nvidia drivers version 285.48 and graphics worked just fine. I formatted it and installed windows 7 ultimate 64bit retail and tried to install nvidia drivers but it failed: "No compatible device found" and install aborted. I tried same version (from ASUS support website) it had pre-installed but same problem. Then i tried every nvidia driver i could find but all gave same error. Tested with 285.48, 285.62, 296.10 and 301.24. Driver installer can't detect device for some reason.



Laptop GPU-indicator led show nvidia graphics are active (light is white, blue is for intel internal-chip). I have installed every other driver and all other devices work fine. I also re-installed (to test if card is broken) original windows version from recovery dvd's and it worked so graphic card is not broken. I have tried to install driver in safe mode and with build-in admin account but no success: every time same error: no compatible device found. Device manager shows exclamation mark on 'standard vga-adapter' and device ID (on details tab) is PCI\VEN_10DE&DEV_0DE9&SUBSYS_21141043&REV_A1. I have also tried to manually install all driver versions via device manager -> update driver -> manually select drier -> disk -> driver for GT 630M but it tells driver is not compatbile with this version of windows.



[all versions are 64bit and i have re-downloaded each pack just to be sure, windows is activated and i have downloaded all updates, system drivers (intel&asus) are updated to latest]



Please help, how to install nvidia drivers? Where i can download correct version? ASUS support can't help :(



Thank you!

#1
Posted 04/27/2012 12:18 PM   
Hey,
here are some links, hope any of them work:

http://forums.laptopvideo2go.com/topic/29002-v28548-windows-7vista-64bit-asus-mobile/
Download: http://laptopvideo2go.com/nvidia/285series/28548_win7x64.exe


http://forums.nvidia.com/index.php?showtopic=223803 (check for link from user "sxedoc")


asus mobile drivers at: http://www.laptopvideo2go.com/
Hey,

here are some links, hope any of them work:



http://forums.laptopvideo2go.com/topic/29002-v28548-windows-7vista-64bit-asus-mobile/

Download: http://laptopvideo2go.com/nvidia/285series/28548_win7x64.exe





http://forums.nvidia.com/index.php?showtopic=223803
(check for link from user "sxedoc")





asus mobile drivers at: http://www.laptopvideo2go.com/

#2
Posted 04/29/2012 02:43 AM   
Hi and thanks for help!
Found working driver from site you suggested,

New ASUS release for nvidia gpus:
http://forums.laptopvideo2go.com/topic/29424-asus-mobile-geforce-29644-released/

Works fine with other than pre-installed OS!
Hi and thanks for help!

Found working driver from site you suggested,



New ASUS release for nvidia gpus:

http://forums.laptopvideo2go.com/topic/29424-asus-mobile-geforce-29644-released/



Works fine with other than pre-installed OS!

#3
Posted 04/29/2012 10:33 AM   
Scroll To Top