New drivers 296.10
  1 / 2    
[url="http://www.nvidia.co.uk/object/win7-winvista-64bit-296.10-whql-driver-uk.html"]http://www.nvidia.co.uk/object/win7-winvista-64bit-296.10-whql-driver-uk.html[/url]

EP45-DS3P; Q9650 @4.1GHz + H50 Cooler; 4G Corsair XMS2; 500G HDD; LG Blu-Ray/DVD; EVGA GTX 670 FTW; EVGA GTX480 SC (PhysX); Akasa Powermax 850W; Packard Bell Maestro 243DL (1920x1080); Win 8 Pro 64 bit

Image

#1
Posted 03/13/2012 01:36 PM   
[quote name='DMcK' date='13 March 2012 - 05:36 AM' timestamp='1331645779' post='1382118']
[url="http://www.nvidia.co.uk/object/win7-winvista-64bit-296.10-whql-driver-uk.html"]http://www.nvidia.co.uk/object/win7-winvista-64bit-296.10-whql-driver-uk.html[/url]
[/quote]

I grabbed them already. I thought the 296.17 did CoD Modern Warfare 3 much better than 295.73. The 295.73 may have stopped some TDR's for people but at the same time it would sometimes slow down MW3 as though my machine wasn't able to push data to my video card fast enough or I was running out of virtual memory. The 296.17 was not supposed to be for Windows 7 but they worked fine on Win7 for me anyway.
[quote name='DMcK' date='13 March 2012 - 05:36 AM' timestamp='1331645779' post='1382118']

http://www.nvidia.co.uk/object/win7-winvista-64bit-296.10-whql-driver-uk.html





I grabbed them already. I thought the 296.17 did CoD Modern Warfare 3 much better than 295.73. The 295.73 may have stopped some TDR's for people but at the same time it would sometimes slow down MW3 as though my machine wasn't able to push data to my video card fast enough or I was running out of virtual memory. The 296.17 was not supposed to be for Windows 7 but they worked fine on Win7 for me anyway.

EVGA GTX 780, Haswell 4770K cpu@3.9 GHz, 16GB RAM, Win 8.1 Pro 64-bit, ASUS Maximus VI Hero motherboard, 250 GB SSD drive, 750W PC Power & Cooling power supply, Samsung 46" LED 1080p TV @60Hz, Soundblaster Z PCI-e.

#2
Posted 03/13/2012 02:09 PM   
[quote name='DMcK' date='13 March 2012 - 05:36 AM' timestamp='1331645779' post='1382118']
[url="http://www.nvidia.co.uk/object/win7-winvista-64bit-296.10-whql-driver-uk.html"]http://www.nvidia.co.uk/object/win7-winvista-64bit-296.10-whql-driver-uk.html[/url]
[/quote]

The UK drivers are 42MB larger than these (200MB vs 158MB):

http://www.nvidia.com/object/win7-winvista-64bit-296.10-whql-driver.html
[quote name='DMcK' date='13 March 2012 - 05:36 AM' timestamp='1331645779' post='1382118']

http://www.nvidia.co.uk/object/win7-winvista-64bit-296.10-whql-driver-uk.html





The UK drivers are 42MB larger than these (200MB vs 158MB):



http://www.nvidia.com/object/win7-winvista-64bit-296.10-whql-driver.html

#3
Posted 03/13/2012 02:13 PM   
Amazing!

The drivers do not disappear upon restart, no ERROR 43, nVIDIA Control Panel works, SLI works...

I wonder what got broken?
Amazing!



The drivers do not disappear upon restart, no ERROR 43, nVIDIA Control Panel works, SLI works...



I wonder what got broken?

#4
Posted 03/13/2012 02:43 PM   
Why are the 296.10 drivers performance improvements not compared against the previous WHQL driver? Why compare against really old WHQL still?
Why are the 296.10 drivers performance improvements not compared against the previous WHQL driver? Why compare against really old WHQL still?

Custom built PC | Intel Core i7 920 @ 2.66GHZ | ASUS P6T Motherboard | 6GB DDR3 1600 RAM | 2x 500GB SATA2 HDD's | Auzentech Forte S/C | Gainward Geforce GTX 560Ti "Phantom 2" 2048MB | Windows 7 Home Premium: Service Pack 1 - x64 | Thermaltake 750watt Toughpower Power Supply | Thermaltake Armor+ MX case.

#5
Posted 03/13/2012 02:52 PM   
[quote name='xorbe' date='14 March 2012 - 12:13 AM' timestamp='1331647989' post='1382134']
The UK drivers are 42MB larger than these (200MB vs 158MB):

http://www.nvidia.com/object/win7-winvista-64bit-296.10-whql-driver.html
[/quote]
Wrong way around, the UK drivers are smaller (158MB). Presumably the UK drivers aren't multilingual/international drivers.
[quote name='xorbe' date='14 March 2012 - 12:13 AM' timestamp='1331647989' post='1382134']

The UK drivers are 42MB larger than these (200MB vs 158MB):



http://www.nvidia.com/object/win7-winvista-64bit-296.10-whql-driver.html



Wrong way around, the UK drivers are smaller (158MB). Presumably the UK drivers aren't multilingual/international drivers.

Custom built PC | Intel Core i7 920 @ 2.66GHZ | ASUS P6T Motherboard | 6GB DDR3 1600 RAM | 2x 500GB SATA2 HDD's | Auzentech Forte S/C | Gainward Geforce GTX 560Ti "Phantom 2" 2048MB | Windows 7 Home Premium: Service Pack 1 - x64 | Thermaltake 750watt Toughpower Power Supply | Thermaltake Armor+ MX case.

#6
Posted 03/13/2012 02:56 PM   
Seems strange that we go months with no WHQL and then get 2 in 3 weeks. Not complaining though, so far these are behaving quite nicely for me /smile.gif' class='bbc_emoticon' alt=':smile:' />
Seems strange that we go months with no WHQL and then get 2 in 3 weeks. Not complaining though, so far these are behaving quite nicely for me /smile.gif' class='bbc_emoticon' alt=':smile:' />

EP45-DS3P; Q9650 @4.1GHz + H50 Cooler; 4G Corsair XMS2; 500G HDD; LG Blu-Ray/DVD; EVGA GTX 670 FTW; EVGA GTX480 SC (PhysX); Akasa Powermax 850W; Packard Bell Maestro 243DL (1920x1080); Win 8 Pro 64 bit

Image

#7
Posted 03/13/2012 02:59 PM   
[quote name='Franpa' date='13 March 2012 - 06:52 AM' timestamp='1331650324' post='1382160']
Why are the 296.10 drivers performance improvements not compared against the previous WHQL driver? Why compare against really old WHQL still?
[/quote]

It would delay the release of the drivers if they took all the additional time required to gather the performance comparison data.
[quote name='Franpa' date='13 March 2012 - 06:52 AM' timestamp='1331650324' post='1382160']

Why are the 296.10 drivers performance improvements not compared against the previous WHQL driver? Why compare against really old WHQL still?





It would delay the release of the drivers if they took all the additional time required to gather the performance comparison data.

EVGA GTX 780, Haswell 4770K cpu@3.9 GHz, 16GB RAM, Win 8.1 Pro 64-bit, ASUS Maximus VI Hero motherboard, 250 GB SSD drive, 750W PC Power & Cooling power supply, Samsung 46" LED 1080p TV @60Hz, Soundblaster Z PCI-e.

#8
Posted 03/13/2012 02:59 PM   
[quote name='DMcK' date='13 March 2012 - 06:59 AM' timestamp='1331650744' post='1382163']
Seems strange that we go months with no WHQL and then get 2 in 3 weeks. Not complaining though, so far these are behaving quite nicely for me /smile.gif' class='bbc_emoticon' alt=':smile:' />
[/quote]

GeForce.com says that compared to the 296.17 Windows 8 driver the version 296.10 WHQL driver is an equivalent driver, a quick refresh from the recent version GeForce 295.73 drivers, and are a must-have for gamers looking for the best experience in upcoming games like Blacklight: Retribution.

Changes and Fixed Issues in Version 296.10
The following sections list the important changes and the most common issues resolved
since version 295.73. This list is only a subset of the total number of changes made in this
driver version. The NVIDIA bug number is provided for reference.
Fixed Single-GPU Issues
 The NVIDIA Installer attempts to install the driver onto an incorrect or nonexistent
hard drive. [909221]
 [Diablo 3 Beta]: The game screen blurs when forcing AA from the NVIDIA Control
Panel. [935597]
 [GeForce GTX 560/GTX 550 Ti]: The NVIDIA Control Panel does not update the
monitor name when a different monitor is hot‐plugged. [784641]
 [GeForce GTX 590] “No NVIDIA High Definition Audio” error occurs with Realtek889
codec. [868406]
 [GeForce GTS 450][SIM2]: Display corruption occurs when entering a house that has a
swimming pool. [905969]
Fixed Multi-GPU Issues
 [SLI] [GeForce 500/400 series][F1 2011]: Game performance with SLI enabled is lower
after the game Patch version 1.02 is applied. [919612]
 [SLI] [GeForce 500 Series][Dirt 3]: The game stutters within the menu and occasionally
during a race. [834048]
 [SLI][ GeForce 500 series][Mirrorʹs Edge]:”Driver not responding” error occurs when
playing the game with SLI enabled.[915576]
 [SLI][GeForce GTX 580][Metro 2033]: The system hangs when launching the
application in DirectX 10/11 mode if both SLI and 3D Vision are enabled. [945885]
 [SLI][GeForce GTX 580][rFactor 2]: The games runs at a low frame rate when SLI is
enabled. [933072]
 [SLI] [GeForce GTX 470]: After the driver is instaled, SLI either cannot be enabled or
causes screen corruption once it is enabled. [934524]
 [3xSLI] [World of Warcraft:Cataclysm]: The character portrait flickers after loading an instanced map.
[quote name='DMcK' date='13 March 2012 - 06:59 AM' timestamp='1331650744' post='1382163']

Seems strange that we go months with no WHQL and then get 2 in 3 weeks. Not complaining though, so far these are behaving quite nicely for me /smile.gif' class='bbc_emoticon' alt=':smile:' />





GeForce.com says that compared to the 296.17 Windows 8 driver the version 296.10 WHQL driver is an equivalent driver, a quick refresh from the recent version GeForce 295.73 drivers, and are a must-have for gamers looking for the best experience in upcoming games like Blacklight: Retribution.



Changes and Fixed Issues in Version 296.10

The following sections list the important changes and the most common issues resolved

since version 295.73. This list is only a subset of the total number of changes made in this

driver version. The NVIDIA bug number is provided for reference.

Fixed Single-GPU Issues

 The NVIDIA Installer attempts to install the driver onto an incorrect or nonexistent

hard drive. [909221]

 [Diablo 3 Beta]: The game screen blurs when forcing AA from the NVIDIA Control

Panel. [935597]

 [GeForce GTX 560/GTX 550 Ti]: The NVIDIA Control Panel does not update the

monitor name when a different monitor is hot‐plugged. [784641]

 [GeForce GTX 590] “No NVIDIA High Definition Audio” error occurs with Realtek889

codec. [868406]

 [GeForce GTS 450][SIM2]: Display corruption occurs when entering a house that has a

swimming pool. [905969]

Fixed Multi-GPU Issues

 [SLI] [GeForce 500/400 series][F1 2011]: Game performance with SLI enabled is lower

after the game Patch version 1.02 is applied. [919612]

 [SLI] [GeForce 500 Series][Dirt 3]: The game stutters within the menu and occasionally

during a race. [834048]

 [SLI][ GeForce 500 series][Mirrorʹs Edge]:”Driver not responding” error occurs when

playing the game with SLI enabled.[915576]

 [SLI][GeForce GTX 580][Metro 2033]: The system hangs when launching the

application in DirectX 10/11 mode if both SLI and 3D Vision are enabled. [945885]

 [SLI][GeForce GTX 580][rFactor 2]: The games runs at a low frame rate when SLI is

enabled. [933072]

 [SLI] [GeForce GTX 470]: After the driver is instaled, SLI either cannot be enabled or

causes screen corruption once it is enabled. [934524]

 [3xSLI] [World of Warcraft:Cataclysm]: The character portrait flickers after loading an instanced map.

EVGA GTX 780, Haswell 4770K cpu@3.9 GHz, 16GB RAM, Win 8.1 Pro 64-bit, ASUS Maximus VI Hero motherboard, 250 GB SSD drive, 750W PC Power & Cooling power supply, Samsung 46" LED 1080p TV @60Hz, Soundblaster Z PCI-e.

#9
Posted 03/13/2012 03:15 PM   
Anyone try bf3 with these yet?
Anyone try bf3 with these yet?

i7 930 stock, gtx 580, gigabyte x58a-ud3r mobo, 6gb 1600 adata ram, 1k wat kingwin modular psu,ath-ad700, dt770 250ohm headphones, WASD mech keyboard (Brown switches), CM storm spawn mouse

#10
Posted 03/13/2012 03:26 PM   
[quote name='randyzie' date='13 March 2012 - 11:26 AM' timestamp='1331652391' post='1382179']
Anyone try bf3 with these yet?
[/quote]
I just tried them with everything on 'Ultra' and for the most part my FPS is from 78-104, mostly staying near 96. There is one spot in 'Rock and a Hard Place' where my rates drop to 27 and everything gets choppy and sluggish. No TDRs yet. I had two TDRs yesterday using last weeks drivers and went back to the 280.62. I never had a TDR using the 280.62 version. With BF3 it's hard to tell if slow frame rates are your system or Origin's servers.
[quote name='randyzie' date='13 March 2012 - 11:26 AM' timestamp='1331652391' post='1382179']

Anyone try bf3 with these yet?



I just tried them with everything on 'Ultra' and for the most part my FPS is from 78-104, mostly staying near 96. There is one spot in 'Rock and a Hard Place' where my rates drop to 27 and everything gets choppy and sluggish. No TDRs yet. I had two TDRs yesterday using last weeks drivers and went back to the 280.62. I never had a TDR using the 280.62 version. With BF3 it's hard to tell if slow frame rates are your system or Origin's servers.

Cooler Master Storm Stryker
ASRock Z77 Extreme4
Intel i7-2600k 4.5 GHz.
RipJaws 2133 MHz. 4 x 4 GB
EVGA GTX-680 SLI
PCPower&Cooling Silencer Mk III 1200W
OCZ Vertex-4 256 GB x 2 RAID0
Cooler Master V8

#11
Posted 03/13/2012 04:52 PM   
[quote name='Franpa' date='13 March 2012 - 06:56 AM' timestamp='1331650567' post='1382162']
Wrong way around, the UK drivers are smaller (158MB). Presumably the UK drivers aren't multilingual/international drivers.
[/quote]

That's weird. My US file is definitely 158MB here on my hdd, and the UK page shows 200 for me, double checked. How weird! Oh well.
[quote name='Franpa' date='13 March 2012 - 06:56 AM' timestamp='1331650567' post='1382162']

Wrong way around, the UK drivers are smaller (158MB). Presumably the UK drivers aren't multilingual/international drivers.





That's weird. My US file is definitely 158MB here on my hdd, and the UK page shows 200 for me, double checked. How weird! Oh well.

#12
Posted 03/13/2012 05:26 PM   
3DMark 11 scores are down: http://3dmark.com/compare/3dm11/2902408/3dm11/2952355
3DMark 11 scores are down: http://3dmark.com/compare/3dm11/2902408/3dm11/2952355

Cooler Master Storm Stryker
ASRock Z77 Extreme4
Intel i7-2600k 4.5 GHz.
RipJaws 2133 MHz. 4 x 4 GB
EVGA GTX-680 SLI
PCPower&Cooling Silencer Mk III 1200W
OCZ Vertex-4 256 GB x 2 RAID0
Cooler Master V8

#13
Posted 03/13/2012 05:52 PM   
[quote name='xorbe' date='13 March 2012 - 01:26 PM' timestamp='1331659582' post='1382253']
That's weird. My US file is definitely 158MB here on my hdd, and the UK page shows 200 for me, double checked. How weird! Oh well.
[/quote]
I get the same 200MB UK and 158MB US downloads.
[quote name='xorbe' date='13 March 2012 - 01:26 PM' timestamp='1331659582' post='1382253']

That's weird. My US file is definitely 158MB here on my hdd, and the UK page shows 200 for me, double checked. How weird! Oh well.



I get the same 200MB UK and 158MB US downloads.

Cooler Master Storm Stryker
ASRock Z77 Extreme4
Intel i7-2600k 4.5 GHz.
RipJaws 2133 MHz. 4 x 4 GB
EVGA GTX-680 SLI
PCPower&Cooling Silencer Mk III 1200W
OCZ Vertex-4 256 GB x 2 RAID0
Cooler Master V8

#14
Posted 03/13/2012 07:10 PM   
[quote name='randyzie' date='13 March 2012 - 12:26 PM' timestamp='1331652391' post='1382179']
Anyone try bf3 with these yet?
[/quote]
My personal opinion is that these drivers suck for BF3. I rolled back to 285.62 and my FPS is back around 98-104.
[quote name='randyzie' date='13 March 2012 - 12:26 PM' timestamp='1331652391' post='1382179']

Anyone try bf3 with these yet?



My personal opinion is that these drivers suck for BF3. I rolled back to 285.62 and my FPS is back around 98-104.

Cooler Master Storm Stryker
ASRock Z77 Extreme4
Intel i7-2600k 4.5 GHz.
RipJaws 2133 MHz. 4 x 4 GB
EVGA GTX-680 SLI
PCPower&Cooling Silencer Mk III 1200W
OCZ Vertex-4 256 GB x 2 RAID0
Cooler Master V8

#15
Posted 03/13/2012 08:16 PM   
  1 / 2    
Scroll To Top