Windows 8 Consumer Preview Geforce Desktop/Notebook Driver Information Updated 3/8/2012
  1 / 16    
On February 29th, Microsoft released Windows 8 Consumer Preview to the public.

http://windows.microsoft.com/en-US/windows-8/iso

At this time, we are recommending all Windows 8 Consumer Preview customers install NVIDIA's display driver 296.17 driver available through Microsoft Windows Update. This is our first driver designed specifically for Microsoft Windows 8 Consumer Preview. After you have had a chance to install this driver, please provide us with your feedback.
On February 29th, Microsoft released Windows 8 Consumer Preview to the public.



http://windows.microsoft.com/en-US/windows-8/iso



At this time, we are recommending all Windows 8 Consumer Preview customers install NVIDIA's display driver 296.17 driver available through Microsoft Windows Update. This is our first driver designed specifically for Microsoft Windows 8 Consumer Preview. After you have had a chance to install this driver, please provide us with your feedback.

Please send me a PM if I fail to keep up on replying in any specific thread or leave a driver feedback: Driver Feedback

#1
Posted 02/29/2012 05:59 PM   
Drivers installed without problems on Win8 Consumer Preview.

Only problem i found so far is codecs like CoreAVC or LavFilter cant use CUDA for video acceleration.

Waiting for new win8 driver... :)
Drivers installed without problems on Win8 Consumer Preview.



Only problem i found so far is codecs like CoreAVC or LavFilter cant use CUDA for video acceleration.



Waiting for new win8 driver... :)

#2
Posted 02/29/2012 07:49 PM   
Driver installed without problems on Win8 Consumer Preview, but i have Lenovo B570 and integrated and nvidia 410M videocard.
On Win7 when i run World of Warcraft it uses NVIDIA card. There is it use only integrated =(, even if i disable integrated video =(
Driver installed without problems on Win8 Consumer Preview, but i have Lenovo B570 and integrated and nvidia 410M videocard.

On Win7 when i run World of Warcraft it uses NVIDIA card. There is it use only integrated =(, even if i disable integrated video =(

#3
Posted 02/29/2012 08:57 PM   
Switching game api to DirectX 9 fix problem, but with Win7 nvidia card uses and when i use DirectX 11 API!
Switching game api to DirectX 9 fix problem, but with Win7 nvidia card uses and when i use DirectX 11 API!

#4
Posted 02/29/2012 09:20 PM   
Hello,
When im trying to install the drivers, I get the following error.
http://imageshack.us/photo/my-images/210/capturekel.png/
My gpu gt555m
P.S. restart didnt work.
Thanks in advance.
Hello,

When im trying to install the drivers, I get the following error.

http://imageshack.us/photo/my-images/210/capturekel.png/

My gpu gt555m

P.S. restart didnt work.

Thanks in advance.

#5
Posted 02/29/2012 09:34 PM   
[color="#4169E1"]I ran into a snag with the Soundblaster X-Fi driver. I forgot how I fixed it before on Win8 Developer Preview so gotta try to remember. The NVidia driver installed fine for me. I ran it as Administrator and did Custom Install with Clean Install. I did not install the 3D stuff.

I never had trouble installing any NVidia driver on Win8 Developer Preview but I am guessing there's probably going to be some issue with NVidia FXAA on Win8 Consumer Preview and that's probably the part ManuelG has held off on telling us so far.[/color]
I ran into a snag with the Soundblaster X-Fi driver. I forgot how I fixed it before on Win8 Developer Preview so gotta try to remember. The NVidia driver installed fine for me. I ran it as Administrator and did Custom Install with Clean Install. I did not install the 3D stuff.



I never had trouble installing any NVidia driver on Win8 Developer Preview but I am guessing there's probably going to be some issue with NVidia FXAA on Win8 Consumer Preview and that's probably the part ManuelG has held off on telling us so far.

EVGA GTX 780, Haswell 4770K cpu@3.9 GHz, 16GB RAM, Win 8.1 Pro 64-bit, ASUS Maximus VI Hero motherboard, 250 GB SSD drive, 750W PC Power & Cooling power supply, Samsung 46" LED 1080p TV @60Hz, Soundblaster Z PCI-e.

#6
Posted 02/29/2012 10:33 PM   
Will we get WDDM 1.2 drivers soon?
Will we get WDDM 1.2 drivers soon?

#7
Posted 03/01/2012 12:00 AM   
[quote name='bb10' date='29 February 2012 - 04:00 PM' timestamp='1330560017' post='1376909']
Will we get WDDM 1.2 drivers soon?
[/quote]

When you install Windows 8 you'll be able to get NVidia WDDM 1.2 drivers off of Windows Updates.
It is the same NVidia WDDM driver that was on Windows Updates for Win8 Developer Preview.
[quote name='bb10' date='29 February 2012 - 04:00 PM' timestamp='1330560017' post='1376909']

Will we get WDDM 1.2 drivers soon?





When you install Windows 8 you'll be able to get NVidia WDDM 1.2 drivers off of Windows Updates.

It is the same NVidia WDDM driver that was on Windows Updates for Win8 Developer Preview.

EVGA GTX 780, Haswell 4770K cpu@3.9 GHz, 16GB RAM, Win 8.1 Pro 64-bit, ASUS Maximus VI Hero motherboard, 250 GB SSD drive, 750W PC Power & Cooling power supply, Samsung 46" LED 1080p TV @60Hz, Soundblaster Z PCI-e.

#8
Posted 03/01/2012 12:23 AM   
[quote name='Infinity7' date='29 February 2012 - 02:33 PM' timestamp='1330554781' post='1376864']
[color="#4169E1"]I ran into a snag with the Soundblaster X-Fi driver. I forgot how I fixed it before on Win8 Developer Preview so gotta try to remember. The NVidia driver installed fine for me. I ran it as Administrator and did Custom Install with Clean Install. I did not install the 3D stuff.

I never had trouble installing any NVidia driver on Win8 Developer Preview but I am guessing there's probably going to be some issue with NVidia FXAA on Win8 Consumer Preview and that's probably the part ManuelG has held off on telling us so far.[/color]
[/quote]

I had to install the BETA version of the X-Fi Titanium drivers and the control panel to get audio working properly.
[quote name='Infinity7' date='29 February 2012 - 02:33 PM' timestamp='1330554781' post='1376864']

I ran into a snag with the Soundblaster X-Fi driver. I forgot how I fixed it before on Win8 Developer Preview so gotta try to remember. The NVidia driver installed fine for me. I ran it as Administrator and did Custom Install with Clean Install. I did not install the 3D stuff.



I never had trouble installing any NVidia driver on Win8 Developer Preview but I am guessing there's probably going to be some issue with NVidia FXAA on Win8 Consumer Preview and that's probably the part ManuelG has held off on telling us so far.





I had to install the BETA version of the X-Fi Titanium drivers and the control panel to get audio working properly.

Please send me a PM if I fail to keep up on replying in any specific thread or leave a driver feedback: Driver Feedback

#9
Posted 03/01/2012 01:32 AM   
Thanks for the drivers! /wink.gif' class='bbc_emoticon' alt=';)' />
Thanks for the drivers! /wink.gif' class='bbc_emoticon' alt=';)' />

Mobo: Gigabyte P67A-UD4-B3 (Rev. 1.1 - F8 Bios)

CPU: Intel® Core™ i5 2500k @5.01 Ghz 1.464v

GPU: Zotac GTX 680

SSD: OCZ Vertex 3 120GB

RAM: 8GB G.Skill Sniper 2133Mhz 9-11-9-24 1.65v

PSU: OCZ 750W Fatal1ty

LED: Sony Bravia EX525

WHQL: Xtreme-G 301.42

OS: Windows 7 Home Premium 64 Bit

Image

i5 2500k 5.0Ghz + GTX 680+580 - Youtube

#10
Posted 03/01/2012 01:55 AM   
Having a big Problem with the recommended Driver : During the Installation I get an Error and when I try to install the Driver via the Device-Manager, I get the Information, that this Driver is not compatible with this Windows Version. It is the 295.73 - German or English the Result is the same …

What can I do to fix this issue ?
Having a big Problem with the recommended Driver : During the Installation I get an Error and when I try to install the Driver via the Device-Manager, I get the Information, that this Driver is not compatible with this Windows Version. It is the 295.73 - German or English the Result is the same …



What can I do to fix this issue ?

#11
Posted 03/01/2012 02:22 AM   
[quote name='Infinity7' date='29 February 2012 - 04:23 PM' timestamp='1330561382' post='1376917']
When you install Windows 8 you'll be able to get NVidia WDDM 1.2 drivers off of Windows Updates.
It is the same NVidia WDDM driver that was on Windows Updates for Win8 Developer Preview.
[/quote]
When I installed win8 I got 270.45 and it was WDDM 1.1 for me. Windows Update also couldn't find any other nvidia drivers.

I have a GTX 460M.
[quote name='Infinity7' date='29 February 2012 - 04:23 PM' timestamp='1330561382' post='1376917']

When you install Windows 8 you'll be able to get NVidia WDDM 1.2 drivers off of Windows Updates.

It is the same NVidia WDDM driver that was on Windows Updates for Win8 Developer Preview.



When I installed win8 I got 270.45 and it was WDDM 1.1 for me. Windows Update also couldn't find any other nvidia drivers.



I have a GTX 460M.

#12
Posted 03/01/2012 02:56 AM   
[quote name='Havenger' date='29 February 2012 - 06:22 PM' timestamp='1330568527' post='1376952']
Having a big Problem with the recommended Driver : During the Installation I get an Error and when I try to install the Driver via the Device-Manager, I get the Information, that this Driver is not compatible with this Windows Version. It is the 295.73 - German or English the Result is the same …

What can I do to fix this issue ?
[/quote]

I just tried it and it works for me. Are you sure you are running the Windows 8 Consumer Preview? Can you give me the exact steps you took to install the driver?
[quote name='Havenger' date='29 February 2012 - 06:22 PM' timestamp='1330568527' post='1376952']

Having a big Problem with the recommended Driver : During the Installation I get an Error and when I try to install the Driver via the Device-Manager, I get the Information, that this Driver is not compatible with this Windows Version. It is the 295.73 - German or English the Result is the same …



What can I do to fix this issue ?





I just tried it and it works for me. Are you sure you are running the Windows 8 Consumer Preview? Can you give me the exact steps you took to install the driver?

Please send me a PM if I fail to keep up on replying in any specific thread or leave a driver feedback: Driver Feedback

#13
Posted 03/01/2012 03:00 AM   
Optimus doesn't work on Intel HM65 SNB system.

295 driver installed without any issue, just GT 555M doesn't accelerate any program (eg. games..).

I suspicious it might because of integrated Intel driver's API didn't link to NV's driver as Intel core driver only has a basic WDM driver updated by Windows Update, no full driver like win7.
Optimus doesn't work on Intel HM65 SNB system.



295 driver installed without any issue, just GT 555M doesn't accelerate any program (eg. games..).



I suspicious it might because of integrated Intel driver's API didn't link to NV's driver as Intel core driver only has a basic WDM driver updated by Windows Update, no full driver like win7.

#14
Posted 03/01/2012 04:58 AM   
[quote name='ManuelG' date='29 February 2012 - 05:32 PM' timestamp='1330565528' post='1376937']
I had to install the BETA version of the X-Fi Titanium drivers and the control panel to get audio working properly.
[/quote]

I finally got it working. I used
Vista 64-bit driver XFTI_PCDRV_LB_2_17_0008
Vista 64-bit Alchemy ALMY_PCAPP_BETA_LB_1_43_06
Vista 64-bit Console Launcher ALMY_PCAPP_BETA_LB_1_43_06

CoD MW3 felt like it was running smoother and faster than Win7 as my initial impression but got to test more to be sure.
Was using driver 295.73, 2x in-game AA + Enhance App Settings + 1x2 Supersampling + 2x Transparency Sparse Grid Supersampling
1920 x 1080 res, Native Textures, High Quality
[quote name='ManuelG' date='29 February 2012 - 05:32 PM' timestamp='1330565528' post='1376937']

I had to install the BETA version of the X-Fi Titanium drivers and the control panel to get audio working properly.





I finally got it working. I used

Vista 64-bit driver XFTI_PCDRV_LB_2_17_0008

Vista 64-bit Alchemy ALMY_PCAPP_BETA_LB_1_43_06

Vista 64-bit Console Launcher ALMY_PCAPP_BETA_LB_1_43_06



CoD MW3 felt like it was running smoother and faster than Win7 as my initial impression but got to test more to be sure.

Was using driver 295.73, 2x in-game AA + Enhance App Settings + 1x2 Supersampling + 2x Transparency Sparse Grid Supersampling

1920 x 1080 res, Native Textures, High Quality

EVGA GTX 780, Haswell 4770K cpu@3.9 GHz, 16GB RAM, Win 8.1 Pro 64-bit, ASUS Maximus VI Hero motherboard, 250 GB SSD drive, 750W PC Power & Cooling power supply, Samsung 46" LED 1080p TV @60Hz, Soundblaster Z PCI-e.

#15
Posted 03/01/2012 05:12 AM   
  1 / 16    
Scroll To Top