Shadow rendering broken in older games?
  1 / 3    
Hi.

This is a bit of a long shot, and i don't think I'll get my answer here, but EA is even less likely to know the answer, or willing to divulge the reasons, so here goes.

I'm revisiting an old game, Need For Speed: Most Wanted, to replay it with some custom content, i.e. custom car, upscaled textures, and that's all well and good, but then i discovered a rather disturbing issue.

http://i44.tinypic.com/idrmtd.jpg

To my knowledge, the game uses UltraShadow II, an nVidia feature, for it's real-time shadow rendering. Problem is, it's not doing its' job. The shadows are rendered at extremely low resolution when they are cast on the world, and as a result, are painful to look at. The issue is more evident in motion than the screenshot.

Can anyone explain why? I have scoured the internet looking for the answer, but most are either unanswered, or speak of a limitation that is only present in ATI cards, such as the X1800.

Does anyone know what i could do to remedy this issue?

Note that this does not happen because of the custom content, even with compatibility mode XPSP3, and no custom content at all, the issue persists. The issue is also present in the new beta drivers. Currently, i am running 285.62 clean. Interesting to note is that while the shadows are terribly rendered on the ground, on the car itself, the shadows are crisp and accurate, but as soon as the same shadow is cast onto the ground, the shadow becomes low-res once again.

I'd really like to get to the bottom of this, as i am planning to mess around with a camera hack and some other neat tricks to create a tribute video. Having these shadows rendered correctly is a must for any closeups.

Help, please?

EDIT: Specs

1055T
8GB
GTX580 3GB
Hi.



This is a bit of a long shot, and i don't think I'll get my answer here, but EA is even less likely to know the answer, or willing to divulge the reasons, so here goes.



I'm revisiting an old game, Need For Speed: Most Wanted, to replay it with some custom content, i.e. custom car, upscaled textures, and that's all well and good, but then i discovered a rather disturbing issue.



http://i44.tinypic.com/idrmtd.jpg



To my knowledge, the game uses UltraShadow II, an nVidia feature, for it's real-time shadow rendering. Problem is, it's not doing its' job. The shadows are rendered at extremely low resolution when they are cast on the world, and as a result, are painful to look at. The issue is more evident in motion than the screenshot.



Can anyone explain why? I have scoured the internet looking for the answer, but most are either unanswered, or speak of a limitation that is only present in ATI cards, such as the X1800.



Does anyone know what i could do to remedy this issue?



Note that this does not happen because of the custom content, even with compatibility mode XPSP3, and no custom content at all, the issue persists. The issue is also present in the new beta drivers. Currently, i am running 285.62 clean. Interesting to note is that while the shadows are terribly rendered on the ground, on the car itself, the shadows are crisp and accurate, but as soon as the same shadow is cast onto the ground, the shadow becomes low-res once again.



I'd really like to get to the bottom of this, as i am planning to mess around with a camera hack and some other neat tricks to create a tribute video. Having these shadows rendered correctly is a must for any closeups.



Help, please?



EDIT: Specs



1055T

8GB

GTX580 3GB

#1
Posted 02/15/2012 08:55 AM   
I don't see anything wrong in this screenshot. How is the shadow supposed to look?
I don't see anything wrong in this screenshot. How is the shadow supposed to look?

Gainward GeForce GTX 470 Golden Sample Edition | Core 2 Quad Q9550 | Gigabyte GA-X84-DS5 | 4 GB PC2-5300 DDR2 RAM | Creative Sound Blaster X-Fi Titanium (SB0880) | BenQ FP241W display | Windows 7 x64 (no SP1 but all updates from WU installed)

#2
Posted 02/15/2012 11:02 AM   
Sharp.

Here's a few more screens of the issue:

http://i44.tinypic.com/23****5.png

Here you can see that the shadows rendered onto the car are very sharp, but the ones on the ground look absolutely terrible. Plus the car's own shadow isn't much better, either.

EDIT: Ugh. THANK YOU Tinypic for repeatedly naming my image inappropriately.

http://i.imgur.com/bicEq.jpg
Sharp.



Here's a few more screens of the issue:



http://i44.tinypic.com/23****5.png



Here you can see that the shadows rendered onto the car are very sharp, but the ones on the ground look absolutely terrible. Plus the car's own shadow isn't much better, either.



EDIT: Ugh. THANK YOU Tinypic for repeatedly naming my image inappropriately.



http://i.imgur.com/bicEq.jpg

#3
Posted 02/15/2012 12:12 PM   
Were they ever sharp on the ground? I haven't played MW for a long time but I don't remember them being any different than on your screenshots.
Were they ever sharp on the ground? I haven't played MW for a long time but I don't remember them being any different than on your screenshots.

Gainward GeForce GTX 470 Golden Sample Edition | Core 2 Quad Q9550 | Gigabyte GA-X84-DS5 | 4 GB PC2-5300 DDR2 RAM | Creative Sound Blaster X-Fi Titanium (SB0880) | BenQ FP241W display | Windows 7 x64 (no SP1 but all updates from WU installed)

#4
Posted 02/15/2012 05:40 PM   
Not many games have 'sharp' shadows, even nowadays. Are you sure they ever looked any better than that?
Not many games have 'sharp' shadows, even nowadays. Are you sure they ever looked any better than that?

#5
Posted 02/15/2012 08:41 PM   
I am certain. I've seen many screenshots where the shadows are rendered sharply, and even personally seen it work back when the game first came out and i played it on my own old machine.

Here's an assortment of screenshots to prove so:

http://img39.imageshack.us/img39/3557/nfsmw03.jpg
http://2.bp.blogspot.com/-b1NrW77H2EM/TbfPdtcPcmI/AAAAAAAAAvY/d69INd7WI8o/s1600/168387_Papel-de-Parede-Need-for-Speed-Most-Wanted--168387_1600x1200.jpg
http://img166.imageshack.us/img166/7442/1zz5.jpg
http://www.canalocio.es/gallery/albums/nfsmw/FiatPunto_EdAgostini_09.jpg
http://extreme.pcgameshardware.de/members/galford-albums-most-wanted-texture-mods-3088-picture354899-textur-mod-2.jpg
http://small-games.info/s/f/n/Need_for_Speed_Most_Wanted_1.jpg
http://douggodfreydesign.com/TextureProjects/screenshots/NFSMW/NFSMW4HR.jpg
http://www.deafgamers.com/06screenshots_a/nfsmw360pic1.jpg

This game was released 2006.

I don't know where you guys get your information about shadows not being sharp in todays gaming, just about every game i've seen as of late with the exception of Skyrim, which can, by the way, be fixed, but they're certainly at an acceptable sharpness level in NFSMW. However, currently, it refuses to render them like this.

I've noticed that MW seems to disable a feature or two whenever it is given an unknown graphics adapter. Is it possible MW has an internal database of cards from which it enables/disables certain features for compatibility?
I am certain. I've seen many screenshots where the shadows are rendered sharply, and even personally seen it work back when the game first came out and i played it on my own old machine.



Here's an assortment of screenshots to prove so:



http://img39.imageshack.us/img39/3557/nfsmw03.jpg

http://2.bp.blogspot.com/-b1NrW77H2EM/TbfPdtcPcmI/AAAAAAAAAvY/d69INd7WI8o/s1600/168387_Papel-de-Parede-Need-for-Speed-Most-Wanted--168387_1600x1200.jpg

http://img166.imageshack.us/img166/7442/1zz5.jpg

http://www.canalocio.es/gallery/albums/nfsmw/FiatPunto_EdAgostini_09.jpg

http://extreme.pcgameshardware.de/members/galford-albums-most-wanted-texture-mods-3088-picture354899-textur-mod-2.jpg

http://small-games.info/s/f/n/Need_for_Speed_Most_Wanted_1.jpg

http://douggodfreydesign.com/TextureProjects/screenshots/NFSMW/NFSMW4HR.jpg

http://www.deafgamers.com/06screenshots_a/nfsmw360pic1.jpg



This game was released 2006.



I don't know where you guys get your information about shadows not being sharp in todays gaming, just about every game i've seen as of late with the exception of Skyrim, which can, by the way, be fixed, but they're certainly at an acceptable sharpness level in NFSMW. However, currently, it refuses to render them like this.



I've noticed that MW seems to disable a feature or two whenever it is given an unknown graphics adapter. Is it possible MW has an internal database of cards from which it enables/disables certain features for compatibility?

#6
Posted 02/16/2012 01:24 AM   
Bumping. Still looking for a way to resolve this.
Bumping. Still looking for a way to resolve this.

#7
Posted 02/17/2012 04:20 AM   
It may be the same issue as with original Splinter Cell. This would mean that we'll need a patch for the game to fix it. Not much NV can do about it.
It may be the same issue as with original Splinter Cell. This would mean that we'll need a patch for the game to fix it. Not much NV can do about it.

Gainward GeForce GTX 470 Golden Sample Edition | Core 2 Quad Q9550 | Gigabyte GA-X84-DS5 | 4 GB PC2-5300 DDR2 RAM | Creative Sound Blaster X-Fi Titanium (SB0880) | BenQ FP241W display | Windows 7 x64 (no SP1 but all updates from WU installed)

#8
Posted 02/17/2012 09:32 AM   
What was the issue with Splinter Cell?
What was the issue with Splinter Cell?

#9
Posted 02/17/2012 12:25 PM   
[quote name='logokas' date='15 February 2012 - 11:55 AM' timestamp='1329296102' post='1369693']
To my knowledge, the game uses UltraShadow II, an nVidia feature, for it's real-time shadow rendering. Problem is, it's not doing its' job.[/quote]
No, this game does not use technology UltraShadow II. This technique works for shadow volumes algorithm.
NFS MW uses the shadow map algorithm.

[quote]The shadows are rendered at extremely low resolution when they are cast on the world, and as a result, are painful to look at. The issue is more evident in motion than the screenshot.Can anyone explain why? [/quote]
The game uses shadow map size 1024x1024. Since this size is the optimum solution performance / quality at the time of game release.

[quote]I have scoured the internet looking for the answer, but most are either unanswered, or speak of a limitation that is only present in ATI cards, such as the X1800.[/quote]
When the game detects ATI card, it does not use shadow filtering ([url="http://http.developer.nvidia.com/GPUGems/gpugems_ch11.html"]PCF[/url]), as previous ATI cards do not support PCF.
Because of this, on ATI cards shadows look a lot worse.

[b][color="#FF0000"][size="3"]ATI:[/size][/color][/b]
[url="http://i44.tinypic.com/v67jf8.jpg"][IMG]http://i44.tinypic.com/v67jf8_th.jpg[/IMG][/url] [url="http://i40.tinypic.com/i1wpi1.jpg"][IMG]http://i40.tinypic.com/i1wpi1_th.jpg[/IMG][/url]

[b][color="#2E8B57"][size="3"]Nvidia:[/size][/color][/b]
[url="http://i42.tinypic.com/w1r1j7.jpg"][IMG]http://i42.tinypic.com/w1r1j7_th.jpg[/IMG][/url] [url="http://i43.tinypic.com/34fmrso.jpg"][IMG]http://i43.tinypic.com/34fmrso_th.jpg[/IMG][/url]

Although series HD2xxx and later support PCF, shadows are still not filtered, because the game still detects the ATI card and does not enable PCF.
However, if you replace ATI Device ID on Nvidia Device ID, game enables PCF and shadows will be filtered.

[quote]Does anyone know what i could do to remedy this issue?[/quote]
Use the debugger, need to find and increase shadow map size.

[font="Comic Sans MS"][b]1024x1024:[/b][/font]
[url="http://i40.tinypic.com/34is47l.png"][img]http://i40.tinypic.com/34is47l_th.png[/img][/url]

[font="Comic Sans MS"][b]2048x2048:[/b][/font]
[url="http://i41.tinypic.com/16t0ky.png"][IMG]http://i41.tinypic.com/16t0ky_th.png[/IMG][/url]

[font="Comic Sans MS"][b]4096x4096:[/b][/font]
[url="http://i39.tinypic.com/fuykyc.png"][IMG]http://i39.tinypic.com/fuykyc_th.png[/IMG][/url]

[font="Comic Sans MS"][b]8192x8192:[/b][/font]
[url="http://i40.tinypic.com/4izc03.png"][IMG]http://i40.tinypic.com/4izc03_th.png[/IMG][/url]
[quote name='logokas' date='15 February 2012 - 11:55 AM' timestamp='1329296102' post='1369693']

To my knowledge, the game uses UltraShadow II, an nVidia feature, for it's real-time shadow rendering. Problem is, it's not doing its' job.

No, this game does not use technology UltraShadow II. This technique works for shadow volumes algorithm.

NFS MW uses the shadow map algorithm.



The shadows are rendered at extremely low resolution when they are cast on the world, and as a result, are painful to look at. The issue is more evident in motion than the screenshot.Can anyone explain why?


The game uses shadow map size 1024x1024. Since this size is the optimum solution performance / quality at the time of game release.



I have scoured the internet looking for the answer, but most are either unanswered, or speak of a limitation that is only present in ATI cards, such as the X1800.


When the game detects ATI card, it does not use shadow filtering (PCF), as previous ATI cards do not support PCF.

Because of this, on ATI cards shadows look a lot worse.



ATI:

Image Image



Nvidia:

Image Image



Although series HD2xxx and later support PCF, shadows are still not filtered, because the game still detects the ATI card and does not enable PCF.

However, if you replace ATI Device ID on Nvidia Device ID, game enables PCF and shadows will be filtered.



Does anyone know what i could do to remedy this issue?


Use the debugger, need to find and increase shadow map size.



1024x1024:

Image



2048x2048:

Image



4096x4096:

Image



8192x8192:

Image

ASUS P8Z68-V PRO/GEN3 / 2550k@4.8Ghz / 8GB DDR III / Gigabyte GTX460 1GB / Chieftec SPS-850C 850W / Windows 7 SP1 x64

#10
Posted 02/21/2012 01:46 PM   
Images are broken, sadly, so i'm half guessing some of these responses.

[quote name='Guzz' date='21 February 2012 - 11:46 PM' timestamp='1329832010' post='1372248']
No, this game does not use technology UltraShadow II. This technique works for shadow volumes algorithm.[/quote]

Interesting. I saw several claims that this was the tech used..Fair enough.

[quote name='Guzz']
When the game detects ATI card, it does not use shadow filtering ([url="http://http.developer.nvidia.com/GPUGems/gpugems_ch11.html"]PCF[/url]), as previous ATI cards do not support PCF.
Because of this, on ATI cards shadows look a lot worse.[/quote]

This much i gathered. But why is it happening on my Gainward GTX 580 Phantom 3? It's an nVidia card.

[quote name='Guzz']
Use the debugger, need to find and increase shadow map size.[/quote]

Sounds reasonable. How do i do this?

At current stage, when i look at the game, it is as if the shadowmaps are 128x128, if even that. On the ground, at least.

At any rate, thank you for this reply, i've been waiting a good while and i was just about ready to give up, really.

EDIT: Now that i've seen the images as well, i must say the difference is astonishing. I really want to see these in my game.
Images are broken, sadly, so i'm half guessing some of these responses.



[quote name='Guzz' date='21 February 2012 - 11:46 PM' timestamp='1329832010' post='1372248']

No, this game does not use technology UltraShadow II. This technique works for shadow volumes algorithm.



Interesting. I saw several claims that this was the tech used..Fair enough.



Guzz said:

When the game detects ATI card, it does not use shadow filtering (PCF), as previous ATI cards do not support PCF.

Because of this, on ATI cards shadows look a lot worse.




This much i gathered. But why is it happening on my Gainward GTX 580 Phantom 3? It's an nVidia card.



Guzz said:

Use the debugger, need to find and increase shadow map size.




Sounds reasonable. How do i do this?



At current stage, when i look at the game, it is as if the shadowmaps are 128x128, if even that. On the ground, at least.



At any rate, thank you for this reply, i've been waiting a good while and i was just about ready to give up, really.



EDIT: Now that i've seen the images as well, i must say the difference is astonishing. I really want to see these in my game.

#11
Posted 02/21/2012 02:38 PM   
[quote name='dr_rus' date='17 February 2012 - 04:32 AM' timestamp='1329471168' post='1370645']
It may be the same issue as with original Splinter Cell. This would mean that we'll need a patch for the game to fix it. Not much NV can do about it.
[/quote]
I'd guess it's the same issue also, but nv actually can do something about it. They could emulate the buffer shadows and force a geforce FX video i.d. for those applications.
[quote name='dr_rus' date='17 February 2012 - 04:32 AM' timestamp='1329471168' post='1370645']

It may be the same issue as with original Splinter Cell. This would mean that we'll need a patch for the game to fix it. Not much NV can do about it.



I'd guess it's the same issue also, but nv actually can do something about it. They could emulate the buffer shadows and force a geforce FX video i.d. for those applications.

#12
Posted 02/21/2012 04:33 PM   
That is actually how Shadows usually look in an NFS game.

hence why i disable them.
That is actually how Shadows usually look in an NFS game.



hence why i disable them.



In Memory of Chris "ChrisRay" Arthington, 1982-2010

CPU:Intel i7 920 @ 3.8(D0), Mainboard:Asus Rampage II Gene, Memory:12GB Corsair Vengeance 1600
Video:EVGA Geforce GTX 680+ 4GB, Sound:Creative XFI Titanium Fatal1ty Pro, Monitor:BenQ G2400WD
HDD:500GB Spinpoint F3, 1TB WD Black, 2TB WD Red, 1TB WD Black
Case:NZXT Guardian 921RB, PSU:Corsair 620HX, OS:Windows 7 SP1

#13
Posted 02/21/2012 09:01 PM   
[quote name='Antifederalist' date='22 February 2012 - 02:33 AM' timestamp='1329842033' post='1372320']
I'd guess it's the same issue also, but nv actually can do something about it. They could emulate the buffer shadows and force a geforce FX video i.d. for those applications.
[/quote]
I tried spoofing the device id to appear to be using an FX 7900. No bite, though i may have done something wrong.

[quote name='Sora' date='22 February 2012 - 07:01 AM' timestamp='1329858096' post='1372524']
That is actually how Shadows usually look in an NFS game.

hence why i disable them.
[/quote]
I disagree, shadows have never appeared THAT blocky to me in an NFS game before. I always left them on.

I really wanna try debugging the game and upping the shadowmaps to 8192x8192, because the screenshot looks amazing. It would be perfect.
[quote name='Antifederalist' date='22 February 2012 - 02:33 AM' timestamp='1329842033' post='1372320']

I'd guess it's the same issue also, but nv actually can do something about it. They could emulate the buffer shadows and force a geforce FX video i.d. for those applications.



I tried spoofing the device id to appear to be using an FX 7900. No bite, though i may have done something wrong.



[quote name='Sora' date='22 February 2012 - 07:01 AM' timestamp='1329858096' post='1372524']

That is actually how Shadows usually look in an NFS game.



hence why i disable them.



I disagree, shadows have never appeared THAT blocky to me in an NFS game before. I always left them on.



I really wanna try debugging the game and upping the shadowmaps to 8192x8192, because the screenshot looks amazing. It would be perfect.

#14
Posted 02/22/2012 02:24 AM   
Final post in this thread.

[img]http://i43.tinypic.com/30t48ye.png[/img]

Thanks to Guzz, who debugged the game to use 8192x8192 shadowmaps. Thank you so much!

This game now looks absolutely gorgeous with the help of ENB and some texture mods, plus a beautiful Agera.

This goes to show that things CAN be fixed after all.
Final post in this thread.



Image



Thanks to Guzz, who debugged the game to use 8192x8192 shadowmaps. Thank you so much!



This game now looks absolutely gorgeous with the help of ENB and some texture mods, plus a beautiful Agera.



This goes to show that things CAN be fixed after all.

#15
Posted 02/29/2012 05:18 AM   
  1 / 3    
Scroll To Top