GTX570 "Could not load direct3d"
Okay, so whenever I try running WoW or LoL. I keep getting the error "Could not load direct3d" I updated all my Drivers, even tried another OS, but my games won't run. The onl yway I get them to work is for me to reinstall my nVidia driver EVERYtime I reboot my computer. Anyone else having this problem? I've tried everything I can possibly think of. Also my Aero effects don't work either unless I reinstall my driver after every bootup. If I see that my Windows 7 Aero effects arent working, then I know that my games won't work either.. I've attached a print screen of my desktop with my computer rating/specs.. for some reason it says I'm running DirectX10, even though I do clean installs of my nVidia driver and have ran the directX setup update. Please anyone? It gets REALLY annoying having to reinstall EVERY boot, and I don' want to just keep my computer sleeping in order to not reboot.

Processor: Intel(R) Core(TM) i5-2500K SandyBridge CPU @ 3.30GHz
RAM: 16GB
Graphics Asus nVidia GeForce GTX570 DirectCU II (742MHz, 1280MB GDDR5, with full DirectX 11 support)
HDD: 1.5TB
Motherboard: ASRock Fatal1ty Z68 Profess1onal Series
Monitors: Asus VE24
Power: KingWin 1000W Lazer Performance Series
Okay, so whenever I try running WoW or LoL. I keep getting the error "Could not load direct3d" I updated all my Drivers, even tried another OS, but my games won't run. The onl yway I get them to work is for me to reinstall my nVidia driver EVERYtime I reboot my computer. Anyone else having this problem? I've tried everything I can possibly think of. Also my Aero effects don't work either unless I reinstall my driver after every bootup. If I see that my Windows 7 Aero effects arent working, then I know that my games won't work either.. I've attached a print screen of my desktop with my computer rating/specs.. for some reason it says I'm running DirectX10, even though I do clean installs of my nVidia driver and have ran the directX setup update. Please anyone? It gets REALLY annoying having to reinstall EVERY boot, and I don' want to just keep my computer sleeping in order to not reboot.



Processor: Intel(R) Core(TM) i5-2500K SandyBridge CPU @ 3.30GHz

RAM: 16GB

Graphics Asus nVidia GeForce GTX570 DirectCU II (742MHz, 1280MB GDDR5, with full DirectX 11 support)

HDD: 1.5TB

Motherboard: ASRock Fatal1ty Z68 Profess1onal Series

Monitors: Asus VE24

Power: KingWin 1000W Lazer Performance Series
Attachments

desktop.png

#1
Posted 02/02/2012 10:23 AM   
[quote name='SAMisFlagged' date='02 February 2012 - 03:53 PM' timestamp='1328178185' post='1364063']
Okay, so whenever I try running WoW or LoL. I keep getting the error "Could not load direct3d" I updated all my Drivers, even tried another OS, but my games won't run. The onl yway I get them to work is for me to reinstall my nVidia driver EVERYtime I reboot my computer. Anyone else having this problem? I've tried everything I can possibly think of. Also my Aero effects don't work either unless I reinstall my driver after every bootup. If I see that my Windows 7 Aero effects arent working, then I know that my games won't work either.. I've attached a print screen of my desktop with my computer rating/specs.. for some reason it says I'm running DirectX10, even though I do clean installs of my nVidia driver and have ran the directX setup update. Please anyone? It gets REALLY annoying having to reinstall EVERY boot, and I don' want to just keep my computer sleeping in order to not reboot.

Processor: Intel(R) Core(TM) i5-2500K SandyBridge CPU @ 3.30GHz
RAM: 16GB
Graphics Asus nVidia GeForce GTX570 DirectCU II (742MHz, 1280MB GDDR5, with full DirectX 11 support)
HDD: 1.5TB
Motherboard: ASRock Fatal1ty Z68 Profess1onal Series
Monitors: Asus VE24
Power: KingWin 1000W Lazer Performance Series
[/quote]

Seems to be an issues with OS which is not storing the NVIDIA files in the registry.

Would recommend you to re-install OS and check. I don't think this is a driver or card issue.
[quote name='SAMisFlagged' date='02 February 2012 - 03:53 PM' timestamp='1328178185' post='1364063']

Okay, so whenever I try running WoW or LoL. I keep getting the error "Could not load direct3d" I updated all my Drivers, even tried another OS, but my games won't run. The onl yway I get them to work is for me to reinstall my nVidia driver EVERYtime I reboot my computer. Anyone else having this problem? I've tried everything I can possibly think of. Also my Aero effects don't work either unless I reinstall my driver after every bootup. If I see that my Windows 7 Aero effects arent working, then I know that my games won't work either.. I've attached a print screen of my desktop with my computer rating/specs.. for some reason it says I'm running DirectX10, even though I do clean installs of my nVidia driver and have ran the directX setup update. Please anyone? It gets REALLY annoying having to reinstall EVERY boot, and I don' want to just keep my computer sleeping in order to not reboot.



Processor: Intel(R) Core(TM) i5-2500K SandyBridge CPU @ 3.30GHz

RAM: 16GB

Graphics Asus nVidia GeForce GTX570 DirectCU II (742MHz, 1280MB GDDR5, with full DirectX 11 support)

HDD: 1.5TB

Motherboard: ASRock Fatal1ty Z68 Profess1onal Series

Monitors: Asus VE24

Power: KingWin 1000W Lazer Performance Series





Seems to be an issues with OS which is not storing the NVIDIA files in the registry.



Would recommend you to re-install OS and check. I don't think this is a driver or card issue.
Scroll To Top