Do i need Nvidia HD audio driver?
Hi

Okey i really don't understand what the problem is. I can play BF3 PERFECTLY fine if i have no sound input.
I think the problem is in the 8 Microsoft HD Audio Devices that installs to my computer. This is how it looks when i have uninstalled them in safe mode.

http://imageshack.us/f/51/dieb.png/


I have tried disabling Realtek in BIOS and only have my steelseries usb sound card activte, doesn't work.
I have tried disabling USB Sound card and just use the usually "pins" on the backside to my realtek, same problem.
I have updated both Realtek and USB Soundcard to newest driver.
It works fine if i run 1 card each (because i only have 1 HD Audio control unit?) dunno.

Should i install Nvidia HD Audio Driver? Because maybe it's Microsofts HD audio devices that are from 2010 that conflicts? I don't know
It's version 6.1.7601.17514 from Microsoft

When i play i have the 2 HD Audio Control Units disabled.

z68a gd65 g3 - latest bios
sli gtx 580 1.5gb twin frozr II - latest vbios
12 gb ram
i7 2600k not OCd
crucial m4 128gb
Hi



Okey i really don't understand what the problem is. I can play BF3 PERFECTLY fine if i have no sound input.

I think the problem is in the 8 Microsoft HD Audio Devices that installs to my computer. This is how it looks when i have uninstalled them in safe mode.



http://imageshack.us/f/51/dieb.png/






I have tried disabling Realtek in BIOS and only have my steelseries usb sound card activte, doesn't work.

I have tried disabling USB Sound card and just use the usually "pins" on the backside to my realtek, same problem.

I have updated both Realtek and USB Soundcard to newest driver.

It works fine if i run 1 card each (because i only have 1 HD Audio control unit?) dunno.



Should i install Nvidia HD Audio Driver? Because maybe it's Microsofts HD audio devices that are from 2010 that conflicts? I don't know

It's version 6.1.7601.17514 from Microsoft



When i play i have the 2 HD Audio Control Units disabled.



z68a gd65 g3 - latest bios

sli gtx 580 1.5gb twin frozr II - latest vbios

12 gb ram

i7 2600k not OCd

crucial m4 128gb

#1
Posted 01/21/2012 02:23 PM   
[quote name='lowblowz' date='21 January 2012 - 02:23 PM' timestamp='1327155804' post='1358729']
Hi

Okey i really don't understand what the problem is. I can play BF3 PERFECTLY fine if i have no sound input.
[/quote]
ok that sounds ok.
[quote name='lowblowz' date='21 January 2012 - 02:23 PM' timestamp='1327155804' post='1358729']
I think the problem is in the 8 Microsoft HD Audio Devices that installs to my computer. This is how it looks when i have uninstalled them in safe mode.

http://imageshack.us/f/51/dieb.png/
[/quote]
I don't understand what the problem is either? Presumably you can play BF3 in some way that is less than perfect? You seem to be saying that the game runs fine with no sound input, not that the game runs fine but that there is no sound output?

[quote name='lowblowz' date='21 January 2012 - 02:23 PM' timestamp='1327155804' post='1358729']
I have tried disabling Realtek in BIOS and only have my steelseries usb sound card activte, doesn't work.
I have tried disabling USB Sound card and just use the usually "pins" on the backside to my realtek, same problem.
I have updated both Realtek and USB Soundcard to newest driver.
It works fine if i run 1 card each (because i only have 1 HD Audio control unit?) dunno.

Should i install Nvidia HD Audio Driver? Because maybe it's Microsofts HD audio devices that are from 2010 that conflicts? I don't know
It's version 6.1.7601.17514 from Microsoft

When i play i have the 2 HD Audio Control Units disabled.

z68a gd65 g3 - latest bios
sli gtx 580 1.5gb twin frozr II - latest vbios
12 gb ram
i7 2600k not OCd
crucial m4 128gb
[/quote]
ok but how do you want the sound to work? through your display's builtin speakers via HDMI? Via stereo speakers/headphones?

To answer the question that is the title of the thread in a roundabout manner: If you are not using the Nvidia audio you can disable the High Definition Audio Controller that is related to the graphics card.

Device manager > display adapters > choose graphics card > properties > details > hardware ids [make a note of the subsys_XXXXXXXX]

Device manager > system devices > high definition audio controller (each in turn) > properties > details > hardware ids [If the subsys_XXXXXXX matches that of the graphics card, you can disable this device. Right click > disable.

Note: If you are using the nvidia audio, chances are you will need the nvidia audio driver.

It's hard to tell but maybe you just need to type sound in the start menu to reach the control panel and choose which device you want as default audio. Tv(hdmi)/Speakers/Digital hd out/usb steelseries thing.
[quote name='lowblowz' date='21 January 2012 - 02:23 PM' timestamp='1327155804' post='1358729']

Hi



Okey i really don't understand what the problem is. I can play BF3 PERFECTLY fine if i have no sound input.



ok that sounds ok.

[quote name='lowblowz' date='21 January 2012 - 02:23 PM' timestamp='1327155804' post='1358729']

I think the problem is in the 8 Microsoft HD Audio Devices that installs to my computer. This is how it looks when i have uninstalled them in safe mode.



http://imageshack.us/f/51/dieb.png/




I don't understand what the problem is either? Presumably you can play BF3 in some way that is less than perfect? You seem to be saying that the game runs fine with no sound input, not that the game runs fine but that there is no sound output?



[quote name='lowblowz' date='21 January 2012 - 02:23 PM' timestamp='1327155804' post='1358729']

I have tried disabling Realtek in BIOS and only have my steelseries usb sound card activte, doesn't work.

I have tried disabling USB Sound card and just use the usually "pins" on the backside to my realtek, same problem.

I have updated both Realtek and USB Soundcard to newest driver.

It works fine if i run 1 card each (because i only have 1 HD Audio control unit?) dunno.



Should i install Nvidia HD Audio Driver? Because maybe it's Microsofts HD audio devices that are from 2010 that conflicts? I don't know

It's version 6.1.7601.17514 from Microsoft



When i play i have the 2 HD Audio Control Units disabled.



z68a gd65 g3 - latest bios

sli gtx 580 1.5gb twin frozr II - latest vbios

12 gb ram

i7 2600k not OCd

crucial m4 128gb



ok but how do you want the sound to work? through your display's builtin speakers via HDMI? Via stereo speakers/headphones?



To answer the question that is the title of the thread in a roundabout manner: If you are not using the Nvidia audio you can disable the High Definition Audio Controller that is related to the graphics card.



Device manager > display adapters > choose graphics card > properties > details > hardware ids [make a note of the subsys_XXXXXXXX]



Device manager > system devices > high definition audio controller (each in turn) > properties > details > hardware ids [If the subsys_XXXXXXX matches that of the graphics card, you can disable this device. Right click > disable.



Note: If you are using the nvidia audio, chances are you will need the nvidia audio driver.



It's hard to tell but maybe you just need to type sound in the start menu to reach the control panel and choose which device you want as default audio. Tv(hdmi)/Speakers/Digital hd out/usb steelseries thing.

GPU: MSI GTX560Ti Twin Frozr II OC 880/4200 (factory overclock)

Monitor: Dell 2312HM 1920x1080@60hz
Monitor/TV: LG32LH5000 1920x1080@50hz

#2
Posted 01/21/2012 02:51 PM   
Thanks for your reply!

[quote name='skilak' date='21 January 2012 - 02:51 PM' timestamp='1327157512' post='1358740']
ok that sounds ok.

I don't understand what the problem is either? Presumably you can play BF3 in some way that is less than perfect? You seem to be saying that the game runs fine with no sound input, not that the game runs fine but that there is no sound output?
[/quote]

I mean i can run the game without crashing if i have no sound plugged in yes. So yea output! My bad

[quote]
ok but how do you want the sound to work? through your display's builtin speakers via HDMI? Via stereo speakers/headphones?

To answer the question that is the title of the thread in a roundabout manner: If you are not using the Nvidia audio you can disable the High Definition Audio Controller that is related to the graphics card.

Device manager > display adapters > choose graphics card > properties > details > hardware ids [make a note of the subsys_XXXXXXXX]

Device manager > system devices > high definition audio controller (each in turn) > properties > details > hardware ids [If the subsys_XXXXXXX matches that of the graphics card, you can disable this device. Right click > disable.

Note: If you are using the nvidia audio, chances are you will need the nvidia audio driver.

It's hard to tell but maybe you just need to type sound in the start menu to reach the control panel and choose which device you want as default audio. Tv(hdmi)/Speakers/Digital hd out/usb steelseries thing.
[/quote]

I have done that procedure countless of times, with no success. I have even tried uninstall them in Safe mode. I have literally tried everything with them...
Weird is i can play fine with 1 card only. So i think it has something to do that i have 8 HD Audio Devices(because i do SLI) and that they conflict with each other?


I have my Headset as default in Sound Devices. And i have 8 HDMI Sound that i have inactivated.

I want it to run through my Headset that uses USB Sound card (Steelseries Siberia V2).

And no im not using Nvidia Audio driver, it seems it comes from Microsoft HD Audio. And i don't understand why they get installed anyway. I don't have HDMI connected, i use DVI. Maybe they are installed even if i use DVI?

If i look what files the 8 HD Audio devices use they use the same file as my USB Sound card(my headset) does. Don't know if thats a problem when i deactivate my HDMI sound in device manager? The files they both use are:
C:\Windows\system32\drivers\dmk.sys
\ksthunk.sys
\portcls.sys
Thanks for your reply!



[quote name='skilak' date='21 January 2012 - 02:51 PM' timestamp='1327157512' post='1358740']

ok that sounds ok.



I don't understand what the problem is either? Presumably you can play BF3 in some way that is less than perfect? You seem to be saying that the game runs fine with no sound input, not that the game runs fine but that there is no sound output?





I mean i can run the game without crashing if i have no sound plugged in yes. So yea output! My bad





ok but how do you want the sound to work? through your display's builtin speakers via HDMI? Via stereo speakers/headphones?



To answer the question that is the title of the thread in a roundabout manner: If you are not using the Nvidia audio you can disable the High Definition Audio Controller that is related to the graphics card.



Device manager > display adapters > choose graphics card > properties > details > hardware ids [make a note of the subsys_XXXXXXXX]



Device manager > system devices > high definition audio controller (each in turn) > properties > details > hardware ids [If the subsys_XXXXXXX matches that of the graphics card, you can disable this device. Right click > disable.



Note: If you are using the nvidia audio, chances are you will need the nvidia audio driver.



It's hard to tell but maybe you just need to type sound in the start menu to reach the control panel and choose which device you want as default audio. Tv(hdmi)/Speakers/Digital hd out/usb steelseries thing.





I have done that procedure countless of times, with no success. I have even tried uninstall them in Safe mode. I have literally tried everything with them...

Weird is i can play fine with 1 card only. So i think it has something to do that i have 8 HD Audio Devices(because i do SLI) and that they conflict with each other?





I have my Headset as default in Sound Devices. And i have 8 HDMI Sound that i have inactivated.



I want it to run through my Headset that uses USB Sound card (Steelseries Siberia V2).



And no im not using Nvidia Audio driver, it seems it comes from Microsoft HD Audio. And i don't understand why they get installed anyway. I don't have HDMI connected, i use DVI. Maybe they are installed even if i use DVI?



If i look what files the 8 HD Audio devices use they use the same file as my USB Sound card(my headset) does. Don't know if thats a problem when i deactivate my HDMI sound in device manager? The files they both use are:

C:\Windows\system32\drivers\dmk.sys

\ksthunk.sys

\portcls.sys

#3
Posted 01/22/2012 12:19 PM   
[quote name='lowblowz' date='22 January 2012 - 12:19 PM' timestamp='1327234742' post='1359054']
I have done that procedure countless of times, with no success. I have even tried uninstall them in Safe mode. I have literally tried everything with them...
Weird is i can play fine with 1 card only. So i think it has something to do that i have 8 HD Audio Devices(because i do SLI) and that they conflict with each other?

[/quote]
I'm going to be honest here, I don't think you have done the procedure that I explained in detail. Follow each step precisely. Nowhere do I mention uninstalling, I said disable. Here, on the left is the before (with the right device disabled, see the icon on the highlighted high definition audio controller) and you will see no nvidia devices under sound/video. On the right is the after when I re-enable it. I have half the devices since no sli but they reappear as I re-enable the correct high definition audio device under system devices.


[img]http://dl.dropbox.com/u/46465795/dm.jpg[/img]
Whether this helps or not is a different matter.
[quote name='lowblowz' date='22 January 2012 - 12:19 PM' timestamp='1327234742' post='1359054']

I have done that procedure countless of times, with no success. I have even tried uninstall them in Safe mode. I have literally tried everything with them...

Weird is i can play fine with 1 card only. So i think it has something to do that i have 8 HD Audio Devices(because i do SLI) and that they conflict with each other?





I'm going to be honest here, I don't think you have done the procedure that I explained in detail. Follow each step precisely. Nowhere do I mention uninstalling, I said disable. Here, on the left is the before (with the right device disabled, see the icon on the highlighted high definition audio controller) and you will see no nvidia devices under sound/video. On the right is the after when I re-enable it. I have half the devices since no sli but they reappear as I re-enable the correct high definition audio device under system devices.





Image

Whether this helps or not is a different matter.

GPU: MSI GTX560Ti Twin Frozr II OC 880/4200 (factory overclock)

Monitor: Dell 2312HM 1920x1080@60hz
Monitor/TV: LG32LH5000 1920x1080@50hz

#4
Posted 01/22/2012 12:35 PM   
[quote name='skilak' date='22 January 2012 - 12:35 PM' timestamp='1327235704' post='1359056']
I'm going to be honest here, I don't think you have done the procedure that I explained in detail. Follow each step precisely. Nowhere do I mention uninstalling, I said disable. Here, on the left is the before (with the right device disabled, see the icon on the highlighted high definition audio controller) and you will see no nvidia devices under sound/video. On the right is the after when I re-enable it. I have half the devices since no sli but they reappear as I re-enable the correct high definition audio device under system devices.


[img]http://dl.dropbox.com/u/46465795/dm.jpg[/img]
Whether this helps or not is a different matter.
[/quote]

Mate, i have put DAYS on this problem and quiet some cash on it aswell, i have tried this aswell.
And yes i have disabled the 2(!) Controller unit. I have a 3rd if i have Realtek enabled in BIOS

On my picture i just showed how they installed again.

Thanks tho for trying to help me mate
[quote name='skilak' date='22 January 2012 - 12:35 PM' timestamp='1327235704' post='1359056']

I'm going to be honest here, I don't think you have done the procedure that I explained in detail. Follow each step precisely. Nowhere do I mention uninstalling, I said disable. Here, on the left is the before (with the right device disabled, see the icon on the highlighted high definition audio controller) and you will see no nvidia devices under sound/video. On the right is the after when I re-enable it. I have half the devices since no sli but they reappear as I re-enable the correct high definition audio device under system devices.





Image

Whether this helps or not is a different matter.





Mate, i have put DAYS on this problem and quiet some cash on it aswell, i have tried this aswell.

And yes i have disabled the 2(!) Controller unit. I have a 3rd if i have Realtek enabled in BIOS



On my picture i just showed how they installed again.



Thanks tho for trying to help me mate

#5
Posted 01/22/2012 02:09 PM   
[quote name='lowblowz' date='22 January 2012 - 02:09 PM' timestamp='1327241364' post='1359087']
Mate, i have put DAYS on this problem and quiet some cash on it aswell, i have tried this aswell.
And yes i have disabled the 2(!) Controller unit. I have a 3rd if i have Realtek enabled in BIOS

On my picture i just showed how they installed again.

Thanks tho for trying to help me mate
[/quote]
You're saying if you right click the items from your picture and choose disable (not uninstall) or the right translated version they instantly re-enable themselves? Automatically? Or after a reboot? Or neither?
[img]http://dl.dropbox.com/u/46465795/here.jpg[/img]

As soon as you choose disable, the icon should change to the one in my disabled picture with the downward arrow. It shouldn't re-enable when you reboot, but what happens as soon as you disable them?
[quote name='lowblowz' date='22 January 2012 - 02:09 PM' timestamp='1327241364' post='1359087']

Mate, i have put DAYS on this problem and quiet some cash on it aswell, i have tried this aswell.

And yes i have disabled the 2(!) Controller unit. I have a 3rd if i have Realtek enabled in BIOS



On my picture i just showed how they installed again.



Thanks tho for trying to help me mate



You're saying if you right click the items from your picture and choose disable (not uninstall) or the right translated version they instantly re-enable themselves? Automatically? Or after a reboot? Or neither?

Image



As soon as you choose disable, the icon should change to the one in my disabled picture with the downward arrow. It shouldn't re-enable when you reboot, but what happens as soon as you disable them?

GPU: MSI GTX560Ti Twin Frozr II OC 880/4200 (factory overclock)

Monitor: Dell 2312HM 1920x1080@60hz
Monitor/TV: LG32LH5000 1920x1080@50hz

#6
Posted 01/22/2012 02:19 PM   
[quote name='skilak' date='22 January 2012 - 02:19 PM' timestamp='1327241946' post='1359089']
You're saying if you right click the items from your picture and choose disable (not uninstall) or the right translated version they instantly re-enable themselves? Automatically? Or after a reboot? Or neither?
[img]http://dl.dropbox.com/u/46465795/here.jpg[/img]

As soon as you choose disable, the icon should change to the one in my disabled picture with the downward arrow. It shouldn't re-enable when you reboot, but what happens as soon as you disable them?
[/quote]

If i disable them they are gone as you say. The 8 HD Audio Devices dissapear if i disable the 2 Control Units. So it's really weird i still crash. That's why i would like to get rid of them completley. But they use the same system files.
As i wrote, my USB Sound Card seems to use the files that these 8 HD Audio Devices use. And i might wonder if they conflict if they use the same files?

Thanks
[quote name='skilak' date='22 January 2012 - 02:19 PM' timestamp='1327241946' post='1359089']

You're saying if you right click the items from your picture and choose disable (not uninstall) or the right translated version they instantly re-enable themselves? Automatically? Or after a reboot? Or neither?

Image



As soon as you choose disable, the icon should change to the one in my disabled picture with the downward arrow. It shouldn't re-enable when you reboot, but what happens as soon as you disable them?





If i disable them they are gone as you say. The 8 HD Audio Devices dissapear if i disable the 2 Control Units. So it's really weird i still crash. That's why i would like to get rid of them completley. But they use the same system files.

As i wrote, my USB Sound Card seems to use the files that these 8 HD Audio Devices use. And i might wonder if they conflict if they use the same files?



Thanks

#7
Posted 01/22/2012 02:26 PM   
[quote name='lowblowz' date='22 January 2012 - 02:26 PM' timestamp='1327242396' post='1359092']
If i disable them they are gone as you say. The 8 HD Audio Devices dissapear if i disable the 2 Control Units. So it's really weird i still crash. That's why i would like to get rid of them completley. But they use the same system files.
As i wrote, my USB Sound Card seems to use the files that these 8 HD Audio Devices use. And i might wonder if they conflict if they use the same files?

Thanks
[/quote]
I couldn't tell you to be honest. You should check the hardware ids of those two bottom devices match the hardware ids of the graphics cards. Once they are disabled you can remove from add/remove programs the "Nvidia HD Audio Driver" if you installed it with a driver package. This shouldn't really matter though.

As long as the USB PnP Sound device is still present it should work. How about this as some ideas as I'm at a loss now:

1. re-enable the realtek onboard and try that with the two nvidia cards disabled and no usb device. To be honest as you are observing I'm not really sure disabling the nvidia audio devices will help.

2. start menu/control panel > sound > choose sound device we've got set as default currently > properties > advanced > see what the default format/quality setting is. Occasionally I've read different games/systems for some reason have a problem if this is set to 48,000 instead of 44,100 but honestly I doubt this is the problem.
[quote name='lowblowz' date='22 January 2012 - 02:26 PM' timestamp='1327242396' post='1359092']

If i disable them they are gone as you say. The 8 HD Audio Devices dissapear if i disable the 2 Control Units. So it's really weird i still crash. That's why i would like to get rid of them completley. But they use the same system files.

As i wrote, my USB Sound Card seems to use the files that these 8 HD Audio Devices use. And i might wonder if they conflict if they use the same files?



Thanks



I couldn't tell you to be honest. You should check the hardware ids of those two bottom devices match the hardware ids of the graphics cards. Once they are disabled you can remove from add/remove programs the "Nvidia HD Audio Driver" if you installed it with a driver package. This shouldn't really matter though.



As long as the USB PnP Sound device is still present it should work. How about this as some ideas as I'm at a loss now:



1. re-enable the realtek onboard and try that with the two nvidia cards disabled and no usb device. To be honest as you are observing I'm not really sure disabling the nvidia audio devices will help.



2. start menu/control panel > sound > choose sound device we've got set as default currently > properties > advanced > see what the default format/quality setting is. Occasionally I've read different games/systems for some reason have a problem if this is set to 48,000 instead of 44,100 but honestly I doubt this is the problem.

GPU: MSI GTX560Ti Twin Frozr II OC 880/4200 (factory overclock)

Monitor: Dell 2312HM 1920x1080@60hz
Monitor/TV: LG32LH5000 1920x1080@50hz

#8
Posted 01/22/2012 02:48 PM   
Scroll To Top