Full Screen Pixelated Graphics All Games
Hello To All,

I apologize first off if this has already been answered but I've looked and can't find anything that helps.

I bought a new 580 GTX in hopes of fixing this issue with straight HDMI out of video card instead of DVI to HDMI to Sony 42" EX500 LCD TV (TV is set to 1 for 1 pixel mapping).
The exact same issue happens with a 280 GTX & 285 GTX that I have. All drivers are up to date as I just reinstalled 64 bit Windows 7

When [b][i][u]ALL[/u][/i][/b] games are played full screen on the LCD TV they look horribly pixelated. When I go to window mode for [u][i][b]ALL[/b][/i][/u] games on the LCD TV they look great.

I also have multiple PC monitors where the games are not affected in full screen mode.

I've ruled out the LCD TV being the issue because all games look great in window mode plus if I revert back to the 260.99 nvidia drivers the issue goes away completely on all 3 of the video cards. It has to be something to do with the driver not reporting to the LCD correctly. I have disabled the HDMI Audio in the Nvidia control panel which allows the 260.99 drivers to work correctly in full screen but there is no change in full screen video with the most recent drivers.

Can anyone please help me? Even if it's just to tell me the Nvidia drivers are whacked since 260.99 for LCD TVs. At least then I can return the 580 and go try an ATI card instead. I truly enjoy the Nvidia products but it's crazy if the drivers have been broke this long for LCD TVs or certain ones.

Thank you,
Jerry Quesenberry
Hello To All,



I apologize first off if this has already been answered but I've looked and can't find anything that helps.



I bought a new 580 GTX in hopes of fixing this issue with straight HDMI out of video card instead of DVI to HDMI to Sony 42" EX500 LCD TV (TV is set to 1 for 1 pixel mapping).

The exact same issue happens with a 280 GTX & 285 GTX that I have. All drivers are up to date as I just reinstalled 64 bit Windows 7



When ALL games are played full screen on the LCD TV they look horribly pixelated. When I go to window mode for ALL games on the LCD TV they look great.



I also have multiple PC monitors where the games are not affected in full screen mode.



I've ruled out the LCD TV being the issue because all games look great in window mode plus if I revert back to the 260.99 nvidia drivers the issue goes away completely on all 3 of the video cards. It has to be something to do with the driver not reporting to the LCD correctly. I have disabled the HDMI Audio in the Nvidia control panel which allows the 260.99 drivers to work correctly in full screen but there is no change in full screen video with the most recent drivers.



Can anyone please help me? Even if it's just to tell me the Nvidia drivers are whacked since 260.99 for LCD TVs. At least then I can return the 580 and go try an ATI card instead. I truly enjoy the Nvidia products but it's crazy if the drivers have been broke this long for LCD TVs or certain ones.



Thank you,

Jerry Quesenberry

#1
Posted 01/08/2012 08:27 PM   
I dunno if it is something this simple, but what resolution are you using "IN game". It sounds to me like your running games in a resolution that is not native to your display and it causes them to look pixelated. Windowed mode would look fine because the window would be the same size as w/e resolution you have set. I have a Sony 40" TV and a GTX 570 and run everything in 1920x1080. Anything lower then that gets more and more pixelated. So if your running in say 720p on a 1080p monitor, it will look pixelated. Some games default to even LOWER resolutions, which would look horrible.

What is the native resolution of your Sony TV?. Is it a 720p TV or a 1080p TV?. What resolution is your desktop? What resolution do you run your games in?.
I dunno if it is something this simple, but what resolution are you using "IN game". It sounds to me like your running games in a resolution that is not native to your display and it causes them to look pixelated. Windowed mode would look fine because the window would be the same size as w/e resolution you have set. I have a Sony 40" TV and a GTX 570 and run everything in 1920x1080. Anything lower then that gets more and more pixelated. So if your running in say 720p on a 1080p monitor, it will look pixelated. Some games default to even LOWER resolutions, which would look horrible.



What is the native resolution of your Sony TV?. Is it a 720p TV or a 1080p TV?. What resolution is your desktop? What resolution do you run your games in?.

i5 2500k @ 4.7ghz

MSI P67A-GD55 (B3)

8GB G.Skill Ripjaws 1600mhz DDR3

MSI GTX570 (OC) 786/4200 1.28gb Videocard

Sony Bravia 40" 120hz LCD(TV)

#2
Posted 01/09/2012 06:22 PM   
The resolutions are set correctly fella. All the games are set at 1080P. As I said previously, when I switch to the old geforce drivers 260.99 without changing anything else the games work the way they are suppose to. It's something broken in all the drivers afterwards that cause the exact same issue. Thank you for at least responding though. I know for a fact that I'm not the only person having the problem as I've seen discussions on this topic on Steam.
The resolutions are set correctly fella. All the games are set at 1080P. As I said previously, when I switch to the old geforce drivers 260.99 without changing anything else the games work the way they are suppose to. It's something broken in all the drivers afterwards that cause the exact same issue. Thank you for at least responding though. I know for a fact that I'm not the only person having the problem as I've seen discussions on this topic on Steam.

#3
Posted 01/10/2012 04:41 AM   
Just curious, never used HDMI with my TV (yet), only the VGA. -
I notice you disabled the HDMI audio with the drivers that [i]do[/i] work, so are you wanting to use HDMI so you can get the audio to the TV's speakers ?
You mention reverting to the 260.99 drivers. Did you have to go back that far ? Have you tried the 275.33 drivers ?

Anyway, buying a GTX580 was never going to be the solution to the issue. I'd be interested in hearing if an ATI card works properly (including sound) with the HDMI > TV though.
Just curious, never used HDMI with my TV (yet), only the VGA. -

I notice you disabled the HDMI audio with the drivers that do work, so are you wanting to use HDMI so you can get the audio to the TV's speakers ?

You mention reverting to the 260.99 drivers. Did you have to go back that far ? Have you tried the 275.33 drivers ?



Anyway, buying a GTX580 was never going to be the solution to the issue. I'd be interested in hearing if an ATI card works properly (including sound) with the HDMI > TV though.

BossDweebe is in his second childhood, or would be if he'd ever left the first.

#4
Posted 01/10/2012 09:28 AM   
The reason for trying the 580 was the direct HDMI out. I was hoping beyond hope that would have cured it but it did not. The reason for cutting off the HDMI sound in the 260.99 drivers was what it took to allow the HDMI to work correctly. If you didn't stop the HDMI audio the picture issue was identical to what I discussed previously. Doing the same in the latest drivers doesn't work at all. I have tried the 270 drivers but it's the same there also. It's definitely driver related though. My issue is that I have seen it reported elsewhere (Steam) also but it doesn't look like Nvidia is worried about fixing it or helping to fix it. Live and learn I guess.
The reason for trying the 580 was the direct HDMI out. I was hoping beyond hope that would have cured it but it did not. The reason for cutting off the HDMI sound in the 260.99 drivers was what it took to allow the HDMI to work correctly. If you didn't stop the HDMI audio the picture issue was identical to what I discussed previously. Doing the same in the latest drivers doesn't work at all. I have tried the 270 drivers but it's the same there also. It's definitely driver related though. My issue is that I have seen it reported elsewhere (Steam) also but it doesn't look like Nvidia is worried about fixing it or helping to fix it. Live and learn I guess.

#5
Posted 01/14/2012 01:32 AM   
The reason for trying the 580 was the direct HDMI out. I was hoping beyond hope that would have cured it but it did not. The reason for cutting off the HDMI sound in the 260.99 drivers was what it took to allow the HDMI to work correctly. If you didn't stop the HDMI audio the picture issue was identical to what I discussed previously. Doing the same in the latest drivers doesn't work at all. I have tried the 270 drivers but it's the same there also. It's definitely driver related though. My issue is that I have seen it reported elsewhere (Steam) also but it doesn't look like Nvidia is worried about fixing it or helping to fix it. Live and learn I guess.
The reason for trying the 580 was the direct HDMI out. I was hoping beyond hope that would have cured it but it did not. The reason for cutting off the HDMI sound in the 260.99 drivers was what it took to allow the HDMI to work correctly. If you didn't stop the HDMI audio the picture issue was identical to what I discussed previously. Doing the same in the latest drivers doesn't work at all. I have tried the 270 drivers but it's the same there also. It's definitely driver related though. My issue is that I have seen it reported elsewhere (Steam) also but it doesn't look like Nvidia is worried about fixing it or helping to fix it. Live and learn I guess.

#6
Posted 01/14/2012 01:32 AM   
I think I've found the answer believe it or not. (At least for me) I went back to a thread someone else had started in May of 2011 that I had written in to see if anything new had been posted. In was in Infinity7's response that I started searching the Nvidia control panel for answers. Again! In the Nvidia Control Panel I went to DISPLAY then ADJUST DESKTOP COLOR SETTINGS and under #3 APPLY THE FOLLOWING ENHANCEMENTS at the very bottom where it says CONTENT TYPE REPORTED TO DISPLAY I changed it from AUTO SELECT to DESKTOP PROGRAMS and it worked even with the HDMI audio enabled. Thanks to those few who did respond I really appreciate your thoughts. And not that Infinity7 will ever see this I can't thank him for the additional thoughts. Hope this helps someone in the future.

Thanks Guys!
I think I've found the answer believe it or not. (At least for me) I went back to a thread someone else had started in May of 2011 that I had written in to see if anything new had been posted. In was in Infinity7's response that I started searching the Nvidia control panel for answers. Again! In the Nvidia Control Panel I went to DISPLAY then ADJUST DESKTOP COLOR SETTINGS and under #3 APPLY THE FOLLOWING ENHANCEMENTS at the very bottom where it says CONTENT TYPE REPORTED TO DISPLAY I changed it from AUTO SELECT to DESKTOP PROGRAMS and it worked even with the HDMI audio enabled. Thanks to those few who did respond I really appreciate your thoughts. And not that Infinity7 will ever see this I can't thank him for the additional thoughts. Hope this helps someone in the future.



Thanks Guys!

#7
Posted 01/14/2012 02:49 AM   
I think I've found the answer believe it or not. (At least for me) I went back to a thread someone else had started in May of 2011 that I had written in to see if anything new had been posted. In was in Infinity7's response that I started searching the Nvidia control panel for answers. Again! In the Nvidia Control Panel I went to DISPLAY then ADJUST DESKTOP COLOR SETTINGS and under #3 APPLY THE FOLLOWING ENHANCEMENTS at the very bottom where it says CONTENT TYPE REPORTED TO DISPLAY I changed it from AUTO SELECT to DESKTOP PROGRAMS and it worked even with the HDMI audio enabled. Thanks to those few who did respond I really appreciate your thoughts. And not that Infinity7 will ever see this I can't thank him for the additional thoughts. Hope this helps someone in the future.

Thanks Guys!
I think I've found the answer believe it or not. (At least for me) I went back to a thread someone else had started in May of 2011 that I had written in to see if anything new had been posted. In was in Infinity7's response that I started searching the Nvidia control panel for answers. Again! In the Nvidia Control Panel I went to DISPLAY then ADJUST DESKTOP COLOR SETTINGS and under #3 APPLY THE FOLLOWING ENHANCEMENTS at the very bottom where it says CONTENT TYPE REPORTED TO DISPLAY I changed it from AUTO SELECT to DESKTOP PROGRAMS and it worked even with the HDMI audio enabled. Thanks to those few who did respond I really appreciate your thoughts. And not that Infinity7 will ever see this I can't thank him for the additional thoughts. Hope this helps someone in the future.



Thanks Guys!

#8
Posted 01/14/2012 02:49 AM   
Thanks for posting your solution. Noted - /book.gif' class='bbc_emoticon' alt=':book:' />
Thanks for posting your solution. Noted - /book.gif' class='bbc_emoticon' alt=':book:' />

BossDweebe is in his second childhood, or would be if he'd ever left the first.

#9
Posted 01/14/2012 09:12 AM   
Thanks for posting your solution. Noted - /book.gif' class='bbc_emoticon' alt=':book:' />
Thanks for posting your solution. Noted - /book.gif' class='bbc_emoticon' alt=':book:' />

BossDweebe is in his second childhood, or would be if he'd ever left the first.

#10
Posted 01/14/2012 09:12 AM   
I know this is a super old thread, but I just wanted to say thank you. I had an issue after my recent w10 upgrade on an HTPC with an Ion GPU. Anything that was full screen video (be it the Netflix app, X1 streaming, etc) would be super pixelated, but if I just moved the mouse to the top of the screen so it went from full screen video to maximized desktop window it cleared right up. I'd imagine based on your fix that it has something to do with the when the Nvidea control panel not reporting correctly with the Sony TV (I also have a Sony TV) when displaying full screen video/games and it reverting back to some LQ settings or something.
I know this is a super old thread, but I just wanted to say thank you. I had an issue after my recent w10 upgrade on an HTPC with an Ion GPU. Anything that was full screen video (be it the Netflix app, X1 streaming, etc) would be super pixelated, but if I just moved the mouse to the top of the screen so it went from full screen video to maximized desktop window it cleared right up.
I'd imagine based on your fix that it has something to do with the when the Nvidea control panel not reporting correctly with the Sony TV (I also have a Sony TV) when displaying full screen video/games and it reverting back to some LQ settings or something.

#11
Posted 12/23/2015 06:15 PM   
[quote="jakejm79"]I know this is a super old thread, but I just wanted to say thank you. I had an issue after my recent w10 upgrade on an HTPC with an Ion GPU. Anything that was full screen video (be it the Netflix app, X1 streaming, etc) would be super pixelated, but if I just moved the mouse to the top of the screen so it went from full screen video to maximized desktop window it cleared right up. I'd imagine based on your fix that it has something to do with the when the Nvidea control panel not reporting correctly with the Sony TV (I also have a Sony TV) when displaying full screen video/games and it reverting back to some LQ settings or something. [/quote] I just tried this, and it works! I'm using a Hisense TV (forgot the size) that runs 1360x768 and playing games like Dishonored was really pixelated, looking at thin bars far away being blobbed out just hurt my eyes.
jakejm79 said:I know this is a super old thread, but I just wanted to say thank you. I had an issue after my recent w10 upgrade on an HTPC with an Ion GPU. Anything that was full screen video (be it the Netflix app, X1 streaming, etc) would be super pixelated, but if I just moved the mouse to the top of the screen so it went from full screen video to maximized desktop window it cleared right up.
I'd imagine based on your fix that it has something to do with the when the Nvidea control panel not reporting correctly with the Sony TV (I also have a Sony TV) when displaying full screen video/games and it reverting back to some LQ settings or something.


I just tried this, and it works! I'm using a Hisense TV (forgot the size) that runs 1360x768 and playing games like Dishonored was really pixelated, looking at thin bars far away being blobbed out just hurt my eyes.

#12
Posted 03/06/2016 03:56 PM   
[quote="LotharQberry"]I think I've found the answer believe it or not. (At least for me) I went back to a thread someone else had started in May of 2011 that I had written in to see if anything new had been posted. In was in Infinity7's response that I started searching the Nvidia control panel for answers. Again! In the Nvidia Control Panel I went to DISPLAY then ADJUST DESKTOP COLOR SETTINGS and under #3 APPLY THE FOLLOWING ENHANCEMENTS at the very bottom where it says CONTENT TYPE REPORTED TO DISPLAY I changed it from AUTO SELECT to DESKTOP PROGRAMS and it worked even with the HDMI audio enabled. Thanks to those few who did respond I really appreciate your thoughts. And not that Infinity7 will ever see this I can't thank him for the additional thoughts. Hope this helps someone in the future.<br> <br> Thanks Guys![/quote] Million of thanks.. It works. I was having horribly pixelated screen when I run YouTube in full screen mode in Chrome. Even when i close the browser the whole desktop will remain pixelated until i change the resolution and then return back to the original resolution (kind of refresh). But with the solution you have posted (CONTENT TYPE REPORTED TO DISPLAY -> DESKTOP PROGRAMS).. It is fixed :)
LotharQberry said:I think I've found the answer believe it or not. (At least for me) I went back to a thread someone else had started in May of 2011 that I had written in to see if anything new had been posted. In was in Infinity7's response that I started searching the Nvidia control panel for answers. Again! In the Nvidia Control Panel I went to DISPLAY then ADJUST DESKTOP COLOR SETTINGS and under #3 APPLY THE FOLLOWING ENHANCEMENTS at the very bottom where it says CONTENT TYPE REPORTED TO DISPLAY I changed it from AUTO SELECT to DESKTOP PROGRAMS and it worked even with the HDMI audio enabled. Thanks to those few who did respond I really appreciate your thoughts. And not that Infinity7 will ever see this I can't thank him for the additional thoughts. Hope this helps someone in the future.<br>
<br>
Thanks Guys!



Million of thanks.. It works. I was having horribly pixelated screen when I run YouTube in full screen mode in Chrome. Even when i close the browser the whole desktop will remain pixelated until i change the resolution and then return back to the original resolution (kind of refresh). But with the solution you have posted (CONTENT TYPE REPORTED TO DISPLAY -> DESKTOP PROGRAMS).. It is fixed :)

#13
Posted 11/06/2017 06:56 PM   
Scroll To Top