Quad-SLI + Dedicated PhysX GeForce = CPU PhysX
Hello forum members,

I have a Quad-SLI System of two gtx 590 and one dedicated gtx 580 for PhysX, set to PhysX-Only-Usage.
I use the latest drivers. Tried some different versions.

If I start Metro 2033 and activate ingame PhysX Info Message in nvidia Controlpanel, it shows that CPU PhysX is used.

If I change PhysX Device to one of the GTX590 GPUs, then GPU PhysX is enabled in the game.

Why cant I use the gtx580 as a PhysX-Device for GPU-PhysX in combination with Quad-SLI?

Solution(s)?

Best regards Sven
Hello forum members,



I have a Quad-SLI System of two gtx 590 and one dedicated gtx 580 for PhysX, set to PhysX-Only-Usage.

I use the latest drivers. Tried some different versions.



If I start Metro 2033 and activate ingame PhysX Info Message in nvidia Controlpanel, it shows that CPU PhysX is used.



If I change PhysX Device to one of the GTX590 GPUs, then GPU PhysX is enabled in the game.



Why cant I use the gtx580 as a PhysX-Device for GPU-PhysX in combination with Quad-SLI?



Solution(s)?



Best regards Sven

#1
Posted 12/30/2011 02:32 PM   
[quote name='Magneto' date='30 December 2011 - 08:32 AM' timestamp='1325255568' post='1349128']
Hello forum members,

I have a Quad-SLI System of two gtx 590 and one dedicated gtx 580 for PhysX, set to PhysX-Only-Usage.
I use the latest drivers. Tried some different versions.

If I start Metro 2033 and activate ingame PhysX Info Message in nvidia Controlpanel, it shows that CPU PhysX is used.

If I change PhysX Device to one of the GTX590 GPUs, then GPU PhysX is enabled in the game.

Why cant I use the gtx580 as a PhysX-Device for GPU-PhysX in combination with Quad-SLI?

Solution(s)?

Best regards Sven
[/quote]

Do you have the 580 dedicated to physX in Control Panel?
[quote name='Magneto' date='30 December 2011 - 08:32 AM' timestamp='1325255568' post='1349128']

Hello forum members,



I have a Quad-SLI System of two gtx 590 and one dedicated gtx 580 for PhysX, set to PhysX-Only-Usage.

I use the latest drivers. Tried some different versions.



If I start Metro 2033 and activate ingame PhysX Info Message in nvidia Controlpanel, it shows that CPU PhysX is used.



If I change PhysX Device to one of the GTX590 GPUs, then GPU PhysX is enabled in the game.



Why cant I use the gtx580 as a PhysX-Device for GPU-PhysX in combination with Quad-SLI?



Solution(s)?



Best regards Sven





Do you have the 580 dedicated to physX in Control Panel?

Done.

#2
Posted 12/30/2011 02:54 PM   
What are the rest of your specifications? Sounds like there maybe be a detection issue which could be your motherboard.

As he said, you need to set the 580 as Dedicated PhysX in NVidia Control Panel. If it's not a selectable option, something is amiss.
What are the rest of your specifications? Sounds like there maybe be a detection issue which could be your motherboard.



As he said, you need to set the 580 as Dedicated PhysX in NVidia Control Panel. If it's not a selectable option, something is amiss.



Image


Image

Help fight Cancer, Alzheimer's and Parkinson's Disease by donating unused CPU and GPU power to Stanford University's Research Folding@Home projects:

Simplest method is to setup the FAH v7 client with this Windows Installation Guide

#3
Posted 12/31/2011 09:35 AM   
as I already said:

"and one dedicated gtx 580 for PhysX, [b]set to PhysX-Only-Usage."[/b]

It seems, that it will not be detected if the separate graphicscard ist set for physX usage. If i choose one of the gtx590 gpus for PhysX it will be recongnized correctly as gpu-physX in game, but with set to gtx580 it will not.

btw, it does not matter if "dedicate for physX" is activated or not. in every case in game it will be recognized gtx-cpu.

maybe quad-sli does not support 4 gpus + 1 one physx?
as I already said:



"and one dedicated gtx 580 for PhysX, set to PhysX-Only-Usage."



It seems, that it will not be detected if the separate graphicscard ist set for physX usage. If i choose one of the gtx590 gpus for PhysX it will be recongnized correctly as gpu-physX in game, but with set to gtx580 it will not.



btw, it does not matter if "dedicate for physX" is activated or not. in every case in game it will be recognized gtx-cpu.



maybe quad-sli does not support 4 gpus + 1 one physx?

#4
Posted 01/02/2012 07:05 PM   
[quote name='Magneto' date='02 January 2012 - 01:05 PM' timestamp='1325531103' post='1350579']
maybe quad-sli does not support 4 gpus + 1 one physx?
[/quote]

Somewhere on the SLI Zone website, it mentions that you can add a 5th GPU as a Dedicated PhysX Processor when using a Quad SLI setup.
[quote name='Magneto' date='02 January 2012 - 01:05 PM' timestamp='1325531103' post='1350579']

maybe quad-sli does not support 4 gpus + 1 one physx?





Somewhere on the SLI Zone website, it mentions that you can add a 5th GPU as a Dedicated PhysX Processor when using a Quad SLI setup.

Oh, it feels so right to dream under the stars
Where a part of me is free to roam where I belong!

#5
Posted 01/08/2012 05:26 AM   
if this setup is supported, then it have to work.

why do i spend 1200 € for quad-sli and another 380 € for a 5th graphics card when it will be cpu physx?
if this setup is supported, then it have to work.



why do i spend 1200 € for quad-sli and another 380 € for a 5th graphics card when it will be cpu physx?

#6
Posted 01/21/2012 12:10 PM   
[quote name='Magneto' date='21 January 2012 - 06:10 AM' timestamp='1327147846' post='1358708']
if this setup is supported, then it have to work.

why do i spend 1200 € for quad-sli and another 380 € for a 5th graphics card when it will be cpu physx?
[/quote]


physX on 590s has become a real PITA in the last few months.



With the early drivers it was possible to run Tri+physX with a pair of 590s, but now it isn't. I've run a 460 for physX w/ my QuadSLI, but I no longer have a motherboard capable of doing so. I can tell you that it has worked for me in the past, but that was when you could still run Tri+physX on just the two 590s as well. There's no telling anymore TBH. I'd recommend you call your card's OEM tech support line for help.

[quote name='Magneto' date='21 January 2012 - 06:10 AM' timestamp='1327147846' post='1358708']

if this setup is supported, then it have to work.



why do i spend 1200 € for quad-sli and another 380 € for a 5th graphics card when it will be cpu physx?







physX on 590s has become a real PITA in the last few months.







With the early drivers it was possible to run Tri+physX with a pair of 590s, but now it isn't. I've run a 460 for physX w/ my QuadSLI, but I no longer have a motherboard capable of doing so. I can tell you that it has worked for me in the past, but that was when you could still run Tri+physX on just the two 590s as well. There's no telling anymore TBH. I'd recommend you call your card's OEM tech support line for help.


Done.

#7
Posted 01/21/2012 07:45 PM   
[quote name='D1llw33d' date='21 January 2012 - 08:45 PM' timestamp='1327175125' post='1358857']
physX on 590s has become a real PITA in the last few months.

With the early drivers it was possible to run Tri+physX with a pair of 590s, but now it isn't. I've run a 460 for physX w/ my QuadSLI, but I no longer have a motherboard capable of doing so. I can tell you that it has worked for me in the past, but that was when you could still run Tri+physX on just the two 590s as well. There's no telling anymore TBH. I'd recommend you call your card's OEM tech support line for help.
[/quote]

Hi and thank you for your answer.

Now I tried beta Driver 295.18 and PhysX seems to work, because it shows, that PhysX-GPU is enabled in the game.

For testing purposes, I ran metro 2033 benchmark with advanced PhysX-Effects enabled.

BUT guess what... my gtx580 PhysX card gpu-usage is equal or less than 5 percent. that seems to be less for me.

I mean, metro 2033 is a game which makes fully usage of physX effects, when enabled....

I cannot believe, that PhysX calculations have nothing to do with gpu-usage...
[quote name='D1llw33d' date='21 January 2012 - 08:45 PM' timestamp='1327175125' post='1358857']

physX on 590s has become a real PITA in the last few months.



With the early drivers it was possible to run Tri+physX with a pair of 590s, but now it isn't. I've run a 460 for physX w/ my QuadSLI, but I no longer have a motherboard capable of doing so. I can tell you that it has worked for me in the past, but that was when you could still run Tri+physX on just the two 590s as well. There's no telling anymore TBH. I'd recommend you call your card's OEM tech support line for help.





Hi and thank you for your answer.



Now I tried beta Driver 295.18 and PhysX seems to work, because it shows, that PhysX-GPU is enabled in the game.



For testing purposes, I ran metro 2033 benchmark with advanced PhysX-Effects enabled.



BUT guess what... my gtx580 PhysX card gpu-usage is equal or less than 5 percent. that seems to be less for me.



I mean, metro 2033 is a game which makes fully usage of physX effects, when enabled....



I cannot believe, that PhysX calculations have nothing to do with gpu-usage...

#8
Posted 01/22/2012 08:59 AM   
Hmm interesting , you got some darn nice hardware for sure . I was always led to believe that a dedicated physix card is not needed for a quad sli setup as the gains are negligible , Have you installed the SLI enhancement software ? I would also try turning things up a bit in the NCP , in manage 3d settings . to force the cards to work , you have alot of power there .
Hmm interesting , you got some darn nice hardware for sure . I was always led to believe that a dedicated physix card is not needed for a quad sli setup as the gains are negligible , Have you installed the SLI enhancement software ? I would also try turning things up a bit in the NCP , in manage 3d settings . to force the cards to work , you have alot of power there .

Image

#9
Posted 01/22/2012 12:41 PM   
[quote name='Magneto' date='22 January 2012 - 02:59 AM' timestamp='1327222778' post='1359009']
Hi and thank you for your answer.

Now I tried beta Driver 295.18 and PhysX seems to work, because it shows, that PhysX-GPU is enabled in the game.

For testing purposes, I ran metro 2033 benchmark with advanced PhysX-Effects enabled.

BUT guess what... my gtx580 PhysX card gpu-usage is equal or less than 5 percent. that seems to be less for me.

I mean, metro 2033 is a game which makes fully usage of physX effects, when enabled....

I cannot believe, that PhysX calculations have nothing to do with gpu-usage...
[/quote]

They actually have very little GPU [i]core[/i] usage. Arkham City only used about 5% of the core itself when I last checked. PhysX stays mostly in the shaders, and the monitoring software focuses on the core.
[quote name='Magneto' date='22 January 2012 - 02:59 AM' timestamp='1327222778' post='1359009']

Hi and thank you for your answer.



Now I tried beta Driver 295.18 and PhysX seems to work, because it shows, that PhysX-GPU is enabled in the game.



For testing purposes, I ran metro 2033 benchmark with advanced PhysX-Effects enabled.



BUT guess what... my gtx580 PhysX card gpu-usage is equal or less than 5 percent. that seems to be less for me.



I mean, metro 2033 is a game which makes fully usage of physX effects, when enabled....



I cannot believe, that PhysX calculations have nothing to do with gpu-usage...





They actually have very little GPU core usage. Arkham City only used about 5% of the core itself when I last checked. PhysX stays mostly in the shaders, and the monitoring software focuses on the core.

Done.

#10
Posted 01/22/2012 05:27 PM   
Hello again , you may find this info useful ....

http://www.geforce.com/Optimize
Hello again , you may find this info useful ....



http://www.geforce.com/Optimize

Image

#11
Posted 01/23/2012 10:49 AM   
Scroll To Top