Monitor stuck in 3d mode Monitor stuck in 3d mode 285.62drivers GTX580
Hi team,

After playing BF3 my BenQ monitor is stuck in 3D mode (the monitor tells me this) even though the light on the 3D emitter has gone dim. Can you help? Thanks

Best regards
Graham
Hi team,



After playing BF3 my BenQ monitor is stuck in 3D mode (the monitor tells me this) even though the light on the 3D emitter has gone dim. Can you help? Thanks



Best regards

Graham

#1
Posted 11/23/2011 12:41 AM   
It's a known issue, it happens when a game doesn't correctly shutdown the D3D Device
It's a known issue, it happens when a game doesn't correctly shutdown the D3D Device
#2
Posted 11/23/2011 12:53 AM   
Is there an easy way to fix it? Or do you have to reboot?
Is there an easy way to fix it? Or do you have to reboot?

#3
Posted 11/24/2011 06:01 AM   
[quote name='vvx' date='24 November 2011 - 07:01 AM' timestamp='1322114516' post='1332026']
Is there an easy way to fix it? Or do you have to reboot?
[/quote]
A log off/log on should be enough in all cases.

And in my experience it's also sufficient to start/close certain programs. Especially IE9 seems to be capable of solving the issue, ie. after closing an IE9 window, my monitor switched back to 2D on regular basis. Might be an coincidence, though.
[quote name='vvx' date='24 November 2011 - 07:01 AM' timestamp='1322114516' post='1332026']

Is there an easy way to fix it? Or do you have to reboot?



A log off/log on should be enough in all cases.



And in my experience it's also sufficient to start/close certain programs. Especially IE9 seems to be capable of solving the issue, ie. after closing an IE9 window, my monitor switched back to 2D on regular basis. Might be an coincidence, though.

#4
Posted 11/24/2011 07:45 AM   
[quote name='vvx' date='24 November 2011 - 10:01 AM' timestamp='1322114516' post='1332026']
Is there an easy way to fix it? Or do you have to reboot?
[/quote]
Easier solution would be launching any 3D programm, which shutdown 3d correctly, run it in 3D and then close it. I prefer to use 3D Vision player for this.
[quote name='vvx' date='24 November 2011 - 10:01 AM' timestamp='1322114516' post='1332026']

Is there an easy way to fix it? Or do you have to reboot?



Easier solution would be launching any 3D programm, which shutdown 3d correctly, run it in 3D and then close it. I prefer to use 3D Vision player for this.

System specs:



CPU:Intel Core i7 930 2800@3880 MHz (Cooled by Noctua NH-D14)

MB: Asus P6T Deluxe v.2

RAM: 6 GB Kingston HyperX (KHX1600C8D3K3/6GX)

GPU: Zotac GTX480 AMP! Edition @ 800 Mhz (core)

HDD: 2Tb SATA-II Western Digital Caviar Black + 2Tb SATA-II Samsung EcoGreen F4EG

Sound: Creative X-Fi Titanium

DVD-RW: ASUS DRW-24B1ST

Case: Aerocool BX-500

PSU: OCZ Z-1000w

Monitor: LG W2363D + nVidia 3D Vision

OS: Windows 7 Ultimate x64 SP1

#5
Posted 11/24/2011 01:38 PM   
Change the monitor refresh-rate in Nvidia Controlpanel.
Change the monitor refresh-rate in Nvidia Controlpanel.

Graphics Card: GTX 780 Ti SLI; Monitor: Acer HN274h

#6
Posted 11/24/2011 04:08 PM   
You can also try closing out whatever browser you launched BF3 with. Sometimes that can be the cause of the monitor staying in 3D mode.
You can also try closing out whatever browser you launched BF3 with. Sometimes that can be the cause of the monitor staying in 3D mode.

-=HeliX=- Mod 3DV Game Fixes
My 3D Vision Games List Ratings

Intel Core i7 920 D0 @4.0GHz 1.29V | EVGA X58 Classified 760 | Win7 x64 Ultimate | Antec 620 LC
Galaxy GeForce GTX 670 GC SLI | Asus VG278H 120Hz LCD + 3D Vision 2 | 12GB Samsung DDR3 1600 35nm
Intel X25-M G2 160GB SSD | WD Black 3x1.5TB RAID 0 | Kingston HyperX 2x128GB SSD RAID 0
Sony STR-DG1000 A/V Receiver | Polk Audio RM6880 7.1 | LG Blu-Ray
Auzen X-Fi HT HD | Logitech G700/G110/G27 | CM HAF X Blue | Antec TPQ-1200W

#7
Posted 11/24/2011 05:12 PM   
[quote name='sebRab' date='24 November 2011 - 09:08 AM' timestamp='1322150933' post='1332190']
Change the monitor refresh-rate in Nvidia Controlpanel.
[/quote]

Of the suggested fixes, this one works. Almost seems like Nvidia should create some tiny application that turns off 3d. Something I could open/close real quick and have it turn off 3d, not having to go into the nvidia control panel or anything like that. Then again, programmers don't like writing a work around for what is a bug, it'd be better to fix the bug. That doesn't seem to be happening either though.
[quote name='sebRab' date='24 November 2011 - 09:08 AM' timestamp='1322150933' post='1332190']

Change the monitor refresh-rate in Nvidia Controlpanel.





Of the suggested fixes, this one works. Almost seems like Nvidia should create some tiny application that turns off 3d. Something I could open/close real quick and have it turn off 3d, not having to go into the nvidia control panel or anything like that. Then again, programmers don't like writing a work around for what is a bug, it'd be better to fix the bug. That doesn't seem to be happening either though.

#8
Posted 11/27/2011 01:43 AM   
[quote name='vvx' date='26 November 2011 - 09:43 PM' timestamp='1322358226' post='1333267']
Almost seems like Nvidia should create some tiny application that turns off 3d. Something I could open/close real quick and have it turn off 3d, not having to go into the nvidia control panel or anything like that.
[/quote]
They did. Look in the start menu under Nvidia Corporation.
[quote name='vvx' date='26 November 2011 - 09:43 PM' timestamp='1322358226' post='1333267']

Almost seems like Nvidia should create some tiny application that turns off 3d. Something I could open/close real quick and have it turn off 3d, not having to go into the nvidia control panel or anything like that.



They did. Look in the start menu under Nvidia Corporation.
#9
Posted 11/27/2011 02:35 AM   
Oh my... now I feel stupid... :)

Never took a look into that start menu. Thanks, cyber! :)
Oh my... now I feel stupid... :)



Never took a look into that start menu. Thanks, cyber! :)

#10
Posted 11/27/2011 05:18 PM   
Scroll To Top