Sonic Generation Optimus Fail Sonic Generations won't run off the 555M GT card
  1 / 5    
Hello,

I downloaded Sonic Generations on my Steam, and I wasn't able to get it running on my laptop. When I go to the Configure option, it only lists the Intel card, and the game won't run if you try to use the card that wasn't configured in the settings.

Here is the cfg file:

Do not manually edit this file, use the configuration tool.
Intel(R) HD Graphics Family
\\.\DISPLAY1
1366.768.60
1 (this is for AA)
0 (This is for Wide/letterbox)
1 (this is for Shadows)
1 (This is for Reflection)
0 (v-sync)
d7b78e66-4256-11cf-ea52-9d24b7c2c535
MONITOR\LGD0292\{4d36e96e-e325-11ce-bfc1-08002be10318}\0000
1515474505

I tried renaming some of the Intel(R) HD Graphics Family to NVIDIA GeForce GT 555M, even tried GeForce GT 555M(0)....but nothing seems to work.

I also tried adding both the configuration tool and the game exe to the Nvidia control panel and forcing the Nvidia video card but still nothing.

Any help?

I'm going to assume that it is the dev fault, they need to take out the stupid "your hardware doesn't match those found in config file" error when you start the game.

When I unplug my laptop, the game runs fine, ofc at 17 fps since the intel video card is pushing the game.

Thanks!
Hello,



I downloaded Sonic Generations on my Steam, and I wasn't able to get it running on my laptop. When I go to the Configure option, it only lists the Intel card, and the game won't run if you try to use the card that wasn't configured in the settings.



Here is the cfg file:



Do not manually edit this file, use the configuration tool.

Intel(R) HD Graphics Family

\\.\DISPLAY1

1366.768.60

1 (this is for AA)

0 (This is for Wide/letterbox)

1 (this is for Shadows)

1 (This is for Reflection)

0 (v-sync)

d7b78e66-4256-11cf-ea52-9d24b7c2c535

MONITOR\LGD0292\{4d36e96e-e325-11ce-bfc1-08002be10318}\0000

1515474505



I tried renaming some of the Intel(R) HD Graphics Family to NVIDIA GeForce GT 555M, even tried GeForce GT 555M(0)....but nothing seems to work.



I also tried adding both the configuration tool and the game exe to the Nvidia control panel and forcing the Nvidia video card but still nothing.



Any help?



I'm going to assume that it is the dev fault, they need to take out the stupid "your hardware doesn't match those found in config file" error when you start the game.



When I unplug my laptop, the game runs fine, ofc at 17 fps since the intel video card is pushing the game.



Thanks!

Alienware m14x (Black)- Dellâ„¢ Laptop, Intel Core i7 2630QM 2.0GHz, 6 GB DDR 1600 MHZ, 750GB 7,200RPM SATA-II HDD, NV GeForce GT555M 1.5GB VRAM, 14.0 HD (720p/1366x768)/WLED, Win 7 Home Prem 64



Custom PC (NZXT Phatom case)- i7 920 @ 4.3 GHZ, 6 GB Ram, 128 SSD + 2 Raptors 150s Raid 0 and 2 TB Seagate, 580 GTX SLI (21.5 Inch 1080p Monitor Samsung).



GameBlurb Community: http://steamcommunity.com/groups/GameBlurb

#1
Posted 11/04/2011 01:58 PM   
Exact same problem here, and I tried the same workarounds. This is completely stupid.
Exact same problem here, and I tried the same workarounds. This is completely stupid.

#2
Posted 11/06/2011 03:27 PM   
i got it to run with mine somehow by playing with nvidia control panel , it shows Nvidia 310m but the gpu is off so i cant start the game :( help is apreciated
i got it to run with mine somehow by playing with nvidia control panel , it shows Nvidia 310m but the gpu is off so i cant start the game :( help is apreciated

#3
Posted 11/08/2011 02:19 PM   
Well, unfortunately I have the same problem. I have a GEFORCE GT 540M and it only recognizes the Intel(R) HD family card...
However, with the Nvidia Panel I put the 3D parameters working with the Intell card so I can play to the game.
But it sucks... (Optimus fault again!)

Please, NVidia, help us!!!
Well, unfortunately I have the same problem. I have a GEFORCE GT 540M and it only recognizes the Intel(R) HD family card...

However, with the Nvidia Panel I put the 3D parameters working with the Intell card so I can play to the game.

But it sucks... (Optimus fault again!)



Please, NVidia, help us!!!

#4
Posted 11/08/2011 05:38 PM   
Same problem here. It really SUCK becouse i spent some money for technology isnt supported!!!! WTF IS THIS!!!
Same problem here. It really SUCK becouse i spent some money for technology isnt supported!!!! WTF IS THIS!!!

#5
Posted 11/09/2011 10:18 PM   
Same problem on my Acer Aspire 5750G with the latest driver version.
The Workaround doesn't work at all!
Same problem on my Acer Aspire 5750G with the latest driver version.

The Workaround doesn't work at all!

#6
Posted 11/10/2011 01:45 AM   
I have contacted SEGA customer support about this and got a reply in like 2 minutes (fast!).

[quote]Dear Customer,

Thank you for contacting SEGA Support.

We are sorry to read that you are encountering this problem with Sonic Generations.

There have been reports of users encountering issues related to the Optimus technology, where games are not being sent the right information regarding the dedicated graphics card and so problems like those you are experiencing arise.

Unfortunately we are not able to provide you with additional assistance, as the Optimus Technology issue is a compatibility problem that is affecting a wide range of games at the moment and we cannot offer any more troubleshooting steps on our side, since the problem lies in the communication between the graphics card drivers and the applications.

However, please rest assured that both the developers and Nvidia are working in order to solve this issue as soon as possible. Please check the Nvidia website for alerts on new driver updates, as they are currently working on a solution in the form of a new driver release.

Kind regards,

Sylvain.[/quote]

tl;dr: this will probably be fixed in a driver and/or game update soon enough.

I'll try to enjoy the game using low graphics mode in the meantime, I suppose. :)
I have contacted SEGA customer support about this and got a reply in like 2 minutes (fast!).



Dear Customer,



Thank you for contacting SEGA Support.



We are sorry to read that you are encountering this problem with Sonic Generations.



There have been reports of users encountering issues related to the Optimus technology, where games are not being sent the right information regarding the dedicated graphics card and so problems like those you are experiencing arise.



Unfortunately we are not able to provide you with additional assistance, as the Optimus Technology issue is a compatibility problem that is affecting a wide range of games at the moment and we cannot offer any more troubleshooting steps on our side, since the problem lies in the communication between the graphics card drivers and the applications.



However, please rest assured that both the developers and Nvidia are working in order to solve this issue as soon as possible. Please check the Nvidia website for alerts on new driver updates, as they are currently working on a solution in the form of a new driver release.



Kind regards,



Sylvain.




tl;dr: this will probably be fixed in a driver and/or game update soon enough.



I'll try to enjoy the game using low graphics mode in the meantime, I suppose. :)

#7
Posted 11/10/2011 05:17 PM   
Sonic Generations doesn't detect the nvidia graphics cards with optimus, but I did find a fix on the internet. It worked for me.

Here‘s a fix for anyone using nvidia graphics cards with optimus. The game doesn‘t detect the graphics card and a patch hasn‘t come out so follow the instructions.

1) Open the nvidia control panel and add both the Config and Game.exe under 3D settings.

2) Switch them both to [High Performance Nvidia Processor]

3) Apply

4) Select [Screen Resolution] from the desktop and click Detect, (Just right click the desktop and then click detect after selecting "screen resolution' in the window that pops up.)

5) Click the greyed out display/displays and look for your Nvidia card. Then ‘attempt to connect anyway‘

6) Apply then select ‘Extend displays‘

7) Open the sonic config and select your nvidia card and play (I still got the error message at this step so I selected the integrated card in the configuration tool, but it still ran on the nvidia card.)

The game runs a lot better on a dedicated graphics card
Sonic Generations doesn't detect the nvidia graphics cards with optimus, but I did find a fix on the internet. It worked for me.



Here‘s a fix for anyone using nvidia graphics cards with optimus. The game doesn‘t detect the graphics card and a patch hasn‘t come out so follow the instructions.



1) Open the nvidia control panel and add both the Config and Game.exe under 3D settings.



2) Switch them both to [High Performance Nvidia Processor]



3) Apply



4) Select [Screen Resolution] from the desktop and click Detect, (Just right click the desktop and then click detect after selecting "screen resolution' in the window that pops up.)



5) Click the greyed out display/displays and look for your Nvidia card. Then ‘attempt to connect anyway‘



6) Apply then select ‘Extend displays‘



7) Open the sonic config and select your nvidia card and play (I still got the error message at this step so I selected the integrated card in the configuration tool, but it still ran on the nvidia card.)



The game runs a lot better on a dedicated graphics card

#8
Posted 11/18/2011 01:55 PM   
Hi Everyone, we are currently working on a solution. We'll integrate the fix into the future updates once its completed.
Hi Everyone, we are currently working on a solution. We'll integrate the fix into the future updates once its completed.

NVIDIA Techical Support

#9
Posted 11/18/2011 10:15 PM   
[quote name='GeforceDave' date='18 November 2011 - 11:15 PM' timestamp='1321654528' post='1329061']
Hi Everyone, we are currently working on a solution. We'll integrate the fix into the future updates once its completed.
[/quote]
I appreciate it. Good to see that something is being done about this.
[quote name='GeforceDave' date='18 November 2011 - 11:15 PM' timestamp='1321654528' post='1329061']

Hi Everyone, we are currently working on a solution. We'll integrate the fix into the future updates once its completed.



I appreciate it. Good to see that something is being done about this.

#10
Posted 11/19/2011 12:09 PM   
[quote name='GeforceDave' date='18 November 2011 - 05:15 PM' timestamp='1321654528' post='1329061']
Hi Everyone, we are currently working on a solution. We'll integrate the fix into the future updates once its completed.
[/quote]



Any idea on when this game will work with nvidia? it is unplayable on the graphics adapter its trying to use, and i cant switch to nvidia still. is that fix still on its way?
[quote name='GeforceDave' date='18 November 2011 - 05:15 PM' timestamp='1321654528' post='1329061']

Hi Everyone, we are currently working on a solution. We'll integrate the fix into the future updates once its completed.









Any idea on when this game will work with nvidia? it is unplayable on the graphics adapter its trying to use, and i cant switch to nvidia still. is that fix still on its way?

#11
Posted 11/24/2011 12:45 PM   
Good to see some confirmation from tech support! I already finished this game, but I'll be sure to come back and play it in full quality once it works with Optimus. :)

[quote name='piz' date='18 November 2011 - 01:55 PM' timestamp='1321624513' post='1328833']
Sonic Generations doesn't detect the nvidia graphics cards with optimus, but I did find a fix on the internet. It worked for me.

Here‘s a fix for anyone using nvidia graphics cards with optimus. The game doesn‘t detect the graphics card and a patch hasn‘t come out so follow the instructions.

1) Open the nvidia control panel and add both the Config and Game.exe under 3D settings.
...
7) Open the sonic config and select your nvidia card and play (I still got the error message at this step so I selected the integrated card in the configuration tool, but it still ran on the nvidia card.)

The game runs a lot better on a dedicated graphics card
[/quote]
Just a heads up, this does not work for all NVidia graphics cards using Optimus. For example, on my K93SV notebook, I can only ever output video through Intel cards. Heck, even if I disable the Intel driver in the device manager, my PC won't use the NVidia graphics drive to take over displaying my screens. This might be some hardware limitation (monitors physically connected to the Intel GPU?).
Good to see some confirmation from tech support! I already finished this game, but I'll be sure to come back and play it in full quality once it works with Optimus. :)



[quote name='piz' date='18 November 2011 - 01:55 PM' timestamp='1321624513' post='1328833']

Sonic Generations doesn't detect the nvidia graphics cards with optimus, but I did find a fix on the internet. It worked for me.



Here‘s a fix for anyone using nvidia graphics cards with optimus. The game doesn‘t detect the graphics card and a patch hasn‘t come out so follow the instructions.



1) Open the nvidia control panel and add both the Config and Game.exe under 3D settings.

...

7) Open the sonic config and select your nvidia card and play (I still got the error message at this step so I selected the integrated card in the configuration tool, but it still ran on the nvidia card.)



The game runs a lot better on a dedicated graphics card



Just a heads up, this does not work for all NVidia graphics cards using Optimus. For example, on my K93SV notebook, I can only ever output video through Intel cards. Heck, even if I disable the Intel driver in the device manager, my PC won't use the NVidia graphics drive to take over displaying my screens. This might be some hardware limitation (monitors physically connected to the Intel GPU?).

#12
Posted 11/28/2011 08:01 PM   
290.36 still no fix
290.36 still no fix

GT540M, i5 2.4ghz 4 cores, 6gb RAM, Win8 x64
no overclocks

#13
Posted 11/30/2011 11:03 AM   
Same problem, and since my Alienware M11x has no VGA port, I don't even have the option of "phantom" multiple displays for the workaround people are posting.
And all my manual manipulations of GUIDs in the config file didn't work.

It truly is a shame there's no "Absolutely-force Intel off" option, so I could at least have a battery-draining workaround (for which I'd be connected to wall power anyway).
Same problem, and since my Alienware M11x has no VGA port, I don't even have the option of "phantom" multiple displays for the workaround people are posting.

And all my manual manipulations of GUIDs in the config file didn't work.



It truly is a shame there's no "Absolutely-force Intel off" option, so I could at least have a battery-draining workaround (for which I'd be connected to wall power anyway).

#14
Posted 12/05/2011 01:21 PM   
On mine, I have to disable the Intel IGP via Device manager, then launch the game. It works well but can cause Nvidia's driver to become unstable after exiting for the rest of your Windows session.
On mine, I have to disable the Intel IGP via Device manager, then launch the game. It works well but can cause Nvidia's driver to become unstable after exiting for the rest of your Windows session.

#15
Posted 12/12/2011 09:57 PM   
  1 / 5    
Scroll To Top