Possible TDR workaround has been found A few games will have performance halved*
  1 / 3    
[b]NOTE: This fix has been used with the 285.62 WHQL drivers on my Asus GTX 480. I see no reason why it wouldn't work with newer drivers.[/b]

[b]*Note that your GPU clocks will be about half of what they are at full power. For some reason, this doesn't matter for some games. In the Witcher 2 and Battlefield Bad Company 2, my FPS is still perfectly normal. In Crysis Warhead though, my FPS is about half what it normally is. However, I can play many games without any FPS drop, and I have no more crashing while I'm just doing stuff on my desktop either.[/b]

If you are getting "Display driver nvlddmkm stopped responding and has successfully recovered" with 28x.xx drivers, this is for you. Here are the steps to fix the problem. I'll explain how I found all of this out later. The steps are really very easy and should take less than 5 minutes.

1. Download NVIDIA Inspector 1.9.5.5
2. Unzip on your desktop, launch program
3. Right click on the "show overclocking" box in the bottom right corner of the window
4. Click "Start multi display power saver"
5. Select your GPU in the "target GPUs" box
6. Select "run multi display power saver at windows startup"
7. Select "Activate P8 State by VPU Usage - Threshold"
8. Adjust the slider so that you have threshold 0%
9. Now, here's a small catch. Go to youtube and open up any video. Pause it and minimize. This gets your VPU usage to something very small, but finite. Once you have the video paused, go back to the nvidia inspector multi display power saver window
10. You should see "current performance state" be "P8", and it should be steady at P8. It should not say P12. If it says P12, make sure you have that video around still! Also make sure that "forced performance state limit" says P8.

You're good to go! Enjoy your stability. :)

Just make sure you keep that youtube video up. You need a finite VPU (video processor usage, I think) in order to maintain the P8 state. If you don't, you'll fall into the P12 state and your computer will probably crash when you try to launch a game. So just keep the video paused in the background, and that's the only catch.

[u][b]The Long Story[/b][/u]
So for those of you wondering what's going on with all this, I'll explain.

This TDR problem has been plaguing me since the new drivers came out. I also have tried to revert to 275.33 drivers, but no success. TDR problem would still occur. However, I COULD get rid of it if I installed an ATI card and its drivers, and then reinstalled my GTX 480 and the 275.33 drivers. Then the TDR would be gone. But many of you don't have an ATI card lying around.

So anyway, I was just doing some homework like normal and my drivers crashed, like normal (these days...). I had MSI afterburner up for some reason at the time. I happened to notice that all my clocks were low. My Clocks were core: 405, memory 324, shader 810. Normally I have core: 700, memory 1848, shader 1401. I didn't really care at the time, I just thought it was odd. The other odd thing is that those clock speeds were frozen and wouldn't budge no matter what I tried. Well, after some time I noticed I had no TDR crashes at all. I thought that was weird/awesome, so I wasn't going to argue with success! I launched a few games, and there were no crashes! I could hardly believe it. But eventually I had to restart my computer, and I lost those clock speeds.

So I knew that I needed those clock speeds again to get my stability back. I did some research, and apparently different power states exist for graphics cards. The nvidia inspector program lets you hold onto a certain state and keep your card there. Video cards have different power states: P12, P8, P3, and P0.
P0 = full power 3d
P3 = low power 3d
P8 = video (lower voltage)
P12 = 2d mode (lower voltage)

P12 is really low power mode. If you try to use P12 and launch a game or something demanding, your computer will probably just freeze. Mine did. But if I run at P8 all the time, I have my stability AND my computer is just like normal for many games! So the goal is to hit P8. The steps that I outlined earlier are what lock you into P8 mode.


So I hope this helps you guys with the TDR problems. At the very least, I suspect your normal web browsing won't be interrupted by TDRs or mouse corruption (which I was getting a lot of). Enjoy!

Please post and let me know if this works for you.


My system specs, if it helps:
Asus P6X58D-Premium
Intel core i7 930 OC'd to 3.5GHz
Asus GTX 480
12GB Corsair XMS3 at 667MHz (6x2GB)
128GB C300 SSD
1TB Samsung F3
500GB Samsung F3
Antec 300 Illusion Black Steel ATX
NOTE: This fix has been used with the 285.62 WHQL drivers on my Asus GTX 480. I see no reason why it wouldn't work with newer drivers.



*Note that your GPU clocks will be about half of what they are at full power. For some reason, this doesn't matter for some games. In the Witcher 2 and Battlefield Bad Company 2, my FPS is still perfectly normal. In Crysis Warhead though, my FPS is about half what it normally is. However, I can play many games without any FPS drop, and I have no more crashing while I'm just doing stuff on my desktop either.



If you are getting "Display driver nvlddmkm stopped responding and has successfully recovered" with 28x.xx drivers, this is for you. Here are the steps to fix the problem. I'll explain how I found all of this out later. The steps are really very easy and should take less than 5 minutes.



1. Download NVIDIA Inspector 1.9.5.5

2. Unzip on your desktop, launch program

3. Right click on the "show overclocking" box in the bottom right corner of the window

4. Click "Start multi display power saver"

5. Select your GPU in the "target GPUs" box

6. Select "run multi display power saver at windows startup"

7. Select "Activate P8 State by VPU Usage - Threshold"

8. Adjust the slider so that you have threshold 0%

9. Now, here's a small catch. Go to youtube and open up any video. Pause it and minimize. This gets your VPU usage to something very small, but finite. Once you have the video paused, go back to the nvidia inspector multi display power saver window

10. You should see "current performance state" be "P8", and it should be steady at P8. It should not say P12. If it says P12, make sure you have that video around still! Also make sure that "forced performance state limit" says P8.



You're good to go! Enjoy your stability. :)



Just make sure you keep that youtube video up. You need a finite VPU (video processor usage, I think) in order to maintain the P8 state. If you don't, you'll fall into the P12 state and your computer will probably crash when you try to launch a game. So just keep the video paused in the background, and that's the only catch.



The Long Story

So for those of you wondering what's going on with all this, I'll explain.



This TDR problem has been plaguing me since the new drivers came out. I also have tried to revert to 275.33 drivers, but no success. TDR problem would still occur. However, I COULD get rid of it if I installed an ATI card and its drivers, and then reinstalled my GTX 480 and the 275.33 drivers. Then the TDR would be gone. But many of you don't have an ATI card lying around.



So anyway, I was just doing some homework like normal and my drivers crashed, like normal (these days...). I had MSI afterburner up for some reason at the time. I happened to notice that all my clocks were low. My Clocks were core: 405, memory 324, shader 810. Normally I have core: 700, memory 1848, shader 1401. I didn't really care at the time, I just thought it was odd. The other odd thing is that those clock speeds were frozen and wouldn't budge no matter what I tried. Well, after some time I noticed I had no TDR crashes at all. I thought that was weird/awesome, so I wasn't going to argue with success! I launched a few games, and there were no crashes! I could hardly believe it. But eventually I had to restart my computer, and I lost those clock speeds.



So I knew that I needed those clock speeds again to get my stability back. I did some research, and apparently different power states exist for graphics cards. The nvidia inspector program lets you hold onto a certain state and keep your card there. Video cards have different power states: P12, P8, P3, and P0.

P0 = full power 3d

P3 = low power 3d

P8 = video (lower voltage)

P12 = 2d mode (lower voltage)



P12 is really low power mode. If you try to use P12 and launch a game or something demanding, your computer will probably just freeze. Mine did. But if I run at P8 all the time, I have my stability AND my computer is just like normal for many games! So the goal is to hit P8. The steps that I outlined earlier are what lock you into P8 mode.





So I hope this helps you guys with the TDR problems. At the very least, I suspect your normal web browsing won't be interrupted by TDRs or mouse corruption (which I was getting a lot of). Enjoy!



Please post and let me know if this works for you.





My system specs, if it helps:

Asus P6X58D-Premium

Intel core i7 930 OC'd to 3.5GHz

Asus GTX 480

12GB Corsair XMS3 at 667MHz (6x2GB)

128GB C300 SSD

1TB Samsung F3

500GB Samsung F3

Antec 300 Illusion Black Steel ATX

#1
Posted 11/02/2011 08:07 PM   
Can you guys see this post? It's been almost two hours and I figured someone would have at least viewed the post. I'm anxious to see if it works for the rest of you. :o
Can you guys see this post? It's been almost two hours and I figured someone would have at least viewed the post. I'm anxious to see if it works for the rest of you. :o

#2
Posted 11/02/2011 09:51 PM   
can anyone try and confirm this?

edit: @kingforger - why p8 and not p0 for full 3d power?
can anyone try and confirm this?



edit: @kingforger - why p8 and not p0 for full 3d power?

#3
Posted 11/02/2011 09:52 PM   
Because for some unknown reason, full power crashes the drivers. The lower clock speeds of P8 does not crash them. If you enabled P0, then you wouldn't be changing anything. The entire point is to lock yourself in at P8 speeds.
Because for some unknown reason, full power crashes the drivers. The lower clock speeds of P8 does not crash them. If you enabled P0, then you wouldn't be changing anything. The entire point is to lock yourself in at P8 speeds.

#4
Posted 11/02/2011 09:59 PM   
This may key nVidia into a possible bug but I fail to see how its any sort of solution.

So to make your equipment operate properly you need to reduce its efficiency by quite a bit and always have youtube open?
This may key nVidia into a possible bug but I fail to see how its any sort of solution.



So to make your equipment operate properly you need to reduce its efficiency by quite a bit and always have youtube open?

PNY GTX 560Ti XLR8 OC2 (stock factory OC)

i5 2500K (stock)

ASRock P67 Extreme4 Gen3

2x4GB GSkill Ripjax X 1600 (stock XMP)

ASUS VH238H

Windows 7 Home Premium x64

#5
Posted 11/02/2011 10:12 PM   
You just pause the video. You just want a finite VPU usage. In other words, you need to go from 0% to about 0.5% usage (while it's paused). This enables the nvidia inspector to enable P8.

Like I said, this is a workaround. It takes away TDR problems, and the performance for some games is just like normal. But you ARE running at half clock speeds, so for other games your performance will be effectively in half. It's a hell of a lot better than crashing every 10 minutes on desktop or every 30 seconds in game like I was getting.
You just pause the video. You just want a finite VPU usage. In other words, you need to go from 0% to about 0.5% usage (while it's paused). This enables the nvidia inspector to enable P8.



Like I said, this is a workaround. It takes away TDR problems, and the performance for some games is just like normal. But you ARE running at half clock speeds, so for other games your performance will be effectively in half. It's a hell of a lot better than crashing every 10 minutes on desktop or every 30 seconds in game like I was getting.

#6
Posted 11/02/2011 10:19 PM   
Why would anybody want to lower their power state permanently. If you turn off power management your TDR's are gone and you dont have to "down clock" your card. I am still not sure if I understand your post fully.

There is already a well known fix for the TDR's. Its all over the forums.
Why would anybody want to lower their power state permanently. If you turn off power management your TDR's are gone and you dont have to "down clock" your card. I am still not sure if I understand your post fully.



There is already a well known fix for the TDR's. Its all over the forums.

#7
Posted 11/02/2011 10:20 PM   
[quote name='wkhtl' date='02 November 2011 - 06:12 PM' timestamp='1320271923' post='1319464']
This may key nVidia into a possible bug but I fail to see how its any sort of solution.

So to make your equipment operate properly you need to reduce its efficiency by quite a bit and always have youtube open?
[/quote]

yeh I find that a little nuts too. lol But when it comes to dealing with nv's constant crap over the years, "whatever works" seems to be all we can do. /wallbash.gif' class='bbc_emoticon' alt=':wallbash:' />
[quote name='wkhtl' date='02 November 2011 - 06:12 PM' timestamp='1320271923' post='1319464']

This may key nVidia into a possible bug but I fail to see how its any sort of solution.



So to make your equipment operate properly you need to reduce its efficiency by quite a bit and always have youtube open?





yeh I find that a little nuts too. lol But when it comes to dealing with nv's constant crap over the years, "whatever works" seems to be all we can do. /wallbash.gif' class='bbc_emoticon' alt=':wallbash:' />

#8
Posted 11/02/2011 10:20 PM   
I'd rather just revert to 275.33 and run fully stable and not leave open anything I dont want to and not downclock my GPU.

Now I mean, congrats to you for finding a workaround and its impressive that you went that deep, I'm just saying at least for me its not a viable solution that works better for me than 275.33
I'd rather just revert to 275.33 and run fully stable and not leave open anything I dont want to and not downclock my GPU.



Now I mean, congrats to you for finding a workaround and its impressive that you went that deep, I'm just saying at least for me its not a viable solution that works better for me than 275.33

PNY GTX 560Ti XLR8 OC2 (stock factory OC)

i5 2500K (stock)

ASRock P67 Extreme4 Gen3

2x4GB GSkill Ripjax X 1600 (stock XMP)

ASUS VH238H

Windows 7 Home Premium x64

#9
Posted 11/02/2011 10:23 PM   
[quote name='chraze' date='02 November 2011 - 06:20 PM' timestamp='1320272413' post='1319471']
Why would anybody want to lower their power state permanently. If you turn off power management your TDR's are gone and you dont have to "down clock" your card. I am still not sure if I understand your post fully.

There is already a well known fix for the TDR's. Its all over the forums.
[/quote]

Really? Can you link me to it? Why are so many people still complaining if a solution is around? If it's that registry one, it doesn't work for me. Furthermore, turning off power management hasn't worked for many of us. I've read a lot of people's accounts of this problem. I've been on this driver forum for the last month lol. Only now am I posting.

And wkhtl, I suppose that's right. I wasn't able to revert to 275.33 unless I installed an ATI card first... However, I also have the benefit of being able to play witcher 2 and BFBC2 with the new drivers, which have much better performance (even though my clocks are down).
[quote name='chraze' date='02 November 2011 - 06:20 PM' timestamp='1320272413' post='1319471']

Why would anybody want to lower their power state permanently. If you turn off power management your TDR's are gone and you dont have to "down clock" your card. I am still not sure if I understand your post fully.



There is already a well known fix for the TDR's. Its all over the forums.





Really? Can you link me to it? Why are so many people still complaining if a solution is around? If it's that registry one, it doesn't work for me. Furthermore, turning off power management hasn't worked for many of us. I've read a lot of people's accounts of this problem. I've been on this driver forum for the last month lol. Only now am I posting.



And wkhtl, I suppose that's right. I wasn't able to revert to 275.33 unless I installed an ATI card first... However, I also have the benefit of being able to play witcher 2 and BFBC2 with the new drivers, which have much better performance (even though my clocks are down).

#10
Posted 11/02/2011 10:23 PM   
This helped. I had freezes/driver lockups on all drivers from 267.59 over 275.33 up to 285.62 and changing settings would not help. Forcing the P8 Power State eliminated ALL freezes/lockups at the cost of losing more than 50% of my FPS, they would go down from e.g. 75 FPS down to 30 FPS. But atm, having no freezes is still worth it.
This helped. I had freezes/driver lockups on all drivers from 267.59 over 275.33 up to 285.62 and changing settings would not help. Forcing the P8 Power State eliminated ALL freezes/lockups at the cost of losing more than 50% of my FPS, they would go down from e.g. 75 FPS down to 30 FPS. But atm, having no freezes is still worth it.

#11
Posted 11/09/2011 08:14 AM   
No help here. My problem is when i watch videos, no matter which browser, i get same error. Have to try those old drivers :(
( NVidia gtx 570 hd ds)
No help here. My problem is when i watch videos, no matter which browser, i get same error. Have to try those old drivers :(

( NVidia gtx 570 hd ds)

#12
Posted 11/09/2011 11:03 AM   
Now this is odd. I tryed those 275.33 drivers and they wont help either. Well, i run driversweeper and install again those new drivers with that ( clean install) or what ever was which is in that install box. Now everything works like they should be. For now /unsure.gif' class='bbc_emoticon' alt=':unsure:' />
Now this is odd. I tryed those 275.33 drivers and they wont help either. Well, i run driversweeper and install again those new drivers with that ( clean install) or what ever was which is in that install box. Now everything works like they should be. For now /unsure.gif' class='bbc_emoticon' alt=':unsure:' />

#13
Posted 11/09/2011 12:08 PM   
A real fix would be to buy a ATI card as nvidia have lost their ****
A real fix would be to buy a ATI card as nvidia have lost their ****

#14
Posted 11/09/2011 02:14 PM   
Huoh.. no help after all. Random crash from driver keeps going.

One good solutions would be buy a Radeon too. Those drivers was a reason why i buy Nvidia few years ago but i see those was a "golden years". Same driver sh*t and nvidias ( your hardware is a problem) bs as like it was in Ati. Maybe some "yellow liquid" has rise nvidias camp after few good years /thumbsdown.gif' class='bbc_emoticon' alt=':thumbsdown:' />
Huoh.. no help after all. Random crash from driver keeps going.



One good solutions would be buy a Radeon too. Those drivers was a reason why i buy Nvidia few years ago but i see those was a "golden years". Same driver sh*t and nvidias ( your hardware is a problem) bs as like it was in Ati. Maybe some "yellow liquid" has rise nvidias camp after few good years /thumbsdown.gif' class='bbc_emoticon' alt=':thumbsdown:' />

#15
Posted 11/09/2011 09:52 PM   
  1 / 3    
Scroll To Top