DirectX function "GetDeviceRemovedReason" failed with DXGI_ERROR_DEVICE_HUNG: Device hung du
The title says it all Folks, I know assumption is the mother of all fuc* ups but I have been having this trouble with the battlefield 3 beta and the full release version of the game and i am assuming that this:

"DirectX function "GetDeviceRemovedReason" failed with DXGI_ERROR_DEVICE_HUNG: Device hung due to badly formed commands... GPU: "NVIDIA GeForce GTX 560 Ti", Driver 28562"

is the cause for my game constantly crashing
http://www.mediafire.com/?dh058htrvu84npy [mediafire.com]

CPU:AMD Phenom(tm) II X4 965 processor (4CPU's), ~3.4GHz
overclocked?: No
GPU:NVIDIA GeForce GTX 560 Ti
sli or Crossfire: no
GPU Driver version: 285.62
Ram: 4 GB
sound card(if used): Creative SB X-Fi
Sound card driver version:6.00.0001.1347

The problem I am having happens every game wether it is MP or SP. I will join a server Play fine for 10-20 mins then the game will freeze with a black screen while a buzzing sound for 2 secs then the last sound played will repeat the last second. Another problem is in SP the game will randomly lag during non intense parts usually when moving inbetween fights. the problem I had in the beta was the same one i am having now with the multiplayer, there are no crash or error reports and I have the latest drivers for my GFX card.

the only way i got an error report was by going into my advanced system settings> performance options and adjusting for best performance and with this it made it look like i had gone back to Win98. and i ran the game and when it crashed i got the error message.

Please help
The title says it all Folks, I know assumption is the mother of all fuc* ups but I have been having this trouble with the battlefield 3 beta and the full release version of the game and i am assuming that this:



"DirectX function "GetDeviceRemovedReason" failed with DXGI_ERROR_DEVICE_HUNG: Device hung due to badly formed commands... GPU: "NVIDIA GeForce GTX 560 Ti", Driver 28562"



is the cause for my game constantly crashing

http://www.mediafire.com/?dh058htrvu84npy
[mediafire.com]



CPU:AMD Phenom(tm) II X4 965 processor (4CPU's), ~3.4GHz

overclocked?: No

GPU:NVIDIA GeForce GTX 560 Ti

sli or Crossfire: no

GPU Driver version: 285.62

Ram: 4 GB

sound card(if used): Creative SB X-Fi

Sound card driver version:6.00.0001.1347



The problem I am having happens every game wether it is MP or SP. I will join a server Play fine for 10-20 mins then the game will freeze with a black screen while a buzzing sound for 2 secs then the last sound played will repeat the last second. Another problem is in SP the game will randomly lag during non intense parts usually when moving inbetween fights. the problem I had in the beta was the same one i am having now with the multiplayer, there are no crash or error reports and I have the latest drivers for my GFX card.



the only way i got an error report was by going into my advanced system settings> performance options and adjusting for best performance and with this it made it look like i had gone back to Win98. and i ran the game and when it crashed i got the error message.



Please help

#1
Posted 10/26/2011 07:06 PM   
Hello, I have the same video card and had the same problem (ctd with the given error message "DXGI_ERROR_DEVICE_HUNG" in roughly every 10 minutes).

Here is what I did:

1.) checked video card driver and updated to latest beta driver
2.) updated directx
3.) stopped my anti-virus program

(none of the above really helped, but then...)

4.) I have updated the BIOS of the video card -> so far (1 hour of gaming) all my problems are gone, no ctd, no freezes, no slowdowns.

Note: flashing the BIOS of the video card is easy, but not for the faint hearted (you may damage your card).

First identify your video card sub-type (mine is GV-N560OC-1GI), and pick it here:
http://www.gigabyte.us/support-downloads/download-center.aspx
and download the BIOS for your card (double check if it is really your BIOS).

Then unpack, run, reboot, enjoy. :-)
Hello, I have the same video card and had the same problem (ctd with the given error message "DXGI_ERROR_DEVICE_HUNG" in roughly every 10 minutes).



Here is what I did:



1.) checked video card driver and updated to latest beta driver

2.) updated directx

3.) stopped my anti-virus program



(none of the above really helped, but then...)



4.) I have updated the BIOS of the video card -> so far (1 hour of gaming) all my problems are gone, no ctd, no freezes, no slowdowns.



Note: flashing the BIOS of the video card is easy, but not for the faint hearted (you may damage your card).



First identify your video card sub-type (mine is GV-N560OC-1GI), and pick it here:

http://www.gigabyte.us/support-downloads/download-center.aspx

and download the BIOS for your card (double check if it is really your BIOS).



Then unpack, run, reboot, enjoy. :-)

#2
Posted 10/26/2011 07:40 PM   
how would i go about doing this?
how would i go about doing this?

#3
Posted 10/26/2011 08:36 PM   
i am running duel GTX 570's SLI
I would like to know the process step by step on how to flash the bios of both my video cards.

I am getting this error and crashing non-stop!
[IMG]http://i41.tinypic.com/svj9y0.jpg[/IMG]

can someone be so kind as to help?
thanks
tony
i am running duel GTX 570's SLI

I would like to know the process step by step on how to flash the bios of both my video cards.



I am getting this error and crashing non-stop!

Image



can someone be so kind as to help?

thanks

tony

#4
Posted 11/03/2011 05:49 AM   
having the same issue with new GTX 580

is there any fix for that? someone?

thanks
having the same issue with new GTX 580



is there any fix for that? someone?



thanks

#5
Posted 11/28/2011 04:51 PM   
Hey Guys! FOUND A SOLUTION!

While playing BF3 I was experiencing two different errors.

The one that happened very often, that made the game unplayable was
a Directx error "getdeviceremovedreason" your graphic deviced was removed bla bla bla.

The other one was a command line error at D3D that I dont remember exactly.

This solution might solve some other GPU/Directx/Driver errors you might be experiencing.

I UNDERLCLOCKED my GPU, I`ve read somewhere that DICE was talking bull**** about factory overclocked GPUs,
and Guess what? My GPU is a GF 8800GTS Fatal1ty(FACTORY OVERCLOCKED), 650MHZ/1600MHZ/1000MHZ Core/Shader/Memory clocks respectively.
But the stock clock of the GPU is 500/1200/800, i`ve used RIVATUNNER and set them to 20% lower.

I UNDERCLOCKED my GPU, but it was OVERCLOCKED from factory, so my UNDERCLOCK still left my GPU with a 10% OVERLOCK.
The game is running fine now, actually I find this solution a TOTAL BULL****, this is the first game in my life i had this kind of problem.
Hey Guys! FOUND A SOLUTION!



While playing BF3 I was experiencing two different errors.



The one that happened very often, that made the game unplayable was

a Directx error "getdeviceremovedreason" your graphic deviced was removed bla bla bla.



The other one was a command line error at D3D that I dont remember exactly.



This solution might solve some other GPU/Directx/Driver errors you might be experiencing.



I UNDERLCLOCKED my GPU, I`ve read somewhere that DICE was talking bull**** about factory overclocked GPUs,

and Guess what? My GPU is a GF 8800GTS Fatal1ty(FACTORY OVERCLOCKED), 650MHZ/1600MHZ/1000MHZ Core/Shader/Memory clocks respectively.

But the stock clock of the GPU is 500/1200/800, i`ve used RIVATUNNER and set them to 20% lower.



I UNDERCLOCKED my GPU, but it was OVERCLOCKED from factory, so my UNDERCLOCK still left my GPU with a 10% OVERLOCK.

The game is running fine now, actually I find this solution a TOTAL BULL****, this is the first game in my life i had this kind of problem.

#6
Posted 12/21/2011 01:58 PM   
I clean-installed the Geforce drivers 332.21, that seemed to remedy the problem thus far.
I clean-installed the Geforce drivers 332.21, that seemed to remedy the problem thus far.

Image

#7
Posted 01/26/2014 10:43 PM   
Scroll To Top