Also unable to use PhysX with GTX 560 Ti
Hi,

I just installed a GTX 560 Ti (with 2 gig Vram) into a Win 7 Ultimate 64 bit system (Intel Core 2 Quad Q9300 @2.50 GHz with 4 gigs memory). The system has a 650 w power supply. While the card works flawlessly in all other areas, PhysX is not working at all. The nVidia control panel shows the PhysX options and allows me to set the GPU for PhysX use, but even when doing that it is only ever running off the CPU (as indicated by the PhysX visual indicator). GPU-Z also shows the PhysX box as unchecked.

I have tried a fresh install of the card after removing all the nVidia drivers (using driver cleaner) to no avail. I have tried uninstalling PhysX and reinstalling that, to no avail. I have tried physically disconnecting my second monitor, to no avail.

Is there any thing else I can try short of a complete system reinstallation to get PhysX working? For the record, it *was* working with my old 9600 GT card right up until I uninstalled it yesterday.

Thanks for any help

Edit: I also decided to try PhysX wth Windows XP (which I can use as a dual boot system). It's the exact same hardware as above, obviously. In XP PhysX is deteted by GPU-Z and can be used in games such as Mirror's Edge. Now I don't know if there's any connection, but with XP GPU-Z indicates that DirectCompute cannot be used (while in Win 7 it can be used).

So with that known, is this issue likely to be due to a 64 bit OS, Win 7 (regardless of 32/64 bit) or a software conflict?
Hi,



I just installed a GTX 560 Ti (with 2 gig Vram) into a Win 7 Ultimate 64 bit system (Intel Core 2 Quad Q9300 @2.50 GHz with 4 gigs memory). The system has a 650 w power supply. While the card works flawlessly in all other areas, PhysX is not working at all. The nVidia control panel shows the PhysX options and allows me to set the GPU for PhysX use, but even when doing that it is only ever running off the CPU (as indicated by the PhysX visual indicator). GPU-Z also shows the PhysX box as unchecked.



I have tried a fresh install of the card after removing all the nVidia drivers (using driver cleaner) to no avail. I have tried uninstalling PhysX and reinstalling that, to no avail. I have tried physically disconnecting my second monitor, to no avail.



Is there any thing else I can try short of a complete system reinstallation to get PhysX working? For the record, it *was* working with my old 9600 GT card right up until I uninstalled it yesterday.



Thanks for any help



Edit: I also decided to try PhysX wth Windows XP (which I can use as a dual boot system). It's the exact same hardware as above, obviously. In XP PhysX is deteted by GPU-Z and can be used in games such as Mirror's Edge. Now I don't know if there's any connection, but with XP GPU-Z indicates that DirectCompute cannot be used (while in Win 7 it can be used).



So with that known, is this issue likely to be due to a 64 bit OS, Win 7 (regardless of 32/64 bit) or a software conflict?

#1
Posted 10/10/2011 05:09 AM   
I seem to have found a fix. After a lot of Google searching, I found a post on the Steam forums that mentioned the following:

[i]Anyway, that allowed me to google the RIGHT question, which was "GPU-Z physx unchecked" or something, and the remedy is to go to your windows\system32 (or syswow64) folder and delete one file:

physx.cpl[/i]

Which worked immediately. GPU-Z now shows PhysX as checked. Running Mirror's Edge now shows that PhysX is being performed by the GPU and the glass shatters in game with out any slow down.
I seem to have found a fix. After a lot of Google searching, I found a post on the Steam forums that mentioned the following:



Anyway, that allowed me to google the RIGHT question, which was "GPU-Z physx unchecked" or something, and the remedy is to go to your windows\system32 (or syswow64) folder and delete one file:



physx.cpl




Which worked immediately. GPU-Z now shows PhysX as checked. Running Mirror's Edge now shows that PhysX is being performed by the GPU and the glass shatters in game with out any slow down.

#2
Posted 10/10/2011 04:56 PM   
I don't have that file so I can't remove it.
And I just noticed that GPU-Z doesn't have a Physx checked and Mirror's Edge is slowing down like hell when Physx is supposed to kick in.
And I have 560 Ti as well.

Tried installing Physx drivers. No help.
Next step is to install latest 295 WHQL drivers, cos I am still running the 280 ones.
I don't have that file so I can't remove it.

And I just noticed that GPU-Z doesn't have a Physx checked and Mirror's Edge is slowing down like hell when Physx is supposed to kick in.

And I have 560 Ti as well.



Tried installing Physx drivers. No help.

Next step is to install latest 295 WHQL drivers, cos I am still running the 280 ones.

#3
Posted 02/24/2012 02:46 PM   
I had the problem of now being able to install PhysX, and found it to be a problem with Windows Installer. I ran Windows FixIt and picked PhysX as the program I was having problems with and it repaired the PhysX portion of Windows Installer, and I was able to then install the latest version. This is the address to get to FixIt: http://support.microsoft.com/fixit. Hope this helps!
I had the problem of now being able to install PhysX, and found it to be a problem with Windows Installer. I ran Windows FixIt and picked PhysX as the program I was having problems with and it repaired the PhysX portion of Windows Installer, and I was able to then install the latest version. This is the address to get to FixIt: http://support.microsoft.com/fixit. Hope this helps!

#4
Posted 02/24/2012 03:40 PM   
[quote name='Bafucin' date='24 February 2012 - 09:46 AM' timestamp='1330094801' post='1374391']
I don't have that file so I can't remove it.
And I just noticed that GPU-Z doesn't have a Physx checked and Mirror's Edge is slowing down like hell when Physx is supposed to kick in.
And I have 560 Ti as well.

Tried installing Physx drivers. No help.
Next step is to install latest 295 WHQL drivers, cos I am still running the 280 ones.
[/quote]


I've had this problem before. Fixed it with the following solution:
[url="http://forums.nvidia.com/index.php?showtopic=204409&view=findpost&p=1259273%20"]http://forums.nvidia.com/index.php?showtopic=204409&view=findpost&p=1259273 [/url]
[quote name='Bafucin' date='24 February 2012 - 09:46 AM' timestamp='1330094801' post='1374391']

I don't have that file so I can't remove it.

And I just noticed that GPU-Z doesn't have a Physx checked and Mirror's Edge is slowing down like hell when Physx is supposed to kick in.

And I have 560 Ti as well.



Tried installing Physx drivers. No help.

Next step is to install latest 295 WHQL drivers, cos I am still running the 280 ones.







I've had this problem before. Fixed it with the following solution:

http://forums.nvidia.com/index.php?showtopic=204409&view=findpost&p=1259273

eVGA Z68 SLI | Intel Core i5-3570K @ 4.5 GHz | Corsair Hydro Series H80i
8GB G.Skill Sniper Series DDR3 | EVGA GTX 580 | OCZ ZX 1000W
OCZ Agility3 120 GB SSD + SanDisk Ultra 120GB SSD
Samsung UN55D6000 + Samsung T240
Win8 Pro x64 / WEI - 8.0 - 8.0 - 8.1 - 8.1 - 7.8
3DMark11 - P7545 / Vantage (PPU disabled) - P28859
F@H Team: 142900

#5
Posted 02/24/2012 04:30 PM   
Renaming the files alone did not help.
I had to install the latest drivers with a clean install.
Now the Physx is checked in GPU-Z and after the renaming ME works as well.
Renaming the files alone did not help.

I had to install the latest drivers with a clean install.

Now the Physx is checked in GPU-Z and after the renaming ME works as well.

#6
Posted 02/25/2012 07:26 AM   
Scroll To Top