Terrible HD playback performance Unable to view 720p, 1080p content smoothly in Win7
I recently purchased a Giada N3 HTPC box from Newegg (http://www.newegg.com/Product/Product.aspx?Item=N82E16856176002) for the sole purpose of setting up a HTPC. It has an Atom 330 and Nvidia Ion platform & graphics. The newegg reviews were very positive and there was a lot of good feedback on playing back 1080p content. Unfortunately my system has extremely poor performance running Windows 7. It does not play YouTube (720p or 1080p) smoothly, it doesn't play Netflix smoothly, some channels in Boxee (e.g. Fox) won't even show a video and others it stutters. I've spent close to 20 hrs researching this, trying different things out, ensuring hardware acceleration is enabled (it is according to Firefox 4.0). I'm at a complete loss. During playback the CPU is between 30% - 50% load. Any suggestions would be greatly appreciated since I can't seem to figure this one out.

Here are a few more specs. I added a 2GB 533Mhz RAM chip and a couple yr old 120GB HD. The system supports 800Mhz RAM, I just used an old 2GB chip I had lying around. Anyone know if that could be an issue? Does memory speed afect graphics playback performance.

Aside from that Win 7 seems to run fine. I've had some random hang-ups, but overall the system has performed well. What is bizarre is that I ran benchmark tests with PassMark performance test and the rating on this system was almost identical to that of my 3yr old lenovo netbook which sports an old Atom 270 single core processor and integrated Intel graphics. The integrated intel graphics outscored the 2D and 3D graphics performance of the Ion by 140% and 55% respectively. Completely blowing it away.
I recently purchased a Giada N3 HTPC box from Newegg (http://www.newegg.com/Product/Product.aspx?Item=N82E16856176002) for the sole purpose of setting up a HTPC. It has an Atom 330 and Nvidia Ion platform & graphics. The newegg reviews were very positive and there was a lot of good feedback on playing back 1080p content. Unfortunately my system has extremely poor performance running Windows 7. It does not play YouTube (720p or 1080p) smoothly, it doesn't play Netflix smoothly, some channels in Boxee (e.g. Fox) won't even show a video and others it stutters. I've spent close to 20 hrs researching this, trying different things out, ensuring hardware acceleration is enabled (it is according to Firefox 4.0). I'm at a complete loss. During playback the CPU is between 30% - 50% load. Any suggestions would be greatly appreciated since I can't seem to figure this one out.



Here are a few more specs. I added a 2GB 533Mhz RAM chip and a couple yr old 120GB HD. The system supports 800Mhz RAM, I just used an old 2GB chip I had lying around. Anyone know if that could be an issue? Does memory speed afect graphics playback performance.



Aside from that Win 7 seems to run fine. I've had some random hang-ups, but overall the system has performed well. What is bizarre is that I ran benchmark tests with PassMark performance test and the rating on this system was almost identical to that of my 3yr old lenovo netbook which sports an old Atom 270 single core processor and integrated Intel graphics. The integrated intel graphics outscored the 2D and 3D graphics performance of the Ion by 140% and 55% respectively. Completely blowing it away.

#1
Posted 08/26/2011 08:33 AM   
Scroll To Top