Manual Control Over Optimus
Hi guys. This is my first message. You can use "nvidiaInspector" called program to manual control over cards. Simply download it from anywhere open, than select "driver profile settings" button. After that scroll down and find "optimus flags for enabled applications". change value to "SHIM_MCCOMPAT_USER_EDITABLE" and press "Apply Changes". Voila :) You can manually select to cards for applications. Tried for "shogun 2" and its working. Game recognizes Nvidia 540m now. This is a temporary fix and do not select preffered Gpu settings from Nvidia Global settings after that. Use applications only.

[img]http://i56.tinypic.com/sn1dvs.png[/img]

[img]http://i54.tinypic.com/2gy813l.png[/img]

For maximum Gpu power; set "Enable application for Optimus" value to "SHIM_RENDERING_MODE_ENABLE" and "optimus flags for enabled applications" to "SHIM_MCCOMPAT_ENABLE". Now Nvidia renders all applications including Aero Effects.
Hi guys. This is my first message. You can use "nvidiaInspector" called program to manual control over cards. Simply download it from anywhere open, than select "driver profile settings" button. After that scroll down and find "optimus flags for enabled applications". change value to "SHIM_MCCOMPAT_USER_EDITABLE" and press "Apply Changes". Voila :) You can manually select to cards for applications. Tried for "shogun 2" and its working. Game recognizes Nvidia 540m now. This is a temporary fix and do not select preffered Gpu settings from Nvidia Global settings after that. Use applications only.



Image



Image



For maximum Gpu power; set "Enable application for Optimus" value to "SHIM_RENDERING_MODE_ENABLE" and "optimus flags for enabled applications" to "SHIM_MCCOMPAT_ENABLE". Now Nvidia renders all applications including Aero Effects.

#1
Posted 08/15/2011 09:43 PM   
Good application but the card control doesn't work for me. :(

GT540M
Good application but the card control doesn't work for me. :(



GT540M

#2
Posted 08/16/2011 07:26 PM   
Those are the settings that are already set on my 540M and it does not handle Aero.
Those are the settings that are already set on my 540M and it does not handle Aero.

#3
Posted 08/17/2011 05:02 AM   
I use 268.26 drivers from Asus and it's working. Tried with newest 280 drivers but it doesnt work.
I use 268.26 drivers from Asus and it's working. Tried with newest 280 drivers but it doesnt work.

#4
Posted 08/17/2011 10:18 AM   
Thank you. I will check this again with that version.

With (V8.17.12.6856) 268.56 this is not working. I will check with the 280.26.
Thank you. I will check this again with that version.



With (V8.17.12.6856) 268.56 this is not working. I will check with the 280.26.

#5
Posted 08/17/2011 07:32 PM   
Actually, this fix works with all drivers. You need to change application specific values from "nvidiaInspector" one by one. Select your profile and change values. Here's my "Shogun 2" fix for 280.26;

[img]http://i54.tinypic.com/k562zc.png[/img]
Actually, this fix works with all drivers. You need to change application specific values from "nvidiaInspector" one by one. Select your profile and change values. Here's my "Shogun 2" fix for 280.26;



Image

#6
Posted 08/17/2011 09:58 PM   
Can you not make another for Napoleon Total war

And would this not damage any hardware of the Laptop???
Can you not make another for Napoleon Total war



And would this not damage any hardware of the Laptop???

#7
Posted 08/19/2011 08:50 PM   
[quote name='davozk' date='19 August 2011 - 10:50 PM' timestamp='1313787026' post='1281656']
Can you not make another for Napoleon Total war

And would this not damage any hardware of the Laptop???
[/quote]

Use same settings for "Shogun 2" and it wont damage your hardware.
[quote name='davozk' date='19 August 2011 - 10:50 PM' timestamp='1313787026' post='1281656']

Can you not make another for Napoleon Total war



And would this not damage any hardware of the Laptop???





Use same settings for "Shogun 2" and it wont damage your hardware.

#8
Posted 08/21/2011 11:33 AM   
I have tried
When I try to start a battle against the computer and the game loads, the games crashes back to desktop, which a message which says that the game has stopped
I have tried

When I try to start a battle against the computer and the game loads, the games crashes back to desktop, which a message which says that the game has stopped

#9
Posted 08/21/2011 09:16 PM   
Hiya! This doesn't work with me.. The game I want to run with 850m still is greyed out and it will run with integrated GPU. Any help?
Hiya! This doesn't work with me.. The game I want to run with 850m still is greyed out and it will run with integrated GPU. Any help?

#10
Posted 11/13/2014 02:40 PM   
Scroll To Top