Nvidia Control Panel missing a lot of options
I recently got myself an asus n53sn with nvidia gt 550m on a win7 64 which works great, but I don't seem to be able to configure the aspect ratio in the control panel, I tend to play games at a lower resolution like 1024x768 while maintaining the aspect ratio on a widescreen. Besides that I seem to be missing a whole list of options!. The only way I can configure the aspect ratio is through the intel graphics properties which doesn't apply to games at all. I updated the nvidia driver several times with a clean install with no success of getting a fully featured control panel. I have a feeling the integrated intel graphics card seems to be the cause of all of this, unfortunately I could not perform a clean install of nvidia drivers without installing the intel driver first.

Does anyone know the cause of this and how to fix this "stripped-down" control panel?

here is your average nvidia control panel

[img]http://www.ldso.net/tronfaq/images/Nvidia_ControlPanel.jpg[/img]

and here is mine

[img] http://oi54.tinypic.com/2w6xmr5.jpg[/img]
I recently got myself an asus n53sn with nvidia gt 550m on a win7 64 which works great, but I don't seem to be able to configure the aspect ratio in the control panel, I tend to play games at a lower resolution like 1024x768 while maintaining the aspect ratio on a widescreen. Besides that I seem to be missing a whole list of options!. The only way I can configure the aspect ratio is through the intel graphics properties which doesn't apply to games at all. I updated the nvidia driver several times with a clean install with no success of getting a fully featured control panel. I have a feeling the integrated intel graphics card seems to be the cause of all of this, unfortunately I could not perform a clean install of nvidia drivers without installing the intel driver first.



Does anyone know the cause of this and how to fix this "stripped-down" control panel?



here is your average nvidia control panel



Image



and here is mine



Image

#1
Posted 07/23/2011 10:31 AM   
[quote name='chinonozu' date='23 July 2011 - 06:31 AM' timestamp='1311417118' post='1269516']
I recently got myself an asus n53sn with nvidia gt 550m on a win7 64 which works great, but I don't seem to be able to configure the aspect ratio in the control panel, I tend to play games at a lower resolution like 1024x768 while maintaining the aspect ratio on a widescreen. Besides that I seem to be missing a whole list of options!. The only way I can configure the aspect ratio is through the intel graphics properties which doesn't apply to games at all. I updated the nvidia driver several times with a clean install with no success of getting a fully featured control panel. I have a feeling the integrated intel graphics card seems to be the cause of all of this, unfortunately I could not perform a clean install of nvidia drivers without installing the intel driver first.

Does anyone know the cause of this and how to fix this "stripped-down" control panel?

here is your average nvidia control panel

[img]http://www.ldso.net/tronfaq/images/Nvidia_ControlPanel.jpg[/img]

and here is mine

[img] http://oi54.tinypic.com/2w6xmr5.jpg[/img]
[/quote]

The short answer is that the Optimus drivers for the mobile chipsets currently do not support this nor will they probably ever support it.
I have a similar machine: a Samsung with a GT540M chipset running Windows 7 x64. The reason the NVIDIA control panel is missing things is that your NVIDIA chip is no longer ultimately responsible for screen resolution and other screen settings. All the NVIDIA output, if the chip is being used in Optimus rendering, goes straight to the built-in Intel Graphics HD 3000 chipset for output to your monitor. I'm guessing you have a laptop that has the Intel Core i3/i5/i7 CPU (I have the Core i7), which means you are running this setup.
Thankfully Intel has a way to set this, it just isn't as easy or obvious.
Assuming you already have the Intel Graphics and Media Control Panel installed and available from your system tray, open up the Graphics Properties from it.
Set it to 'Advanced Mode' and go to 'Display' -> 'General Settings'.
You'll notice there is a 'scaling' setting in there. If you currently have your resolution set to the native resolution of your monitor, this scaling drop-down box will not have all the selections. For example, drop your resolution down to something lower than your monitor's resolution and accept it, now notice you have a couple more options in the scaling drop-down box. Ultimately when you run a game, you'll want the 'Scale Full Screen'. Set your resolution back, and it should probably be set to 'Maintain Display Scaling'.
Start your game. Assuming you are not running the game at a resolution equal to your monitor's native resolution (for example, I was running Deus Ex 3 at 1280x720, my monitor does 1920x1080), press Ctrl+Alt+F11. This is a hotkey sequence for the Intel driver to now set your scaling value to 'Scale Full Screen' which you should notice a increase in detail. My monitor also reports what the incoming resolution it gets off the HDMI input. When I do not do this it is incoming at 1280x720p at 60Hz. When I hit ctrl+alt+f11 once it gets set to 1920x1080p at 60hz, even though the game is set to 1280x720p. If you hit this sequence one more time, it sets it to "center" which means it will use black bars and not upscale the image (same thing as the NVIDIA scaling option to maintain the aspect ratio).
Unfortunately you will have to do this each time you get into a game as the Intel control panel isn't as full-featured to have game profiles or intelligent settings. Also beware that once you leave the game, it usually sets your desktop resolution back to the resolution of the game so you will have to fix that.
[quote name='chinonozu' date='23 July 2011 - 06:31 AM' timestamp='1311417118' post='1269516']

I recently got myself an asus n53sn with nvidia gt 550m on a win7 64 which works great, but I don't seem to be able to configure the aspect ratio in the control panel, I tend to play games at a lower resolution like 1024x768 while maintaining the aspect ratio on a widescreen. Besides that I seem to be missing a whole list of options!. The only way I can configure the aspect ratio is through the intel graphics properties which doesn't apply to games at all. I updated the nvidia driver several times with a clean install with no success of getting a fully featured control panel. I have a feeling the integrated intel graphics card seems to be the cause of all of this, unfortunately I could not perform a clean install of nvidia drivers without installing the intel driver first.



Does anyone know the cause of this and how to fix this "stripped-down" control panel?



here is your average nvidia control panel



Image



and here is mine



Image





The short answer is that the Optimus drivers for the mobile chipsets currently do not support this nor will they probably ever support it.

I have a similar machine: a Samsung with a GT540M chipset running Windows 7 x64. The reason the NVIDIA control panel is missing things is that your NVIDIA chip is no longer ultimately responsible for screen resolution and other screen settings. All the NVIDIA output, if the chip is being used in Optimus rendering, goes straight to the built-in Intel Graphics HD 3000 chipset for output to your monitor. I'm guessing you have a laptop that has the Intel Core i3/i5/i7 CPU (I have the Core i7), which means you are running this setup.

Thankfully Intel has a way to set this, it just isn't as easy or obvious.

Assuming you already have the Intel Graphics and Media Control Panel installed and available from your system tray, open up the Graphics Properties from it.

Set it to 'Advanced Mode' and go to 'Display' -> 'General Settings'.

You'll notice there is a 'scaling' setting in there. If you currently have your resolution set to the native resolution of your monitor, this scaling drop-down box will not have all the selections. For example, drop your resolution down to something lower than your monitor's resolution and accept it, now notice you have a couple more options in the scaling drop-down box. Ultimately when you run a game, you'll want the 'Scale Full Screen'. Set your resolution back, and it should probably be set to 'Maintain Display Scaling'.

Start your game. Assuming you are not running the game at a resolution equal to your monitor's native resolution (for example, I was running Deus Ex 3 at 1280x720, my monitor does 1920x1080), press Ctrl+Alt+F11. This is a hotkey sequence for the Intel driver to now set your scaling value to 'Scale Full Screen' which you should notice a increase in detail. My monitor also reports what the incoming resolution it gets off the HDMI input. When I do not do this it is incoming at 1280x720p at 60Hz. When I hit ctrl+alt+f11 once it gets set to 1920x1080p at 60hz, even though the game is set to 1280x720p. If you hit this sequence one more time, it sets it to "center" which means it will use black bars and not upscale the image (same thing as the NVIDIA scaling option to maintain the aspect ratio).

Unfortunately you will have to do this each time you get into a game as the Intel control panel isn't as full-featured to have game profiles or intelligent settings. Also beware that once you leave the game, it usually sets your desktop resolution back to the resolution of the game so you will have to fix that.

#2
Posted 08/18/2011 02:48 AM   
Scroll To Top