Cannot select NVIDIA GPU as preferred graphics processor. All changes in the NVIDIA Control Panel re
I have recently purchased a Fujitsu NH751 with the GeForce GT 525M in it. After playing a couple of games I have realized that it's never "kicking in", so I went into the NVIDIA Control Panel > 3D Settings > Manage 3D Settings > Global Settings > Preferred Graphics Processor and selected High-performance NVIDIA processor, clicked Apply, and tried again.

When nothing changed I went back into the Control Panel only to find the option reverted back, by itself, to Auto-select (which imminently chooses the integrated Intel option)...

After a bit of fiddling it was obvious that no matter the change I made in the Manage 3D Settings menu, they would revert back to defaults upon leaving it (ie: going to another menu, closing the control panel, etc).

The right-click context menu option to start games using Run with graphics processor > High-performance NVIDIA processor also does nothing; all .exes still use the integrated processing.

I have tried removing and reinstalling both Intel and NVIDIA drivers, being unfortunately blocked from installing the latest ones (by Fujitsu, I suppose), so I am stuck with:
Intel: 8.15.10.2246
NVIDIA: 8.17.12.6640

Has anybody else experienced this and found how to overcome the issue?

Thanks.
I have recently purchased a Fujitsu NH751 with the GeForce GT 525M in it. After playing a couple of games I have realized that it's never "kicking in", so I went into the NVIDIA Control Panel > 3D Settings > Manage 3D Settings > Global Settings > Preferred Graphics Processor and selected High-performance NVIDIA processor, clicked Apply, and tried again.



When nothing changed I went back into the Control Panel only to find the option reverted back, by itself, to Auto-select (which imminently chooses the integrated Intel option)...



After a bit of fiddling it was obvious that no matter the change I made in the Manage 3D Settings menu, they would revert back to defaults upon leaving it (ie: going to another menu, closing the control panel, etc).



The right-click context menu option to start games using Run with graphics processor > High-performance NVIDIA processor also does nothing; all .exes still use the integrated processing.



I have tried removing and reinstalling both Intel and NVIDIA drivers, being unfortunately blocked from installing the latest ones (by Fujitsu, I suppose), so I am stuck with:

Intel: 8.15.10.2246

NVIDIA: 8.17.12.6640



Has anybody else experienced this and found how to overcome the issue?



Thanks.

#1
Posted 05/20/2011 05:19 PM   
@deniouso, I've been trying too, with no success. All the control panel will do is let me prefer it for certain applications, and even then it doesn't always obey. It's spec'd by nVidia at 2560x1600 output, and I need it to do just that while my desktop is in the shop. Best I can get on my HP ZR30w is a lame 1388(or something like that)x800, and that's coming from the Intel chipset. Grrr!

Arthur P.Johnson
Samsung QX410-J01 with nVidia 310m
Windows 7 Home Premium
HP ZR30w Monitor /wallbash.gif' class='bbc_emoticon' alt=':wallbash:' />
@deniouso, I've been trying too, with no success. All the control panel will do is let me prefer it for certain applications, and even then it doesn't always obey. It's spec'd by nVidia at 2560x1600 output, and I need it to do just that while my desktop is in the shop. Best I can get on my HP ZR30w is a lame 1388(or something like that)x800, and that's coming from the Intel chipset. Grrr!



Arthur P.Johnson

Samsung QX410-J01 with nVidia 310m

Windows 7 Home Premium

HP ZR30w Monitor /wallbash.gif' class='bbc_emoticon' alt=':wallbash:' />

#2
Posted 05/21/2011 02:29 AM   
Just disable this shit service from your system : NVIDIA Display Service (nvsvc32.exe)
Just disable this shit service from your system : NVIDIA Display Service (nvsvc32.exe)

#3
Posted 12/03/2013 02:10 AM   
Scroll To Top