My new 525M cant play GTA 4
Hi Peeps,
I recently bought a new 15.6' Dell XPS L502X, with Intel Core i7-2630QM 2.00 GHz (sandy bridge) processor and 6GB RAM. As most of you know it has an Intel Integrated HD card and a NVIDIA GeForce GT 525M 1GB card for graphics.

My problem is i cannot run Grand Theft Auto IV properly on this. The game starts and the quality is very low and flaky (i cant change any graphic setting in the game while playing) and it pauses like every second. This is very annoying and i don't know what to do. I am not even sure my system is switching to nvidia card when the game starts.

I am sure the specs are more than good enough to play the game. Somebody please help me out. Thanks.
Hi Peeps,

I recently bought a new 15.6' Dell XPS L502X, with Intel Core i7-2630QM 2.00 GHz (sandy bridge) processor and 6GB RAM. As most of you know it has an Intel Integrated HD card and a NVIDIA GeForce GT 525M 1GB card for graphics.



My problem is i cannot run Grand Theft Auto IV properly on this. The game starts and the quality is very low and flaky (i cant change any graphic setting in the game while playing) and it pauses like every second. This is very annoying and i don't know what to do. I am not even sure my system is switching to nvidia card when the game starts.



I am sure the specs are more than good enough to play the game. Somebody please help me out. Thanks.

#1
Posted 04/20/2011 09:11 PM   
Have you installed the latest drivers for your card (270.61)? I had the exact same problem as you and those solved the problem, the card is now recognized and the game plays normally.
Have you installed the latest drivers for your card (270.61)? I had the exact same problem as you and those solved the problem, the card is now recognized and the game plays normally.

#2
Posted 04/21/2011 12:47 PM   
Yea I have the same problem with Dell XPS (but sandy bridge i5 2410m and 4gb ram.) They released new driver 18.4.2011 and It works for several games like PES 2010/2011. But It didn't affect GTA IV.
In graphic settings you finally see detected GT525m after last patch, mentioned above. But when you start game, It goes really laggy.
Yea I have the same problem with Dell XPS (but sandy bridge i5 2410m and 4gb ram.) They released new driver 18.4.2011 and It works for several games like PES 2010/2011. But It didn't affect GTA IV.

In graphic settings you finally see detected GT525m after last patch, mentioned above. But when you start game, It goes really laggy.

#3
Posted 04/21/2011 07:41 PM   
I actually found my solution. Yes, first off, update the nvidia drivers (released april 10ish, 2011). Then, if u still have to, manually select that nvidia gpu as ur preferred card for gta 4 application in ur graphic options (this is because optimus switches between intel and nvidia cards for apparently a better performance and power consumpsion). The game works just fine, that too at its max setting.

Now, if ur game freezes a lot or has a drunk cam effect (camera violently shaking) that is a whole new issue. That's Rockstar games reply for all of us who chose to download it. There are cracks available to fix these issues, just download and enjoy the game.
I actually found my solution. Yes, first off, update the nvidia drivers (released april 10ish, 2011). Then, if u still have to, manually select that nvidia gpu as ur preferred card for gta 4 application in ur graphic options (this is because optimus switches between intel and nvidia cards for apparently a better performance and power consumpsion). The game works just fine, that too at its max setting.



Now, if ur game freezes a lot or has a drunk cam effect (camera violently shaking) that is a whole new issue. That's Rockstar games reply for all of us who chose to download it. There are cracks available to fix these issues, just download and enjoy the game.

#4
Posted 04/23/2011 05:08 PM   
Okay...so for your solution, firstly go to the GTA IV folder, find the file named commandline.txt. Here, delete all the no restriction commands, basically the first two inputs of the command line, and then, where you have the refresh rate written, next to that write availablevideomem 52.0-percentvidmem 100
or just delete everything on that command line and copy the following and save it.
Your command line should look EXACTLY like:


height 1024 -width 1280 -refreshrate 75 -availablevidmem 52.0-percentvidmem 100-texturequality 5 -renderquality 5 -viewdistance 5 -shadowdensity 5

Okay, now open you nVidia control panel, go to 3-D settings and, select the program settings tab, and scroll down to select the GTA IV programme
Here, reduce your max pre rendered frames from the default 3 to 1 or 0, and multi display/mixed GPU accelaration to compatability performance mode.
Nowrun the game...graphics wont be perfect, but it is enough to enjoy the game, and will give you no more errors.
Try this out and tell me if it works. It worked for me!!!!
Okay...so for your solution, firstly go to the GTA IV folder, find the file named commandline.txt. Here, delete all the no restriction commands, basically the first two inputs of the command line, and then, where you have the refresh rate written, next to that write availablevideomem 52.0-percentvidmem 100

or just delete everything on that command line and copy the following and save it.

Your command line should look EXACTLY like:





height 1024 -width 1280 -refreshrate 75 -availablevidmem 52.0-percentvidmem 100-texturequality 5 -renderquality 5 -viewdistance 5 -shadowdensity 5



Okay, now open you nVidia control panel, go to 3-D settings and, select the program settings tab, and scroll down to select the GTA IV programme

Here, reduce your max pre rendered frames from the default 3 to 1 or 0, and multi display/mixed GPU accelaration to compatability performance mode.

Nowrun the game...graphics wont be perfect, but it is enough to enjoy the game, and will give you no more errors.

Try this out and tell me if it works. It worked for me!!!!

#5
Posted 01/07/2012 06:30 AM   
I did this without updating any drivers or patching the game......the problem is with the software detecting the video memory of your graphics card!
I did this without updating any drivers or patching the game......the problem is with the software detecting the video memory of your graphics card!

#6
Posted 01/07/2012 06:32 AM   
I am having the same issues with my gt540m ughh
I am having the same issues with my gt540m ughh

#7
Posted 01/08/2012 06:32 AM   
for the available vidmem why would you use 52.0? could you use 80.0 instead?
for the available vidmem why would you use 52.0? could you use 80.0 instead?

#8
Posted 01/08/2012 10:13 PM   
[quote name='VDX' date='06 January 2012 - 10:32 PM' timestamp='1325917929' post='1352735']
I did this without updating any drivers or patching the game......the problem is with the software detecting the video memory of your graphics card!
[/quote]

It is not just Optimus. This game essentially has problems with graphics cards that have over 2GB of video memory.
[quote name='VDX' date='06 January 2012 - 10:32 PM' timestamp='1325917929' post='1352735']

I did this without updating any drivers or patching the game......the problem is with the software detecting the video memory of your graphics card!





It is not just Optimus. This game essentially has problems with graphics cards that have over 2GB of video memory.

Please send me a PM if I fail to keep up on replying in any specific thread or leave a driver feedback: Driver Feedback

#9
Posted 01/11/2012 10:27 AM   
Scroll To Top