Unable to play Half-Life 1 with NVIDIA GPU
  1 / 3    
Hello,

I'm having an issue with my new Notebook (ThinkPad T520). I often play SvenCoop which is an active and popular mod for Half-Life 1. As SvenCoop is pushing the Half-Life engine to its limits (and beyond) it needs a proper GPU to run smothly. The NVIDIA control panel has Half-life listed as a game, but it defaults to the integrated GPU, and I can't change it. I can right-click on the hl.exe file and select the NVIDIA GPU, but according to the GPU monitor, it's not being used when Half-Life is running.

Thanks for assistance!
Hello,



I'm having an issue with my new Notebook (ThinkPad T520). I often play SvenCoop which is an active and popular mod for Half-Life 1. As SvenCoop is pushing the Half-Life engine to its limits (and beyond) it needs a proper GPU to run smothly. The NVIDIA control panel has Half-life listed as a game, but it defaults to the integrated GPU, and I can't change it. I can right-click on the hl.exe file and select the NVIDIA GPU, but according to the GPU monitor, it's not being used when Half-Life is running.



Thanks for assistance!

#1
Posted 03/30/2011 03:08 PM   
*push*
*push*

#2
Posted 04/18/2011 08:29 PM   
Well optimus has had issues with many games that will not run correctly because optimus does not sense high GPU load in some games and does not switch over to the integrated chip. that could be due to a fault in the program itself or the game just doesnt utilize enough of the GPU for optimus to think it needs to switch graphics. but that is mostly speculation. one way you could potentially resolve this is trying to find an option in your BIOS that can disable the integrated graphics all together. That is my suggestion. If that is not possible then i hope someone can pop there heads in who may know more about optimus. I only know more of its function rather than actual experience with it.

EDIT: after looking up that laptop i found that the ones checked out all had NVS 4200m which is not a gaming card. that is something used more for workstations.
Well optimus has had issues with many games that will not run correctly because optimus does not sense high GPU load in some games and does not switch over to the integrated chip. that could be due to a fault in the program itself or the game just doesnt utilize enough of the GPU for optimus to think it needs to switch graphics. but that is mostly speculation. one way you could potentially resolve this is trying to find an option in your BIOS that can disable the integrated graphics all together. That is my suggestion. If that is not possible then i hope someone can pop there heads in who may know more about optimus. I only know more of its function rather than actual experience with it.



EDIT: after looking up that laptop i found that the ones checked out all had NVS 4200m which is not a gaming card. that is something used more for workstations.

#3
Posted 04/18/2011 08:35 PM   
You're right. It's not a gaming card. But other games like Half-Life 2 run without any problems and other players with other Optimus based cards have the same problem.

As far as I know the GPU isn't selected automaticly. The selection is based on a list of executables. For example: I installed Age of Mythology which was unkown to the driver and thous was unplayable with the Intel GPU. I added aom.exe to the executables which should use the NVIDIA GPU and taadaa: It runs fine.

Basicly this is the same procedure for Half-Life 1/SvenCoop. But the driver just wont let me switch the GPU for that game. Its greyed out. I do not know why and how to override it.
[attachment=20699:screen.jpg]
You're right. It's not a gaming card. But other games like Half-Life 2 run without any problems and other players with other Optimus based cards have the same problem.



As far as I know the GPU isn't selected automaticly. The selection is based on a list of executables. For example: I installed Age of Mythology which was unkown to the driver and thous was unplayable with the Intel GPU. I added aom.exe to the executables which should use the NVIDIA GPU and taadaa: It runs fine.



Basicly this is the same procedure for Half-Life 1/SvenCoop. But the driver just wont let me switch the GPU for that game. Its greyed out. I do not know why and how to override it.

[attachment=20699:screen.jpg]

#4
Posted 04/20/2011 07:17 AM   
*push*
*push*

#5
Posted 05/02/2011 06:01 PM   
Hello!

I've got the same problem as author. As you can see on the img, I can't change what graphic card have to use.... It's very annoying cuz I have low FPS in HL1 or DOD1.



NVIDIA PLZ DO SMTHG WITH THIS!
Hello!



I've got the same problem as author. As you can see on the img, I can't change what graphic card have to use.... It's very annoying cuz I have low FPS in HL1 or DOD1.







NVIDIA PLZ DO SMTHG WITH THIS!

#6
Posted 05/12/2011 04:31 PM   
I have the same problem, I cant start the game at all, I tried to make a copy of hl.exe and rename it to hl_test.exe , and then I added it to the nvidia control panel using the nvidia gpu, then I tried to start the game using the modified exe, original half-life worked, I was able to play tutorial and history mode, but when I tried to launch some mods such opposing force or the well known cstrike 1.6, them crashed at menu.

playing with integrated graphics its not an option for me, it runs at very slow FPS when other modern games such as crysis 2 run at decent speed using the nvidia gpu.

using windows 7 64 bits and nvidia gt525m and nvidia control panel 3.6.750.0

help apreciated
I have the same problem, I cant start the game at all, I tried to make a copy of hl.exe and rename it to hl_test.exe , and then I added it to the nvidia control panel using the nvidia gpu, then I tried to start the game using the modified exe, original half-life worked, I was able to play tutorial and history mode, but when I tried to launch some mods such opposing force or the well known cstrike 1.6, them crashed at menu.



playing with integrated graphics its not an option for me, it runs at very slow FPS when other modern games such as crysis 2 run at decent speed using the nvidia gpu.



using windows 7 64 bits and nvidia gt525m and nvidia control panel 3.6.750.0



help apreciated

#7
Posted 05/16/2011 06:53 PM   
I have the low fps problem too. I don't understand why it's not possible to change the settings of the "hl.exe". Hope there will be a solution soon.
I am using a GT 540M on WIN7 64 and also control panel 3.6.750.0
I have the low fps problem too. I don't understand why it's not possible to change the settings of the "hl.exe". Hope there will be a solution soon.

I am using a GT 540M on WIN7 64 and also control panel 3.6.750.0

#8
Posted 05/17/2011 02:00 AM   
Hello everyone ...

Here is what seems to work for me:
Instead of adding the "hl.exe" try to add "steam.exe". It works for the problem with the fps drops but it seems not to work properly because turning vsync off in the driver settings doesn't do anything.

Hope this is a bit helpful
Hello everyone ...



Here is what seems to work for me:

Instead of adding the "hl.exe" try to add "steam.exe". It works for the problem with the fps drops but it seems not to work properly because turning vsync off in the driver settings doesn't do anything.



Hope this is a bit helpful

#9
Posted 05/17/2011 10:38 AM   
woot!


I finally got it working with full fps, using the nvidia GPU :D


here is what I did

I made a copy of hl.exe and renamed to hl_test.exe

I added hl_test.exe to the nvidia control panel settings.

then go to the hl_test.exe nvidia profile and make sure the nvidia GPU is selected

I'm sorry if there are some translation mistakes, my english is not perfect and my nvidia control panel is on spanish language (yep, I'm spanish)
--------------------------------------------------------------

then edit the profile setings to look like this

multiple screen aceleration (performance mode)

antiaisling config (controlled by the app)

antiaisling mode(controlled by the app)

gamma correction (disabled)

antiaisling - transparency (disabled)

cuda GPU (all, and make sure your nvidia gpu is selected there)

antisopic filder (disabled)

texture filter - quality (performance)

texture filter - LOD diference (allow)

texture filter - antisopic optimitation (disabled)

texture filter - trilineal optimitation (disabled)

energy mode (max performance)

max ammount of prerenderized frames (3)

ambient oclusion (I cant change this feature cuz it ask is not compatible)

bound optimization (Disabled)


v-sync (force disabled)

texture filter - antispic filter (disabled)

triple buffer (enabled)


-------------------------------------------------------



if you want to run this on steam, you will need to rename the correct exe


for example, how make this work for cstrike:

go to the steam main folder, then go to steamapps, then go to your account name, and then go to the cstrike folder.

then copy/rename the hl.exe to hl_test.exe

if you just open hl_test.exe you will just open half-life instead counter strike, so you will have to do a small trick.

create a shortcut to the hl_test.exe

and then add the following parameter.

-game cstrike

example:

"C:\Program Files (x86)\Steam\steamapps\captain_falcon\counter-strike\hl_test.exe" -game cstrike


I tested this sucesfully on Non-steam Half-life with Opposing force (-game gearbox) parameter.

I hope this helps someone

EDIT: I noticed this trick just works for the non-steam versions, for some reason the steam version refuses to use the gpu for me /blarg.gif' class='bbc_emoticon' alt=':/' />
woot!





I finally got it working with full fps, using the nvidia GPU :D





here is what I did



I made a copy of hl.exe and renamed to hl_test.exe



I added hl_test.exe to the nvidia control panel settings.



then go to the hl_test.exe nvidia profile and make sure the nvidia GPU is selected



I'm sorry if there are some translation mistakes, my english is not perfect and my nvidia control panel is on spanish language (yep, I'm spanish)

--------------------------------------------------------------



then edit the profile setings to look like this



multiple screen aceleration (performance mode)



antiaisling config (controlled by the app)



antiaisling mode(controlled by the app)



gamma correction (disabled)



antiaisling - transparency (disabled)



cuda GPU (all, and make sure your nvidia gpu is selected there)



antisopic filder (disabled)



texture filter - quality (performance)



texture filter - LOD diference (allow)



texture filter - antisopic optimitation (disabled)



texture filter - trilineal optimitation (disabled)



energy mode (max performance)



max ammount of prerenderized frames (3)



ambient oclusion (I cant change this feature cuz it ask is not compatible)



bound optimization (Disabled)





v-sync (force disabled)



texture filter - antispic filter (disabled)



triple buffer (enabled)





-------------------------------------------------------







if you want to run this on steam, you will need to rename the correct exe





for example, how make this work for cstrike:



go to the steam main folder, then go to steamapps, then go to your account name, and then go to the cstrike folder.



then copy/rename the hl.exe to hl_test.exe



if you just open hl_test.exe you will just open half-life instead counter strike, so you will have to do a small trick.



create a shortcut to the hl_test.exe



and then add the following parameter.



-game cstrike



example:



"C:\Program Files (x86)\Steam\steamapps\captain_falcon\counter-strike\hl_test.exe" -game cstrike





I tested this sucesfully on Non-steam Half-life with Opposing force (-game gearbox) parameter.



I hope this helps someone



EDIT: I noticed this trick just works for the non-steam versions, for some reason the steam version refuses to use the gpu for me /blarg.gif' class='bbc_emoticon' alt=':/' />

#10
Posted 05/17/2011 11:43 AM   
Adding the steam.exe doesn't work properly. The GPU-Activity-Tool shows that HL.exe is running with the nvidia card. My new problem is, that its not possible to configure the settings of that file using the nvidia options. So the only thing i had to do is turning off vsync in the general nvidia options. CS 1.6, 100 fps and no fps drops because of HE grens.
Hope this will help /wink.gif' class='bbc_emoticon' alt=';)' />
Adding the steam.exe doesn't work properly. The GPU-Activity-Tool shows that HL.exe is running with the nvidia card. My new problem is, that its not possible to configure the settings of that file using the nvidia options. So the only thing i had to do is turning off vsync in the general nvidia options. CS 1.6, 100 fps and no fps drops because of HE grens.

Hope this will help /wink.gif' class='bbc_emoticon' alt=';)' />

#11
Posted 05/17/2011 02:55 PM   
[quote name='capitankasar' date='17 May 2011 - 11:43 AM' timestamp='1305632581' post='1238189']EDIT: I noticed this trick just works for the non-steam versions, for some reason the steam version refuses to use the gpu for me
[/quote]

same for me. dont work fot steam. only CS for steam work correctly for me, without that trick


BIG EDIT: I HAVE SOLUTION FOR STEAM (WORK FOR ME!)

do everything as capitankasar said. do everything like ernel said. make shortcuts on your desktop. In your NVIDIA panel, tick option that is in red box on my scr (it's in polish, but it will be also 3rd position in your menu - something as "add to rightclik menu RUN WITH/USING NVIDIA..."), go to your desktop and rightclick on created shortcut and RUN WITH/USING NVIDI0. 100 fps for me.
[quote name='capitankasar' date='17 May 2011 - 11:43 AM' timestamp='1305632581' post='1238189']EDIT: I noticed this trick just works for the non-steam versions, for some reason the steam version refuses to use the gpu for me





same for me. dont work fot steam. only CS for steam work correctly for me, without that trick





BIG EDIT: I HAVE SOLUTION FOR STEAM (WORK FOR ME!)



do everything as capitankasar said. do everything like ernel said. make shortcuts on your desktop. In your NVIDIA panel, tick option that is in red box on my scr (it's in polish, but it will be also 3rd position in your menu - something as "add to rightclik menu RUN WITH/USING NVIDIA..."), go to your desktop and rightclick on created shortcut and RUN WITH/USING NVIDI0. 100 fps for me.

#12
Posted 05/17/2011 03:32 PM   
after installing the latest drivers the game crash in full screen /blarg.gif' class='bbc_emoticon' alt=':/' />

the only way to play without crashes is start the game windowed ¬¬

I also noticed about league of legends game crashes while alt tabing with the latest 275.33 drivers for my GT525M GPU

I never though I would find so many problems while gamming on a laptop :O
after installing the latest drivers the game crash in full screen /blarg.gif' class='bbc_emoticon' alt=':/' />



the only way to play without crashes is start the game windowed ¬¬



I also noticed about league of legends game crashes while alt tabing with the latest 275.33 drivers for my GT525M GPU



I never though I would find so many problems while gamming on a laptop :O

#13
Posted 06/18/2011 11:28 PM   
Hey there everyone!

I am happy to see that the last post in this thread was yesterday, I hope this still has some relevance, and I hope that over Google, some more people will get here.. maybe someone who knows a solution, or an official statement from Nvidia, that would also be nice ... =/

I am using HL1 non-steam, Win7 64bit, Nvidia 540M, latest drivers etc, everything installed.
I have the exact same problem as described in this thread, I can't choose the Nvidia GPU and am stuck with the default integrated one. Basically I could play the game, but I am kind of a perfectionist and would love to tweak Anti-Aliasing and Texture Filtering, etc.


My observations:
- Half-Life is named "Half Life (half-life/hl.exe)" in the Nvidia list, if that helps in any way.
- I tried using a "hl_test.exe" and modifying the Nvidia settings on that. The problem is, using this exe, the game crashes every time I try to start a new game / load a saved game. I have tried giving it the correct "scurity rights", I don't really know how those are called in english (right click on shortcut -> properties -> security, and add everything there).
- I tried out what would happen if I just place a new file named "hl.exe" on the desktop (right click -> new text document -> "hl.exe") and add that to Nvidia. It seems that this is not possible, Nvidia identifies it as the Half-Life one, although it clearly isn't.
- I have Steam and CS 1.6 installed. The game also uses a hl.exe, but strangely, this is listed under "Counter-Strike" in the Nvidia list, and I can activate the Nvidia GPU without any problem.
- Could the rendering modus be the problem? I use OpenGL, trying to switch it has led to crashes and also didn't seem to have an impact on the available Nvidia options.

So the problem to solve would be: How can I get a "hl_test.exe" to load my game saves without crashing OR how can I use another "hl.exe" (copy of the original) and add it to the Nvidia list that isn't strangely being identified as "Half-Life", althought it doesn't necessarily have to be.
Or, from a different perspective, why is that even a problem?? Even for Adobe Acrobat Reader I can enable the Nvidia GPU, what the hell??
Hey there everyone!



I am happy to see that the last post in this thread was yesterday, I hope this still has some relevance, and I hope that over Google, some more people will get here.. maybe someone who knows a solution, or an official statement from Nvidia, that would also be nice ... =/



I am using HL1 non-steam, Win7 64bit, Nvidia 540M, latest drivers etc, everything installed.

I have the exact same problem as described in this thread, I can't choose the Nvidia GPU and am stuck with the default integrated one. Basically I could play the game, but I am kind of a perfectionist and would love to tweak Anti-Aliasing and Texture Filtering, etc.





My observations:

- Half-Life is named "Half Life (half-life/hl.exe)" in the Nvidia list, if that helps in any way.

- I tried using a "hl_test.exe" and modifying the Nvidia settings on that. The problem is, using this exe, the game crashes every time I try to start a new game / load a saved game. I have tried giving it the correct "scurity rights", I don't really know how those are called in english (right click on shortcut -> properties -> security, and add everything there).

- I tried out what would happen if I just place a new file named "hl.exe" on the desktop (right click -> new text document -> "hl.exe") and add that to Nvidia. It seems that this is not possible, Nvidia identifies it as the Half-Life one, although it clearly isn't.

- I have Steam and CS 1.6 installed. The game also uses a hl.exe, but strangely, this is listed under "Counter-Strike" in the Nvidia list, and I can activate the Nvidia GPU without any problem.

- Could the rendering modus be the problem? I use OpenGL, trying to switch it has led to crashes and also didn't seem to have an impact on the available Nvidia options.



So the problem to solve would be: How can I get a "hl_test.exe" to load my game saves without crashing OR how can I use another "hl.exe" (copy of the original) and add it to the Nvidia list that isn't strangely being identified as "Half-Life", althought it doesn't necessarily have to be.

Or, from a different perspective, why is that even a problem?? Even for Adobe Acrobat Reader I can enable the Nvidia GPU, what the hell??

My System:

Model: Acer Aspire 5742G

OS: Win7 64bit Home Premium (SP1)

Processor: Intel i5 M460 @2.53 GHz

Graphics: NVidia GeForce GT 540M

DirectX: DX11

Memory: 4 GB

Resolution: 1366x768

#14
Posted 06/19/2011 10:40 AM   
[quote name='Coffin87' date='19 June 2011 - 12:40 PM' timestamp='1308480019' post='1253777']
So the problem to solve would be: How can I get a "hl_test.exe" to load my game saves without crashing OR how can I use another "hl.exe" (copy of the original) and add it to the Nvidia list that isn't strangely being identified as "Half-Life", althought it doesn't necessarily have to be.
Or, from a different perspective, why is that even a problem?? Even for Adobe Acrobat Reader I can enable the Nvidia GPU, what the hell??
[/quote]

yes, the hl_test.exe or rename it to any other name except hl.exe trick is needed, else nvidia software will lock the gpu to intel due it detect half-life, wich make the game unplayable with such low fps. (its a kinda funny that nvidia decided to force their gpu users to play old games with low fps and by locking the profile to the intel "awesome" graphics)

I had sucess with 275.50 beta drivers, however the rename trick ,add the custom exe to the panel, select nvidia gpu and disable triple buffering is required to play the game at decent speed.

yes triple buffering is buggy also for a lot of games such as doom3, doom3 exp, prey ..... those games crash at startup unless you disable that setting at the nvidia control panel

happy with my new laptop?

not really, I get a headache everytime I try to play some games /blarg.gif' class='bbc_emoticon' alt=':/' />
[quote name='Coffin87' date='19 June 2011 - 12:40 PM' timestamp='1308480019' post='1253777']

So the problem to solve would be: How can I get a "hl_test.exe" to load my game saves without crashing OR how can I use another "hl.exe" (copy of the original) and add it to the Nvidia list that isn't strangely being identified as "Half-Life", althought it doesn't necessarily have to be.

Or, from a different perspective, why is that even a problem?? Even for Adobe Acrobat Reader I can enable the Nvidia GPU, what the hell??





yes, the hl_test.exe or rename it to any other name except hl.exe trick is needed, else nvidia software will lock the gpu to intel due it detect half-life, wich make the game unplayable with such low fps. (its a kinda funny that nvidia decided to force their gpu users to play old games with low fps and by locking the profile to the intel "awesome" graphics)



I had sucess with 275.50 beta drivers, however the rename trick ,add the custom exe to the panel, select nvidia gpu and disable triple buffering is required to play the game at decent speed.



yes triple buffering is buggy also for a lot of games such as doom3, doom3 exp, prey ..... those games crash at startup unless you disable that setting at the nvidia control panel



happy with my new laptop?



not really, I get a headache everytime I try to play some games /blarg.gif' class='bbc_emoticon' alt=':/' />

#15
Posted 07/12/2011 12:44 AM   
  1 / 3    
Scroll To Top