Memory leak problems with GeForce 540M and Autodesk programs.
  1 / 12    
I have a GeForce 540M running driver version 265.77. When I am running Autodesk programs using my GeForce card I consistently run out of memory after using the program for 10-20 minutes. Maya opens and works great at first, but will gradually get worse and worse until the computer runs out of memory. Mudbox won't open, but will continue to eat away at the memory until the computer crashes.

If I load the program using the integrated graphics (Intel HD Graphics, driver version 8.15 10 2253) I can run the programs without any memory problems . However, the integrated Intel card cannot handle the load and the programs are jumpy are difficult to use.

I'm hoping this can be fixed with a driver update. I will also be posting this problem on the Autodesk as their software may be contributing to the problem also.
I have a GeForce 540M running driver version 265.77. When I am running Autodesk programs using my GeForce card I consistently run out of memory after using the program for 10-20 minutes. Maya opens and works great at first, but will gradually get worse and worse until the computer runs out of memory. Mudbox won't open, but will continue to eat away at the memory until the computer crashes.



If I load the program using the integrated graphics (Intel HD Graphics, driver version 8.15 10 2253) I can run the programs without any memory problems . However, the integrated Intel card cannot handle the load and the programs are jumpy are difficult to use.



I'm hoping this can be fixed with a driver update. I will also be posting this problem on the Autodesk as their software may be contributing to the problem also.

#1
Posted 03/25/2011 04:05 PM   
Hi!

I am a Game Engine programmer, and i have traced my application memory leak down to the nVidia Optimus driver too!
nVidia, please, wouldn't you have a look at your drivers for Optimus more often?

I am running with a GeForce GT 540M

I am very dissapointed, because:

- Optimus drivers are very hard to find on the Web-site
- A lot of games have problems with the driver.
- Memory leak in the OpenGL driver

When i run my application with the Intel Graphics, it runs as it should.

Btw., the Intel Graphics even performs up to 10% better than the GeForce? That shouldn't be like that, should it?
Hi!



I am a Game Engine programmer, and i have traced my application memory leak down to the nVidia Optimus driver too!

nVidia, please, wouldn't you have a look at your drivers for Optimus more often?



I am running with a GeForce GT 540M



I am very dissapointed, because:



- Optimus drivers are very hard to find on the Web-site

- A lot of games have problems with the driver.

- Memory leak in the OpenGL driver



When i run my application with the Intel Graphics, it runs as it should.



Btw., the Intel Graphics even performs up to 10% better than the GeForce? That shouldn't be like that, should it?

#2
Posted 04/11/2011 11:14 AM   
i joined the forum to complain about a similar issue.

my laptop's got GF 540M,

tried autodesk mudbox 2012 (64bit)..... it doesn't work :(

when i click on the program, it eats up all the available ram in a few seconds ( 4G DDR3 ), and hangs the laptop

tried updating the gpu driver to 270.51, nada, same issue.

tried mudbox 2012 ( 32bit ), it crashes.

i haven't tried other packages like maya 2012, 3dsmax 2012, etc, but i see that there indeed are issues...

just what's going on here? i got a laptop that is relatively fast because i do graphic work on my free time.. ( instead of a netbook or something )

how come GF 540M drivers are sold with different brands of laptops, but the drivers simply don't do the job?

i've been a loyal customer of nvidia (for quite a while now. first nvidia i had was 4200 Ti i think) , but i think when i build a new desktop in the near future, i'm strongly considering an ATI..

FYI, when i force the program to use intel gpu, it returns an error message saying that it's not good enough or something. if i force it to use nvidia gpu, memory leak.... HELLLLLL!!
i joined the forum to complain about a similar issue.



my laptop's got GF 540M,



tried autodesk mudbox 2012 (64bit)..... it doesn't work :(



when i click on the program, it eats up all the available ram in a few seconds ( 4G DDR3 ), and hangs the laptop



tried updating the gpu driver to 270.51, nada, same issue.



tried mudbox 2012 ( 32bit ), it crashes.



i haven't tried other packages like maya 2012, 3dsmax 2012, etc, but i see that there indeed are issues...



just what's going on here? i got a laptop that is relatively fast because i do graphic work on my free time.. ( instead of a netbook or something )



how come GF 540M drivers are sold with different brands of laptops, but the drivers simply don't do the job?



i've been a loyal customer of nvidia (for quite a while now. first nvidia i had was 4200 Ti i think) , but i think when i build a new desktop in the near future, i'm strongly considering an ATI..



FYI, when i force the program to use intel gpu, it returns an error message saying that it's not good enough or something. if i force it to use nvidia gpu, memory leak.... HELLLLLL!!

#3
Posted 04/14/2011 06:33 AM   
Same issue, new dell xps i7, win7 64 bit 8 G ram with 540m graphics, memory leak with Mudbox 2012, although Maya is running OK but havent run it much so far as just loaded. I have run all the updates and Mudbox just doesnt run and eats away all the memory. Hope there is a fix for this as I bought it for mudbox.............grrrrrr
Same issue, new dell xps i7, win7 64 bit 8 G ram with 540m graphics, memory leak with Mudbox 2012, although Maya is running OK but havent run it much so far as just loaded. I have run all the updates and Mudbox just doesnt run and eats away all the memory. Hope there is a fix for this as I bought it for mudbox.............grrrrrr

#4
Posted 04/20/2011 09:04 PM   
tried the latest gpu driver update from nvidia ( one released a couple of days ago ),

still having the same memory leak issue here...
tried the latest gpu driver update from nvidia ( one released a couple of days ago ),



still having the same memory leak issue here...

#5
Posted 04/20/2011 10:12 PM   
I have the same "memory leak" issue with SideFX Houdini + GT525M optimus.

I believe the current generation of Optimus gpu's are totally unsuitable for any sort of 3d applications. Does NVIDIA actually care about these issues?

R.
I have the same "memory leak" issue with SideFX Houdini + GT525M optimus.



I believe the current generation of Optimus gpu's are totally unsuitable for any sort of 3d applications. Does NVIDIA actually care about these issues?



R.

#6
Posted 04/24/2011 06:47 AM   
I also got xps 15 laptop for 3d rendering and vfx stuff and even i am experiencing the same memory leak in mudbox 2011....
cannot even start mudbox.... can any1 tell how to completely disable optimus?
I also got xps 15 laptop for 3d rendering and vfx stuff and even i am experiencing the same memory leak in mudbox 2011....

cannot even start mudbox.... can any1 tell how to completely disable optimus?

#7
Posted 04/27/2011 09:34 AM   
XPS 15
Intel i5 2.3 Ghz
4 Gb DDR3
Nvidia GeForce 525M 1 Gb
W7 Home premium 64 bits

Same problem with a plain Autocad 2011 64 bits....

Could someone at Nvidia do something about it?

Thanks for listen to me.
XPS 15

Intel i5 2.3 Ghz

4 Gb DDR3

Nvidia GeForce 525M 1 Gb

W7 Home premium 64 bits



Same problem with a plain Autocad 2011 64 bits....



Could someone at Nvidia do something about it?



Thanks for listen to me.

#8
Posted 05/03/2011 01:36 PM   
i just bought the new dell xps L502x i7, win7 64 bit 8G ram with nvidia GT 540m with the intention to use autodesk products, the computer responds poorly to the products, mudbox has a major memory leak and within a few minutes (if the process isn't killed) the computer runs out of memmory, 3ds max 2012 also performs poorly.
nvidia please sort this problem out.
i just bought the new dell xps L502x i7, win7 64 bit 8G ram with nvidia GT 540m with the intention to use autodesk products, the computer responds poorly to the products, mudbox has a major memory leak and within a few minutes (if the process isn't killed) the computer runs out of memmory, 3ds max 2012 also performs poorly.

nvidia please sort this problem out.

#9
Posted 05/05/2011 01:07 PM   
This is a very poor. Max 2012 seems to work but Mudbox 2012 doesn't on my GT 540M 2GB (Acer 5750G).

NVIDIA - please get some decent drivers sorted before you release hardware, or send a sticker to be put on these machines saying they will not run Mudbox etc. until an as yet unknown point in the future.

I can't think of another industry where you would get away with this. Imagine a car manufacturer saying they will come and add the windscreen wipers in a few months. Or worse they just don't say anything when you ask them how you are supposed to drive in the rain....
This is a very poor. Max 2012 seems to work but Mudbox 2012 doesn't on my GT 540M 2GB (Acer 5750G).



NVIDIA - please get some decent drivers sorted before you release hardware, or send a sticker to be put on these machines saying they will not run Mudbox etc. until an as yet unknown point in the future.



I can't think of another industry where you would get away with this. Imagine a car manufacturer saying they will come and add the windscreen wipers in a few months. Or worse they just don't say anything when you ask them how you are supposed to drive in the rain....

#10
Posted 05/06/2011 09:35 PM   
still no solution yet??????
still no solution yet??????

#11
Posted 05/09/2011 04:21 AM   
Still nothing, Very disappointed with this crappy 540m, wheres the best place to email to get some response from nvidia?
Still nothing, Very disappointed with this crappy 540m, wheres the best place to email to get some response from nvidia?

#12
Posted 05/09/2011 05:10 PM   
geforces are gaming cards and not really suited for professional apps, they also use drivers optimized for gaming which might be the reason why you're seeing those issues. quadro cards are the ones you should be looking at. i dont know if you can use modded quadro drivers on an optimus laptop but worst case scenario you just have to run a system restore (if you're lazy) or uninstall drivers from safe mode if they dont work.


on another note, this is a user to user forum, meaning you wont get much suport (if any) around these parts from nvidia employees.
geforces are gaming cards and not really suited for professional apps, they also use drivers optimized for gaming which might be the reason why you're seeing those issues. quadro cards are the ones you should be looking at. i dont know if you can use modded quadro drivers on an optimus laptop but worst case scenario you just have to run a system restore (if you're lazy) or uninstall drivers from safe mode if they dont work.





on another note, this is a user to user forum, meaning you wont get much suport (if any) around these parts from nvidia employees.

#13
Posted 05/10/2011 10:09 AM   
You must be kidding right?

geforce cards have always performed fine with 3d windowed open gl applications. Quadro cards may have been faster, but they were never the only option.

With this optimus misery we are not talking about a small performance problem but about a massive memory leak that makes these cards entirely unusable.

The second part of your post does make sense, what would be the channel to get proper support?

R.
You must be kidding right?



geforce cards have always performed fine with 3d windowed open gl applications. Quadro cards may have been faster, but they were never the only option.



With this optimus misery we are not talking about a small performance problem but about a massive memory leak that makes these cards entirely unusable.



The second part of your post does make sense, what would be the channel to get proper support?



R.

#14
Posted 05/11/2011 10:18 AM   
that's bad! I was just about to order the new dell xps15 with the 540M.
Did anyone alredy tryed the new driver 270.61 WHQL??
http://www.nvidia.com/object/notebook-win7-winvista-64bit-270.61-whql-driver.html

thanks
Alberto
that's bad! I was just about to order the new dell xps15 with the 540M.

Did anyone alredy tryed the new driver 270.61 WHQL??

http://www.nvidia.com/object/notebook-win7-winvista-64bit-270.61-whql-driver.html



thanks

Alberto

#15
Posted 05/12/2011 02:16 PM   
  1 / 12    
Scroll To Top