Dragon age 2 - dx11 performance
  1 / 3    
Simply put it's horrible. Even with the 267.26 drivers that were supposed to improve performance.

System specs : i5 2400 / 4gb 1333 mhz / gtx 560 ti

On 1680x1050 dx11 it runs at 20-25 fps with all the options enabled - very high (4xaa)
At high only - 35-50 fps (no tesselation, dof, advanced lighting etc) (4xaa)

Ati's are basically crushing nvidia in this game.

Same settings as above on a 6870

1680x1050 dx11 very high all enabled - 45 fps (4xaa)

I never expected this especially with nvidia's supposed better and faster dx11 rendering tech.

Another interesting benchmark : http://www.hardwareheaven.com/reviews/1127/pg9/amd-radeon-hd-6990-graphics-card-review-dragon-age-2.html - as you can see nvidia gets totaled
Simply put it's horrible. Even with the 267.26 drivers that were supposed to improve performance.



System specs : i5 2400 / 4gb 1333 mhz / gtx 560 ti



On 1680x1050 dx11 it runs at 20-25 fps with all the options enabled - very high (4xaa)

At high only - 35-50 fps (no tesselation, dof, advanced lighting etc) (4xaa)



Ati's are basically crushing nvidia in this game.



Same settings as above on a 6870



1680x1050 dx11 very high all enabled - 45 fps (4xaa)



I never expected this especially with nvidia's supposed better and faster dx11 rendering tech.



Another interesting benchmark : http://www.hardwareheaven.com/reviews/1127/pg9/amd-radeon-hd-6990-graphics-card-review-dragon-age-2.html - as you can see nvidia gets totaled

Motherboard: Gigabyte PH67-UD3-B3

Cpu: I5 2400 @ 3.1 ghz

Ram: Kingston 2x2gb 1333 mhz ddr3 + Corsair 2x4gb XMS3 1333mhz ddr3 = 12gb

Video card: Gigabyte 680 OC

PSU: Corsair 850W TX V2

Display: 40" Samsung LE40C530 (1920x1080)

Operating system: Windows 7 ultimate 64bit

Forceware version: 301.24

Case: Recom Powerstation Evo - 5x120mm fans

#1
Posted 03/08/2011 06:40 AM   
with my gtx 460 i got 20fps lol.......
with my gtx 460 i got 20fps lol.......

#2
Posted 03/08/2011 07:09 AM   
Yep, horrible performance. I wonder when nVidia will correct this, if ever. It's unacceptably bad right now. Unplayable.
Yep, horrible performance. I wonder when nVidia will correct this, if ever. It's unacceptably bad right now. Unplayable.

#3
Posted 03/08/2011 04:51 PM   
Yeah it's really bad for me too. I never would have thought that i'd have problems with this games performance after running crysis/metro maxed lol.
Yeah it's really bad for me too. I never would have thought that i'd have problems with this games performance after running crysis/metro maxed lol.

Ubelsteiner Rig

Intel Q9550 @ 3.9Ghz

Asus P5E-VM HDMI

4x2GB DDR2-1000

Nvidia GTX 570 (900/1800/2000)

Creative X-Fi

In-Win BR-665

Mitsubishi 60" DLP

#4
Posted 03/08/2011 06:32 PM   
In the demo, I would get black triangles where tessellation should be. It was useless.
In the demo, I would get black triangles where tessellation should be. It was useless.



8130p @ 5.1Ghz : GTX 570 x2 - cuda workstation



i5-2500k @ 4.4Ghz : GTX 570 - itx media pc

#5
Posted 03/08/2011 07:33 PM   
They've fixed the black triangles in the Beta driver, but the performance is pathetic.
They've fixed the black triangles in the Beta driver, but the performance is pathetic.
#6
Posted 03/08/2011 11:44 PM   
Downloading the game as we speak so i'll see how it is for me, i got the same triangles in the demo but the fps was around 40 ish
Edit: Haha, it's not released till the 11th in the Uk i presume so it won't let me run it lol.
Downloading the game as we speak so i'll see how it is for me, i got the same triangles in the demo but the fps was around 40 ish

Edit: Haha, it's not released till the 11th in the Uk i presume so it won't let me run it lol.

Image

#7
Posted 03/09/2011 01:12 AM   
Running GTX570 SLI here and also getting sub=standard performance. The beta drivers are better but still not good enough.

I'm starting to feel like I chose the wrong company since ATI users are having no trouble.
Running GTX570 SLI here and also getting sub=standard performance. The beta drivers are better but still not good enough.



I'm starting to feel like I chose the wrong company since ATI users are having no trouble.

#8
Posted 03/09/2011 05:08 PM   
[quote name='Jdp311' date='09 March 2011 - 10:08 AM' timestamp='1299690480' post='1204868']
Running GTX570 SLI here and also getting sub=standard performance. The beta drivers are better but still not good enough.

I'm starting to feel like I chose the wrong company since ATI users are having no trouble.
[/quote]
So has any1 got a fix for the terible DX11 performance for Nvidia user's?
[quote name='Jdp311' date='09 March 2011 - 10:08 AM' timestamp='1299690480' post='1204868']

Running GTX570 SLI here and also getting sub=standard performance. The beta drivers are better but still not good enough.



I'm starting to feel like I chose the wrong company since ATI users are having no trouble.



So has any1 got a fix for the terible DX11 performance for Nvidia user's?

#9
Posted 03/10/2011 06:57 AM   
[img]http://img593.imageshack.us/img593/3198/dao2gpuusagenvidia.jpg[/img]

This is my GPU usage with high settings, awesome /blarg.gif' class='bbc_emoticon' alt=':/' />
Image



This is my GPU usage with high settings, awesome /blarg.gif' class='bbc_emoticon' alt=':/' />

#10
Posted 03/10/2011 09:41 AM   
Just stop whining and wait for a driver update :P
Just stop whining and wait for a driver update :P

Image

#11
Posted 03/10/2011 12:42 PM   
[quote name='Krony' date='10 March 2011 - 07:42 AM' timestamp='1299760949' post='1205292']
Just stop whining and wait for a driver update :P
[/quote]

So glad you're willing to bend over and accept sub-standard performance. They claim to be the best and stamp 'plays better on Nvidia' all over everything, so that's what I expect. If you don't, just go away.

Thanks.
[quote name='Krony' date='10 March 2011 - 07:42 AM' timestamp='1299760949' post='1205292']

Just stop whining and wait for a driver update :P





So glad you're willing to bend over and accept sub-standard performance. They claim to be the best and stamp 'plays better on Nvidia' all over everything, so that's what I expect. If you don't, just go away.



Thanks.

#12
Posted 03/10/2011 10:30 PM   
While it is annoying that they do not have SLI, or proper GPU utlization for DA2, it is not always so that Nvidia is the trailing for a game release and driver support, each company will have its lag for a driver release to fix performance in a game. That is why I havnt bought a game that is brand new in over 3 years.

AMD had drivers ready for DA2, Nvidia did not, hats off to AMD.
While it is annoying that they do not have SLI, or proper GPU utlization for DA2, it is not always so that Nvidia is the trailing for a game release and driver support, each company will have its lag for a driver release to fix performance in a game. That is why I havnt bought a game that is brand new in over 3 years.



AMD had drivers ready for DA2, Nvidia did not, hats off to AMD.

Using Left over CPU coolers to keep phones cool since 2012.

Image

#13
Posted 03/10/2011 11:03 PM   
http://www.overclock.net/pc-games/961022-dragon-age-2-sli-gpu-usage.html

This may help the SLI issues, it doesn't seem to effect single GPUs though. Check it out.
http://www.overclock.net/pc-games/961022-dragon-age-2-sli-gpu-usage.html



This may help the SLI issues, it doesn't seem to effect single GPUs though. Check it out.

#14
Posted 03/11/2011 02:08 PM   
My GTX580 have some problems running in DX11 Very high.

Setting the game to high helps, but that also disables tesselation and other lightning stuff.

We need a fix.
My GTX580 have some problems running in DX11 Very high.



Setting the game to high helps, but that also disables tesselation and other lightning stuff.



We need a fix.

HAF X Full tower with 1200W Corsair ATX Gold
ROG Asus Maximus IV Sandy Bridge
i7 2600k 3,4 ~ 4,2Ghz with Zalman cooler
16Gb Vengeance 15250MB/s
2x2 TB HD, Writing at 185-200MB/s, 500GB for Windows 7 Ultimate
ASUS GeForce GTX 780 OC
27" 16:9 HD 1ms response

#15
Posted 03/11/2011 03:51 PM   
  1 / 3    
Scroll To Top