YouTube activates 3D Vision in Firefox
  1 / 3    
Hi guys,

I recently upgraded my driver to the following:

NVIDIA 3D Vision Controller Driver 266.21
NVIDIA 3D Vision Driver 266.58
NVIDIA Graphics Driver 266.58
NVIDIA PhysX System Software 9.10.0514

My system:

GeForce GTX 260
Windows 7 (x64)

For some reason, whenever I attempt to play a video on YouTube in Firefox, the following happens:

1) The screen briefly goes black.
2) The green light on the infra red transmitter goes bright green.
3) The shutter glasses activate.
4) Windows displays a message about switching to the "Windows 7 Basic color scheme".

Ordinarily, these are the things I expect to see happening when viewing a 3D image/video on 3D Vision Live, but this is youtube we're talking about here - there is no stereoscopic content.

Investigating further, I disabled ALL addins in Firefox and tried again. Nothing happened (including no video since it needed flash)

I then enabled ONLY the Shockwave Flash plugin and tried again. The problem was then evident again.

So, the bare minimum to reproduce:

1) Stereoscopic 3D enabled via NVIDIA Control Panel.
2) Using Firefox browser.
3) Flash Plugin enabled.
4) YouTube website.

Is this something that's co-incidentally just changed on the YouTube website recently, or is there an issue with the new driver?

It wouldn't matter so much except that I have two monitors and have all kinds of problems when 3d kicks in and both are enabled, so for now I need to disable a monitor just to watch any video on YouTube, even though they're not even using stereoscopic 3d.

I'd love to hear some feedback on this. I've read similar posts from others with different hardware, leading me to believe the issue is with the driver itself.

Please let me know what you think!

Thanks so much for reading this.

- Ken

UPDATE: The version of the Shockwave Flash add-on in Firefox is 10.2.152.26 which is the latest according to http://get.adobe.com/flashplayer/.
Hi guys,



I recently upgraded my driver to the following:



NVIDIA 3D Vision Controller Driver 266.21

NVIDIA 3D Vision Driver 266.58

NVIDIA Graphics Driver 266.58

NVIDIA PhysX System Software 9.10.0514



My system:



GeForce GTX 260

Windows 7 (x64)



For some reason, whenever I attempt to play a video on YouTube in Firefox, the following happens:



1) The screen briefly goes black.

2) The green light on the infra red transmitter goes bright green.

3) The shutter glasses activate.

4) Windows displays a message about switching to the "Windows 7 Basic color scheme".



Ordinarily, these are the things I expect to see happening when viewing a 3D image/video on 3D Vision Live, but this is youtube we're talking about here - there is no stereoscopic content.



Investigating further, I disabled ALL addins in Firefox and tried again. Nothing happened (including no video since it needed flash)



I then enabled ONLY the Shockwave Flash plugin and tried again. The problem was then evident again.



So, the bare minimum to reproduce:



1) Stereoscopic 3D enabled via NVIDIA Control Panel.

2) Using Firefox browser.

3) Flash Plugin enabled.

4) YouTube website.



Is this something that's co-incidentally just changed on the YouTube website recently, or is there an issue with the new driver?



It wouldn't matter so much except that I have two monitors and have all kinds of problems when 3d kicks in and both are enabled, so for now I need to disable a monitor just to watch any video on YouTube, even though they're not even using stereoscopic 3d.



I'd love to hear some feedback on this. I've read similar posts from others with different hardware, leading me to believe the issue is with the driver itself.



Please let me know what you think!



Thanks so much for reading this.



- Ken



UPDATE: The version of the Shockwave Flash add-on in Firefox is 10.2.152.26 which is the latest according to http://get.adobe.com/flashplayer/.

#1
Posted 02/20/2011 06:21 AM   
[quote name='theken' date='20 February 2011 - 07:21 AM' timestamp='1298182910' post='1196174']
Hi guys,

I recently upgraded my driver to the following:

NVIDIA 3D Vision Controller Driver 266.21
NVIDIA 3D Vision Driver 266.58
NVIDIA Graphics Driver 266.58
NVIDIA PhysX System Software 9.10.0514

My system:

GeForce GTX 260
Windows 7 (x64)

For some reason, whenever I attempt to play a video on YouTube in Firefox, the following happens:

1) The screen briefly goes black.
2) The green light on the infra red transmitter goes bright green.
3) The shutter glasses activate.
4) Windows displays a message about switching to the "Windows 7 Basic color scheme".

Ordinarily, these are the things I expect to see happening when viewing a 3D image/video on 3D Vision Live, but this is youtube we're talking about here - there is no stereoscopic content.

Investigating further, I disabled ALL addins in Firefox and tried again. Nothing happened (including no video since it needed flash)

I then enabled ONLY the Shockwave Flash plugin and tried again. The problem was then evident again.

So, the bare minimum to reproduce:

1) Stereoscopic 3D enabled via NVIDIA Control Panel.
2) Using Firefox browser.
3) Flash Plugin enabled.
4) YouTube website.

Is this something that's co-incidentally just changed on the YouTube website recently, or is there an issue with the new driver?

It wouldn't matter so much except that I have two monitors and have all kinds of problems when 3d kicks in and both are enabled, so for now I need to disable a monitor just to watch any video on YouTube, even though they're not even using stereoscopic 3d.

I'd love to hear some feedback on this. I've read similar posts from others with different hardware, leading me to believe the issue is with the driver itself.

Please let me know what you think!

Thanks so much for reading this.

- Ken

UPDATE: The version of the Shockwave Flash add-on in Firefox is 10.2.152.26 which is the latest according to http://get.adobe.com/flashplayer/.
[/quote]

Same problem here, however, it's getting worse.

First, only Youtube fullscreen movies had those problems.
After that, Every Flash fullscreen movie had those problems.
Now, everytime I launch a youtube movie (NOT FULLSCREEN), I get the same problem.

It's getting really annoying now... Is there a fix available?
[quote name='theken' date='20 February 2011 - 07:21 AM' timestamp='1298182910' post='1196174']

Hi guys,



I recently upgraded my driver to the following:



NVIDIA 3D Vision Controller Driver 266.21

NVIDIA 3D Vision Driver 266.58

NVIDIA Graphics Driver 266.58

NVIDIA PhysX System Software 9.10.0514



My system:



GeForce GTX 260

Windows 7 (x64)



For some reason, whenever I attempt to play a video on YouTube in Firefox, the following happens:



1) The screen briefly goes black.

2) The green light on the infra red transmitter goes bright green.

3) The shutter glasses activate.

4) Windows displays a message about switching to the "Windows 7 Basic color scheme".



Ordinarily, these are the things I expect to see happening when viewing a 3D image/video on 3D Vision Live, but this is youtube we're talking about here - there is no stereoscopic content.



Investigating further, I disabled ALL addins in Firefox and tried again. Nothing happened (including no video since it needed flash)



I then enabled ONLY the Shockwave Flash plugin and tried again. The problem was then evident again.



So, the bare minimum to reproduce:



1) Stereoscopic 3D enabled via NVIDIA Control Panel.

2) Using Firefox browser.

3) Flash Plugin enabled.

4) YouTube website.



Is this something that's co-incidentally just changed on the YouTube website recently, or is there an issue with the new driver?



It wouldn't matter so much except that I have two monitors and have all kinds of problems when 3d kicks in and both are enabled, so for now I need to disable a monitor just to watch any video on YouTube, even though they're not even using stereoscopic 3d.



I'd love to hear some feedback on this. I've read similar posts from others with different hardware, leading me to believe the issue is with the driver itself.



Please let me know what you think!



Thanks so much for reading this.



- Ken



UPDATE: The version of the Shockwave Flash add-on in Firefox is 10.2.152.26 which is the latest according to http://get.adobe.com/flashplayer/.





Same problem here, however, it's getting worse.



First, only Youtube fullscreen movies had those problems.

After that, Every Flash fullscreen movie had those problems.

Now, everytime I launch a youtube movie (NOT FULLSCREEN), I get the same problem.



It's getting really annoying now... Is there a fix available?

#2
Posted 02/20/2011 02:01 PM   
Humm ! I'm not alone :)
Humm ! I'm not alone :)

#3
Posted 02/20/2011 02:52 PM   
Same problem here, i think have to be with the multiple monitors issue.
Same problem here, i think have to be with the multiple monitors issue.

#4
Posted 02/20/2011 04:20 PM   
[font="Arial"]Seems that quite a few of us are having the same issue as per this earlier posted topic here [url="http://forums.nvidia.com/index.php?showtopic=193456"]http://forums.nvidia...howtopic=193456[/url] (Search is your friend).

By the way, my Nvidia version numbers looks the same as theken's above:

[font="Arial"]"NVIDIA 3D Vision Controller Driver 266.21
NVIDIA 3D Vision Driver 266.58
NVIDIA Graphics Driver 266.58
NVIDIA PhysX System Software 9.10.0514"[/font][/font]
Seems that quite a few of us are having the same issue as per this earlier posted topic here http://forums.nvidia...howtopic=193456 (Search is your friend).



By the way, my Nvidia version numbers looks the same as theken's above:



"NVIDIA 3D Vision Controller Driver 266.21

NVIDIA 3D Vision Driver 266.58

NVIDIA Graphics Driver 266.58

NVIDIA PhysX System Software 9.10.0514"

#5
Posted 02/20/2011 05:34 PM   
You do have 3d vision disabled right? Click the disable 3d vision icon.

It will happen whenever a video is in one of your supported 3d modes like 1080 or 720.
You do have 3d vision disabled right? Click the disable 3d vision icon.



It will happen whenever a video is in one of your supported 3d modes like 1080 or 720.
I did disable 3D Vision and it was still happening, however, after shutting down and restarting the computer with 3D Vision already turned off, this behavior stopped happening.

Edit:

I can now disable 3D Vision and stop it from happening without re-booting, I do not know why I couldn't do that yesterday, maybe I thought I had disabled it and it did not - oh well.

I think that turning off 3D Vision before playing videos is an acceptable solution, but it does raise another question - With 3D Vision enabled and 3D Vision starting up when playing a Youtube video, does this mean we can now have Stereo 3D Youtube videos?
I did disable 3D Vision and it was still happening, however, after shutting down and restarting the computer with 3D Vision already turned off, this behavior stopped happening.



Edit:



I can now disable 3D Vision and stop it from happening without re-booting, I do not know why I couldn't do that yesterday, maybe I thought I had disabled it and it did not - oh well.



I think that turning off 3D Vision before playing videos is an acceptable solution, but it does raise another question - With 3D Vision enabled and 3D Vision starting up when playing a Youtube video, does this mean we can now have Stereo 3D Youtube videos?

#7
Posted 02/20/2011 10:34 PM   
[quote name='eqzitara' date='20 February 2011 - 01:28 PM' timestamp='1298237310' post='1196415']
You do have 3d vision disabled right? Click the disable 3d vision icon.

It will happen whenever a video is in one of your supported 3d modes like 1080 or 720.
[/quote]

It's true. The infra-red emitter won't come on unless you have Stereoscopic 3D enabled to begin with. (as I mentioned in the steps to reproduce this)

While I agree that disabling it prevents the issue from happening, I think it's more of a temporary workaround than a lasting solution. In normal day-to-day running of Windows, you shouldn't need to have to switch Stereoscopic 3D on and off as you go. The graphics card should not activate 3D Vision unless it is actually producing stereoscopic output, as I understand it. In the case of YouTube on Firefox, there seems to be no obvious reason why it would activate like this, when the content is not stereoscopic.

I also tested the theory of it being related to the resolution. I was able to reproduce the problem playing an old 176x144 video that I had uploaded to YouTube years ago, so it doesn't appear to be anything to do with the resolution of the source video. Had you meant the size of the flash player itself? In my test the video was showing at 480x360.

I tried making a simple HTML page on my local machine, embedding the same YouTube video. In such cases the problem did NOT happen. It appears the source of the problem is on regular YouTube pages, not when a YouTube video is embedded elsewhere.

Is it possible the issue is with YouTube themselves, or do we think it's the driver that's at fault?

- K
[quote name='eqzitara' date='20 February 2011 - 01:28 PM' timestamp='1298237310' post='1196415']

You do have 3d vision disabled right? Click the disable 3d vision icon.



It will happen whenever a video is in one of your supported 3d modes like 1080 or 720.





It's true. The infra-red emitter won't come on unless you have Stereoscopic 3D enabled to begin with. (as I mentioned in the steps to reproduce this)



While I agree that disabling it prevents the issue from happening, I think it's more of a temporary workaround than a lasting solution. In normal day-to-day running of Windows, you shouldn't need to have to switch Stereoscopic 3D on and off as you go. The graphics card should not activate 3D Vision unless it is actually producing stereoscopic output, as I understand it. In the case of YouTube on Firefox, there seems to be no obvious reason why it would activate like this, when the content is not stereoscopic.



I also tested the theory of it being related to the resolution. I was able to reproduce the problem playing an old 176x144 video that I had uploaded to YouTube years ago, so it doesn't appear to be anything to do with the resolution of the source video. Had you meant the size of the flash player itself? In my test the video was showing at 480x360.



I tried making a simple HTML page on my local machine, embedding the same YouTube video. In such cases the problem did NOT happen. It appears the source of the problem is on regular YouTube pages, not when a YouTube video is embedded elsewhere.



Is it possible the issue is with YouTube themselves, or do we think it's the driver that's at fault?



- K

#8
Posted 02/21/2011 12:40 AM   
[quote name='XYandZ' date='20 February 2011 - 02:34 PM' timestamp='1298241284' post='1196453']
I did disable 3D Vision and it was still happening, however, after shutting down and restarting the computer with 3D Vision already turned off, this behavior stopped happening.

Edit:

I can now disable 3D Vision and stop it from happening without re-booting, I do not know why I couldn't do that yesterday, maybe I thought I had disabled it and it did not - oh well.

I think that turning off 3D Vision before playing videos is an acceptable solution, but it does raise another question - With 3D Vision enabled and 3D Vision starting up when playing a Youtube video, does this mean we can now have Stereo 3D Youtube videos?
[/quote]

When I tested it I found that after disabling 3D Vision you need to quit Firefox completely (all windows) before you can then re-open Firefox and view a YouTube video without the issue coming up.

I would hope that stereo YouTube videos could be available in future. It'd be nice to see content like 3D Vision Live on YouTube. I still maintain, though, that 3D shouldn't be kicking in unless the content is actually stereoscopic. Something strange is still afoot here!
[quote name='XYandZ' date='20 February 2011 - 02:34 PM' timestamp='1298241284' post='1196453']

I did disable 3D Vision and it was still happening, however, after shutting down and restarting the computer with 3D Vision already turned off, this behavior stopped happening.



Edit:



I can now disable 3D Vision and stop it from happening without re-booting, I do not know why I couldn't do that yesterday, maybe I thought I had disabled it and it did not - oh well.



I think that turning off 3D Vision before playing videos is an acceptable solution, but it does raise another question - With 3D Vision enabled and 3D Vision starting up when playing a Youtube video, does this mean we can now have Stereo 3D Youtube videos?





When I tested it I found that after disabling 3D Vision you need to quit Firefox completely (all windows) before you can then re-open Firefox and view a YouTube video without the issue coming up.



I would hope that stereo YouTube videos could be available in future. It'd be nice to see content like 3D Vision Live on YouTube. I still maintain, though, that 3D shouldn't be kicking in unless the content is actually stereoscopic. Something strange is still afoot here!

#9
Posted 02/21/2011 12:42 AM   
[quote name='aragdun' date='20 February 2011 - 08:20 AM' timestamp='1298218806' post='1196297']
Same problem here, i think have to be with the multiple monitors issue.
[/quote]

The problem happens even when I only have one monitor enabled. The only difference is that if both monitors are enabled at the time, I need to do some enthusiastic ALT+F4 mashing to get anything back up on the screen. When only one monitor is enabled, the screen just goes black for a moment and then re-appears in Windows 7 Basic colour scheme. I've been testing it with only one monitor enabled, to try to simplify the issue as much as possible.

Just out of interest though... is anyone experiencing this who only has one monitor, or do you all have two? (or more?)

- K
[quote name='aragdun' date='20 February 2011 - 08:20 AM' timestamp='1298218806' post='1196297']

Same problem here, i think have to be with the multiple monitors issue.





The problem happens even when I only have one monitor enabled. The only difference is that if both monitors are enabled at the time, I need to do some enthusiastic ALT+F4 mashing to get anything back up on the screen. When only one monitor is enabled, the screen just goes black for a moment and then re-appears in Windows 7 Basic colour scheme. I've been testing it with only one monitor enabled, to try to simplify the issue as much as possible.



Just out of interest though... is anyone experiencing this who only has one monitor, or do you all have two? (or more?)



- K

#10
Posted 02/21/2011 12:45 AM   
While this issue does seem to be Firefox related, it's not confined to youtube. I have the same problem over at Vimeo. I think it may be a flash/firefox/nvidia issue. I also am running dual monitors although they're cloned and only one is on at a time, (projector/lcd panel)
While this issue does seem to be Firefox related, it's not confined to youtube. I have the same problem over at Vimeo. I think it may be a flash/firefox/nvidia issue. I also am running dual monitors although they're cloned and only one is on at a time, (projector/lcd panel)

#11
Posted 02/21/2011 01:50 AM   
Ok this is why it happens. There is no code in movies that tells your display its 3d. If [u]3d vision is enabled any resolution it can accept it will assume it is 3d.[/u] Depending on your monitor it can be many resolutions but mostly it is 1280x720 and 1920x1080. [u]If you are watching a movie in full screen it will assume it is whatever your desktop resolution is(so if you are watching 480p resolution movie and go full screen with 1280x720 resolution 3d vision will enable[/u] Just turn off 3d vision unless gaming.
Ok this is why it happens. There is no code in movies that tells your display its 3d. If 3d vision is enabled any resolution it can accept it will assume it is 3d. Depending on your monitor it can be many resolutions but mostly it is 1280x720 and 1920x1080. If you are watching a movie in full screen it will assume it is whatever your desktop resolution is(so if you are watching 480p resolution movie and go full screen with 1280x720 resolution 3d vision will enable Just turn off 3d vision unless gaming.
[quote name='eqzitara' date='20 February 2011 - 09:21 PM' timestamp='1298254891' post='1196530']
Ok this is why it happens. 3d Vision does not know when what you are watching is a 3d movie or not. There is no code in movies that tells your display its 3d. Thats why if you go to watch a 3d movie you have to enable everything and tell your video player that your watching a 3d movie. If [u]3d vision is enabled any resolution it can accept it will assume it is 3d.[/u] Depending on your monitor it can be many resolutions but mostly it is 1280x720 and 1920x1080. [u]If you are watching a movie in full screen it will assume it is whatever your desktop resolution is(so if you are watching 480p resolution movie and go full screen with 1280x720 resolution 3d vision will enable[/u] Just turn off 3d vision unless gaming.
[/quote]


then it should be a system wide behavior and not restricted to Firefox. In IE, videos play just fine, either window or full screen mode. Also, if i revert back to the previous drivers, everything works fine in all browsers.
[quote name='eqzitara' date='20 February 2011 - 09:21 PM' timestamp='1298254891' post='1196530']

Ok this is why it happens. 3d Vision does not know when what you are watching is a 3d movie or not. There is no code in movies that tells your display its 3d. Thats why if you go to watch a 3d movie you have to enable everything and tell your video player that your watching a 3d movie. If 3d vision is enabled any resolution it can accept it will assume it is 3d. Depending on your monitor it can be many resolutions but mostly it is 1280x720 and 1920x1080. If you are watching a movie in full screen it will assume it is whatever your desktop resolution is(so if you are watching 480p resolution movie and go full screen with 1280x720 resolution 3d vision will enable Just turn off 3d vision unless gaming.







then it should be a system wide behavior and not restricted to Firefox. In IE, videos play just fine, either window or full screen mode. Also, if i revert back to the previous drivers, everything works fine in all browsers.

#13
Posted 02/21/2011 03:25 AM   
I guess your right but it happens with 720p videos with me where it assumes its 3d for me(non browser. And firefox so I don't know. Well anywho long story short just disable it when not gaming.
I guess your right but it happens with 720p videos with me where it assumes its 3d for me(non browser. And firefox so I don't know. Well anywho long story short just disable it when not gaming.
I have one monitor, same problem..
I have one monitor, same problem..

#15
Posted 02/21/2011 11:40 AM   
  1 / 3    
Scroll To Top