Google Earth now in 3D!
  1 / 3    
I recently installed the new drivers (266.58) and now whenever I start Google Earth it switches to 3D mode and I have to put my glasses on to see the map.

Apparently this is a "new feature" in these drivers!

# Adds 3D Vision Window Mode support for the following games and applications:

* Google Earth

Anyone know how to disable this "feature" in Google Earth (so far the only way I've found is to switch to OpenGL mode, instead of DirectX).

It's really annoying and there doesn't seem to be any benefit to switching to this windowed 3D mode for Google Earth. Except for the map the rest is in 2D and the 3D map doesn't give you any extra 3D perspective (other than the entire map window is on a different plane).
I recently installed the new drivers (266.58) and now whenever I start Google Earth it switches to 3D mode and I have to put my glasses on to see the map.



Apparently this is a "new feature" in these drivers!



# Adds 3D Vision Window Mode support for the following games and applications:



* Google Earth



Anyone know how to disable this "feature" in Google Earth (so far the only way I've found is to switch to OpenGL mode, instead of DirectX).



It's really annoying and there doesn't seem to be any benefit to switching to this windowed 3D mode for Google Earth. Except for the map the rest is in 2D and the 3D map doesn't give you any extra 3D perspective (other than the entire map window is on a different plane).

#1
Posted 01/27/2011 10:03 AM   
yeah, I didn't find google earth to be enhanced by 3d vision. Maybe when every single building in every town and city is modeled, then it'll be cooler. But convergence cannot be changed either so there's no way to experiment with different 3d settings either. /confused.gif' class='bbc_emoticon' alt=':confused:' />
yeah, I didn't find google earth to be enhanced by 3d vision. Maybe when every single building in every town and city is modeled, then it'll be cooler. But convergence cannot be changed either so there's no way to experiment with different 3d settings either. /confused.gif' class='bbc_emoticon' alt=':confused:' />

AsRock X58 Extreme6 mobo
Intel Core-i7 950 @ 4ghz
6gb Corsair Dominator DDR3 2000
ASUS DirectCU II GTX 780 3gb
Corsair TX 950w PSU
NZXT Phantom Red/Black Case
3d Vision 1 w/ Samsung 2233rz Monitor
3d Vision 2 w/ ASUS VG278HE Monitor

#2
Posted 01/27/2011 09:02 PM   
[quote name='pjm' date='27 January 2011 - 02:03 AM' timestamp='1296122629' post='1184460']
I recently installed the new drivers (266.58) and now whenever I start Google Earth it switches to 3D mode and I have to put my glasses on to see the map.

Apparently this is a "new feature" in these drivers!

# Adds 3D Vision Window Mode support for the following games and applications:

* Google Earth

Anyone know how to disable this "feature" in Google Earth (so far the only way I've found is to switch to OpenGL mode, instead of DirectX).

It's really annoying and there doesn't seem to be any benefit to switching to this windowed 3D mode for Google Earth. Except for the map the rest is in 2D and the 3D map doesn't give you any extra 3D perspective (other than the entire map window is on a different plane).
[/quote]

Umm, is this a trick question? (CTRL + T) to turn off 3d vision.
[quote name='pjm' date='27 January 2011 - 02:03 AM' timestamp='1296122629' post='1184460']

I recently installed the new drivers (266.58) and now whenever I start Google Earth it switches to 3D mode and I have to put my glasses on to see the map.



Apparently this is a "new feature" in these drivers!



# Adds 3D Vision Window Mode support for the following games and applications:



* Google Earth



Anyone know how to disable this "feature" in Google Earth (so far the only way I've found is to switch to OpenGL mode, instead of DirectX).



It's really annoying and there doesn't seem to be any benefit to switching to this windowed 3D mode for Google Earth. Except for the map the rest is in 2D and the 3D map doesn't give you any extra 3D perspective (other than the entire map window is on a different plane).





Umm, is this a trick question? (CTRL + T) to turn off 3d vision.

#3
Posted 01/28/2011 01:09 AM   
[quote name='mammoman' date='28 January 2011 - 11:09 AM' timestamp='1296176951' post='1184792']
Umm, is this a trick question? (CTRL + T) to turn off 3d vision.
[/quote]

thanks - I never knew that, unfortunately it leaves the map at a lower brightness than it is normally is which makes it harder to read, so it's still better to use OpenGL mode at the moment.

Why isn't there an option somewhere so the user can decide if the application is going to switch to 3D mode?
[quote name='mammoman' date='28 January 2011 - 11:09 AM' timestamp='1296176951' post='1184792']

Umm, is this a trick question? (CTRL + T) to turn off 3d vision.





thanks - I never knew that, unfortunately it leaves the map at a lower brightness than it is normally is which makes it harder to read, so it's still better to use OpenGL mode at the moment.



Why isn't there an option somewhere so the user can decide if the application is going to switch to 3D mode?

#4
Posted 01/28/2011 06:19 AM   
[quote name='pjm' date='27 January 2011 - 10:19 PM' timestamp='1296195596' post='1184883']
thanks - I never knew that, unfortunately it leaves the map at a lower brightness than it is normally is which makes it harder to read, so it's still better to use OpenGL mode at the moment.

Why isn't there an option somewhere so the user can decide if the application is going to switch to 3D mode?
[/quote]

Look at the Nvidia control panel. In there are some settings like setting up witch keys to enable, disable 3d mode, and whether or not you want your apps to automatically start in 3d.
[quote name='pjm' date='27 January 2011 - 10:19 PM' timestamp='1296195596' post='1184883']

thanks - I never knew that, unfortunately it leaves the map at a lower brightness than it is normally is which makes it harder to read, so it's still better to use OpenGL mode at the moment.



Why isn't there an option somewhere so the user can decide if the application is going to switch to 3D mode?





Look at the Nvidia control panel. In there are some settings like setting up witch keys to enable, disable 3d mode, and whether or not you want your apps to automatically start in 3d.

#5
Posted 01/28/2011 12:59 PM   
[quote name='pjm' date='27 January 2011 - 11:03 AM' timestamp='1296122629' post='1184460']
It's really annoying and there doesn't seem to be any benefit to switching to this windowed 3D mode for Google Earth. Except for the map the rest is in 2D and the 3D map doesn't give you any extra 3D perspective (other than the entire map window is on a different plane).
[/quote]

Not true, try flying just over New York City with all buildings enabled... It really is stunning, not just a 2D plane in the background !
[quote name='pjm' date='27 January 2011 - 11:03 AM' timestamp='1296122629' post='1184460']

It's really annoying and there doesn't seem to be any benefit to switching to this windowed 3D mode for Google Earth. Except for the map the rest is in 2D and the 3D map doesn't give you any extra 3D perspective (other than the entire map window is on a different plane).





Not true, try flying just over New York City with all buildings enabled... It really is stunning, not just a 2D plane in the background !

#6
Posted 01/28/2011 01:12 PM   
I'm sorry this thread struck me as kind of funny....Earth! Now in 3d!!
I'm sorry this thread struck me as kind of funny....Earth! Now in 3d!!

#7
Posted 01/28/2011 01:48 PM   
For me, there is not 3D building. Everything is flat, but deep at a few "inches in the screen".

I'm using the latest drivers 266.58
For me, there is not 3D building. Everything is flat, but deep at a few "inches in the screen".



I'm using the latest drivers 266.58

#8
Posted 01/30/2011 09:07 PM   
[quote name='kitarolivier' date='31 January 2011 - 07:07 AM' timestamp='1296421653' post='1186203']
For me, there is not 3D building. Everything is flat, but deep at a few "inches in the screen".

I'm using the latest drivers 266.58
[/quote]

yes this is the same as everyone is seeing, which makes the whole thing pretty useless, and there is NO OPTION to TURN IT OFF!

It turns google earth into an "annoying" application that you need to use glasses for, where previously it was a "useful" app.

(as pointed out by another poster) there is a 3D building layer you can turn on, but this was available pre the forced 3D switch on and I never found it very useful. It was only interesting for about 3 minutes, but then I turned it off.
[quote name='kitarolivier' date='31 January 2011 - 07:07 AM' timestamp='1296421653' post='1186203']

For me, there is not 3D building. Everything is flat, but deep at a few "inches in the screen".



I'm using the latest drivers 266.58





yes this is the same as everyone is seeing, which makes the whole thing pretty useless, and there is NO OPTION to TURN IT OFF!



It turns google earth into an "annoying" application that you need to use glasses for, where previously it was a "useful" app.



(as pointed out by another poster) there is a 3D building layer you can turn on, but this was available pre the forced 3D switch on and I never found it very useful. It was only interesting for about 3 minutes, but then I turned it off.

#9
Posted 01/30/2011 09:34 PM   
what about when you switch to the sky version? does it render in 3d? the constellations or the moon shots?
what about when you switch to the sky version? does it render in 3d? the constellations or the moon shots?

System:

Intel I7 920 overclocked to 4ghz

Asus Rampage Extreme II

2 Ge-force 480 in SLI

GTX 295 PhysX Card

12gb ddr3 2000mhz ram

Intel SSD in RAID 0

BR RW

1000w Sony surround sound

NVIDIA 3D Vision



3d displays tested:



Mitsubishi 65" DLP 3d HDTV (good old 1080p checkerboard since 2007!!!)

Panasonic VT25 (nice 2d but I returned it due to cross talk)

Acer H5360 720p on 130" screen (the best 3d)

23" Acer LCD monitor (horrible cross talk- sold it)

Samsung 65D8000

#10
Posted 01/31/2011 09:40 PM   
I can't get Google Earth in 3D, and I would appreciate if someone can help me... I have a new ASUS G73JW 3D laptop with GeForce GTX 460M and 3D Vision. other applications run beautifully in 3D but GE remains 2D in both DirectX and OpenGL modes. do I need to change any other settings? or perhaps GE 3D works only on desktop GeForce? any ideas?

I also have Quadro card on my desktop PC, and GE runs in 3D without problem. but I also need to be able to give 3D presentations to my clients on my laptop. hope you can help, thnx...

ps- @DanielJoy: sky version works in 3D mode as well, however it's just a flat 2D image of stars and galaxies, there's no "depth"... Moon and Mars have a real 3D terrain (just like Earth).
I can't get Google Earth in 3D, and I would appreciate if someone can help me... I have a new ASUS G73JW 3D laptop with GeForce GTX 460M and 3D Vision. other applications run beautifully in 3D but GE remains 2D in both DirectX and OpenGL modes. do I need to change any other settings? or perhaps GE 3D works only on desktop GeForce? any ideas?



I also have Quadro card on my desktop PC, and GE runs in 3D without problem. but I also need to be able to give 3D presentations to my clients on my laptop. hope you can help, thnx...



ps- @DanielJoy: sky version works in 3D mode as well, however it's just a flat 2D image of stars and galaxies, there's no "depth"... Moon and Mars have a real 3D terrain (just like Earth).

#11
Posted 02/14/2011 05:45 AM   
THANK YOU NVIDIA!!! works great... there are a few bugs... the depth perception is hard to adjust but you can adjust it. The icons are all 3d but the mouse cursor isn't. The hud and popup windows dont render quite right. Other than that it works just like it should with no loss of frame rate too! Looks best with terrain on!
THANK YOU NVIDIA!!! works great... there are a few bugs... the depth perception is hard to adjust but you can adjust it. The icons are all 3d but the mouse cursor isn't. The hud and popup windows dont render quite right. Other than that it works just like it should with no loss of frame rate too! Looks best with terrain on!

#12
Posted 02/14/2011 07:25 AM   
ad5os, that's great, I know the feeling... ))
can you please tell me if you have Quadro or GeForce card? if GeForce, how did you make GE work with it in 3D? (please read my post above)
thanks for your help..
ad5os, that's great, I know the feeling... ))

can you please tell me if you have Quadro or GeForce card? if GeForce, how did you make GE work with it in 3D? (please read my post above)

thanks for your help..

#13
Posted 02/17/2011 11:34 PM   
[quote name='ZZ3D' date='17 February 2011 - 05:34 PM' timestamp='1297985699' post='1195205']
ad5os, that's great, I know the feeling... ))
can you please tell me if you have Quadro or GeForce card? if GeForce, how did you make GE work with it in 3D? (please read my post above)
thanks for your help..
[/quote]


Honestly I didn't even know it was enabled until I opened google earth and it went into 3d mode automatically. It looks like what the driver or software is doing is makeing a slightly off centered window to the side and when you adjust the depth you are just adjusting that 2nd window so the left part of the screen looks a lil weird. I have a geforce 560, brand new with what I think are the latest drivers. one thing i found helped whas while adjusting the depth wheel to also zoom in and out so it refreshes the google earth screen. Hope that helps.. also you need it on DirectX mode I believe.
[quote name='ZZ3D' date='17 February 2011 - 05:34 PM' timestamp='1297985699' post='1195205']

ad5os, that's great, I know the feeling... ))

can you please tell me if you have Quadro or GeForce card? if GeForce, how did you make GE work with it in 3D? (please read my post above)

thanks for your help..







Honestly I didn't even know it was enabled until I opened google earth and it went into 3d mode automatically. It looks like what the driver or software is doing is makeing a slightly off centered window to the side and when you adjust the depth you are just adjusting that 2nd window so the left part of the screen looks a lil weird. I have a geforce 560, brand new with what I think are the latest drivers. one thing i found helped whas while adjusting the depth wheel to also zoom in and out so it refreshes the google earth screen. Hope that helps.. also you need it on DirectX mode I believe.

#14
Posted 02/18/2011 01:17 AM   
[quote name='ad5os' date='17 February 2011 - 08:17 PM' timestamp='1297991855' post='1195243']
Honestly I didn't even know it was enabled until I opened google earth and it went into 3d mode automatically. It looks like what the driver or software is doing is makeing a slightly off centered window to the side and when you adjust the depth you are just adjusting that 2nd window so the left part of the screen looks a lil weird. I have a geforce 560, brand new with what I think are the latest drivers. one thing i found helped whas while adjusting the depth wheel to also zoom in and out so it refreshes the google earth screen. Hope that helps.. also you need it on DirectX mode I believe.
[/quote]
thanks, ad5os. I just tested GE again, but it's still not working in 3d : -(
I also went through all the settings in Nvidia Control Panel but I don't see anything that would prevent stereo in GE.
could it be that notebook version of GeForce driver (for GTX 460M in my case) is not supporting stereo in GE...? if so, why would Nvidia enable stereo in desktop card driver and not in mobile driver??
[quote name='ad5os' date='17 February 2011 - 08:17 PM' timestamp='1297991855' post='1195243']

Honestly I didn't even know it was enabled until I opened google earth and it went into 3d mode automatically. It looks like what the driver or software is doing is makeing a slightly off centered window to the side and when you adjust the depth you are just adjusting that 2nd window so the left part of the screen looks a lil weird. I have a geforce 560, brand new with what I think are the latest drivers. one thing i found helped whas while adjusting the depth wheel to also zoom in and out so it refreshes the google earth screen. Hope that helps.. also you need it on DirectX mode I believe.



thanks, ad5os. I just tested GE again, but it's still not working in 3d : -(

I also went through all the settings in Nvidia Control Panel but I don't see anything that would prevent stereo in GE.

could it be that notebook version of GeForce driver (for GTX 460M in my case) is not supporting stereo in GE...? if so, why would Nvidia enable stereo in desktop card driver and not in mobile driver??

#15
Posted 02/18/2011 04:07 AM   
  1 / 3    
Scroll To Top