HOW TO : Fix Overscaling issue on VX2435 monitors (and others) PC Monitors seen as an HDTV causing o
I just ran into this issue after installing the 266.58 driver so I decided to post it. It seem to happen on other driver version also...

This is for the Viewsonic VX2435 monitor but this will normaly work for all monitors that as this issue because it being detected as an HDTV by the NVIDIA card. My setup is running a GTX 460 but I found that alot of other models can suffer from this, down to the 8 series and more, I dont know.

This require minimum knowledge in registry editing and basic computer operation. I'm not willing to do a noob-proof detailed guide...
*Registry editing is dangerous and can turn your computer in a Barbie penthouse blablabla...

In short, over-scaling issue is because the monitor can also behave as an HDTV. Some are able to fix it by disabling audio via HDMI, but others cant get it work by natural configuration. The fix is simple, tell the card to override the hdtv capability of the monitor and see it as a pc monitor only. Note that you will lose the "audio via HDMI" capability.


[b]How to override the HDTV flag of a monitor :[/b]

1)In regedit, go to "HKLM\SYSTEM\CURRENTCONTROLSET\CONTROL\VIDEO\"

2)Find your device (video card)
Device look like {B1133990-63AA-4C41-8EBF-0454478E0CF6}.
In the 0000 key in it, you can see the "Device Description" value, example "NVIDIA GeForce GTX 460".

3)Add the binary value to override EDID
Directly in 0000, create a new REG_BINARY value, name it "OverrideEdidFlags0".
Set value as follow "5a 63 1e bd 00 00 ff ff 04 00 00 00 7e 01 00"
Exit and Reboot.

This should do the trick. In the Control panel, you will only see PC resolutions, no HDTV anymore.



[b]Other monitors than VX2435[/b] : You need to find the 4 HEX that identify you monitor. Google for "Phoenix EDID Designer" (free) and run it. Extract Registry EDID for your monitor and open Byte Viewer. The 4 Hex value are from 08 to 0B (first row). Then do all the step above and in the OverrideEdidFlags0 value, change the 4 first HEX to what you found in Byte Viewer. In the example above, the 4 HEX that identify the VX2435 monitor are "5a 63 1e bd".


I hope this will help some of you... And I hope this will be fixed in future driver release...

Ben
I just ran into this issue after installing the 266.58 driver so I decided to post it. It seem to happen on other driver version also...



This is for the Viewsonic VX2435 monitor but this will normaly work for all monitors that as this issue because it being detected as an HDTV by the NVIDIA card. My setup is running a GTX 460 but I found that alot of other models can suffer from this, down to the 8 series and more, I dont know.



This require minimum knowledge in registry editing and basic computer operation. I'm not willing to do a noob-proof detailed guide...

*Registry editing is dangerous and can turn your computer in a Barbie penthouse blablabla...



In short, over-scaling issue is because the monitor can also behave as an HDTV. Some are able to fix it by disabling audio via HDMI, but others cant get it work by natural configuration. The fix is simple, tell the card to override the hdtv capability of the monitor and see it as a pc monitor only. Note that you will lose the "audio via HDMI" capability.





How to override the HDTV flag of a monitor :



1)In regedit, go to "HKLM\SYSTEM\CURRENTCONTROLSET\CONTROL\VIDEO\"



2)Find your device (video card)

Device look like {B1133990-63AA-4C41-8EBF-0454478E0CF6}.

In the 0000 key in it, you can see the "Device Description" value, example "NVIDIA GeForce GTX 460".



3)Add the binary value to override EDID

Directly in 0000, create a new REG_BINARY value, name it "OverrideEdidFlags0".

Set value as follow "5a 63 1e bd 00 00 ff ff 04 00 00 00 7e 01 00"

Exit and Reboot.



This should do the trick. In the Control panel, you will only see PC resolutions, no HDTV anymore.







Other monitors than VX2435 : You need to find the 4 HEX that identify you monitor. Google for "Phoenix EDID Designer" (free) and run it. Extract Registry EDID for your monitor and open Byte Viewer. The 4 Hex value are from 08 to 0B (first row). Then do all the step above and in the OverrideEdidFlags0 value, change the 4 first HEX to what you found in Byte Viewer. In the example above, the 4 HEX that identify the VX2435 monitor are "5a 63 1e bd".





I hope this will help some of you... And I hope this will be fixed in future driver release...



Ben

#1
Posted 01/19/2011 11:21 PM   
[quote name='Ben000' date='19 January 2011 - 04:21 PM' timestamp='1295479309' post='1180115']
How to fix my Nvidia overscan issue with my VX2435wm monitor[/quote]

Thank you, thank you, thank you. I have been updating Nvidia drivers to see if the issue was fixed and then rolling back to old drivers because the disable/enable HDMI audio trick ceased to work after a certain driver iteration.

Now I have the latest drivers, my monitor is at 1920x1200 and I don't have to go through cockamamie steps of disabling HDMI audio to remove overscan when my graphics card doesn't even have HDMI outs.



You have saved me minutes on each reboot and allowed me to utilize the latest drivers instead of some really outdated ones. Thank you so so much.
[quote name='Ben000' date='19 January 2011 - 04:21 PM' timestamp='1295479309' post='1180115']

How to fix my Nvidia overscan issue with my VX2435wm monitor



Thank you, thank you, thank you. I have been updating Nvidia drivers to see if the issue was fixed and then rolling back to old drivers because the disable/enable HDMI audio trick ceased to work after a certain driver iteration.



Now I have the latest drivers, my monitor is at 1920x1200 and I don't have to go through cockamamie steps of disabling HDMI audio to remove overscan when my graphics card doesn't even have HDMI outs.







You have saved me minutes on each reboot and allowed me to utilize the latest drivers instead of some really outdated ones. Thank you so so much.

#2
Posted 03/20/2011 09:48 AM   
There are a few LCD models that came out around the same time as this LCD model which share panel manufacturer and same behavior where the connected device is detected incorrectly. We've tried working with the company to see if there was a possible workaround via a firmware update but non is available. We did implement a workaround in previous drivers but the method breaks WHQL compatibility and therefore we had to remove this. Our plan now is to blacklist known monitors so that the drivers automatically disables HD Audio when it detects these monitors and forces PC mode only.
There are a few LCD models that came out around the same time as this LCD model which share panel manufacturer and same behavior where the connected device is detected incorrectly. We've tried working with the company to see if there was a possible workaround via a firmware update but non is available. We did implement a workaround in previous drivers but the method breaks WHQL compatibility and therefore we had to remove this. Our plan now is to blacklist known monitors so that the drivers automatically disables HD Audio when it detects these monitors and forces PC mode only.

Please send me a PM if I fail to keep up on replying in any specific thread or leave a driver feedback: Driver Feedback

#3
Posted 03/21/2011 03:55 AM   
Could You please add the LG L245WP monitor to the black list? :) I have the same overscan problem with all newer drivers :(.
Could You please add the LG L245WP monitor to the black list? :) I have the same overscan problem with all newer drivers :(.

i7 2600K; ASRock P67 Extreme6; Patriot 8GB 1333,

GeForce GTX 580,

OCZ V3 MI 120GB + WD VR 150GB + 2x200GB Samsung SP RAID 0 + WDC 400GB; Plextor PX-LB950SA,

SB X-Fi XG

Corsair 1000W,

LG L245WP,

7 x64 Pro

#4
Posted 03/22/2011 03:59 PM   
[quote name='FXmAniac' date='22 March 2011 - 08:59 AM' timestamp='1300809567' post='1211693']
Could You please add the LG L245WP monitor to the black list? :) I have the same overscan problem with all newer drivers :(.
[/quote]

Sure.
[quote name='FXmAniac' date='22 March 2011 - 08:59 AM' timestamp='1300809567' post='1211693']

Could You please add the LG L245WP monitor to the black list? :) I have the same overscan problem with all newer drivers :(.





Sure.

Please send me a PM if I fail to keep up on replying in any specific thread or leave a driver feedback: Driver Feedback

#5
Posted 03/22/2011 05:03 PM   
As I can see, this as not been fixed yet...

NVIDIA, is it possible to at least not override the "OverrideEdidFlags0" key when driver are updated? This is a bit annoying to edit registry at every new driver...

Thanks!
As I can see, this as not been fixed yet...



NVIDIA, is it possible to at least not override the "OverrideEdidFlags0" key when driver are updated? This is a bit annoying to edit registry at every new driver...



Thanks!

#6
Posted 07/10/2011 05:31 PM   
Hello,

I tried this fix but unfortunately it didn't do anything. I have a SONY Vaio laptop with a GT425M Nvidia card, and I connected my ViewSonic VSC2A1E to my laptop via a DVI cable. The image on the monitor is blurry and whenever I set it to a non-4:3 resolution, such as its native 1440x900 I get a wide, dark band on the left of my VS monitor's screen, and the image basically goes on with the same amount beyond the right edge of the screen. I installed the latest drivers and tried this fix but to no avail. :( I'm running Windows 7 Home Premium x64, if it helps.

Thanks a billion in advance!
Andrei
Hello,



I tried this fix but unfortunately it didn't do anything. I have a SONY Vaio laptop with a GT425M Nvidia card, and I connected my ViewSonic VSC2A1E to my laptop via a DVI cable. The image on the monitor is blurry and whenever I set it to a non-4:3 resolution, such as its native 1440x900 I get a wide, dark band on the left of my VS monitor's screen, and the image basically goes on with the same amount beyond the right edge of the screen. I installed the latest drivers and tried this fix but to no avail. :( I'm running Windows 7 Home Premium x64, if it helps.



Thanks a billion in advance!

Andrei

#7
Posted 10/11/2011 05:31 PM   
Hi again

I have got used to editing registry on every new driver, to force the right EDID for my LG monitor, but now I come across a bigger problem. I want to connect a HDTV as an auxiliary display. Will I be able to send the audio signal through HDMI to TV, when I have the "OverrideEdidFlags0" enabled?
I know that it is set to my monitor EDID code, but the audio "feature" in control panel disappeared after doing the trick, so I do not know if it comes back after I connect the HDTV. I would like fo figure it out before I buy some expensive HDMI cable (it will cost a lot, because I need ~15m).

To sum up, I want to connect everything as following:

1) LG L245WP monitor @ DVI->HDMI - Primary display (needs the EDID registry trick)
2) LG L1720P monitor @ DVI->DVI - Secondary display for extended desktop (works ok.)
3) LG 42LE5500 HDTV @ HDMI->HDMI - Third displays for movies (HDMI audio needed)

Will it work?

Thanks in advance

EDIT:
I was able to borrow an HDMI cable and can confirm, that everything is working fine. It is a pity, however, that I can not use 3 displays simultanously.
Hi again



I have got used to editing registry on every new driver, to force the right EDID for my LG monitor, but now I come across a bigger problem. I want to connect a HDTV as an auxiliary display. Will I be able to send the audio signal through HDMI to TV, when I have the "OverrideEdidFlags0" enabled?

I know that it is set to my monitor EDID code, but the audio "feature" in control panel disappeared after doing the trick, so I do not know if it comes back after I connect the HDTV. I would like fo figure it out before I buy some expensive HDMI cable (it will cost a lot, because I need ~15m).



To sum up, I want to connect everything as following:



1) LG L245WP monitor @ DVI->HDMI - Primary display (needs the EDID registry trick)

2) LG L1720P monitor @ DVI->DVI - Secondary display for extended desktop (works ok.)

3) LG 42LE5500 HDTV @ HDMI->HDMI - Third displays for movies (HDMI audio needed)



Will it work?



Thanks in advance



EDIT:

I was able to borrow an HDMI cable and can confirm, that everything is working fine. It is a pity, however, that I can not use 3 displays simultanously.

i7 2600K; ASRock P67 Extreme6; Patriot 8GB 1333,

GeForce GTX 580,

OCZ V3 MI 120GB + WD VR 150GB + 2x200GB Samsung SP RAID 0 + WDC 400GB; Plextor PX-LB950SA,

SB X-Fi XG

Corsair 1000W,

LG L245WP,

7 x64 Pro

#8
Posted 10/13/2011 12:13 PM   
Still not fixed, quite annoyed to fix this every time I install this driver...

Will Nvidia fix this once and for all? Is it that hard to add this KEY automatically?
Still not fixed, quite annoyed to fix this every time I install this driver...



Will Nvidia fix this once and for all? Is it that hard to add this KEY automatically?

#9
Posted 02/07/2012 03:10 AM   
I have a VX2435wm. Got overscan problem too and there is solution: simply pushing and holding "2" button to switch from "Video mode" to "PC mode". It will not work if registry fix is already applied.
I have another two problems.
First problem - when monitor is connected via DVI->HDMI colors become "toxic" and this effect cannot be removed by "playing" with contrast and gamma in nVidia Control Panel. Everyting looks fine when connected via DVI->Dsub.
Second problem - when i shutdown my PC monitor doesn't go into standby mode. A have only a blue screen and "No Signal" message. This is really boring.

The most offensive is that on my old 8800GTX i have none of this problems - no overscan, no toxic color effect, monitor normally goes into standby mode. With GTX295 or 560Ti intalled a have them all.

nVidia! Give us please any solution. I've already replaced my GTX295 with 560Ti because of TDR's and i don't want to replace my LCD.
I have a VX2435wm. Got overscan problem too and there is solution: simply pushing and holding "2" button to switch from "Video mode" to "PC mode". It will not work if registry fix is already applied.

I have another two problems.

First problem - when monitor is connected via DVI->HDMI colors become "toxic" and this effect cannot be removed by "playing" with contrast and gamma in nVidia Control Panel. Everyting looks fine when connected via DVI->Dsub.

Second problem - when i shutdown my PC monitor doesn't go into standby mode. A have only a blue screen and "No Signal" message. This is really boring.



The most offensive is that on my old 8800GTX i have none of this problems - no overscan, no toxic color effect, monitor normally goes into standby mode. With GTX295 or 560Ti intalled a have them all.



nVidia! Give us please any solution. I've already replaced my GTX295 with 560Ti because of TDR's and i don't want to replace my LCD.

Galaxy GTX 295 single PCB (Reference)

AMD Phenom II X4 965 BE (3600Mhz @ 1.40V)

Asus M4N82 Deluxe

4Gb DDR2 1066Mhz Geil (5-5-5-15@2.2V)

PSU 850W Corsair

Ethernet Killer NIC M1 PCI

Viewsonic 24'' VX2435WM

#10
Posted 02/07/2012 09:05 AM   
This is THE BEST thing that I've ever read. Thank you SO MUCHHHHHHHH for figuring this out. I have spent way too long messing around with different solutions that, well weren't solutions. This is seriously one of the best things someone could have done. Thanks
This is THE BEST thing that I've ever read. Thank you SO MUCHHHHHHHH for figuring this out. I have spent way too long messing around with different solutions that, well weren't solutions. This is seriously one of the best things someone could have done. Thanks

#11
Posted 01/23/2014 06:26 AM   
For anyone landing on this thread with a similar problem (in my case: nvidia integrated gpu + Viewsonic LCD connected via vga port/d-sub + Windows 7) with the overscan issue to the right of the screen, I've got a very simple solution. This is a refresh rate issue. So this is what you have to do: 1. Make sure you have the nvidia drivers and control panel installed (if for any reason you can't follow the last step because some of the options are not available, try installing older drivers until you find ones that work). 2. Install the regular signed drivers for your monitor. Most probably it will tell you that your monitor model wasn't found. Doesn't matter, finish the installation and then install them again, and choose "re-install", so you end up with a "viewsonic" folder in the root of your main hard drive with all the .inf files. Then force the installation of the driver for your monitor by choosing "update driver" in the device manager and look for it in this viewsonic folder. Restart Windows. 3. Next, you have to add a custom resolution in Nvidia control panel with the right refresh rate. In my case, the monitor's native resolution is 1920x1080, so I began testing different refresh rates (always between 60 and 70), until I discovered the overscan issue was gone when I set the monitor at 1920x1080 @ [b]62hz[/b]. So when you find the refresh rate that solves the issue, add that resolution+refresh rate combination, and then make sure the option "Hide modes that this monitor cannot display" is selected in windows' "screen resolution-->advanced settings, monitor tab". Make sure the refresh rate you just added is selected. Restart, and enjoy.
For anyone landing on this thread with a similar problem (in my case: nvidia integrated gpu + Viewsonic LCD connected via vga port/d-sub + Windows 7) with the overscan issue to the right of the screen, I've got a very simple solution. This is a refresh rate issue. So this is what you have to do:

1. Make sure you have the nvidia drivers and control panel installed (if for any reason you can't follow the last step because some of the options are not available, try installing older drivers until you find ones that work).

2. Install the regular signed drivers for your monitor. Most probably it will tell you that your monitor model wasn't found. Doesn't matter, finish the installation and then install them again, and choose "re-install", so you end up with a "viewsonic" folder in the root of your main hard drive with all the .inf files. Then force the installation of the driver for your monitor by choosing "update driver" in the device manager and look for it in this viewsonic folder. Restart Windows.

3. Next, you have to add a custom resolution in Nvidia control panel with the right refresh rate. In my case, the monitor's native resolution is 1920x1080, so I began testing different refresh rates (always between 60 and 70), until I discovered the overscan issue was gone when I set the monitor at 1920x1080 @ 62hz. So when you find the refresh rate that solves the issue, add that resolution+refresh rate combination, and then make sure the option "Hide modes that this monitor cannot display" is selected in windows' "screen resolution-->advanced settings, monitor tab". Make sure the refresh rate you just added is selected. Restart, and enjoy.

#12
Posted 04/15/2014 03:35 AM   
Scroll To Top