How do I disable PhysX (latest driver)
Essentially the title, I've been having trouble running ArmA 2 with decent settings and would like to try running it with PhysX disabled.

I've searched the forums and no results have come up. I don't want to rollback as the performance increased when I updated.

I have all the optimal system requirements for the game and would really like to enjoy the game with decent FPS.


On a side note, if I uninstall PhysX where would I find the drivers for it on the site?
Essentially the title, I've been having trouble running ArmA 2 with decent settings and would like to try running it with PhysX disabled.



I've searched the forums and no results have come up. I don't want to rollback as the performance increased when I updated.



I have all the optimal system requirements for the game and would really like to enjoy the game with decent FPS.





On a side note, if I uninstall PhysX where would I find the drivers for it on the site?

#1
Posted 07/04/2010 11:47 PM   
[quote name='DropoftheGun' post='1082777' date='Jul 5 2010, 11:47 AM']Essentially the title, I've been having trouble running ArmA 2 with decent settings and would like to try running it with PhysX disabled.

I've searched the forums and no results have come up. I don't want to rollback as the performance increased when I updated.

I have all the optimal system requirements for the game and would really like to enjoy the game with decent FPS.


On a side note, if I uninstall PhysX where would I find the drivers for it on the site?[/quote]

As far as I am aware, having PhysX enabled or disabled with this game should not make any difference, as I am pretty sure it is not a game supporting PhysX.

If you really want to try disabling PhysX though, right click on your desktop, open the nvidia control panel, and in the left hand pane their will be a PhysX tab and in there there will be an option to set PhysX to your GPU or CPU, or disable it altogether.

Maybe you are having some other issue with this game. What are your systems' specs so we can have a good look at whats going on.

Oh and welcome to the forums..... /wave.gif' class='bbc_emoticon' alt=':wave:' />
[quote name='DropoftheGun' post='1082777' date='Jul 5 2010, 11:47 AM']Essentially the title, I've been having trouble running ArmA 2 with decent settings and would like to try running it with PhysX disabled.



I've searched the forums and no results have come up. I don't want to rollback as the performance increased when I updated.



I have all the optimal system requirements for the game and would really like to enjoy the game with decent FPS.





On a side note, if I uninstall PhysX where would I find the drivers for it on the site?



As far as I am aware, having PhysX enabled or disabled with this game should not make any difference, as I am pretty sure it is not a game supporting PhysX.



If you really want to try disabling PhysX though, right click on your desktop, open the nvidia control panel, and in the left hand pane their will be a PhysX tab and in there there will be an option to set PhysX to your GPU or CPU, or disable it altogether.



Maybe you are having some other issue with this game. What are your systems' specs so we can have a good look at whats going on.



Oh and welcome to the forums..... /wave.gif' class='bbc_emoticon' alt=':wave:' />

MY RIG

Gigabyte GA-Z68XP-UD4H

i5 2500K @ 4.6Ghz
8GB Kingston HyperX 1600mhz
2x Gigabyte GTX670 OC Windforce Version SLI
Corsair H100 Cooler
Corsair HX1050W
Corsair Force Series 3 120GB (OS)
Seagate Barracuda 1TB (Storage, games etc)
X-Fi Titanium Fatal1ty
Corsair 600T Graphite - White
3x Samsung Syncmaster 2433BW+ In Surround

#2
Posted 07/05/2010 01:09 AM   
Hey and thanks!

The problem with attempting to disable is that's not an option in the CPanel

Here are my specs (I did add -nosplash -cpuCount=2 -exThreads=1 to the launch properties in Steam and it helped IMMENSELY)

Core 2 duo 2.8GHz
NVidia 9800GTX+
8 GB DDR2 800MHz RAM
7200rpm HDD
Vista x64
Hey and thanks!



The problem with attempting to disable is that's not an option in the CPanel



Here are my specs (I did add -nosplash -cpuCount=2 -exThreads=1 to the launch properties in Steam and it helped IMMENSELY)



Core 2 duo 2.8GHz

NVidia 9800GTX+

8 GB DDR2 800MHz RAM

7200rpm HDD

Vista x64

#3
Posted 07/05/2010 01:17 AM   
There is (and never was) a way to completely disable PhysX in the drivers. All you could ever do was disable GPU PhysX, so it runs on the CPU, as it would if you didn't have a PhysX-capable card. Usually, this would result in a drop in performance, not a gain.

PhysX is only [!] software that runs the physics calulations on the GPU instead of on the CPU. Games still had to perform physics calculations before PhysX. They just did them on the CPU and still do, in most cases.

And, as marv has indicated, this only applies to games that actually support PhysX and ArmA 2 is not one of them. This game will perform its physics calulations on the CPU without using PhysX.

Most games that do support PhysX allow you to turn it off, anyway.

The only way to really stop PhysX running is to uninstall it. Again, this will have no effect in games that don't use it.
There is (and never was) a way to completely disable PhysX in the drivers. All you could ever do was disable GPU PhysX, so it runs on the CPU, as it would if you didn't have a PhysX-capable card. Usually, this would result in a drop in performance, not a gain.



PhysX is only [!] software that runs the physics calulations on the GPU instead of on the CPU. Games still had to perform physics calculations before PhysX. They just did them on the CPU and still do, in most cases.



And, as marv has indicated, this only applies to games that actually support PhysX and ArmA 2 is not one of them. This game will perform its physics calulations on the CPU without using PhysX.



Most games that do support PhysX allow you to turn it off, anyway.



The only way to really stop PhysX running is to uninstall it. Again, this will have no effect in games that don't use it.

Core i5 4670K @ 4.3GHz with 4GHz uncore
Corsair H100 water cooler
8GB Patriot Viper DDR3 @ 2400MHz
Gigabyte Z87X-OC mobo
SLI eVGA GTX670 FTW (1227MHz boost 6800MHz VRAM)
Soundblaster Z with 5.1 speakers
112GB OCZ Vertex 3 SSD
240GB OCZ Vertex 4 SSD
Corsair Carbide 500R case (white)
Akasa PowerXtreme 1200W PSU
HP ZR2740W 2560 x 1440 27" IPS panel
Windows 7 Pro 64bit

#4
Posted 07/05/2010 12:05 PM   
[quote name='DropoftheGun' post='1082777' date='Jul 4 2010, 07:47 PM']...On a side note, if I uninstall PhysX where would I find the drivers for it on the site?[/quote]
The [url="http://www.nvidia.com/Download/index5.aspx?lang=en-us"]nVidia Driver Download page[/url] has a listing for the PhysX System Software as a separate installation package...
[quote name='DropoftheGun' post='1082777' date='Jul 4 2010, 07:47 PM']...On a side note, if I uninstall PhysX where would I find the drivers for it on the site?

The nVidia Driver Download page has a listing for the PhysX System Software as a separate installation package...

Intel Siler DX79SI Desktop Extreme | Intel Core i7-3820 Sandy Bridge-Extreme | DangerDen M6 and Koolance MVR-40s w/Black Ice Stealths | 32 GB Mushkin PC3-12800LV | NVIDIA GTX 660 Ti SLI | PNY GTX 470 | 24 GB RAMDisk (C:\Temp\Temp) | 120 GB Intel Cherryville SSDs (OS and UserData)| 530 GB Western Digital VelociRaptor SATA 2 RAID0 (C:\Games\) | 60 GB G2 SSDs (XP Pro and Linux) | 3 TB Western Digital USB-3 MyBook (Archive) | LG BP40NS20 USB ODD | LG IPS236 Monitor | LogiTech X-530 Speakers | Plantronics GameCom 780 Headphones | Cooler Master UCP 1100 | Cooler Master HAF XB | Windows 7 Pro x64 SP1

Stock is Extreme now

#5
Posted 07/05/2010 12:18 PM   
Sorry, was gonna say that, but forgot while I was typing the other stuff!
Sorry, was gonna say that, but forgot while I was typing the other stuff!

Core i5 4670K @ 4.3GHz with 4GHz uncore
Corsair H100 water cooler
8GB Patriot Viper DDR3 @ 2400MHz
Gigabyte Z87X-OC mobo
SLI eVGA GTX670 FTW (1227MHz boost 6800MHz VRAM)
Soundblaster Z with 5.1 speakers
112GB OCZ Vertex 3 SSD
240GB OCZ Vertex 4 SSD
Corsair Carbide 500R case (white)
Akasa PowerXtreme 1200W PSU
HP ZR2740W 2560 x 1440 27" IPS panel
Windows 7 Pro 64bit

#6
Posted 07/05/2010 01:23 PM   
Teamwork...
Teamwork...

Intel Siler DX79SI Desktop Extreme | Intel Core i7-3820 Sandy Bridge-Extreme | DangerDen M6 and Koolance MVR-40s w/Black Ice Stealths | 32 GB Mushkin PC3-12800LV | NVIDIA GTX 660 Ti SLI | PNY GTX 470 | 24 GB RAMDisk (C:\Temp\Temp) | 120 GB Intel Cherryville SSDs (OS and UserData)| 530 GB Western Digital VelociRaptor SATA 2 RAID0 (C:\Games\) | 60 GB G2 SSDs (XP Pro and Linux) | 3 TB Western Digital USB-3 MyBook (Archive) | LG BP40NS20 USB ODD | LG IPS236 Monitor | LogiTech X-530 Speakers | Plantronics GameCom 780 Headphones | Cooler Master UCP 1100 | Cooler Master HAF XB | Windows 7 Pro x64 SP1

Stock is Extreme now

#7
Posted 07/05/2010 01:54 PM   
[quote name='Discordia' post='1083047' date='Jul 5 2010, 08:05 AM']There is (and never was) a way to completely disable PhysX in the drivers. All you could ever do was disable GPU PhysX, so it runs on the CPU, as it would if you didn't have a PhysX-capable card. Usually, this would result in a drop in performance, not a gain.

PhysX is only [!] software that runs the physics calulations on the GPU instead of on the CPU. Games still had to perform physics calculations before PhysX. They just did them on the CPU and still do, in most cases.

And, as marv has indicated, this only applies to games that actually support PhysX and ArmA 2 is not one of them. This game will perform its physics calulations on the CPU without using PhysX.

Most games that do support PhysX allow you to turn it off, anyway.

The only way to really stop PhysX running is to uninstall it. Again, this will have no effect in games that don't use it.[/quote]

[quote]Hi,

World of Warcraft does not support PsychX, It would be recommended to avoid using it along side as it may cause performance problems, or in your case crashes.

I am not aware of any plans to introduce support for this as it would likely require that the game is specifically coded for Direct x 10.1[/quote]

[url="http://forums.wow-europe.com/thread.html?topicId=7679728702&sid=1"]http://forums.wow-europe.com/thread.html?t...28702&sid=1[/url]
[quote name='Discordia' post='1083047' date='Jul 5 2010, 08:05 AM']There is (and never was) a way to completely disable PhysX in the drivers. All you could ever do was disable GPU PhysX, so it runs on the CPU, as it would if you didn't have a PhysX-capable card. Usually, this would result in a drop in performance, not a gain.



PhysX is only [!] software that runs the physics calulations on the GPU instead of on the CPU. Games still had to perform physics calculations before PhysX. They just did them on the CPU and still do, in most cases.



And, as marv has indicated, this only applies to games that actually support PhysX and ArmA 2 is not one of them. This game will perform its physics calulations on the CPU without using PhysX.



Most games that do support PhysX allow you to turn it off, anyway.



The only way to really stop PhysX running is to uninstall it. Again, this will have no effect in games that don't use it.



Hi,



World of Warcraft does not support PsychX, It would be recommended to avoid using it along side as it may cause performance problems, or in your case crashes.



I am not aware of any plans to introduce support for this as it would likely require that the game is specifically coded for Direct x 10.1




http://forums.wow-europe.com/thread.html?t...28702&sid=1

#8
Posted 07/05/2010 08:27 PM   
Scroll To Top