Windows 7 driver set wrong frequency to HDTV(NM) Full-HD playback Perfect Natural Motion cant work w
  1 / 10    
I have Philips 52PFL9703 with [b]Perfect Natural Motion[/b] system, connected to second DVI port of my 8800GTX via DVI-HDMI adapter and HDMI cable. I use VLC player to view Full-HD cinemas on my TV.

Under Windows XP I select TV resolution 1920x1080 [b]24Hz[/b] (there is no other frequency) - and everything worked like a charm - Perfect Natural Motion (PNM) makes entire film quite smooth. Everything works perfect!

But under Windows 7 I got a huge problem. Both frequencies in TV settings ([b]24[/b]Hz and [b]23(???)[/b]Hz) does not perfectly fit Philips desired frequency range. [b]24Hz is completely unusable[/b] - PNM stops working every 10-15 seconds, so framerate drops to plain 24 fps for 4-5 frames.

23Hz looks much better for the first 5 minutes or so. But then PNM [u]gradually[/u] drops to 24 fps, plays 24 fps for several seconds, and gradually start working again. Overall degrade cycle is 30-60 seconds. Then PNM works again for the next 5 minutes or so. And cycle repeats. It drive me nuts.

I have send driver bug report to Nvidia via website feedback form. I've called Microsoft - and yes, they blame Nvidia driver, and they suggest ask Nvidia for updated driver. I filled up Philips support form, Philips call me back - and yes, they blame NVidia for the wrong frequency from videodriver. [b]I hope to hear from Nvidia finally!!!![/b]

What did you changed in Win7 drivers re:tvset frequency??? [b]How it did work in WinXP???[/b] And what I can do???

But since there are many experienced Nvidia users on these forums, please tell me - where I should look to find exact TV frequency in XP and in 7? [b]I am technically experienced user[/b] - I can do any registry edit, .inf file edit, etc.
I have Philips 52PFL9703 with Perfect Natural Motion system, connected to second DVI port of my 8800GTX via DVI-HDMI adapter and HDMI cable. I use VLC player to view Full-HD cinemas on my TV.



Under Windows XP I select TV resolution 1920x1080 24Hz (there is no other frequency) - and everything worked like a charm - Perfect Natural Motion (PNM) makes entire film quite smooth. Everything works perfect!



But under Windows 7 I got a huge problem. Both frequencies in TV settings (24Hz and 23(???)Hz) does not perfectly fit Philips desired frequency range. 24Hz is completely unusable - PNM stops working every 10-15 seconds, so framerate drops to plain 24 fps for 4-5 frames.



23Hz looks much better for the first 5 minutes or so. But then PNM gradually drops to 24 fps, plays 24 fps for several seconds, and gradually start working again. Overall degrade cycle is 30-60 seconds. Then PNM works again for the next 5 minutes or so. And cycle repeats. It drive me nuts.



I have send driver bug report to Nvidia via website feedback form. I've called Microsoft - and yes, they blame Nvidia driver, and they suggest ask Nvidia for updated driver. I filled up Philips support form, Philips call me back - and yes, they blame NVidia for the wrong frequency from videodriver. I hope to hear from Nvidia finally!!!!



What did you changed in Win7 drivers re:tvset frequency??? How it did work in WinXP??? And what I can do???



But since there are many experienced Nvidia users on these forums, please tell me - where I should look to find exact TV frequency in XP and in 7? I am technically experienced user - I can do any registry edit, .inf file edit, etc.

#1
Posted 12/14/2009 04:50 PM   
Where I should look to find [b]exact TV frequency in Windows XP and in Windows 7?[/b]
Where I should look to find exact TV frequency in Windows XP and in Windows 7?

#2
Posted 12/15/2009 05:44 PM   
[quote name='SergeSF' post='965120' date='Dec 15 2009, 08:44 PM']Where I should look to find [b]exact TV frequency in Windows XP and in Windows 7?[/b][/quote]
Where I should look to find exact TV frequency in Windows XP and in Windows 7?
[quote name='SergeSF' post='965120' date='Dec 15 2009, 08:44 PM']Where I should look to find exact TV frequency in Windows XP and in Windows 7?

Where I should look to find exact TV frequency in Windows XP and in Windows 7?

#3
Posted 12/16/2009 04:35 PM   
Hello SergeSF,
Do you have by chance tested different driver versions? We keep an archive list on our Software Downloads page from the URL below:

[url="http://www.nvidia.com/Download/Find.aspx?lang=en-us"]http://www.nvidia.com/Download/Find.aspx?lang=en-us[/url]

If you are using the latest drivers, try disabling the HDMI Audio from the NVIDIA Control Panel, even if you are outputting audio from a sound card. You will find this option in the "Change resolution" panel inside of the NVIDIA Control Panel. Some Philips HDMI displays have issues with Geforce which could lead to image corruption when audio over HDMI is enabled.
Hello SergeSF,

Do you have by chance tested different driver versions? We keep an archive list on our Software Downloads page from the URL below:



http://www.nvidia.com/Download/Find.aspx?lang=en-us



If you are using the latest drivers, try disabling the HDMI Audio from the NVIDIA Control Panel, even if you are outputting audio from a sound card. You will find this option in the "Change resolution" panel inside of the NVIDIA Control Panel. Some Philips HDMI displays have issues with Geforce which could lead to image corruption when audio over HDMI is enabled.

Please send me a PM if I fail to keep up on replying in any specific thread or leave a driver feedback: Driver Feedback

#4
Posted 12/17/2009 01:51 AM   
[quote name='ManuelG' post='966139' date='Dec 17 2009, 04:51 AM']Hello SergeSF,
Do you have by chance tested different driver versions? We keep an archive list on our Software Downloads page from the URL below:

[url="http://www.nvidia.com/Download/Find.aspx?lang=en-us"]http://www.nvidia.com/Download/Find.aspx?lang=en-us[/url]

If you are using the latest drivers, try disabling the HDMI Audio from the NVIDIA Control Panel, even if you are outputting audio from a sound card. You will find this option in the "Change resolution" panel inside of the NVIDIA Control Panel. Some Philips HDMI displays have issues with Geforce which could lead to image corruption when audio over HDMI is enabled.[/quote]
Thank you for reply, Manuel!

HDMI Sound can't be disabled. I select "Turm off", click "Apply" - and HDMI Sound swith switches back to "On" [b]itself[/b]. Something is wrong there. Probably since I don't have actual HDMI sound output, just DVI-HDMI adapter. Anyway, it does not help - video still cycled desyncronised every 5 minutes of playback.

I have installed old Vista driver 178.13. It does not help either.[b] 5-minute desynchronise cycle still exist[/b].

[b]So, there is SERIOUS problem with HDTV output.[/b] Microsoft says: this is Nvidia problem.

In Windows XP all available Nvidia drivers has NO SUCH PROBLEM at all.
Please help! [b]I can't use Windows 7 for Full-HD video playback due to this display frequency bug!!!!!![/b]
[quote name='ManuelG' post='966139' date='Dec 17 2009, 04:51 AM']Hello SergeSF,

Do you have by chance tested different driver versions? We keep an archive list on our Software Downloads page from the URL below:



http://www.nvidia.com/Download/Find.aspx?lang=en-us



If you are using the latest drivers, try disabling the HDMI Audio from the NVIDIA Control Panel, even if you are outputting audio from a sound card. You will find this option in the "Change resolution" panel inside of the NVIDIA Control Panel. Some Philips HDMI displays have issues with Geforce which could lead to image corruption when audio over HDMI is enabled.

Thank you for reply, Manuel!



HDMI Sound can't be disabled. I select "Turm off", click "Apply" - and HDMI Sound swith switches back to "On" itself. Something is wrong there. Probably since I don't have actual HDMI sound output, just DVI-HDMI adapter. Anyway, it does not help - video still cycled desyncronised every 5 minutes of playback.



I have installed old Vista driver 178.13. It does not help either. 5-minute desynchronise cycle still exist.



So, there is SERIOUS problem with HDTV output. Microsoft says: this is Nvidia problem.



In Windows XP all available Nvidia drivers has NO SUCH PROBLEM at all.

Please help! I can't use Windows 7 for Full-HD video playback due to this display frequency bug!!!!!!

#5
Posted 12/18/2009 10:31 PM   
Hi,

Using the nVidia 9600M GS with 256meg video memory, I was trying to get my laptop to support 23.976 Hz vertical synchronization frequency on my LG Electronics 42LH5000 LCD TV through HDMI. The TV supports virtually any set of timings I throw at it, it's absolutely marvellous. However, using the nVidia notebook driver version 195.62 on Windows 7 x64, I seemed quite unable to obtain the correct frequency. The driver is a final release and was made available on www.nzone.com on 4th December. It offers the ability to manually enter the timings in nVidia Control Panel, using the Add Custom Resolution button.

After a fresh driver install, there's 23 Hz 1920x1080p in the list of resolutions to pick from. I can see in Media Player Classic Home Cinema that it's actually 23.966 instead of 23, by pressing CTRL+J and looking at the first value in the upper left corner of the screen when the value stabilizes. This is while playing a video file which uses 23.976 frames per second, with the GPU's trilinear buffering switched on and the GPU's energy saving feature switched off. Of course 23.966 isn't anywhere near 23.976 in terms of smooth video playback, so I experimented with the timings for several hours in an attempt to get things right.

Active pixels are 1920x1080. Front porches are kept at their initial values of 640 pixels horizontal and 5 pixels vertical, sync widths are also unchanged at 44 pixels horizontal and 4 pixels vertical. Horizontal total was 2752 and I changed it to 2760. Vertical total was 1125 and I changed it to 1171. This way, a horizontal refresh of 28.08 KHz is reported automatically upon moving the cursor to a different input box, whereas the vertical refresh has to be entered manually. It was at 23.000 Hz because I had to choose '23' in the topmost part of the settings panel to be able to apply the timings to the correct name, and I changed it from 23.000 to 23.978 so that upon moving the cursor to a different input box once more, a dot clock of 77.4959 MHz is reported automatically.

Enabling this custom resolution after having added it successfully, produced a most surprising result. The vertical refresh as shown by Media Player Classic Home Cinema is now 23.976. The green line on the graph in the lower right corner of the screen is almost perfectly straight horizontal. This would indicate that everything is working as intended, since it takes about 58 minutes until the line has lowered itself by half a frame. In other words, the video file's framerate is very slightly slower than the GPU's refresh rate. This is due to the fact the video file's framerate is only 23.976 instead of standard 23.976023976023976... = 24000:1001. I added a custom resolution for 32 bit colors in 60 Hz 1920x1080p (with unchanged timings) as well, because otherwise 60 Hz 1920x1080p supports only 16 bit colors.

Sometimes during my experiments, by mistake I had tried completely wrong timings which caused the GPU's vertical refresh frequency to 'skip' at irregular intervals (the horizontal green line would then keep on jumping upwards precisely onto the blue line directly above it, very often, while falling back to its original horizontal state each time instantly afterwards), all until I changed desktop resolution back to something natively supported, but sometimes that still wouldn't fix it so I had to remove the HDMI cable and then put it back in again. This is because an HDMI connection does not reset itself until the cable is removed, so even if you power down both your computer and the TV / monitor without disconnecting the HDMI cable it's still possible to have persisting trouble after an experiment gone bad (even if you also changed desktop resolution back to something 'normal' before shutting down).

The HDMI audio feature switching back on again all by itself immediately after you've switched it off, is something I got too. Power off both your computer and your TV / monitor, disconnect the HDMI cable, reconnect it, power everything up again and it should be fixed.

The GPU and the TV are working miraculously fine in Full HD 23p (read: '24000:1001p' /rofl.gif' class='bbc_emoticon' alt=':rofl:' />) on my cheap HTPC laptop in DXVA mode, so maybe next I should give that funny Reclock software thingy a try to see if I can use it to upsample all those 23.976 framerate files back to their original 23.976023976... /w00twave.gif' class='bbc_emoticon' alt=':w00twave:' />

I guess I won't be needing it for files which don't last two hours, luckily. /no.gif' class='bbc_emoticon' alt=':no:' />

I offer special thanks to Eric Steven Raymond, for writing the excellent 'XFree86 Video Timings HOWTO': /thanks.gif' class='bbc_emoticon' alt=':thanks:' />
Oh and by the way, [b]Merry Christmas![/b] /santa.gif' class='bbc_emoticon' alt=':santa:' />

YPG=-
Hi,



Using the nVidia 9600M GS with 256meg video memory, I was trying to get my laptop to support 23.976 Hz vertical synchronization frequency on my LG Electronics 42LH5000 LCD TV through HDMI. The TV supports virtually any set of timings I throw at it, it's absolutely marvellous. However, using the nVidia notebook driver version 195.62 on Windows 7 x64, I seemed quite unable to obtain the correct frequency. The driver is a final release and was made available on www.nzone.com on 4th December. It offers the ability to manually enter the timings in nVidia Control Panel, using the Add Custom Resolution button.



After a fresh driver install, there's 23 Hz 1920x1080p in the list of resolutions to pick from. I can see in Media Player Classic Home Cinema that it's actually 23.966 instead of 23, by pressing CTRL+J and looking at the first value in the upper left corner of the screen when the value stabilizes. This is while playing a video file which uses 23.976 frames per second, with the GPU's trilinear buffering switched on and the GPU's energy saving feature switched off. Of course 23.966 isn't anywhere near 23.976 in terms of smooth video playback, so I experimented with the timings for several hours in an attempt to get things right.



Active pixels are 1920x1080. Front porches are kept at their initial values of 640 pixels horizontal and 5 pixels vertical, sync widths are also unchanged at 44 pixels horizontal and 4 pixels vertical. Horizontal total was 2752 and I changed it to 2760. Vertical total was 1125 and I changed it to 1171. This way, a horizontal refresh of 28.08 KHz is reported automatically upon moving the cursor to a different input box, whereas the vertical refresh has to be entered manually. It was at 23.000 Hz because I had to choose '23' in the topmost part of the settings panel to be able to apply the timings to the correct name, and I changed it from 23.000 to 23.978 so that upon moving the cursor to a different input box once more, a dot clock of 77.4959 MHz is reported automatically.



Enabling this custom resolution after having added it successfully, produced a most surprising result. The vertical refresh as shown by Media Player Classic Home Cinema is now 23.976. The green line on the graph in the lower right corner of the screen is almost perfectly straight horizontal. This would indicate that everything is working as intended, since it takes about 58 minutes until the line has lowered itself by half a frame. In other words, the video file's framerate is very slightly slower than the GPU's refresh rate. This is due to the fact the video file's framerate is only 23.976 instead of standard 23.976023976023976... = 24000:1001. I added a custom resolution for 32 bit colors in 60 Hz 1920x1080p (with unchanged timings) as well, because otherwise 60 Hz 1920x1080p supports only 16 bit colors.



Sometimes during my experiments, by mistake I had tried completely wrong timings which caused the GPU's vertical refresh frequency to 'skip' at irregular intervals (the horizontal green line would then keep on jumping upwards precisely onto the blue line directly above it, very often, while falling back to its original horizontal state each time instantly afterwards), all until I changed desktop resolution back to something natively supported, but sometimes that still wouldn't fix it so I had to remove the HDMI cable and then put it back in again. This is because an HDMI connection does not reset itself until the cable is removed, so even if you power down both your computer and the TV / monitor without disconnecting the HDMI cable it's still possible to have persisting trouble after an experiment gone bad (even if you also changed desktop resolution back to something 'normal' before shutting down).



The HDMI audio feature switching back on again all by itself immediately after you've switched it off, is something I got too. Power off both your computer and your TV / monitor, disconnect the HDMI cable, reconnect it, power everything up again and it should be fixed.



The GPU and the TV are working miraculously fine in Full HD 23p (read: '24000:1001p' /rofl.gif' class='bbc_emoticon' alt=':rofl:' />) on my cheap HTPC laptop in DXVA mode, so maybe next I should give that funny Reclock software thingy a try to see if I can use it to upsample all those 23.976 framerate files back to their original 23.976023976... /w00twave.gif' class='bbc_emoticon' alt=':w00twave:' />



I guess I won't be needing it for files which don't last two hours, luckily. /no.gif' class='bbc_emoticon' alt=':no:' />



I offer special thanks to Eric Steven Raymond, for writing the excellent 'XFree86 Video Timings HOWTO': /thanks.gif' class='bbc_emoticon' alt=':thanks:' />

Oh and by the way, Merry Christmas! /santa.gif' class='bbc_emoticon' alt=':santa:' />



YPG=-

#6
Posted 12/19/2009 05:58 AM   
All I can say - [b]WOW!![/b] /woot.gif' class='bbc_emoticon' alt=':woot:' />
Many, many thanks!!!

Now I have to connect another boot drive and boot into Win7 to test all of your suggestions.
And shame on NVidia for setting wrong frequencies for all drivers since Vista era begins. I don't have a chance to test it with Vista before, since Vista box goes in dust years ago. Never used it longer than 3 days. /yucky.gif' class='bbc_emoticon' alt=':yucky:' />

Looks like nobody reports the same problem before! Probably nobody use Vista and Win7 for Full-HD viewing, lamers /turned.gif' class='bbc_emoticon' alt=':turned:' />

Thank you again!!
All I can say - WOW!! /woot.gif' class='bbc_emoticon' alt=':woot:' />

Many, many thanks!!!



Now I have to connect another boot drive and boot into Win7 to test all of your suggestions.

And shame on NVidia for setting wrong frequencies for all drivers since Vista era begins. I don't have a chance to test it with Vista before, since Vista box goes in dust years ago. Never used it longer than 3 days. /yucky.gif' class='bbc_emoticon' alt=':yucky:' />



Looks like nobody reports the same problem before! Probably nobody use Vista and Win7 for Full-HD viewing, lamers /turned.gif' class='bbc_emoticon' alt=':turned:' />



Thank you again!!

#7
Posted 12/19/2009 10:19 AM   
Well, I created custom display mode. Just changed frequency from [b]23[/b] to [b]23.976024[/b] (024 does not saves), since other digits in my case was different from yours, probably due to different TV models.
But[b] I can't set this custom mode![/b] Turn off both PC and TV, unplug HDMI cable from TV, plug it again and turn on PC and TV - does not work. Going to Nvidia Control Panel and select my Custom mode - it switches back to PC(??) 23Hz resolution (??) right after clicking Apply button. Even running Nvcplui.exe as Adminstrator does not help.

Whew! Nvidia drivers are bugged as hell!!
Well, I created custom display mode. Just changed frequency from 23 to 23.976024 (024 does not saves), since other digits in my case was different from yours, probably due to different TV models.

But I can't set this custom mode! Turn off both PC and TV, unplug HDMI cable from TV, plug it again and turn on PC and TV - does not work. Going to Nvidia Control Panel and select my Custom mode - it switches back to PC(??) 23Hz resolution (??) right after clicking Apply button. Even running Nvcplui.exe as Adminstrator does not help.



Whew! Nvidia drivers are bugged as hell!!

#8
Posted 12/19/2009 12:45 PM   
[quote name='SergeSF' post='967379' date='Dec 19 2009, 11:19 AM']All I can say - [b]WOW!![/b] /woot.gif' class='bbc_emoticon' alt=':woot:' />
Many, many thanks!!![/quote]
You're welcome. :)
[quote name='SergeSF' post='967379' date='Dec 19 2009, 11:19 AM']Now I have to connect another boot drive and boot into Win7 to test all of your suggestions.[/quote]
Windows 7 x64 is not bad for HTPC, just needs the Windows 7 Manager software package to fine tune everything. Throw in k-lite codec pack (for Haali Media Splitter and AC3Filter), then you're good to go. You'll probably need to use CUDA if you want GPU-accelerated decoding on your card (for example CoreAVC), because I think the 8800 GTX is not DXVA 2.0 compliant (the 8800 GT is). Or maybe you don't even need it to be 2.0 for Media Player Classic Home Cinema, I honestly dunno.
[quote name='SergeSF' post='967379' date='Dec 19 2009, 11:19 AM']And shame on NVidia for setting wrong frequencies for all drivers since Vista era begins. I don't have a chance to test it with Vista before, since Vista box goes in dust years ago. Never used it longer than 3 days. /yucky.gif' class='bbc_emoticon' alt=':yucky:' />[/quote]
If nVidia hadn't put all of their magic dust into getting CUDA to work before brushing up the frequency, I'd probably have bought an ATI card instead. Now we can all just go and flame Charlie from The Inquirer some more. Please? /teehee.gif' class='bbc_emoticon' alt=':teehee:' /> As for Microsoft: they seem to have learnt alot since Vista (I know Charlie never will /thumbsdown.gif' class='bbc_emoticon' alt=':thumbsdown:' />).
[quote name='SergeSF' post='967379' date='Dec 19 2009, 11:19 AM']Looks like nobody reports the same problem before! Probably nobody use Vista and Win7 for Full-HD viewing, lamers /turned.gif' class='bbc_emoticon' alt=':turned:' />[/quote]
Maybe they were simply too busy playing their videogames with CUDA? /mage.gif' class='bbc_emoticon' alt=':mage:' />
[quote name='SergeSF' post='967379' date='Dec 19 2009, 11:19 AM']Thank you again!![/quote]
May the f[i]a[/i]rce be with you! /starwars.gif' class='bbc_emoticon' alt=':starwars:' />
[quote name='SergeSF' post='967379' date='Dec 19 2009, 11:19 AM']All I can say - WOW!! /woot.gif' class='bbc_emoticon' alt=':woot:' />

Many, many thanks!!!

You're welcome. :)

[quote name='SergeSF' post='967379' date='Dec 19 2009, 11:19 AM']Now I have to connect another boot drive and boot into Win7 to test all of your suggestions.

Windows 7 x64 is not bad for HTPC, just needs the Windows 7 Manager software package to fine tune everything. Throw in k-lite codec pack (for Haali Media Splitter and AC3Filter), then you're good to go. You'll probably need to use CUDA if you want GPU-accelerated decoding on your card (for example CoreAVC), because I think the 8800 GTX is not DXVA 2.0 compliant (the 8800 GT is). Or maybe you don't even need it to be 2.0 for Media Player Classic Home Cinema, I honestly dunno.

[quote name='SergeSF' post='967379' date='Dec 19 2009, 11:19 AM']And shame on NVidia for setting wrong frequencies for all drivers since Vista era begins. I don't have a chance to test it with Vista before, since Vista box goes in dust years ago. Never used it longer than 3 days. /yucky.gif' class='bbc_emoticon' alt=':yucky:' />

If nVidia hadn't put all of their magic dust into getting CUDA to work before brushing up the frequency, I'd probably have bought an ATI card instead. Now we can all just go and flame Charlie from The Inquirer some more. Please? /teehee.gif' class='bbc_emoticon' alt=':teehee:' /> As for Microsoft: they seem to have learnt alot since Vista (I know Charlie never will /thumbsdown.gif' class='bbc_emoticon' alt=':thumbsdown:' />).

[quote name='SergeSF' post='967379' date='Dec 19 2009, 11:19 AM']Looks like nobody reports the same problem before! Probably nobody use Vista and Win7 for Full-HD viewing, lamers /turned.gif' class='bbc_emoticon' alt=':turned:' />

Maybe they were simply too busy playing their videogames with CUDA? /mage.gif' class='bbc_emoticon' alt=':mage:' />

[quote name='SergeSF' post='967379' date='Dec 19 2009, 11:19 AM']Thank you again!!

May the farce be with you! /starwars.gif' class='bbc_emoticon' alt=':starwars:' />

#9
Posted 12/19/2009 01:23 PM   
[quote name='SergeSF' post='967403' date='Dec 19 2009, 01:45 PM']Well, I created custom display mode. Just changed frequency from [b]23[/b] to [b]23.976024[/b] (024 does not saves), since other digits in my case was different from yours, probably due to different TV models.
But[b] I can't set this custom mode![/b] Turn both PC and TV, unplug HDMI cable from TV, plug it again and turn on PC and TV - does not work. Going to Nvidia Control Panel and select my Custom mode - it switches back to PC(??) 23Hz resolution (??) right after clicking Apply button. Even running Nvcplui.exe as Adminstrator does not help.

Whew! Nvidia drivers are bugged as hell!![/quote]
That's probably because your TV can't cope with the 1171 vertical total. :(

Maybe someone at nVidia can explain more. For all it still matters though, here's some more details on how I've managed it.

You need to change the '24' to '23' in the topmost part of the panel to start with, to be able to save your new timings properly (or else you will probably override the 24p mode's timings with them, rather than the 23p mode's). Also, after you've hit the Test button, you need to make sure the checkbox in front of the new resolution is checked, or else the 23p mode's timings will probably not be overridden with the ones you want to override them with. The '23' in the topmost part is just a plain text name which is used to distinguish between all the other names in NVIDIA Control Panel | Display | Change resolution | Refresh rate (dropdown list). So it's just text, which is shown as an item in this dropdown list. I know it can be hard to figure that out. Anyway, I didn't set my vertical refresh frequency to 23.976024. I wrote that I set it to 23.97[b]8[/b] and that apart from this, I only changed two other values (horizontal total and vertical total). This gave me pretty much [b]exactly[/b] 24000:1001 Hz, for reasons I'm still very curious about... :lol:

Once the custom resolution is properly added, you should be able to just pick '23' from the list I mentioned, same as before you overrided (read: 'customized') the timings which had been previously used by it (before you overrided them). So now, when you pick it, it should be using the new timings instead of the original default ones. This can be confusing too, because the button is labeled 'Add Custom Resolution'. The button can be used to do alot more than just adding custom resolutions. In other words, it can also be used to [b]override[/b] a resolution with a new (read: 'added') custom one, rather than merely adding one (the 23p one being a perfect example). You can edit / delete by clicking the small pencil / cross, but you can also add / override by clicking the Add Custom Resolution button: if you use the topmost part of the panel which pops up after clicking this button, you can choose 1920x1080, 32 bit, 23p. By doing so, you will actually be able to 'override' that particular 23p mode's default timings by socalled 'adding' it (I'm calling it override because I think just adding something is not quite the same thing as adding something which will replace something else in such way that the replacement can still be undone...). So you override it by adding it, even though it's already there (albeit with different timings). /book.gif' class='bbc_emoticon' alt=':book:' />

Clicking the little red cross will delete the override when you click OK. However, it's possible that in order to correctly restore your desktop resolution back to the 23p mode's 'default' timings, you have to change desktop resolution to for example 1920x1080 16 bit 60p and then back to 32 bit 23p again, especially if you see the green line skipping like I described in my first reply (the skipping is sharp peaks at about 0.5 - 1.5 second, irregular intervals, with each peak having the same height as the distance between the long blue lines I think, like this: ___/\______/\___/\_________/\______/\__ ). So in other words, you only have to remove the HDMI cable if this method doesn't fix this weird type of skipping, or, secondly, if you see the HDMI audio switching back on immediately by itself (and in both cases you possibly need to power down as well). I think I fixed the audio issue on my laptop by first removing the cable on both ends (because both ends are HDMI and I've read there's a difference between removing only one end and removing both ends), then powering down and up again, then reconnecting the cable. However, you aren't using a laptop GPU like I am, and your PC has DVI (and DVI-to-HDMI) whereas I have HDMI only, so chances are you're seeing completely different things indeed. Nevertheless, if it's working for me then I think it could also have worked for you because I don't see why the 8800 GTX wouldn't be able to use the same timings as my 9600M GS. Bad combination of TV / GPU, it seems.

By the way, unchecking the checkbox in front of the resolution's name instead of clicking the little red cross behind it, will not undo the override in any way. Also, I paused the video file playback each time before starting a new timings experiment, to not stress the GPU too much while fiddling around with its transistors. /play_ball.gif' class='bbc_emoticon' alt=':playball:' />
[quote name='SergeSF' post='967403' date='Dec 19 2009, 01:45 PM']Well, I created custom display mode. Just changed frequency from 23 to 23.976024 (024 does not saves), since other digits in my case was different from yours, probably due to different TV models.

But I can't set this custom mode! Turn both PC and TV, unplug HDMI cable from TV, plug it again and turn on PC and TV - does not work. Going to Nvidia Control Panel and select my Custom mode - it switches back to PC(??) 23Hz resolution (??) right after clicking Apply button. Even running Nvcplui.exe as Adminstrator does not help.



Whew! Nvidia drivers are bugged as hell!!

That's probably because your TV can't cope with the 1171 vertical total. :(



Maybe someone at nVidia can explain more. For all it still matters though, here's some more details on how I've managed it.



You need to change the '24' to '23' in the topmost part of the panel to start with, to be able to save your new timings properly (or else you will probably override the 24p mode's timings with them, rather than the 23p mode's). Also, after you've hit the Test button, you need to make sure the checkbox in front of the new resolution is checked, or else the 23p mode's timings will probably not be overridden with the ones you want to override them with. The '23' in the topmost part is just a plain text name which is used to distinguish between all the other names in NVIDIA Control Panel | Display | Change resolution | Refresh rate (dropdown list). So it's just text, which is shown as an item in this dropdown list. I know it can be hard to figure that out. Anyway, I didn't set my vertical refresh frequency to 23.976024. I wrote that I set it to 23.978 and that apart from this, I only changed two other values (horizontal total and vertical total). This gave me pretty much exactly 24000:1001 Hz, for reasons I'm still very curious about... :lol:



Once the custom resolution is properly added, you should be able to just pick '23' from the list I mentioned, same as before you overrided (read: 'customized') the timings which had been previously used by it (before you overrided them). So now, when you pick it, it should be using the new timings instead of the original default ones. This can be confusing too, because the button is labeled 'Add Custom Resolution'. The button can be used to do alot more than just adding custom resolutions. In other words, it can also be used to override a resolution with a new (read: 'added') custom one, rather than merely adding one (the 23p one being a perfect example). You can edit / delete by clicking the small pencil / cross, but you can also add / override by clicking the Add Custom Resolution button: if you use the topmost part of the panel which pops up after clicking this button, you can choose 1920x1080, 32 bit, 23p. By doing so, you will actually be able to 'override' that particular 23p mode's default timings by socalled 'adding' it (I'm calling it override because I think just adding something is not quite the same thing as adding something which will replace something else in such way that the replacement can still be undone...). So you override it by adding it, even though it's already there (albeit with different timings). /book.gif' class='bbc_emoticon' alt=':book:' />



Clicking the little red cross will delete the override when you click OK. However, it's possible that in order to correctly restore your desktop resolution back to the 23p mode's 'default' timings, you have to change desktop resolution to for example 1920x1080 16 bit 60p and then back to 32 bit 23p again, especially if you see the green line skipping like I described in my first reply (the skipping is sharp peaks at about 0.5 - 1.5 second, irregular intervals, with each peak having the same height as the distance between the long blue lines I think, like this: ___/\______/\___/\_________/\______/\__ ). So in other words, you only have to remove the HDMI cable if this method doesn't fix this weird type of skipping, or, secondly, if you see the HDMI audio switching back on immediately by itself (and in both cases you possibly need to power down as well). I think I fixed the audio issue on my laptop by first removing the cable on both ends (because both ends are HDMI and I've read there's a difference between removing only one end and removing both ends), then powering down and up again, then reconnecting the cable. However, you aren't using a laptop GPU like I am, and your PC has DVI (and DVI-to-HDMI) whereas I have HDMI only, so chances are you're seeing completely different things indeed. Nevertheless, if it's working for me then I think it could also have worked for you because I don't see why the 8800 GTX wouldn't be able to use the same timings as my 9600M GS. Bad combination of TV / GPU, it seems.



By the way, unchecking the checkbox in front of the resolution's name instead of clicking the little red cross behind it, will not undo the override in any way. Also, I paused the video file playback each time before starting a new timings experiment, to not stress the GPU too much while fiddling around with its transistors. /play_ball.gif' class='bbc_emoticon' alt=':playball:' />

#10
Posted 12/19/2009 06:53 PM   
[b]YPG:[/b] What can I say? The only one -[size=7][b] THANK YOU!!!!!!!!!!!!!!!!!!!!! [/b][/size]:rolleyes: /w00t.gif' class='bbc_emoticon' alt=':w00t:' /> /woot.gif' class='bbc_emoticon' alt=':woot:' /> :D

Before I changed just frequency, no other digits. That was my mistake.
Now I'd set everything following your suggestions. And - Voila! It works!!
Tomorrow I'll try to watch some really long movie (more than 2 hours, as you suggested).

BTW, can I post your idea on some website? With your credits, of course!

And again: THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU!
YPG: What can I say? The only one - THANK YOU!!!!!!!!!!!!!!!!!!!!! :rolleyes: /w00t.gif' class='bbc_emoticon' alt=':w00t:' /> /woot.gif' class='bbc_emoticon' alt=':woot:' /> :D



Before I changed just frequency, no other digits. That was my mistake.

Now I'd set everything following your suggestions. And - Voila! It works!!

Tomorrow I'll try to watch some really long movie (more than 2 hours, as you suggested).



BTW, can I post your idea on some website? With your credits, of course!



And again: THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU! THANK YOU!

#11
Posted 12/19/2009 11:30 PM   
Ineresting, this "changed" display resolution goes to "PC" list...

[url="http://radikal.ru/F/i028.radikal.ru/0912/01/1badb3eb8135.gif.html"][img]http://i028.radikal.ru/0912/01/1badb3eb8135t.jpg[/img][/url]
Ineresting, this "changed" display resolution goes to "PC" list...



Image

#12
Posted 12/19/2009 11:37 PM   
[quote name='SergeSF' post='967626' date='Dec 20 2009, 12:30 AM']YPG: What can I say? The only one - THANK YOU!!!!!!!!!!!!!!!!!!!!! :rolleyes: /w00t.gif' class='bbc_emoticon' alt=':w00t:' /> /woot.gif' class='bbc_emoticon' alt=':woot:' /> :D[/quote]
No Problemo. /banana.gif' class='bbc_emoticon' alt=':banana:' />
[quote name='SergeSF' post='967626' date='Dec 20 2009, 12:30 AM']Before I changed just frequency, no other digits. That was my mistake.
Now I'd set everything following your suggestions. And - Voila! It works!![/quote]
Nice. Have you verified it in Media Player Classic Home Cinema by playing a 23.976 framerate file, then pressing CTRL+J ? The first value in the upper left corner of the screen should stay at 23.976 almost constantly and the green line on the graph in the lower right corner of the screen should be stabilized almost perfectly flat horizontal (with only very very slight fluctuations, but on my laptop it's showing a little bit more irregularity for like only a second or two after I start or unpause the movie). The red line should look almost exactly the same, but always in the middle of the graph (on my laptop, this line is showing a sharp spike each time I unpause the movie after pausing it, and also each time I move my mouse pointer into the bottom area of my screen so that my player shows its onscreen user controls, but otherwise it stays flat horizontal just the way it should be).
[quote name='SergeSF' post='967626' date='Dec 20 2009, 12:30 AM']Tomorrow I'll try to watch some really long movie (more than 2 hours, as you suggested).[/quote]
Using Media Player Classic Home Cinema in DXVA mode with Haali Media Splitter external filter (and AC3Filter) to play a 23.976 fps .mkv (~13gig, 1080p, x264, DTS) on my laptop, I am getting a smooth result although it still isn't 100 percent perfect, so here's some more detailed info on how I've tested it a little bit, using my custom resolution's tweaked timings. In my NVIDIA Control Panel | 3D Settings, my triple buffering is on and adaptive performance (HybridPower) is off. In my Haali Media Splitter, input buffer is 19200 and priority boost is on. In my Media Player Classic Home Cinema, Process priority above normal is on, Launch files in fullscreen is on but Change fullscreen resolution is off (because it somehow triggers the 'skipping' bug which I described earlier on here), EVR Custom Presenter is on, Accurate Vsync is on, GPU control is on / on / on. AC3Filter output is 5.1 (AS IS) PCM 24 bit 48 KHz.

You can use spacebar to pause / unpause the movie. Each time I paused and unpaused, the green line (when the file is opened into the player, press CTRL+J to toggle this) stabilized at a different position. After a second or two, it stabilized usually somewhere in between the long blue line which is in the middle of the graph (in our specific case, it should be the one which is almost perfectly overlapped by the red one constantly) and the long blue line which is directly above the other one. Occasionally, it stabilized somewhere very slighly outside this area. I kept using spacebar | (wait a fraction of a second) | spacebar, until the green line stabilized as high as possible: slightly above the area I just described, or almost. Usually, I was able to put it somewhere around that position in only a few attempts, before the movie's introduction logo went away. If I didn't succeed this before the movie's intro was finished, I clicked stop | play and I retried. Let me further explain why I did this spacebar trick. The vertical refresh of my GPU and TV are assumed to be 24000:1001 Hz now, which is the correct frequency for Blu Ray players in north america (and not 23.976). The movie file is only 23.976 fps instead of 24000:1001 (and of course 23.976 is very very slightly less than 24000:1001). So after I watched my movie file like this for about 58 minutes without pausing it, the green line had very very slowly moved down, as a direct result from the fact the movie file uses a framerate which is very very slightly too slow (like I just explained). So now, after about 58 minutes of waiting without touching anything, the green line had moved a distance almost exactly equal to half the height of the area I earlier described. Half the height of that area corresponds to half a video frame, I think. In other words, if I play a long enough movie file this way, it should usually take about two hours until my green line jumps up one frame (depending on how well I managed to do the spacebar trick and so on). When that happens, there should be one video frame being displayed twice and my green line should start to go down again very very slowly until the same thing happens again or until the movie is either finished or somehow interrupted. /icecream.gif' class='bbc_emoticon' alt=':icecream:' /> :D Well, as a matter of fact if my laptop's vertical refresh frequency had been [b]exactly [/b]24000:1001 then after this thing happens, a 23.976 fps movie would need to continue playing for more than eleven and a half hours for it to happen again really.

Anyway, I'd say about two hours is already not so very bad after all. Besides, it's only one frame being displayed twice every two hours or so: everything is perfectly smooth apart from it and maybe there's also a good chance this can still be further improved using different custom timings. If anyone has found more accurate ones, I'd be very grateful to find out what those are. Thanks alot!
[quote name='SergeSF' post='967626' date='Dec 20 2009, 12:30 AM']BTW, can I post your idea on some website? With your credits, of course![/quote]
Yes of course, that's fine.
[quote name='SergeSF' post='967629' date='Dec 20 2009, 12:37 AM']Ineresting, this "changed" display resolution goes to "PC" list...[/quote]
That's happening here also. It's kind of annoying because you have to scroll up the list each time, but nevertheless I'm not overly fussed about that anymore. /haha.gif' class='bbc_emoticon' alt=':haha:' />
[quote name='SergeSF' post='967626' date='Dec 20 2009, 12:30 AM']YPG: What can I say? The only one - THANK YOU!!!!!!!!!!!!!!!!!!!!! :rolleyes: /w00t.gif' class='bbc_emoticon' alt=':w00t:' /> /woot.gif' class='bbc_emoticon' alt=':woot:' /> :D

No Problemo. /banana.gif' class='bbc_emoticon' alt=':banana:' />

[quote name='SergeSF' post='967626' date='Dec 20 2009, 12:30 AM']Before I changed just frequency, no other digits. That was my mistake.

Now I'd set everything following your suggestions. And - Voila! It works!!

Nice. Have you verified it in Media Player Classic Home Cinema by playing a 23.976 framerate file, then pressing CTRL+J ? The first value in the upper left corner of the screen should stay at 23.976 almost constantly and the green line on the graph in the lower right corner of the screen should be stabilized almost perfectly flat horizontal (with only very very slight fluctuations, but on my laptop it's showing a little bit more irregularity for like only a second or two after I start or unpause the movie). The red line should look almost exactly the same, but always in the middle of the graph (on my laptop, this line is showing a sharp spike each time I unpause the movie after pausing it, and also each time I move my mouse pointer into the bottom area of my screen so that my player shows its onscreen user controls, but otherwise it stays flat horizontal just the way it should be).

[quote name='SergeSF' post='967626' date='Dec 20 2009, 12:30 AM']Tomorrow I'll try to watch some really long movie (more than 2 hours, as you suggested).

Using Media Player Classic Home Cinema in DXVA mode with Haali Media Splitter external filter (and AC3Filter) to play a 23.976 fps .mkv (~13gig, 1080p, x264, DTS) on my laptop, I am getting a smooth result although it still isn't 100 percent perfect, so here's some more detailed info on how I've tested it a little bit, using my custom resolution's tweaked timings. In my NVIDIA Control Panel | 3D Settings, my triple buffering is on and adaptive performance (HybridPower) is off. In my Haali Media Splitter, input buffer is 19200 and priority boost is on. In my Media Player Classic Home Cinema, Process priority above normal is on, Launch files in fullscreen is on but Change fullscreen resolution is off (because it somehow triggers the 'skipping' bug which I described earlier on here), EVR Custom Presenter is on, Accurate Vsync is on, GPU control is on / on / on. AC3Filter output is 5.1 (AS IS) PCM 24 bit 48 KHz.



You can use spacebar to pause / unpause the movie. Each time I paused and unpaused, the green line (when the file is opened into the player, press CTRL+J to toggle this) stabilized at a different position. After a second or two, it stabilized usually somewhere in between the long blue line which is in the middle of the graph (in our specific case, it should be the one which is almost perfectly overlapped by the red one constantly) and the long blue line which is directly above the other one. Occasionally, it stabilized somewhere very slighly outside this area. I kept using spacebar | (wait a fraction of a second) | spacebar, until the green line stabilized as high as possible: slightly above the area I just described, or almost. Usually, I was able to put it somewhere around that position in only a few attempts, before the movie's introduction logo went away. If I didn't succeed this before the movie's intro was finished, I clicked stop | play and I retried. Let me further explain why I did this spacebar trick. The vertical refresh of my GPU and TV are assumed to be 24000:1001 Hz now, which is the correct frequency for Blu Ray players in north america (and not 23.976). The movie file is only 23.976 fps instead of 24000:1001 (and of course 23.976 is very very slightly less than 24000:1001). So after I watched my movie file like this for about 58 minutes without pausing it, the green line had very very slowly moved down, as a direct result from the fact the movie file uses a framerate which is very very slightly too slow (like I just explained). So now, after about 58 minutes of waiting without touching anything, the green line had moved a distance almost exactly equal to half the height of the area I earlier described. Half the height of that area corresponds to half a video frame, I think. In other words, if I play a long enough movie file this way, it should usually take about two hours until my green line jumps up one frame (depending on how well I managed to do the spacebar trick and so on). When that happens, there should be one video frame being displayed twice and my green line should start to go down again very very slowly until the same thing happens again or until the movie is either finished or somehow interrupted. /icecream.gif' class='bbc_emoticon' alt=':icecream:' /> :D Well, as a matter of fact if my laptop's vertical refresh frequency had been exactly 24000:1001 then after this thing happens, a 23.976 fps movie would need to continue playing for more than eleven and a half hours for it to happen again really.



Anyway, I'd say about two hours is already not so very bad after all. Besides, it's only one frame being displayed twice every two hours or so: everything is perfectly smooth apart from it and maybe there's also a good chance this can still be further improved using different custom timings. If anyone has found more accurate ones, I'd be very grateful to find out what those are. Thanks alot!

[quote name='SergeSF' post='967626' date='Dec 20 2009, 12:30 AM']BTW, can I post your idea on some website? With your credits, of course!

Yes of course, that's fine.

[quote name='SergeSF' post='967629' date='Dec 20 2009, 12:37 AM']Ineresting, this "changed" display resolution goes to "PC" list...

That's happening here also. It's kind of annoying because you have to scroll up the list each time, but nevertheless I'm not overly fussed about that anymore. /haha.gif' class='bbc_emoticon' alt=':haha:' />

#13
Posted 12/21/2009 07:24 PM   
First of all: IT WORKS!

[img]http://img46.imageshack.us/img46/4989/htpc12012010113234.jpg[/img]

[img]http://img96.imageshack.us/img96/6861/htpc12012010113344.jpg[/img]

My problem now is that the process destroy the 24Hz option, that I need to watch the 24.000 films.

Do you have the same problem?
First of all: IT WORKS!



Image



Image



My problem now is that the process destroy the 24Hz option, that I need to watch the 24.000 films.



Do you have the same problem?

#14
Posted 01/12/2010 11:08 AM   
[quote name='SuperCurro' post='979879' date='Jan 12 2010, 12:08 PM']Do you have the same problem?[/quote]
Yes, I have. /yes.gif' class='bbc_emoticon' alt=':yes:' /> You can get it back to 'normal' by removing the custom resolution: click the Add Resolutions button, then the [color="#FF0000"][b]X[/b][/color]. Add the custom resolution again to get 23.976 again. I hate it too, but nevertheless it helps.
[quote name='SuperCurro' post='979879' date='Jan 12 2010, 12:08 PM']Do you have the same problem?

Yes, I have. /yes.gif' class='bbc_emoticon' alt=':yes:' /> You can get it back to 'normal' by removing the custom resolution: click the Add Resolutions button, then the X. Add the custom resolution again to get 23.976 again. I hate it too, but nevertheless it helps.

#15
Posted 01/13/2010 08:41 AM   
  1 / 10    
Scroll To Top